08:00:12 <flypig> #startmeeting Sailfish OS, open source, collaboration -- 17th March 2022
08:00:12 <sailbot> Meeting started Thu Mar 17 08:00:12 2022 UTC. The chair is flypig. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:12 <sailbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:20 <flypig> #info Meeting information and agenda can be found here:
08:00:23 <flypig> #link https://forum.sailfishos.org/t/community-meeting-on-irc-17th-march-2022/10557
08:00:30 <flypig> Good morning everyone.
08:00:48 <flypig> I am the meeting's chairperson today, and will be doing my best to keep time and order. Please respect the timings and no sudden movements around the Internecivus Raptus in the corner.
08:01:11 <flypig> Hope you're all doing well, let's start as usual with the introductions.
08:01:12 <flypig> #topic Brief introduction (5 min). Please prefix your name/handle with #info
08:01:16 <Nico> #info Nico - community
08:01:26 <ExTechOp> #info Otto Mäkelä - community
08:01:30 <pherjung> #info pherjung - community
08:01:46 <flypig> #info David Llewellyn-Jones - sailor @ jolla
08:03:20 <Thaodan> #info - Björn Bidar - sailor @ Jolla
08:03:23 <Nico> 3:1? o:
08:03:27 <flypig> It's going to be a community win today. We're lacking sailors this morning :)
08:03:28 <Nico> Ah
08:04:23 <abr> #info Andrew Branson - another sailor
08:04:52 <flypig> Even stevens?
08:06:05 <flypig> Okay, well thanks all for joining today.
08:06:25 <flypig> We actually didn't have any advance questions, so it's all about the general discussion this morning.
08:06:32 <flypig> #topic General discussion (30 min)
08:07:27 <Nico> So I was at a Sailfish meetup yesterday and people complained, that there is not enough to talk about recently, because there was no recent release. Probably the same reason why the community meetings are so quiet atm :D
08:07:52 <flypig> Nico, you answered the question I was about to ask :) Thank you.
08:07:52 <ExTechOp> Oh dear, no questions at all. Do we yet have estimated dates for the 4.4 release?
08:08:24 <flypig> 4.4 has had an unusually long gestation.
08:08:25 <Nico> ExTechOp, when it is ready? :D
08:08:44 <dcaliste> #info Damien Caliste, community
08:08:58 <Nico> Yay, community is leading again!
08:09:14 <ExTechOp> Do we have a meta-date: when could we get an estimate on when it will be released?
08:09:43 <flypig> abr, do you know what the current public info about the next release is?
08:10:20 <Nico> Some people were also bummed out that there was no quicker fix for the call issues. Some sailor wrote on the forums that those should be fixed for 4.4.0, but there is no release of that yet, so every normal user still randomly can't receive calls :D
08:11:15 <shayoden> hello
08:11:24 <flypig> Nico, this is useful feedback. The frustration on that point is understandable.
08:11:30 <flypig> Hello shayoden.
08:11:32 <abr> flypig: no, just that it's SOON
08:11:54 <dcaliste> Which is better that "soon", I guess ;)
08:12:12 <Ric9k> Good morning
08:12:18 <flypig> dcaliste, haha, definitely :)
08:12:22 <pherjung> Nico: I noticed you get notification if you use Sailfish-Connect
08:12:25 <flypig> Good morning Ric9k.
08:13:04 <flypig> Nico, any other news from the meeting?
08:13:07 <Nico> Someone also seems the issue recently, that when they hang up, it doesn't send the other party the usual hang up sign, but instead it seems to mark them as unreachable, which causes them to be sent an SMS about a missed call, even though they hung up :D
08:13:45 <Nico> Then there was some banter about various people, who should release new versions of their apps, but that's not on Jolla :3
08:14:15 <Nico> And the usual talks about Qt versions, open-sourcing and such, but no need to repeat that :D
08:14:49 <flypig> Nico, concerning the hanging up bug, is that this one? https://forum.sailfishos.org/t/incoming-voice-calls-dont-get-rejected-hangup-same-bug-via-the-ui-and-programmatically/10076
08:15:56 <dcaliste> I don't know exactly, but from the description Nico gave, it looks different.
08:16:24 <Nico> Yeah, it sounded slightly different
08:16:45 <dcaliste> In the bug you mentioned, flypig, the other party don't see the hang-up and the phone continue to ring.
08:16:49 <Nico> My guess is that the phone disconnects, like it always seems to do after a call, before it can hang it up
08:16:55 <dcaliste> No communication has been established.
08:17:12 <dcaliste> I mean in the bug you mentioned.
08:17:42 <flypig> In which case, it would be useful to have a proper bug report for it. Would there be any way to get more detail Nico?
08:17:48 <dcaliste> Nico, may I ask ? You initiated the call ? Is the bug always when the call is initiated by third party ?
08:18:03 <Nico> Sure, IÄll see if I can tell them to report it on the forum :D
08:18:03 <dcaliste> s/You/Who/
08:18:20 <flypig> Thank you, that would be really appreciated.
08:18:28 <Nico> dcaliste, from what they said, it seemed to have been always when they got the call yes
08:19:04 <Nico> Interestingly none and the table ever experienced that issue, so it seems to be unique to that person, I think they were the only one with the XA though :3
08:19:07 <dcaliste> So, maybe it could be related in fact.
08:19:49 <dcaliste> I'll try to see if I can reproduce something similar with my office land-line. With it, I can reproduce the ring again one mentioned by flypig.
08:20:43 <Nico> Mhm, otherwise maybe I can get that user to produce some logs as well, since they seem to be able to repro it somewhat reliably :3
08:21:11 <Nico> Btw, is the network disconnection after a call really needed or is that a bug?
08:21:54 <abr> is it the switch back to 4G doing that? does it still happen if you lock it on 3G?
08:21:58 <dcaliste> If they were is 4G, I think yes, because the call need to degrade to 3G or 2G to be placed. And then, switch back to 4G.
08:21:58 <Nico> Had a few people trying to call me back immediately after I called them and they got to their phone to late, but I was unreachable, since my phone disconnects after a call and takes a few seconds to reconnect
08:22:31 <Nico> But usually the switch to 4G is pretty seamless, so why does that happen only after a call?
08:24:14 <flypig> I'll just log this bug to the minutes.
08:24:17 <flypig> #info Nico reported from the Berlin meetup that a user had experienced the following issue:
08:24:21 <flypig> #info "when they hang up, it doesn't send the other party the usual hang up sign, but instead it seems to mark them as unreachable, which causes them to be sent an SMS about a missed call, even though they hung up"
08:24:24 <flypig> #info Nico will ask the user to submit a bug report via the forum.
08:24:28 <Thaodan> Sorry been busy with Xperia stuff.
08:24:46 <Thaodan> I can try to reproduce that on Xperia 1 and Xperia 1 II later.
08:25:16 <Nico> Mhm, I sent them a message about reporting it as a bug too now, so hopefully that will happen :D
08:25:28 <flypig> Great, many thanks Nico.
08:25:58 <Nico> But it might just be that the phone tries to switch to 4G before it actually has completed sending the hangup, so it fails to send it
08:26:37 <flypig> That would still be a bug though :)
08:26:41 <abr> would be good to test if you get the same behaviour when you're 3G only
08:26:43 <Nico> Yeah
08:26:47 <abr> that would narrow it down to the switch
08:28:27 <Nico> I relayed that, now we'll just have to wait
08:28:32 <flypig> #info Correction: Munich meetup, not Berlin meetup.
08:29:19 <Nico> Apart from that we talked about a few websites that didn't work in the browser, but those should be fixed in 4.4.0, since that seems to switch to gecko 78 and those websites complained about an outdated browser ;-)
08:29:22 <flypig> Hopefully the original reporter will step forwards, but either way this has been useful, thank you Nico.
08:31:03 <flypig> Are there plans for another meetup in the future?
08:31:25 <ExTechOp> Are the 4.4 release delays due to internal things, or are there any aspects where the community could be of help?
08:31:32 <Nico> Ah, right, there was one other issue, that might not have a forum bug report? Someone has a really weird nextcloud setup with custom ports and a subdomain and most stuff works with that apart from the calendar
08:31:44 <flypig> ExTechOp, a great question.
08:32:20 <Nico> flypig, yeah, there are somewhat regular meetups actually, last one was in November and apparently there is a mailing list, I just never knew that there was one 15min away from my home :D
08:32:25 <Thaodan> All I can say is that it is progressing good, I think none of us here are equipped to make a more detailed statement.
08:32:51 <Thaodan> Nico, flypig we need another FOSDEM Meetup XD
08:33:01 <flypig> Also, worth adding that the community already gave a lot of great input to the release.
08:33:05 <pherjung> flypig: The next French speaking meetup will take place on 7th April. It's not confirmed yet
08:33:07 <flypig> Thaodan, yes indeed!
08:33:09 <Nico> Well, I was at FOSDEM and none met up with me!
08:33:10 <Thaodan> Fosdem 2023 please!
08:33:14 <Thaodan> I man can dream.
08:33:32 <flypig> Nico, we must have missed each other!
08:33:43 <Nico> Well, I was manning the Matrix stand
08:34:06 <Nico> In the end I even took it over, even though I am not an official Element or Matrix employee, that was fun too :D
08:34:45 <flypig> You gave a lightning talk too?
08:34:51 <Nico> Yeah :3
08:34:58 <dcaliste> Nico, if the person having issue with the calendar could open a bug on the forum, I'll look into it.
08:35:00 <Nico> But it got cut off at the end >.>
08:35:01 <flypig> I actually watched it, it was good :)
08:35:32 <flypig> Sticker extensions.
08:35:39 <Nico> dcaliste, I will relay that, I think it is actually just the usual bug of a nonstandard config not being handled nicely :3
08:35:47 <Nico> flypig, thanks!
08:36:04 <Nico> Sadly stickers don't relay to IRC nicely!
08:36:12 <Thaodan> They do as images
08:36:24 <Thaodan> most clients can show images in the chat
08:37:10 <dcaliste> Thanks Nico, even non standard config should work. Even if not in a strait forward way… and with tweeks !
08:37:11 <Thaodan> I hope matrix provides some official C/C++ based API.
08:37:22 <flypig> #info Another user experienced problems with the Calendar connecting to a Nextcloud server (with unusual URLs).
08:37:28 <Thaodan> Matrix is a mess besides the two sdks they have.
08:37:38 <Thaodan> something like tdlib would be nice.
08:38:06 <Nico> Thaodan, you don't like my mtxclient or libquotient? :3
08:38:24 <flypig> It would be good to get the Nextcloud bug clear too, especially if you're interesting to look at it dcaliste.
08:38:28 <Nico> (I am the Nheko maintainer)
08:38:44 <Thaodan> Nico: Something with official blessing
08:39:22 <dcaliste> flypig, indeed, there is no technical reason not too be able to use exotic config. I'm looking forward into the bug report to see where it's failing.
08:39:51 <flypig> dcaliste, can I log that in the minutes?
08:39:59 <dcaliste> Sure, no problem.
08:40:06 <flypig> #info dcaliste offered to look at the Nextcloud bug when it comes in.
08:40:09 <flypig> Thank you :)
08:40:13 <flypig> We hit our 30 mins timeslot, but we have time today, so we can run for a bit longer.
08:40:14 <Nico> Thaodan, where is the fun in that! My non standard SDKs are better anyway, the famedly dart SDK and my C++ one ;p
08:41:32 <Nico> Does anyone else have something to say but me? :D
08:42:01 <flypig> ExTechOp, just to answer your question directly, at this point in the release cycle, the community is already contributing as much as is possible.
08:42:15 <ExTechOp> OK
08:42:57 <Thaodan> Nico: Idk but good that it is progressing. Now I only need a bridge to IRC
08:43:49 <Nico> Thaodan, well, you are on the wrong side of the bridge! There is also an IRC bridge you can host to join all channels using IRC, but it is pretty much unmaintained :3
08:44:24 <pherjung> Did Jolla took a look on this bug https://forum.sailfishos.org/t/first-row-from-bottom-on-app-grid-interact-with-top-menu/7593?
08:44:54 <Nico> Ah, I sadly can't find it, but I think there was a rust PR to one of the Sailfish repos by the whisperfish developer like half a year ago, that was still open recently. Did someone have a look at that one? :D
08:45:48 <flypig> Nico, I *think* that got merged.
08:45:56 <Thaodan> Nico: It's merged
08:46:57 <Nico> Oh, neat :D
08:47:03 <flypig> pherjung, I'm not certain, but if not, I'll log an internal report about it. Thanks for flagging it up.
08:47:08 <Nico> Seems like stuff is happening that I don't notice .-.
08:47:33 <Nico> So that will be in the next release then too? :3
08:47:42 <flypig> #action Create an internal bug report about https://forum.sailfishos.org/t/first-row-from-bottom-on-app-grid-interact-with-top-menu/7593
08:47:47 <Thaodan> Much stuff happens every day :D Our progress is publicly visible on Github
08:48:17 <flypig> If I recall correctly, the Rust PR was for the SDK, rather than the OS though.
08:48:48 <Nico> flypig, yes, probably, it was something, that made building whisperfish harder in the SDK, so that makes sense
08:48:55 <Thaodan> That's the same in that case.
08:48:56 <Nico> And explains why I couldn't find it just now!
08:49:51 <Ric9k> If there is enough time, may I make a comment? Even if I missed the topics anouncement?
08:50:05 <Nico> So, if your progress is all on Github... where is my qt5.15/qt6 progress ;p
08:50:13 <rubdos[m]> Yes, for the SDK. indeed
08:50:15 <Nico> Ric9k, there were no topics!
08:50:18 <flypig> Ric9k, yes, we have some more time, please go ahead.
08:50:24 <rubdos[m]> I'm also in another meeting
08:50:37 <Nico> rubdos.clone()
08:50:44 <rubdos[m]> It's a mutex
08:50:49 <Nico> Dang
08:50:53 <rubdos[m]> RwLock.
08:51:17 <Ric9k> Thank you. Next release should support old devices as much as possible. Staying out of the consumerism rush, Continuing supporting older devices as much as technically possible, This avoids a huge rare ressources waste and users money loss. This would be/is a clear environmental acting from Jolla. Good for us, good for Jolla image. I am specially thinking about GPS (XA2) and VoLTE for the next versions.
08:51:44 <rubdos[m]> That PR has been merged btw, Nico
08:51:45 <Ric9k> (very personal opinion but seems to me of some interrest)
08:52:04 <rubdos[m]> I wonder however when it's going to be included in the SDK, because I look forward to it
08:52:09 <Nico> Ruben De Smet, yeah, you are late, we already found that out!
08:52:17 <rubdos[m]> sowwy 😢
08:52:38 <flypig> Ric9k, thanks, it's good to have your view, and Jolla has always prided itself on its long support cycle.
08:53:05 <flypig> Ric9k, could you summarise in 10-ish words for the minutes?
08:53:34 <ExTechOp> BTW what is the status of predictive typing, am I mistaken that there doesn't seem to be "official" versions for 4.3.0?
08:53:39 <Nico> Ruben De Smet, I will forgive you... for now!
08:54:15 <Thaodan> flypig, Ric9k: Exactly we try do our best with the limitations that manufacturers put upon on us.
08:54:16 <flypig> ExTechOp, I don't think that's correct: there is predictive typing for 4.3.0. Could you elaborate?
08:54:27 <Thaodan> e.g. Android Kernels
08:54:43 <Nico> ExTechOp, did you install it? I have predictive typing, but there wasn't one in the initial X10 ii release, so maybe that's why it is missing on your device still?
08:55:31 <flypig> I'll wrap things up shortly, but are there any other points anyone would like logged to the minutes from all this great discussion?
08:56:08 <Nico> Uh, no, you guys are doing a great job! You should do a release so that people can see that without looking at the github!
08:57:09 <flypig> Thanks Nico :)
08:57:40 <Nico> (I mean, I have other ways to peek, but I can't talk about that! Argh!)
08:57:42 <Ric9k> flypig: hmm, yes...need some time...
08:58:48 <flypig> Ric9k, does this work? "Ric9k promoted the cause of support for older devices, especially GPS and VoLTE for the XA2."
09:00:13 <pherjung> Ric9k: In a way, this is the aim of postmarketOS
09:00:32 <Nico> pherjung, but Sailfish is prettier!
09:00:54 <pherjung> Nico: You mean UI/UX?
09:01:08 <Nico> Yes :3
09:01:16 <Ric9k> flypig: Choose, had that: It is important that Jolla stays different and green by keeping support on old devices. For natural ressources an users budgets. E.g. GPS bugfix and VoLTE on XA2.
09:01:37 <pherjung> because postmarketOS doesn't develop their own interface
09:01:57 <flypig> #info pherjung: The next French speaking meetup will take place on 7th April. It's not confirmed yet.
09:02:23 <flypig> #info Ric9k: It is important that Jolla stays different and green by keeping support on old devices. For natural resources an users budgets. E.g. GPS bugfix and VoLTE on XA2.
09:02:33 <Ric9k> pherjung: Great, didn't know exactly. But SFos is more usable and very very agreable :--)
09:03:50 <pherjung> by the way, what's the name of the user interface of Sailfish? Silica?
09:04:31 <Nico> The compositor is called lipstick and it always makes me laugh :D
09:05:09 <flypig> Okay, we must wrap up the meeting now, but thanks for the nice comments about SFOS of course :)
09:05:19 <flypig> #topic Next meeting time and date (5 min)
09:05:28 <flypig> Proposing Thursday 31st March at 07:00am UTC
09:05:44 <Nico> Sounds pretty fine :3
09:05:58 <flypig> The clocks change before the 31st, so this is an hour earlier to make it the same time (10am) in Finland.
09:06:02 <dcaliste> French time will have switch to summer. I don't know for the other countries…
09:06:09 <Ric9k> Thank you for this meeting, for the work and listening!
09:06:27 <flypig> dcaliste, indeed. I think this should leave it at the same time in France too.
09:06:43 <Nico> I think most countries will switch time, yes
09:06:54 <flypig> Thanks Ric9k, good to hear your thoughts.
09:06:55 <ExTechOp> Let's hope the proposal by Finland to get rid of time changing finally moves forward in the EU.
09:07:07 <Nico> Yes, please!
09:07:07 <flypig> Yes, we can hope ExTechOp :)
09:07:19 <Nico> One less programming headache!
09:08:01 <flypig> Alright, it seems no objections to the proposal, so let's go with it.
09:08:02 <ExTechOp> Considering there's a similar suggestion in the US, one can hope.
09:08:03 <flypig> #info Next meeting will be held on Thursday 31st March 2022 at 07:00am UTC: 2022-03-31T0700Z
09:08:04 <dcaliste> Oops flypig, sorry, of course I messed up. Yes 7am will be the same local time… My bad.
09:08:20 <flypig> dcaliste, no apology necessary, it's good that you flagged it up.
09:08:28 <flypig> Thanks all for a really nice discussion today.
09:08:32 <flypig> #endmeeting