07:01:10 <flypig> #startmeeting Sailfish OS, open source, collaboration -- 12th May 2022
07:01:10 <sailbot> Meeting started Thu May 12 07:01:10 2022 UTC. The chair is flypig. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:01:10 <sailbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:01:21 <flypig> #info Meeting information and agenda can be found here:
07:01:26 <flypig> #link https://forum.sailfishos.org/t/community-meeting-on-irc-12th-may-2022/11334
07:01:35 <flypig> I am the meeting's chairperson today, and will be doing my best to keep time and order. Please respect the timings and your elders.
07:01:40 <flypig> #topic Brief introduction (5 min). Please prefix your name/handle with #info
07:02:12 <ExTechOp> #info Otto Mäkelä, community
07:02:20 <pherjung> #info pherjung, community
07:02:22 <dcaliste_> #info Damien Caliste, community
07:02:23 <sledges> #info Simonas Leleiva - privateer
07:03:11 <flypig> #info David Llewellyn-Jones, sailor @ jolla
07:03:13 <Thaodan> #info Björn Bidar - Sailor @ Jolla
07:04:08 <jwalden> #info JP Walden - Sailor @ Jolla
07:04:37 <lbt> #info David Greaves - Sailor and OBS guy
07:07:11 <flypig> It's great to see everyone today. If anyone else would like to reveal themselves, now is the time!
07:08:47 <flypig> Okay, that must be everyone. What is that? 3:4 community:sailors?
07:09:15 <rainemak> #info Raine Mäkeälinen - Sailor @ Jolla
07:09:16 <Thaodan> Some might lurk from Telegram
07:09:22 <flypig> Indeed :)
07:09:27 <rainemak> #info Raine Mäkeläinen - Sailor @ Jolla
07:09:42 <flypig> We only had one main question and piggz said he may arrive a little late, so we will start with the bug roundup.
07:09:44 <Thaodan> telegram shows at least 4 lurkers
07:09:54 <flypig> #topic Bug roundup (15 mins -- asked by pherjung)
07:10:00 <flypig> #info The Community Bug Coordination team have continued their careful and thorough herding of bugs.
07:10:06 <flypig> #info Thank you for the list of bugs to review. We've been through them carefully; I'll list the outcomes for each of them and then we can discuus any issues.
07:10:23 <piggz> flypig: im here right no ... school run in 20 mins
07:10:23 <flypig> There's quite a few, so please bear with me.
07:10:47 <flypig> #info The following have been tagged as "fixed".
07:10:51 <flypig> #link https://forum.sailfishos.org/t/exporting-contacts-people-with-vcardconverter-doesnt-work/11132
07:10:55 <flypig> #link https://forum.sailfishos.org/t/main-camera-does-not-start/1905
07:10:58 <flypig> #link https://forum.sailfishos.org/t/incoming-calls-are-suppressed-and-a-notification-is-missing/2075
07:11:01 <flypig> #link https://forum.sailfishos.org/t/audio-output-detection-stopped-working/1038
07:11:06 <flypig> #info The following has had a fix applied for the next release.
07:11:10 <flypig> #link https://forum.sailfishos.org/t/4-4-0-58-tap-missing-call-doesnt-open-phone-app/10819
07:11:15 <flypig> #info The following are now tagged as "tracked" and have PRs proposed to fix them.
07:11:22 <flypig> #link https://forum.sailfishos.org/t/4-3-0-4-2-0-4-1-0-4-0-1-deleted-screenshot-is-not-handled-properly-via-notifications/5801
07:11:27 <flypig> #link https://forum.sailfishos.org/t/4-2-0-4-1-0-4-0-1-horizontal-line-over-one-line-sms-message-bubbles/4866
07:11:30 <flypig> #link https://forum.sailfishos.org/t/4-2-0-number-of-email-preview-rows-change/8083
07:11:38 <flypig> #info The following already had an internal report and is now tagged as "tracked"
07:11:43 <flypig> #link https://forum.sailfishos.org/t/bluetooth-toggle-and-indicator-is-out-of-sync-with-reality/6490
07:11:48 <flypig> #info The following have new internal bug reports and have been tagged as "tracked"
07:11:53 <flypig> #link https://forum.sailfishos.org/t/help-for-getting-mms-with-the-french-mobile-operator-bouygues/3243
07:11:56 <flypig> #link https://forum.sailfishos.org/t/browser-cookie-whitelist-not-working/10981
07:11:58 <flypig> #link https://forum.sailfishos.org/t/design-flaw-calendar-weekday-overlapping-in-german/10951
07:12:01 <flypig> #link https://forum.sailfishos.org/t/browser-paste-multiple-digits-when-numeric-keyboard-is-on/10035
07:12:04 <flypig> #link https://forum.sailfishos.org/t/browser-paste-multiple-digits-when-numeric-keyboard-is-on/10035
07:12:11 <flypig> Finally...
07:12:12 <flypig> #info I've left this one as it is so I can look at the logs in more detail.
07:12:14 <flypig> #link https://forum.sailfishos.org/t/4-4-0-58-carddav-sync-with-nextcloud-fails/11033
07:12:19 <flypig> That's all of them. Once again, thanks to the bug team for all your hard work. It was particularly nice to see the reports which already had suggestions for fixes.
07:12:27 <flypig> Any comments about either these bugs, or the process? Do things seem to be working okay?
07:12:45 <pherjung> You pasted the same link twice
07:12:59 <flypig> Oh, sorry. Which one. One second.
07:13:11 <pherjung> 3rd last one
07:13:33 <flypig> #info The following also has a new internal bug report and has been tagged as "tracked"
07:13:39 <flypig> #link https://forum.sailfishos.org/t/screenshot-leads-to-lipstick-high-cpu-and-battery-drain/7142
07:13:47 <flypig> It should have been that one. Apologies.
07:14:14 <sledges> you can use #undo next time ;)
07:14:27 <pherjung> This one hasn't been reviewed: https://forum.sailfishos.org/t/4-4-0-58-carddav-sync-with-nextcloud-fails/11033
07:14:30 <flypig> Noted.
07:14:58 <flypig> pherjung, that's right. I need to go through the log for that one in more detail.
07:15:41 <pherjung> isn't the tag pending appropriate? Or a little to early to add it?
07:16:49 <flypig> Yes, probably pending sounds appropriate in this case then. I've tagged it as pending.
07:18:06 * pherjung is now an happy bug coordinator :)
07:18:32 <flypig> Great! That's very gratifying to hear :)
07:19:43 <flypig> Does anything need changing with the process right now? We should continue refining it of course.
07:20:02 <pherjung> As we discussed privately, there are a lot of bug reports. A lot are from SailfishOS 3 and I first thought it could be a good idea to track them. Finally, it's better to stay focus on the current list.
07:21:02 <flypig> Okay good. I will add that to the minutes.
07:21:05 <pherjung> Once it's over, I think it could be helpfull to ask all users to verify if their bug are still real
07:21:23 <flypig> #info <pherjung> there are a lot of bug reports. A lot are from SailfishOS 3 and I first thought it could be a good idea to track them. Finally, it's better to stay focus on the current list.
07:21:25 <pherjung> Are you fine with this process?
07:21:34 <flypig> #info <pherjung> Once it's over, I think it could be helpfull to ask all users to verify if their bug are still real
07:22:25 <flypig> It seems like you and the team are having to do a lot of effort in the background pherjung, but it seems to be producing results. So I'm happy with the process as long as you are.
07:24:02 <flypig> We do have a couple more minutes, but if that covers things, I'd suggest we move on to the next question.
07:24:25 <pherjung> It's fine for me, we can move to the next question
07:24:34 <flypig> #topic Community OBS status after May 2022 (10 min -- asked by rinigus)
07:24:41 <flypig> #info <rinigus> We are getting close to the anniversary of the announcement regarding community OBS.
07:24:49 <flypig> #info <rinigus> As the commitment by Jolla was made for a year, it would be great to hear what are the plans regarding OBS.
07:24:57 <flypig> #link https://forum.sailfishos.org/t/community-obs-refurbished-and-re-floated/6556
07:25:17 <flypig> I think rinigus isn't able to make it, but thank you for the question.
07:25:24 <flypig> I have to be honest, I tried really hard to get a firm answer to your question, but it seems that the decision has yet to be made.
07:25:31 <flypig> So, this is the best I can do:
07:25:37 <piggz> ok, ill be gone in a few minutes ... school run ..... can we have commitment to keeping OBS, i think we have proved its usefulness with a new store and ports.....
07:25:47 <flypig> #info <Jolla> We've been following usage of OBS carefully and are impressed with how well it's been made use of by the community.
07:25:52 <flypig> #info <Jolla> While it clearly provides benefits, OBS is still a significant resource drain and we are still therefore considering how to support it longer term.
07:25:57 <flypig> #info <Jolla> Although we're coming to the end of the 12 month period, we're still exploring options, and therefore it won't be taken out of service imminently.
07:26:03 <flypig> #info <Jolla> As soon as the situation is clearer a concrete announcement will be made.
07:26:43 <flypig> piggz, sorry that time is tight for you, I thought it would be the other way around (that you'd arrive later!).
07:26:45 <flypig> lbt is here, so maybe can shed more light on things.
07:26:55 <lbt> hehe
07:27:24 <flypig> I'd also suggest that we can push back the same question to the next meeting, if you like piggz?
07:27:46 <lbt> not really - it's not been something we've been thinking about recently
07:28:31 <lbt> there is certainly no push to get the OBS shutdown that I'm aware of
07:28:51 <lbt> Personally I'd take this as "no news is good news"
07:28:53 <dcaliste_> about bug 11033, I've commented on the forum about the possible cause for the bug according to the available logs (previous topic, sorry).
07:30:19 <flypig> Thanks for that dcaliste_, very helpful and appreciated.
07:30:43 <flypig> Similarly, lbt, I think that's a helpful addition, thanks.
07:34:10 <flypig> Is there anything further to add here? Does anyone want anything added to the minutes?
07:35:48 <flypig> Okay, well we hit our allotted 10 minutes on the topic, so let's go to general discussion.
07:35:48 <pherjung> I'm not aware how OBS works, but isn't a possibility to share the server with another community?
07:35:55 <pherjung> Sorry
07:36:07 <flypig> No, don't apologise pherjung. Perhaps lbt could comment on that?
07:37:01 <lbt> We use a specific version of the OBS that has modifications for building ARM using scratchbox2 so that makes it quite specialised
07:37:46 <Thaodan> You would basicly need to setup your own obs with those patches plus distributing jolla packages
07:37:54 <lbt> yes
07:38:11 <lbt> That's the main reason that the Suse OBS won't work for us - and that's where many other projects end up (and where we started many years ago)
07:38:52 <flypig> So, you think it's unlikely to be viable to share it like this lbt, Thaodan?
07:39:07 <lbt> correct
07:39:30 <Thaodan> It also not that easy to maintain for a single person.
07:39:53 <Thaodan> It does a lot more than a simple ci server because it manages repos and the building.
07:40:28 <lbt> yes, there's a whole set of infrastructure behind it
07:42:03 <Thaodan> I think the best thing is to show uses for it that show value for things like harbour, things that reduce time spend in other areas.
07:43:36 <flypig> At the moment the link between "chum -> harbour benefit" isn't very clear. It would be good if this could be demonstrated somehow.
07:44:34 <flypig> We're now quite over time though. We're not in a huge rush, but we can of course continue in General discussion anyway.
07:44:45 <flypig> #topic General discussion (20 min)
07:45:40 <lbt> I think it would be interesting to see what the community thinks about the OBS - what value it provides.
07:46:22 <lbt> Things like applications but also collaborative work, libraries etc
07:46:31 <flypig> Yes, I'd totally agree with that. It would be good if that was enunciated somewhere.
07:47:38 <Thaodan> I think the value is well known to those that are active in the community but it would be more helpful to also see this benefit outside
07:47:58 <lbt> I don't see much pressure to "do something" from Jolla's side at the moment - maybe the community could take a month or two to get a handle on this - after all the 12 month experience goes both ways
07:48:36 <lbt> Thaodan: yes, and as flypig says, to express this somehow
07:49:22 <flypig> Practically speaking, is there anything to be done right now that could help with this?
07:49:25 <lbt> What would a new user  get out of using the OBS etc etc
07:50:49 <Thaodan> flypig: I'd say cleaner and better packaging helps us as jolla sailors because community has less issues in the long run
07:51:44 <Thaodan> organizing around obs help community with that collaborative work on packages.
07:52:03 <dcaliste_> rinigus explained it well last year when it was discussed to shut down the OBS.
07:52:28 <flypig> Was that on the forum dcaliste_? Do you have a link by any chance?
07:52:34 <dcaliste_> He discussed also the pro and con of other "building" services.
07:52:56 <dcaliste_> flypig, let me look for it in the forum...
07:53:03 <flypig> Thank you!
07:53:19 <flypig> Could some more detail about the uses, benefits and results from OBS be added to the documentation?
07:53:23 <flypig> #link https://docs.sailfishos.org/Services/Development/Open_Build_Service/
07:54:18 <Thaodan> flypig: I'd think so. App devs could be encoured to use the obs. E.g. for testing or test releases.
07:54:18 <flypig> At the moment, reading those docs as a first-time SFOS developer, I might not get a full idea about what OBS is used for.
07:54:21 <pherjung> this one https://forum.sailfishos.org/t/obs-shut-down-and-next-steps/1814/9 ?
07:54:42 <dcaliste_> flypig, rereading https://forum.sailfishos.org/t/obs-shut-down-and-next-steps/1814 may be of interest.
07:55:05 <dcaliste_> Ah pherjung you were quicker than I was ;)
07:56:19 <flypig> #info For info about the benefits and uses of OBS, the earlier discussion on the forum covers useful ground.
07:56:19 <pherjung> This one is interesting too https://forum.sailfishos.org/t/announcing-sailfishos-chum/7381
07:56:30 <flypig> #link https://forum.sailfishos.org/t/obs-shut-down-and-next-steps/1814/9
07:56:51 <flypig> #link https://forum.sailfishos.org/t/announcing-sailfishos-chum/7381
07:58:53 <flypig> Okay, we're hitting time. let me just mention, in case anyone missed it, there was a hint at a future announcement yesterday.
07:58:56 <flypig> #link https://twitter.com/JollaHQ/status/1524377383985459200
07:59:58 <flypig> Would anyone like to make any final comments, or have anything added to the minutes?
08:00:08 <pherjung> Is it possible that VoLTE come together?
08:01:25 <piggz> lbt: flypig:Thaodan back ... have we not demonstrated OBS benefits already?  we put a lot of effort into it a year ago, and its tiring to go over the same cycle
08:02:25 <lbt> I think it's more to consolidate and confirm now that the OBS (and specifically Chum) has actually been in use for some time
08:02:36 <flypig> pherjung, I can't give an answer to that I'm afraid.
08:02:37 <lbt> There were a lot of "it should do this"....
08:02:49 <lbt> now the community can say "it DOES do this..."
08:03:35 <lbt> so I see it more of an affirmation of the OBS which should be able to confirm it's value and that should help cement it in place
08:03:49 <abr> and maybe a little "and now it could do THIS"
08:04:11 <lbt> yes - that would be good too - there is actually a lot more potential there
08:04:35 <lbt> After all we're able to develop an entire OS because the OBS helps so much ;)
08:05:18 <dcaliste_> Some stat on number of packages, link between packages (since chum is used to host libraries contrary to harbour), update rate of packages... woulkd be great.
08:05:33 <dcaliste_> It would show the importance of chum in my opinion.
08:06:23 <abr> yeah it's definitely shown realized potential instead of just wishes
08:06:48 <pherjung> SailfishOS community isn't that big, that's perhaps why we don't see the huge benefit
08:06:56 <dcaliste_> That being said, I can't understand neither why a builder in a FOSS environment is not de facto a usefull thing.
08:07:10 <piggz> number of packages is >210 ... get updates to process most days
08:08:15 <lbt> dcaliste_: there is the counter argument that the SDK provides the builder functionality
08:08:36 <lbt> so the OBS is more of a community builder than "the only builder"
08:08:44 <dcaliste_> Yeh, builder is a confusing term, I mean a builder with dependency handling and online.
08:09:20 <piggz> sdk sucks for managing things professionally, eg for managing ports ... and obs does all the distribution ....
08:09:29 <piggz> perhaps lbt can provide package download stats?
08:09:36 <Thaodan> The SDK is nice for development but maintaining things is much harder.
08:09:55 <Thaodan> OBS together with webhooks make packaging so much easier.
08:10:19 <dcaliste_> As rinigus mentioned, building *and distributing* a full stack (at leqst 3-4 libs + app) is not that convenient in SDK.
08:10:22 <piggz> how about jolla reture their internal obs and use the sdk instead .... does that make sense? :D
08:10:35 <lbt> haha...
08:12:07 <dcaliste_> For instance, I'm happy with the SDK for my own purpose when touching the calendar stack, but if I would need to distribute my chances, that would be a nightmare. I'm happy that Jolla is building all the stack themselves on ... an (internal) OBS.
08:14:49 <lbt> I think these comments are all fodder for confirming the value of the OBS.
08:14:55 <abr> are there many packages in chum that are also already on the jolla store?
08:15:26 <Thaodan> It is the same  for other things like telepathy development
08:15:28 <lbt> The point is more that these benefits have now actually been realised and are not just theoretical
08:15:33 <abr> because there's something affirming about seeing the route from source to package to store
08:15:50 <Thaodan> abr:  I think many are. Communi-IRC is now one (since yesterday)
08:16:14 <lbt> so  the community can look at this and say after 12 months we've done X,Y,Z and benefit from A,B,C ...
08:16:22 <flypig> lbt, the comments are valuable to be sure, but this is a transient discussion. It might be helpful to have something more concret.
08:16:58 <lbt> flypig: right - and that's what I was suggesting earlier... tha the community take some time over the next few weeks to solidify these ideas
08:17:16 <flypig> We're going to have to wrap this up. Are there any practical steps or actions to be noted?
08:17:33 <lbt> essentially to now put the case to Jolla "here's what we did with the OBS over the last 12 months ... now... can we keep it?"
08:17:51 <lbt> That sounds like a good forum topic :D :D
08:18:26 <flypig> So, for the minutes?: 'We encourage the community  to now put the case to Jolla "here's what we did with the OBS over the last 12 months ... now... can we keep it?"'
08:18:49 <lbt> wfm
08:19:05 <flypig> #info 'We encourage the community to now put the case to Jolla "here's what we did with the OBS over the last 12 months ... now... can we keep it?"
08:19:46 <piggz> lbt: can you provide download stats for chum and other areas of OBS like nemo:hw:*:* ?
08:20:08 <lbt> ummm ... not easily
08:20:46 <flypig> lbt, not easily because they don't exist, or because it's private info?
08:21:01 <lbt> they don't exist
08:21:19 <piggz> webserver logs + some python :P
08:21:53 <lbt> yes, but there are a few ways to pull data from the OBS - API, https download, internal dependency pulls
08:22:12 <piggz> ah rats, i forgot my foilauth password
08:22:15 <lbt> just external https should be doable
08:22:26 <flypig> lbt, would you be willing to look into it for the next meeting?
08:22:32 <lbt> OK
08:22:37 <flypig> Great, thank you.
08:23:06 <flypig> #action lbt to look into publishing any potentially useful OBS/chum stats.
08:23:18 <flypig> Alright. I'm sorry to cut the really nice discussion short, but we've spent some time on this now, and hopefully it's been useful.
08:23:31 <flypig> #topic Next meeting time and date (5 min)
08:23:34 <piggz> i can write down some chum stats, and maybe get a list of ports on obs
08:24:08 <flypig> Could you share those also at the next meeting piggz?
08:24:24 <piggz> sure
08:24:28 <flypig> Great, thank you.
08:24:30 <flypig> #action piggz to share chum stats at the next meeting.
08:24:39 <flypig> For the next meeting:
08:24:40 <flypig> Proposing Thursday 26th May at 07:00am UTC
08:25:03 <flypig> Any objections?
08:25:21 <ExTechOp> On vacation then, but I'll be on the next one.
08:25:40 <ExTechOp> A side note, yesterday I got a single-ring phone call from +2420594xxxxx (+242 Republic of the Congo) and apparently they were expecting me to call back https://www.fcc.gov/consumers/guides/one-ring-phone-scam
08:26:16 <flypig> We will miss you ExTechOp, but have a great vacation :)
08:26:33 <dcaliste_> ExTechOp, yeh that's common scam indeed.
08:26:40 <dcaliste_> flypig no objection on planed date.
08:26:53 <flypig> Thanks for the warning ExTechOp. It's very easy to fall into those traps.
08:27:10 <flypig> Alright, the date is set.
08:27:10 <flypig> #info Next meeting will be held on Thursday 26th May 2022 at 07:00am UTC:  2022-05-26T0700Z
08:27:45 <flypig> Thanks all for the useful and detailed discussions this week. We'll no doubt return to the topic of OBS in the future.
08:27:49 <flypig> #endmeeting