#sailfishos-meeting: Sailfish OS, open source, collaboration -- 23rd June 2022

Meeting started by flypig at 07:00:48 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: (flypig, 07:00:55)
    2. https://forum.sailfishos.org/t/community-meeting-on-irc-23rd-june-2022/11888 (flypig, 07:00:58)

  1. Brief introduction (5 min). Please prefix your name/handle with #info (flypig, 07:01:12)
    1. Nico, community <3 (Nico, 07:01:24)
    2. Ruben De Smet, community (rubdos[m], 07:01:39)
    3. Andrew Branson, sailor (abr, 07:01:47)
    4. Raine Mäkeläinen, sailor @ Jolla (rainemak_, 07:01:52)
    5. Cryx - Community first time ever using this kind of chat, so hint me if I do something wrong... (Cryx, 07:01:54)
    6. David Llewellyn-Jones, sailor @ jolla (flypig, 07:02:06)
    7. pherjung, community (pherjung, 07:02:11)
    8. Otto Mäkelä, community (ExTechOp, 07:04:35)
    9. JP Walden, sailor @ Jolla (jwalden, 07:05:09)
    10. fridlmue - community (fridl, 07:05:24)

  2. Adding additional Media Codecs to Sailfish OS (5 min -- asked by Cryx) (flypig, 07:07:04)
    1. <Cryx> Sailfish OS is missing some Media Codecs that are available by default on other systems (both mobile and desktop). (flypig, 07:07:08)
    2. <Cryx> This results in files being unsupported by SFOS and can't be opend and show an error message about the missing codec. (flypig, 07:07:12)
    3. <Cryx> For example: Photos taken with other devices and uploaded to Nextcloud aren't viewable in Gallery - in my case these are Photos taken with an iPhone that are in HEIC format. Same thing for videos in H. 265/HEVC. (flypig, 07:07:19)
    4. <Cryx> And beside that I'd like to see especially Support for *ALAC* (Apple Lossless) as well. As far as I know (didn't do further Research right now) these Codecs could be used for free. (flypig, 07:07:26)
    5. Simonas Leleiva - nearly made the introductions:) (sledges, 07:07:27)
    6. <Cryx> So adding them - and maybe other additional Codecs that might be useful - to SFOS by default the whole system would be better up to date and would also offer a better User experience instead of dissapointment because of unplayable media files. (flypig, 07:07:37)
    7. <Cryx> (Maybe something that's related to missing codecs: Disney+ can't play Videos and ends up with error 39...). (flypig, 07:07:44)
    8. <Cryx> Wish/Conclusion: Add native supports for following codecs: ALAC; HEIC; H. 265/HEVC (flypig, 07:07:50)
    9. https://forum.sailfishos.org/t/compiling-gstreamer-plugin/11805/7?u=cryx (flypig, 07:07:57)
    10. <Jolla> Sailfish OS has two sources of codecs. Generally, all software codecs are built as GStreamer plugins, whether they’re packaged as separate libs, ffmpeg codecs or built-into GStreamer itself. (flypig, 07:08:21)
    11. <Jolla> We don't allow any license-encumbered codecs in there, e.g. we don't build the 'ugly' set at all. Hardware codecs come from the underlying Android drivers and are exposed to GStreamer through our 'gst-droid' GStreamer plugin. (flypig, 07:08:30)
    12. <Jolla> Most of these require licenses, which is why we use the codecs from the device rather than bundle our own - they're already licensed for your device. (flypig, 07:08:44)
    13. <Jolla> H.265/HEVC is not a free codec, but if you have a recent Sailfish X device then you should already have support through a hardware codec (which unfortunately older devices don't support). (flypig, 07:08:55)
    14. <Jolla> There's a tricky bug to solve in thumbnail generation in the Gallery app though - that only uses software codecs so you won't see a thumbnail but the video should play fine. (flypig, 07:09:03)
    15. <Jolla> However, that same bug would stop you from viewing HEIC files too. (flypig, 07:09:10)
    16. <Jolla> ALAC looks more promising as it seems to be available in FFmpeg, though we're not building it in right now. (flypig, 07:09:14)
    17. <Jolla> We'd have to double check if there are any licensing restrictions for that, and if it's clear (which looks likely) then we could add it for the next release. (flypig, 07:09:22)
    18. <Jolla> A quick test seemed to work anyway, and prompted by the request we have a PR to add it in. (flypig, 07:09:36)
    19. https://github.com/sailfishos/ffmpeg/pull/2 (flypig, 07:09:39)

  3. Update Rust (10m -- asked by rubdos) (flypig, 07:17:34)
    1. <rubdos> Whisperfish requires Rust 1.56. I don't like to put this forward, but the shipped Rust compiler is getting old. It is currently on version 1.52, which is today one year and one month old. (flypig, 07:17:49)
    2. <rubdos> This is not usually old in Compiler Land, but sadly, for Rust, it is. There are a few problems with this. I will take Whisperfish for context. (flypig, 07:17:56)
    3. <rubdos> It's becoming increasingly difficult to deal with Rust 1.52. I fear that in a month or two, we will need to move towards Rust 2021, which is only available as of 1.56 (flypig, 07:18:03)
    4. https://doc.rust-lang.org/edition-guide/rust-2021/index.html (flypig, 07:18:10)
    5. <rubdos> The reasoning behind this, is that libsignal-client is moving forward, and has transitive dependencies that already moved on to Rust 2021. (flypig, 07:18:13)
    6. <rubdos> Among these are cryptographic base libraries, for which I'm rather angry that they put these requirements already, given their important position in the whole ecosystem. (flypig, 07:18:19)
    7. <rubdos> Another reason for a bump of the required Rust version, is that many libraries and dependencies are adopting new features from even before edition 2021. (flypig, 07:18:26)
    8. <rubdos> Among those are Actix (MSRV 1.53), and even libsignal-client itself. (flypig, 07:18:41)
    9. <rubdos> All of the above, summarized: for Whisperfish to be able to function and keep up with Signal's developments, we require a version bump of Rust to at least 1.56, relatively soon. (flypig, 07:18:51)
    10. <rubdos> Not updating means not updating libsignal (I'm maintaining a fork now, to patch around new features, but I won't be able to hold that much longer), and not updating libsignal means potentially getting booted from their servers, or losing compatibility with future clients. (flypig, 07:18:59)
    11. <rubdos> Signal is very lenient in this, and they promise to maintain compatibility for three months, but in reality it's usually more like a year. (flypig, 07:19:07)
    12. <rubdos> Now, I understand that the Rust version is tied to the Gecko ESR release that Jolla builds for. (flypig, 07:19:12)
    13. <rubdos> The required Rust version for different Firefox versions are tabulated here: (flypig, 07:19:16)
    14. https://firefox-source-docs.mozilla.org/writing-rust-code/update-policy.html (flypig, 07:19:18)
    15. <rubdos> From that table, it's clear that Jolla doesn't *need* to update Rust in order to get even Firefox 100, so I understand that Jolla does not want to do the heavy lifting unless strictly necessary. (flypig, 07:19:22)
    16. <rubdos> I'm willing to chip in and bump the versions, but I'd love some feedback on whether Jolla will accept such big changes. (flypig, 07:19:31)
    17. <Jolla> Thanks for your question rubdos; you shouldn't feel bad about putting it forwards, it’s a great question. (flypig, 07:19:57)
    18. <Jolla> Whisperfish is one of the few Sailfish OS community apps that relies on Rust, so it’s really helpful and important to get your perspective on its use. (flypig, 07:20:05)
    19. <Jolla> In addition, as you point out, Rust is needed for the gecko engine that powers the Sailfish browser. Rust isn't an officially supported language on the Sailfish SDK, but of course we want to support developers and would love to see wider use of Rust in the future. (flypig, 07:20:13)
    20. <Jolla> You’ve very kindly offered to do the heavy lifting, and that's great because unfortunately, in the spirit of openness, we’re unlikely to be able to prioritise this in the near future. (flypig, 07:20:23)
    21. <Jolla> Getting this change through will still require significant work from Jolla (e.g. reworking the browser build process; testing the results). (flypig, 07:20:31)
    22. <Jolla> We can’t guarantee any timescales, but we do offer to work as closely as we can with you given resource constraints to help the process through. (flypig, 07:20:37)
    23. <Jolla> If you’d be willing to start the process, please ask any questions as things progress, and we will be happy to look at any PRs you submit. (flypig, 07:20:44)
    24. <Jolla> We’d also be interested to work with you to test out the gecko build process with the newer Rust. Our contributions will to be on a best-effort basis for now (I.e. no timescales or guarantees). (flypig, 07:20:51)
    25. https://github.com/sailfishos/rust/issues/4 (rubdos[m], 07:26:35)
    26. https://github.com/sailfishos/rust/issues/11 (rubdos[m], 07:26:39)
    27. https://github.com/sailfishos/rust/issues/12 (rubdos[m], 07:26:44)
    28. rubdos[m] requested that Jolla review these ^^ open issues. (flypig, 07:26:59)

  4. 4G should work on both SIMs simultaneously (5 min -- asked by remote) (flypig, 07:28:57)
    1. <remote> Sailfish OS doesn't support 4G on both SIM slots, Android (and HW) does. So why do we have this artificial limitation and when will Sailfish OS allow both SIMs run in 4G? (flypig, 07:29:03)
    2. <Jolla> We have an internal task about this issue and it has been worked on; unfortunately on some devices running 4G on both slots does cause issues for the modem on some devices, and it's currently not clear why. (flypig, 07:29:41)
    3. <Jolla> This needs to be addressed before we can enable it and this is why the limitation has been introduced. It is something that we are looking into however. (flypig, 07:29:49)

  5. Community Bug Coordination Team summary (5 min -- asked by pherjung) (flypig, 07:36:38)
    1. <pherjung> A summary of the results from the Community Bug Coordination Team's activity during the last fortnight. (flypig, 07:36:45)
    2. <Jolla> The Community Bug Coordination Team have done a superb job once again this fortnight. (flypig, 07:37:02)
    3. <Jolla> As a result of their work, we now have: (flypig, 07:37:07)
    4. <Jolla> - An addition 10 high quality bug reports now recorded internally and tagged as "tracked". (flypig, 07:37:12)
    5. <Jolla> - Four bug reports tagged as "fixed". (flypig, 07:37:17)
    6. <Jolla> - Two duplicate bug reports closed (flypig, 07:37:22)
    7. <Jolla> - One bug report that was tagged incorrectly now tagged as "tracked". (flypig, 07:37:26)
    8. <Jolla> - One thread moved out of the bug report category. (flypig, 07:37:35)
    9. <pherjung_> some bug reports only appears in some special conditions and disappear once the user flash his phone again. I think we can just tag them as pending. For instance: (flypig, 07:47:34)
    10. https://forum.sailfishos.org/t/saved-alarms-and-timers-disappearing-after-reboot/11066 (flypig, 07:47:40)

  6. Updating kf5bluezqt - MediaTransport conflict (15min -- asked by Nico) (flypig, 07:49:08)
    1. <Nico> Jolla intends to deprecate QBluetooth (part of QtConnectivity) usage in Sailfish (flypig, 07:49:15)
    2. https://forum.sailfishos.org/t/deprecation-notice-bluez-gnutls-qtconnectivity-qtsysteminfo-repomd-pattern-builder/ (flypig, 07:49:19)
    3. <Nico>Some applications currently use this to talk to advanced bluetooth gadgets. One of them is OBDFish: (flypig, 07:49:27)
    4. https://github.com/explit7/OBDFish (flypig, 07:49:31)
    5. <Nico> I wanted to update that application to use kf5bluezqt, since doing raw Dbus calls is not something I am comfortable with. The characteristics stuff in kf5bluezqt should be usable as a replacement for QBluetoothSocket. (flypig, 07:49:37)
    6. <Nico> This was however added after the 5.50 version currently available in Sailfish. (flypig, 07:49:44)
    7. <Nico> While that package was updated in February, it was only updated to 5.50, since newer version add a MediaTransport API which the Sailfish package added independently as a patch. (flypig, 07:49:57)
    8. <Nico> I would like to figure out how to move forward with that conflict to get a newer kf5bluezqt before QBluetooth is removed. (flypig, 07:50:04)
    9. <Nico> Ideally we could just switch to the upstream implementation of MediaTransport, but this doesn't expose some properties Sailfish does and some things have different names. (flypig, 07:50:12)
    10. <Nico> You can find my current work in progress upgrade to 5.82.0 here: (flypig, 07:50:17)
    11. https://github.com/deepbluev7/kf5bluezqt (flypig, 07:50:20)
    12. <Jolla> First of all, kudos for taking the plunge and updating your application, and for the nice work you've already done looking into kf5bluezqt. (flypig, 07:51:54)
    13. <Jolla> Just to clarify a point to avoid any confusion, the current version of kf5bluezqt on Vanha Rauma is 5.24.0. (flypig, 07:52:01)
    14. <Jolla> It has since been updated to 5.50.0 on our internal development branch (i.e. in the repositories) but this won't go out to devices until a later release. (flypig, 07:52:08)
    15. <Jolla> For reference, the 5.24.0 version currently on devices: (flypig, 07:52:15)
    16. https://github.com/sailfishos/kf5bluezqt/tree/4e8986ee4faaff717185f69f49d6ed4c7191c75a (flypig, 07:52:19)
    17. <Jolla> The latest version 5.50.0 for a future Sailfish release: (flypig, 07:52:22)
    18. https://github.com/sailfishos/kf5bluezqt (flypig, 07:52:26)
    19. <Jolla> The latest upstream version 5.95.0 (mirror): (flypig, 07:52:29)
    20. <Jolla> #link https://github.com/sailfishos-mirror/bluez-qt (flypig, 07:52:32)
    21. <Jolla> We’d also like to upgrade to the latest release. The reason we haven't yet is for the reasons you've cited: that the best path to the latest release while retaining the Sailfish specific modifications isn't clear. (flypig, 07:52:38)
    22. <Jolla> This means that switching directly to upstream isn't possible and some work is needed to patch the code. (flypig, 07:52:46)
    23. <Jolla> We’d like to work with you to perform the upgrade, but this will depend on availability on both sides (and especially not everyone will be available at all times during the summer). (flypig, 07:52:52)
    24. <Jolla> We had a look at your changes to move up to 5.82.0 and you’ve already made a good start. (flypig, 07:52:58)
    25. <Jolla> It's hard to comment on the changes in generality, but if you have specific questions, then if you ask them here, we will do our best to follow up and discuss with the relevant Sailors (if they're not already present today). (flypig, 07:53:05)
    26. <Jolla> It would also help if you could create a PR of your changes into the Sailfish repository, even as a WiP PR if it’s not yet in mergeable form. (flypig, 07:53:13)
    27. <Nico> Jolla properties for the media stuff: (flypig, 07:55:39)
    28. https://github.com/deepbluev7/kf5bluezqt/blob/7a7473bc87fc3a7c78b3028f432c77fdf2bc4ded/rpm/0002-Add-MediaTransport-org.bluez.MediaTransport1-wrapper.patch#L342 (flypig, 07:55:42)
    29. <Nico> Upstream list of properties: (flypig, 07:56:05)
    30. https://github.com/sailfishos-mirror/bluez-qt/blob/e10c3a398b0571dcdf4866091bffbbace3899345/src/mediatransport.h#L31 (flypig, 07:56:08)
    31. <Nico> I will open a PR to discuss the codey bits, otherwise I am good (flypig, 08:10:55)

  7. General discussion (15 min) (flypig, 08:11:21)
    1. ACTION: flypig to add a "Pending PR" request to the community meeting announcement. (flypig, 08:33:17)

  8. Next meeting time and date (5 min) (flypig, 08:33:31)
    1. Next meeting will be held on Thursday 7th July 2022 at 07:00am UTC: 2022-07-07T0700Z (flypig, 08:35:19)


Meeting ended at 08:35:36 UTC (full logs).

Action items

  1. flypig to add a "Pending PR" request to the community meeting announcement.


Action items, by person

  1. flypig
    1. flypig to add a "Pending PR" request to the community meeting announcement.


People present (lines said)

  1. flypig (198)
  2. Nico (88)
  3. rubdos[m] (24)
  4. pherjung_ (16)
  5. abr (9)
  6. fridl (9)
  7. Cryx (7)
  8. ExTechOp (4)
  9. rainemak (4)
  10. sailbot (3)
  11. thilo[m] (2)
  12. rainemak_ (1)
  13. pherjung (1)
  14. jwalden (1)
  15. sledges (1)


Generated by MeetBot 0.1.4.