#sailfishos-meeting: Sailfish OS, open source, collaboration -- 4th August 2022

Meeting started by flypig at 07:00:13 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: (flypig, 07:00:18)
    2. https://forum.sailfishos.org/t/community-meeting-on-irc-4th-august-2022/12456 (flypig, 07:00:23)

  1. Brief introduction (5 min). Please prefix your name/handle with #info (flypig, 07:00:52)
    1. fridlmue - community (fridl, 07:01:49)
    2. Andrew Branson - sailor (abr, 07:01:50)
    3. Otto Mäkelä - community (ExTechOp, 07:02:04)
    4. Anton Thomasson - community, partly paricipating (attah_work, 07:02:04)
    5. David Llewellyn-Jones - sailor @ Jolla (flypig, 07:02:22)
    6. Simonas Leleiva - privateer for Jolla (sledges, 07:02:23)
    7. Björn Bidar - sailor @ Jolla (Thaodan, 07:03:06)
    8. piggz, community (piggz, 07:05:14)

  2. 5G support (5 mins -- asked by cquence) (flypig, 07:06:00)
    1. <cquence> I'd like to inquire about the plans to enable 5G connectivity in 10III. Are there any plans to enable 5G? (flypig, 07:06:08)
    2. <cquence> If so any rough timeframes (1,2,3 releases away or similar) you can possibly share? (flypig, 07:06:15)
    3. <Jolla> Supporting 5G requires a broad set of changes at various OS levels. These include adaptation support, ofono support and ofono plugin support. (flypig, 07:06:49)
    4. <Jolla> Right now our focus is on refining the breadth and depth of our VoLTE implementation. (flypig, 07:06:57)
    5. <Jolla> For future 5G developments, our suggestion is to keep an eye on the relevant repositories, or Damien's Repository Roundup in the newsletter. (flypig, 07:07:04)
    6. <Thaodan> There are two points of interest here. First the hybris way of doing this: we have ofono-binder-plugin which talks to the Qti blob and thous only needs to implement the IRadio interfaces and react to the new interfaces. (flypig, 07:15:25)
    7. So far we have IRadio 1.4, we would need 1.6 (flypig, 07:15:37)
    8. <Thaodan> For adaptations that don't use the binder plugin and thus directly talk to the modem the situation is different it depends on how far ofono is in talking to the modem. E.g. QMI in terms of Qt (flypig, 07:15:52)

  3. OAuth2 support in Microsoft Exchange commercial plug-in (5 mins -- asked by DrYak) (flypig, 07:18:10)
    1. <DrYak> Do we have a status update for the support of OAuth2 in the Microsoft Exchange? (flypig, 07:18:16)
    2. <DrYak> After Alien-Dalvik, getting support for my employer's e-mail servers is the second most important reason for buying the licence to Sailfish X. (flypig, 07:18:27)
    3. See the following forum links for more info. (flypig, 07:18:32)
    4. https://forum.sailfishos.org/t/modern-authentication-oauth-support-for-the-microsoft-exchange-activesync-e-mail-contacts-calendar/5237 (flypig, 07:18:37)
    5. https://forum.sailfishos.org/t/basic-authentication-deprecated-by-microsoft/2905/14 (flypig, 07:18:41)
    6. <Jolla> Thanks for your question Ivan, and also for buying a Sailfish X licence. (flypig, 07:19:16)
    7. <Jolla> You'll already be aware of the details, but for the benefit of others, this relates to the Exchange Active Sync (EAS) support on Sailfish OS for syncing emails, calendars and contacts with Exchange services such as Office365. (flypig, 07:19:23)
    8. <Jolla> Microsoft have said they plan to disable password authentication in October 2022 (there may be some exceptions), after which it will be necessary to authenticate using OAtuh, which the sailfish-eas daemon doesn't currently support. (flypig, 07:19:32)
    9. https://techcommunity.microsoft.com/t5/exchange-team-blog/basic-authentication-deprecation-in-exchange-online-may-2022/ba-p/ (flypig, 07:19:41)
    10. <Jolla> As is already stated on the forum thread we do have an internal task covering this, and there has been some work undertaken on an implementation. (flypig, 07:19:45)
    11. <Jolla> However, unfortunately it's not possible to give further details about the likelihood or timescales for a solution at this point. (flypig, 07:19:54)
    12. <Jolla> We aim to report progress back to the tracked forum topic. The need for the functionality is reinforced by both the discussion on the forum and the fact you've raised it here today, so the input is useful to us. (flypig, 07:20:02)

  4. Future plans for SailJail (10 mins -- asked by attah) (flypig, 07:30:14)
    1. <attah> This springs from discussions about Storeman, but applies to all third-party apps. (flypig, 07:30:22)
    2. <attah> What are Jolla's long term goals for GUI apps in the Jolla Store ("harbour") and outside of it (e.g., at OpenRepos or SailfishOS:Chum) WRT SailJail. (flypig, 07:30:28)
    3. <attah> Do you plan to either enforce a proper SailJail configuration sooner or later, or to keep it optional forever (by simply deploying a [X-Sailjail] Sandboxing=Disabled in an app's .desktop file), or to take an intermediate route, e.g., by alerting users when installing apps which have opted out of sandboxing? (flypig, 07:30:41)
    4. <Jolla> First a quick recap of the current situation. Sandboxing was turned on by default for all apps in Sailfish OS 4.4.0. This means that: (flypig, 07:31:08)
    5. <Jolla> 1. Apps with permissions specified in the desktop file are granted only those permissions. (flypig, 07:31:16)
    6. <Jolla> 1. Apps with permissions specified in the desktop file are granted only those permissions. (flypig, 07:31:20)
    7. <Jolla> 3. Apps can have sandboxing explicitly disabled to run in the same way they would have done before sandboxing was introduced. (flypig, 07:31:25)
    8. <Jolla> The roadmap that brought us here was posted on the Jolla blog last year: (flypig, 07:31:32)
    9. https://blog.jolla.com/whats-up-with-sandboxing/ (flypig, 07:31:37)
    10. <Jolla> Due to the summer vacations I wasn't able to get a definitive answer, but my understanding is that there are no immediate plans for any changes to this, or for changes to the harbour requirements in relation to sandboxing. (flypig, 07:31:44)
    11. Correction: (flypig, 07:32:28)
    12. <Jolla> 2. Apps without any permissions specified are granted a default set of permissions which are shown to the user. (flypig, 07:32:29)
    13. <Jolla> This doesn't mean there won't be changes in the future, but that's my understanding of the current situation. (flypig, 07:32:53)
    14. <Jolla> There may be changes to the permissions that are available (for example changes were made to allow access to the compass) or to the scope of the default sandboxing profile. (flypig, 07:33:01)
    15. <Jolla> We have some improvements to the sandboxing documentation in the pipeline. (flypig, 07:33:22)

  5. Harbor API progress (in special QtLocation) (10 mins -- asked by fridlmue) (flypig, 07:45:30)
    1. <fridlmue> There have always been some discussions about Harbour-allowed APIs in the past, recently also some changes. (flypig, 07:45:49)
    2. <fridlmue> Also there has been a poll from Jolla some time ago. (flypig, 07:45:55)
    3. https://forum.sailfishos.org/t/api-priority-poll-take-ii/4159 (flypig, 07:46:00)
    4. <fridlmue> Can Jolla perhaps give a short update, if they are working actively on some of these points? (Of course those who have not been tackled yet.) (flypig, 07:46:03)
    5. <fridlmue> My question originates from the need of implementing some relatively simple "map" view in a app showing some shapes in colors and the current position. (flypig, 07:46:12)
    6. <fridlmue> I would love to have it Harbour-compliant and most native, but in case there will be no solution in the foreseeable time, I would need to tackle it by a leaflet in a web view or something like that (which I really don't prefer...). Interaction with the app itself will then be another challenge. (flypig, 07:46:20)
    7. <fridlmue> On the other hand, if there is something in the pipeline (like QtLocation), it would be a wast of effort and I would wait... (flypig, 07:46:27)
    8. <Jolla> You're correct that there have been some changes in the relatively recent past to support more APIs in harbour. The poll was useful for prioritisation and we are also always looking at ways to support more capabilities. (flypig, 07:46:39)
    9. <Jolla> As it stands though, it's not possible to announce any plans in relation to future harbour APIs. (flypig, 07:46:45)
    10. <Jolla> In particular in relation to QtLocation, we would recommend using an alternative mapping approach if you're planning to submit your app to the Jolla Store in the near future. (flypig, 07:46:52)
    11. <Jolla> If this situation changes we will of course make a clear announcement in the forum. (flypig, 07:47:00)
    12. <Jolla> We also look forward to receiving your app (maybe you could share some more details?). (flypig, 07:47:03)

  6. Open PR discussion (10 mins -- asked by jolla) (flypig, 07:54:43)
    1. <jolla> Any open PRs to discuss or promote? (flypig, 07:54:49)
    2. https://github.com/pulls?q=is%3Aopen+is%3Apr+org%3Asailfishos (flypig, 07:54:53)
    3. https://github.com/pulls?q=is%3Aopen+is%3Apr+org%3Amer-hybris (flypig, 07:58:11)
    4. https://github.com/mer-hybris/droid-hal-device/pull/311 is open and required for local builds to work with newer droidmedia and no minisf start in servicemanager.rc (Thaodan, 08:00:04)
    5. Thaodan noted the following PR which may address some issues faced by community members. (flypig, 08:03:40)
    6. https://github.com/mer-hybris/droid-hal-device/pull/311 (flypig, 08:03:42)

  7. Untracked bug reports (10 mins -- asked by pherjung) (flypig, 08:05:38)
    1. <pherjung> On bug 10926, his SD card is invisible for the default (and hidden) file browser. (flypig, 08:05:44)
    2. <pherjung> What should modified to get more logs from native file browser? (flypig, 08:05:52)
    3. <pherjung> This section could be used to complete the official documentation. (flypig, 08:05:56)
    4. https://forum.sailfishos.org/t/unencrypted-fat-sdcard-doesnt-properly-mount-via-gui/10926 (flypig, 08:05:59)
    5. https://docs.sailfishos.org/Reference/Sailfish_OS_Cheat_Sheet/ (flypig, 08:06:02)
    6. <Jolla> The Community Bug Coordination Team have done a superb job once again over the last four weeks. Here are the usual stats from their work: (flypig, 08:06:26)
    7. <Jolla> - 13 high quality bug reports now recorded internally and tagged as "tracked". (flypig, 08:06:32)
    8. <Jolla> - 2 bug reports marked as "pending" more info. (flypig, 08:06:34)
    9. <Jolla> - 4 bug reports tagged as "fixed". (flypig, 08:06:37)
    10. <Jolla> - 3 marked as duplicates and closed. (flypig, 08:06:40)
    11. <Jolla> To move on to the question about SD card logging. (flypig, 08:06:44)
    12. <Jolla> The code that handles enumeration of the different partitions can be found in nemo-qml-plugin-systemsettings. (flypig, 08:06:49)
    13. https://github.com/sailfishos/nemo-qml-plugin-systemsettings/blob/master/src/partitionmodel.cpp (flypig, 08:06:53)
    14. <Jolla> The debug output there uses the lcMemoryCardLog logging category, which resolves to "org.sailfishos.settings.memorycard" (flypig, 08:07:01)
    15. https://github.com/sailfishos/nemo-qml-plugin-systemsettings/blob/1d7164f1b0eb7e6696f614eb93e29b067d4677fc/src/logging.cpp (flypig, 08:07:05)
    16. <Jolla> So to get more output you can activate this logging category as follows for the Settings app and hidden file browser respectively. (flypig, 08:07:08)
    17. <Jolla> QT_LOGGING_RULES="org.sailfishos.settings.memorycard=true" sailfish-filemanager (flypig, 08:07:11)
    18. <Jolla> QT_LOGGING_RULES="org.sailfishos.settings.memorycard=true" devel-su -p jolla-settings (flypig, 08:07:13)
    19. <Jolla> Hopefully the output from this may help the user get to the bottom of the issue. (flypig, 08:07:17)
    20. <Thaodan> one can run jolla-settings in gdb. make sure to install debug symbols for nemo-qml-plugin-settings. (flypig, 08:11:52)
    21. Thaodan suggested to step through the methods in https://github.com/sailfishos/nemo-qml-plugin-systemsettings/blob/master/src/udisks2monitor.cpp#L74 (flypig, 08:12:34)
    22. <abr> you can also add that logging to /usr/share/qt5/qtlogging.ini (flypig, 08:12:46)

  8. General discussion (10 min) (flypig, 08:17:40)
    1. piggz requested that 10ii VoLTE rpms be moved to hw-common for use by porters. (flypig, 08:29:44)
    2. Thaodan noted that this should be considered for the 10 III rpms too. (flypig, 08:31:29)
    3. ACTION: flypig to check internal bug reports for https://forum.sailfishos.org/t/activesync-produces-incorrectly-timed-events-due-to-winter-summer-time-setting/12483 (flypig, 08:31:55)

  9. Next meeting time and date (5 min) (flypig, 08:32:19)
    1. Next meeting will be held on Thursday 18th August 2022 at 07:00am UTC: 2022-08-18T0700Z (flypig, 08:33:45)


Meeting ended at 08:34:28 UTC (full logs).

Action items

  1. flypig to check internal bug reports for https://forum.sailfishos.org/t/activesync-produces-incorrectly-timed-events-due-to-winter-summer-time-setting/12483


Action items, by person

  1. flypig
    1. flypig to check internal bug reports for https://forum.sailfishos.org/t/activesync-produces-incorrectly-timed-events-due-to-winter-summer-time-setting/12483


People present (lines said)

  1. flypig (170)
  2. Thaodan (54)
  3. abr (29)
  4. attah_work (22)
  5. ExTechOp (17)
  6. DrYak (15)
  7. fridl (10)
  8. piggz (5)
  9. sailbot (2)
  10. dryak_ (2)
  11. sledges (1)


Generated by MeetBot 0.1.4.