08:00:04 <rainemak> #startmeeting Sailfish OS, open source, collaboration -- 9th Nov 2023
08:00:04 <sailbot> Meeting started Thu Nov  9 08:00:04 2023 UTC. The chair is rainemak. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:04 <sailbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:04 <rainemak> #info Meeting information and agenda can be found here:
08:00:04 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-irc-9th-november-2023/17180
08:00:04 <rainemak> I am the meeting's chairperson today, and will be doing my best to keep time and order. Please respect the timings and bee-hive.
08:00:04 <rainemak> #topic Brief introduction (5 min). Please prefix your name/handle with #info
08:00:06 <rainemak> #info Raine Mäkeläinen, sailor @ Jolla, chairperson today
08:00:16 <ExTechOp> #info Otto Mäkelä, community
08:01:29 <Crabster> #info Crabster - lurker
08:02:37 <flypig> #info David Llewellyn-Jones, community
08:03:58 <dr4Ke> #info dr4Ke, community
08:04:52 <Nico> #info Nico, community
08:05:08 <rainemak> let's move to the first topic
08:05:13 <rainemak> #topic Add a new tag not-reproducible to the category bug reports (5mins -- asked by pherjung)
08:05:13 <rainemak> #info <pherjung> Some details about the topic: Some bug reports are well written
08:05:13 <rainemak> #info <pherjung> and easily reproducible, but only with specific conditions. Until
08:05:13 <rainemak> #info <pherjung> these conditions are found, such a tag would be a nice to have.
08:05:31 <rainemak> #info <Jolla> Thank you for this suggestion. This is sounds like a good idea.
08:05:31 <rainemak> #info <Jolla> Are there other tags that we should add?
08:05:44 <rainemak> I think tag should be called 'non-reproducible'. How does that sound like?
08:07:13 <Nico> Well, it is reproducible apparently, so something like "rare" or so maybe would fit more, but it doesn't sound like a bug only tag :D
08:07:54 <rainemak> I'm not sure but those discourse tags might be bound to categories. But you're right.
08:08:26 <rainemak> Imo, rare is not same non-reproducible => both could be added
08:08:28 <Nico> I think some github repos use some prefix + uncommon
08:08:36 <Nico> Sure
08:08:45 <rainemak> uncommon is not bad either
08:08:51 <rainemak> instead of rare
08:09:03 <Nico> Yeah, I think it sounds better
08:09:22 <Nico> And it is not like tags are that expensive to maintain, I'd say
08:09:27 <Nico> Thank you :)
08:09:37 <rainemak> should we add then 'uncommon' and 'non-reproducible'
08:09:54 <Nico> I'd say that sounds good :)
08:10:04 <rainemak> Indeed, we can adjust them as we go
08:10:39 <rainemak> #action Add 'uncommon' and 'non-reproducible' tags for bug category (on the forum)
08:10:49 <rainemak> let's move on
08:10:58 <rainemak> #topic Open PR discussion (10 mins -- asked by jolla)
08:11:06 <rainemak> #info <Jolla> Any open PRs to discuss?
08:11:47 <Nico> flypig, do you have anything?
08:12:03 <Nico> Otherwise looking at the attendance it looks unlikely :D
08:12:12 <rainemak> You're right
08:12:38 <rainemak> There's no need to have 10min slot for this today
08:12:42 <rainemak> it seems
08:13:02 <flypig> Sorry, I was distracted :) No I don't have anything to mention.
08:13:17 <flypig> dcaliste is usually on top of this, but I think isn't joining today.
08:13:27 <Nico> Then let's move on, I guess :3
08:14:21 <rainemak> #topic Untracked bug reports (5 min -- asked by pherjung)
08:14:21 <rainemak> #info <pherjung> Untracked bug reports
08:14:21 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-irc-9th-november-2023/17180/3
08:14:38 <rainemak> #info <Jolla> As always, the Community Bug Coordination Team have done a superb job.
08:14:38 <rainemak> #info <Jolla> As a result of their work, we now have:
08:14:38 <rainemak> #info <Jolla> 7 high quality bug reports now recorded internally and tagged as "tracked".
08:14:38 <rainemak> #info <Jolla> 3 report is still under investigation.
08:15:06 <rainemak> btw, should also have 'needinfo' tag
08:15:26 <Nico> Sounds good :D
08:15:32 <Nico> All the tags!
08:15:45 <flypig> Some "good" bugs in that list, it would be nice to have fixes for.
08:16:06 <flypig> Nice work as always.
08:16:08 <rainemak> 'uncommon', 'non-reproducible' and 'needinfo'
08:16:40 <Nico> Clearly it should be "needsinfo"
08:16:45 * Nico starts bikeshedding
08:16:56 <flypig> What is bikeshedding?
08:17:03 <rainemak> #action Add 'uncommon', 'non-reproducible', 'needinfo' tags for bug category (on the forum)
08:17:10 <rainemak> let's move on
08:17:15 <Nico> When you argue about the color of the bike shed instead of more important things
08:17:23 <rainemak> #topic General discussion (5 min)
08:17:26 <flypig> Haha. Thanks Nico :)
08:17:37 <Nico> Because the other things are harder to argue about, but everyone has opinions about the color
08:17:42 <rainemak> flypig, great work once again with esr91
08:17:56 <Nico> Oh yeah, congrats on getting a picture out!
08:18:04 <Nico> It was a long and interesting ride!
08:18:08 <flypig> Thanks rainemak. I was happy to get a picture, but there's still a lot more to do though :)
08:18:12 <rainemak> hopefully, embedlite-components fixing would be enough to get touch working
08:18:13 <flypig> Thanks Nico too.
08:18:45 <flypig> rainemak, yes, I'm hoping you're right. There are a lot of errors from the JavaScript parts, so fixing those will surely help (and be necessary).
08:18:46 <rainemak> flypig, yeap, indeed there are but this is a good milestone
08:19:08 <flypig> I'm really keen to get the changes into the Jolla repos though. Is that doable?
08:19:21 <Nico> At least you are now not working completely in the dark :3
08:19:25 <rainemak> and in any case those needs to be fixed as that's the glue between user interface and the engine
08:19:33 <flypig> Nico, exactly, that makes a huge difference.
08:19:42 <flypig> rainemak, indeed!
08:20:02 <rainemak> I created sailfishos-esr91 branches some time back already for each repository
08:20:19 <flypig> Thanks rainemak. So I should create a PR into them?
08:20:25 <rainemak> please, create PRs for them
08:20:34 <flypig> What to do about the changes in the gecko-mirror repo though?
08:20:43 <flypig> Turn them into patches already?
08:20:57 <flypig> (I'd prefer not to, but the mirror should be a mirror, right?)
08:21:00 <rainemak> I think that's the only feasible way
08:21:28 <rainemak> it's only git am --3way away from being the same
08:21:44 <rainemak> even --3way is not needed when they are all clean
08:22:20 <rainemak> and your own clone can contain patches applied
08:22:25 <Nico> Maybe it is a good time to now find at least some patches that are obviously correct and part them out and keep the other stuff still in your gecko branch for now?
08:23:08 <flypig> Yeah, it'll need some work and thought, because some patches are spread across multiple commits currently. I just need to put the time in.
08:23:24 <rainemak> worth noting that sailfishos-esr91 branches can be considered as work-in-progress branches
08:23:32 <ExTechOp> By the way, have people been bothered with the "sounds disappear" bug, since I noticed that I haven't seen it for a while? https://forum.sailfishos.org/t/4-1-0-23-4-0-1-48-4-4-0-64-4-5-0-16-no-notification-sounds-ringing-sms-alarm/4886/
08:23:51 <Nico> No, my sounds has been very solid recently
08:24:02 <flypig> Yes, I've not experienced this either I'm afraid.
08:24:30 <Nico> Otoh, I also drowned my 10 II and am on a 10 III now :D
08:25:22 <flypig> Drowned?! I thought the 10 II was waterproof (in practice, but not on paper).
08:25:22 <ExTechOp> Another question, do we expect the echo cancellation on Xperia 10 III to be fixed any time soon, I'm getting tired of needing headphones to use it?
08:26:16 <rainemak> I think it's on sony's side. So, I have my doubts.
08:26:28 <Nico> flypig, it had a tiny hair crack in the screen and then I got into a bad thunderstorm with hail and lots of water on top of a mountain between Austria and Italy and it then got a blue screen and then a black screen :D
08:26:46 <Nico> Possibly fixable, but had no time for that yet
08:26:55 <ExTechOp> Nico A heroic death for a phone.
08:27:05 <flypig> Oh dear :( You clearly give your phone a bit of a workout!
08:27:12 <Nico> It helped me out a lot, so it will be remembered dearly :3
08:27:44 <rainemak> let's schedule next meeting... next
08:27:45 <Nico> But also it was a nice digital detox for the rest of the journey :D
08:27:48 <flypig> I hope you weren't relying on it to get you down the mountain again?
08:28:20 <Nico> Well, kinda, but Mountains have the nice property, that the way down is usually indicated by a decline
08:28:30 <flypig> Ha ha :D
08:28:39 <rainemak> #topic Next meeting time and date (5 min)
08:28:39 <rainemak> Proposing Thursday 23rd November at 07:00am UTC.
08:28:51 <Nico> And it was only like 5 days left of hiking and it was the same general direction as before
08:29:07 <Nico> Sounds good as a date, rainemak :3
08:29:18 <rainemak> #info Next meeting will be held on Thursday 23rd November 2023 at 07:00am UTC: 2023-11-23T0700Z
08:29:28 <rainemak> settled then
08:29:35 <rainemak> Thank you everyone for the meeting!
08:29:35 <ExTechOp> Works for me.
08:29:38 <flypig> Great!
08:29:42 <ExTechOp> Thank you everybody!
08:29:43 <flypig> Thanks rainemak, all!
08:29:46 <rainemak> #endmeeting