08:00:00 <rainemak> #startmeeting Sailfish OS, open source, collaboration -- 7th Dec 2023
08:00:00 <sailbot_> Meeting started Thu Dec  7 08:00:00 2023 UTC. The chair is rainemak. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:00 <sailbot_> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:25 <rainemak> That was a sharp start :-)
08:00:31 <rainemak> #info Meeting information and agenda can be found here:
08:00:31 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-irc-7th-december-2023/17429
08:00:31 <rainemak> I am the meeting's chairperson today, and will be doing my best to keep time and order. Please respect the timings and bee-hive.
08:00:31 <rainemak> #topic Brief introduction (5 min). Please prefix your name/handle with #info
08:00:33 <ExTechOp> #info Otto Mäkelä, community
08:00:57 <rainemak> #info Raine Mäkeläinen, sailor @ Jolla, chairperson today
08:01:07 <Zyuc2G> #info Zyuc2G, community/dev
08:01:29 <Crabster> #info Crabster - lurker
08:01:39 <karry> #info Lukáš Karas - community developer
08:01:41 <Keto> #info Pami Ketolainen, sailor @ Jolla
08:01:45 <sledges> #info Simonas Leleiva -- privateer for wotsits:)
08:01:49 <b100dian[m]> #info Vlad G., community
08:02:26 <b100dian[m]> Morning :)
08:03:29 <sledges> sailbot_ has a tail_, thus won't be able to change channel topic..
08:04:05 <ExTechOp> sledges Even though ChanServ gave it /op ?
08:04:06 <rainemak> sledges, I'll update topic after the meeting
08:04:19 <sledges> i.e. for ongoing discussion topics
08:04:57 <Keto> it just didn't have ops from the start as Raine was faster than me :)
08:05:06 <dcaliste> #info Damien Caliste, community
08:05:15 <rainemak> Keto, :-)
08:05:41 <rainemak> Alright, let's start with the first topic. Welcome everybody!
08:05:41 <nephros> #info Peter G., community
08:05:52 <rainemak> #topic Future of Jolla (8mins -- asked by Valorsoguerriero97)
08:05:52 <rainemak> #info <Valorsoguerriero97> There are ongoing rumors, docs and newspaper citing that
08:05:52 <rainemak> #info <Valorsoguerriero97> Jolla is under debt restoration, how it is going? The plan
08:05:52 <rainemak> #info <Valorsoguerriero97> is accepted? What we can do to help? What are the consequences
08:05:52 <rainemak> #info <Valorsoguerriero97> for SFOS and supported devices?
08:06:22 <rainemak> #info <Jolla> A solution was finally found on November 24, 2023 as the local District Court
08:06:22 <rainemak> #info <Jolla> decided on the restructuring program and obligated a complete sale of the business
08:06:22 <rainemak> #info <Jolla> to another company. The entire business and staff of Jolla Ltd. has now transferred
08:06:22 <rainemak> #info <Jolla> to a new company in whole.
08:06:23 <rainemak> #info <Jolla>
08:06:25 <rainemak> #info <Jolla> The new legal entity was named Jollyboys Ltd, but as it has now acquired the Jolla and
08:06:28 <rainemak> #info <Jolla> Sailfish brands and trademarks, you may consider the legal entity name to be secondary
08:06:31 <rainemak> #info <Jolla> - it’s the new Jolla anyway.
08:06:42 <rainemak> #info <Jolla>
08:06:42 <rainemak> #info <Jolla> No consequences for Sailfish OS as entire business and staff were transferred to another
08:06:42 <rainemak> #info <Jolla> company. Similarly, Sailfish X program continued as part of business transfer.
08:06:44 <rainemak> #info <Jolla>
08:06:46 <rainemak> #info <Jolla> Let’s keep on sailing together!
08:06:48 <rainemak> #info <Jolla>
08:06:50 <rainemak> #link https://forum.sailfishos.org/t/sailfish-community-news-30th-november-jolla-reborn/17473
08:07:30 <ExTechOp> Hurrah!
08:07:32 <sledges> \o/
08:07:54 <rainemak> Indeed! Hurrah!
08:08:18 <b100dian[m]> Good news of the year!
08:08:43 <dcaliste> Yeh, good news. Particularly for the Jolla employees, em, Jollyboys employees !
08:09:05 <tuplasuhveli[m]> #info tuplasuhveli, community (late and currently at work)
08:10:03 <rainemak> I'd emphasize that Jolla and Sailfish brands and trademarks belong to the new entity.
08:10:34 <rainemak> this is now new Jolla
08:11:19 <Zyuc2G> It might be more relevant for my question later, but who owns the proprietary code? Is it Jollyboys?
08:12:03 <rainemak> the entire business and staff of Jolla ltd has now transferred to Jollaboys
08:13:07 <sebix[m]> Why was the new entity necessary? (Or will that be answered in a future forum post?)
08:15:31 <rainemak> entire business includes practically everything
08:17:10 <rainemak> sebix[m], I am not a lawyer
08:17:45 <rainemak> I guess this is covered - let's sail on.
08:17:52 <rainemak> #topic Drain on Xperia 10 III (3mins -- asked by Valorsoguerriero97)
08:17:57 <rainemak> #info <Valorsoguerriero97> There are some bug reports citing that the 10 III is having battery
08:17:57 <rainemak> #info <Valorsoguerriero97> drain, what’s the point of solving those issues?
08:18:03 <rainemak> #info <Jolla> These has been some investigation into the battery drain but no obvious reason
08:18:03 <rainemak> #info <Jolla> has been found yet.
08:18:03 <rainemak> #link https://forum.sailfishos.org/t/high-battery-drainage-xperia-10-iii/12393
08:19:46 <rainemak> Please post your ideas / findings to the forum. We can further discuss findings in the community meetings and forum.
08:20:09 <rainemak> Next we have a question about OBS tar_git.
08:20:15 <rainemak> #topic OBS tar_git support of fileserver (5mins -- asked by vlagged / b100dian)
08:20:24 <rainemak> #info <vlagged / b100dian> There is at least a tar_git copy on github which supports
08:20:24 <rainemak> #info <vlagged / b100dian> a command-line param called “fileserver” 1. This would allow
08:20:24 <rainemak> #info <vlagged / b100dian> a build to start by downloading an internet resource of a known
08:20:24 <rainemak> #info <vlagged / b100dian> SHA-1 if listed in a _sources file.
08:20:24 <rainemak> #info <vlagged / b100dian>
08:20:26 <rainemak> #info <vlagged / b100dian> This is however not listed in the service spec now.
08:20:27 <rainemak> #info <vlagged / b100dian>
08:20:29 <rainemak> #info <vlagged / b100dian> The use case is for example software built with npm or yarn which cannot
08:20:32 <rainemak> #info <vlagged / b100dian> run on OBS (network access) or has a very high cache size (think 500MiB
08:20:35 <rainemak> #info <vlagged / b100dian> cache for a 5MiB build output) - however can be easily be built in other
08:20:38 <rainemak> #info <vlagged / b100dian> CI systems such as github/gitlab/codeberg’s.
08:20:42 <rainemak> #info <vlagged / b100dian>
08:20:44 <rainemak> #info <vlagged / b100dian> It would be useful to use the output of a such build automatically in
08:20:47 <rainemak> #info <vlagged / b100dian> an OBS build (which would do the non-nodejs part such as qml, c++ rpm
08:20:50 <rainemak> #info <vlagged / b100dian> packages) by specifying the URL to download & the expected SHA-1 sum,
08:20:53 <rainemak> #info <vlagged / b100dian> just as fileserver param is doing.
08:20:55 <rainemak> #link https://github.com/MeeGoIntegration/obs-service-tar-git/blob/master/tar_git#L69
08:20:57 <rainemak> #info <Jolla> The fileserver parameter in tar_git is not listed in the service spec because it allows
08:21:00 <rainemak> #info <Jolla> access to local files. So it would require some modifications before enabling.
08:21:02 <rainemak> #info <Jolla>
08:21:04 <rainemak> #info <Jolla> There are also other OBS source services which provide similar functionality and which
08:21:07 <rainemak> #info <Jolla> we could consider enabling
08:21:09 <rainemak> #link https://github.com/openSUSE/obs-service-download_files
08:21:13 <rainemak> #link https://github.com/openSUSE/obs-service-download_url
08:21:15 <rainemak> #info <Jolla> Those do not seem to have checksum verification for the downloaded file, but otherwise
08:21:18 <rainemak> #info <Jolla> should be fit for the purpose.
08:22:03 <b100dian[m]> That check can be manually added in the build spec though
08:22:12 <Keto> rainemak: your line splitting could be better ;)
08:22:31 <rainemak> Keto, I guess it could
08:22:38 <b100dian[m]> I should write less in a question:)
08:23:15 <b100dian[m]> So will download_* services be enabled any time soon?
08:23:28 <rainemak> b100dian[m], if you don't mind, I'll drop next time vlagged from the nick -> it should cleanup lines a bit
08:23:50 <Keto> I can probably install those after the meeting, iirc they come packaged in opensuse
08:24:12 <b100dian[m]> Or are there any solution for nodejs builds, like access to npm repo?
08:24:22 <b100dian[m]> Rainemak: sure
08:24:25 <rainemak> I have understood that both are your nicks? Is my understanding right.
08:24:49 <rainemak> :nod:
08:25:08 <b100dian[m]> Keto: that would be great!
08:25:32 <Keto> there is also an node/npm service, but that seems a lot more complicated
08:26:07 <b100dian[m]> Oh, _that_ I didnt know/study
08:26:31 <b100dian[m]> Rainemak: yes, both mine
08:26:50 <rainemak> we have few extra minutes that we could allocate to this topic if needed.
08:27:01 <Keto> and I'm not sure how that npm service runs the stuff, and what kind of setup it need
08:27:46 <Keto> so I would go with the download_files service, which is simple and easy to use
08:28:21 <b100dian[m]> Keto: it probably uses package.json But for starters, dowload_files should be good already
08:29:03 <rainemak> Time to move on... we few questions still to cover. Please continue in the generic discussion at the end. Ok?
08:29:10 <b100dian[m]> I think we're good here here on this topic
08:29:16 <rainemak> thanks...
08:29:25 <rainemak> #topic PWA / Web Push notifications (10mins -- asked by vlagged / b100dian)
08:29:25 <rainemak> #info <vlagged / b100dian> Web push notifications are usually available when service workers are.
08:29:25 <rainemak> #info <vlagged / b100dian> This allows a running browser/webview app to get messages from websocket
08:29:25 <rainemak> #info <vlagged / b100dian> connections and pass them to the host OS as native notifications.
08:29:26 <rainemak> #info <vlagged / b100dian>
08:29:28 <rainemak> #info <vlagged / b100dian> Currently sailfish-browser doesn’t pass HTML5 Web Notifications
08:29:30 <rainemak> #info <vlagged / b100dian> Test - Bennish.net (no popup for permission => denied). Is there any
08:29:32 <rainemak> #info <vlagged / b100dian> specific place this could is tweaked to “say no” and where would a
08:29:35 <rainemak> #info <vlagged / b100dian> browser/webview patch need to look at first to enable these?
08:29:37 <rainemak> #link https://developer.mozilla.org/en-US/docs/Web/API/Push_API
08:29:39 <rainemak> #link https://www.bennish.net/web-notifications.html
08:29:46 <rainemak> I could have cleaned that already... sorry
08:30:02 <rainemak> #info <Jolla> Web push notifications need support at least to sailfish-components-webview and
08:30:02 <rainemak> #info <Jolla> embedlite-components and possibly browser or other components but it is not a huge
08:30:02 <rainemak> #info <Jolla> task but still takes quite an amount of work. PWAs i.e. progressive web apps are
08:30:02 <rainemak> #info <Jolla> apps that run using web engine but appear as regular apps and thus need a lot more
08:30:03 <rainemak> #info <Jolla> such as launcher integration, handling of installation/uninstallation and
08:30:05 <rainemak> #info <Jolla> many other changes and therefore is a lot bigger task.
08:30:07 <rainemak> #info <Jolla>
08:30:09 <rainemak> #info <Jolla> In general, progressive web apps are something that we should look in the light
08:30:13 <rainemak> #info <Jolla> of new technology development. Mozilla’s developer network has a good article
08:30:15 <rainemak> #info <Jolla> regarding progressive web apps – worth reading if you’re not familiar with
08:30:17 <rainemak> #info <Jolla> progressive web apps.
08:30:19 <rainemak> #link https://developer.mozilla.org/en-US/docs/Web/Progressive_web_apps
08:31:40 <b100dian[m]> Most of the launcher integration and local database can be done by a sailfish-qml project embedding a webview today, but not the enablement of push notification
08:32:11 <rainemak> b100dian[m], it really depends on how it should be implemented
08:32:37 <rainemak> b100dian[m], browser and webview do not share the same rendering pipeline
08:33:12 <b100dian[m]> I imagine that first step is to find where the permission can be enabled/asked for, which I wasnt able to myself
08:33:21 <b100dian[m]> Then see what needs to be done from there
08:33:28 <rainemak> notification is one part of this
08:33:52 <rainemak> step-by-step approach works but this needs to planning and roadmapping
08:34:01 <b100dian[m]> Probably an event sent to the webview for a notification and integrator app handles it?
08:34:22 <rainemak> for example, how does this align with engine update? a question that we should tackle.
08:35:36 <b100dian[m]> Indeed, I should probably try to build the new engine instead of the current one to debug this, but I still wouldn't know where to start with enabling it.
08:35:54 <rainemak> b100dian[m], I'm not completely sure what you're aiming for. There's some existing work for the web notification that we could look first.
08:36:22 <b100dian[m]> Oh, I didn't know about existing work
08:36:23 <rainemak> b100dian[m], but even that is more complex and should not be overlooked
08:37:03 <b100dian[m]> Is this work in the open?
08:37:07 <rainemak> let's see if we could resurrect that work
08:37:23 <rainemak> should be in open...
08:37:43 <sledges> How Firefox for Android works is receiving WebPush signal from GeckoView engine, and creating Android notification
08:37:52 <rainemak> #action Jolla to check whether we could resurrect past web notification work
08:38:19 <rainemak> sledges, that's the first step that should be implemented
08:38:26 <sledges> Perhaps similar needs implementing in the sailfish-browser (chrome) part
08:38:37 <rainemak> then getting service background works to work is another thing
08:38:51 <rainemak> then getting service background workers to work is another thing
08:39:07 <sledges> Aren't service workers part of GeckoView? That seems to work out of the box in Android somehow:)
08:39:12 <b100dian[m]> I'm interested in the webview + running notifications when an app and it's webview are on. A background service is indeed a more complex matter for sailfish-browers
08:39:30 <b100dian[m]> I think not even desktop browsers notify when not running, am I wrong?
08:39:50 <sledges> b100dian[m]: correct, if you close desktop browser, all bets are off
08:40:00 <rainemak> let's find the old branch
08:40:20 <b100dian[m]> service workers should be a JS worker that is already supported by our gecko
08:40:26 <rainemak> this triggered nice discussion but it's time to move on
08:40:33 <sledges> rainemak: ah now I remember, Firefox for Android sadly relies on Google's Firebase via their own push server
08:40:41 <rainemak> sledges, correct
08:40:49 <sledges> this is how they solve the problem of OOM killer shutting down Firefox browser for Android
08:40:57 <rainemak> Let's move the final question.
08:41:07 <rainemak> #topic New ownership and opensourcing/GPLv3 (10mins -- asked by Zyuc2G)
08:41:07 <rainemak> #info <Zyuc2G> Given SailfishOS proprietary assets are under new ownership, is there any renewed
08:41:07 <rainemak> #info <Zyuc2G> effort to release them under FOSS licensing (in particular Silica)?
08:41:22 <rainemak> #info <Jolla> This question relates to the strategy work of the new Jolla. We will come back
08:41:22 <rainemak> #info <Jolla> to you asking questions. For now, please give us time for the strategy work.
08:42:17 <ExTechOp> What is the expected time scale here?
08:43:01 <rainemak> ExTechOp, too early to say but you'll certainly hear when there's something to share
08:43:18 <Zyuc2G> Sorry you said last question, will nephros's question be asked this week? About the repos that were opensourced and then removed.
08:43:58 <rainemak> Zyuc2G, that wasn't really a question. Let's cover it on the generic.
08:44:41 <rainemak> There was also one 5G question. Unfortunately that came a bit too late. Let's
08:44:41 <rainemak> cover that on the next meeting. Thanks.
08:45:18 <rainemak> #topic Open PR discussion (10 mins -- asked by Jolla)
08:45:26 <rainemak> #info <Jolla> Any open PRs to discuss?
08:46:03 <rainemak> anything
08:47:40 <rainemak> If fine for all, I'd move forward and spare time for generic
08:48:03 <rainemak> going once
08:48:10 <rainemak> going twice
08:48:22 <rainemak> #info <topic> Bug reports by the community bug coordination team (5 min -- asked by thigg)
08:48:22 <rainemak> #link https://forum.sailfishos.org/t/new-role-community-bug-coordinator/10935
08:48:22 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-irc-7th-december-2023/17429/9
08:48:22 <rainemak> #info <thigg> Only got a few items prepared this time
08:48:22 <rainemak> #info <Jolla> As a result of the work, we now have:
08:48:24 <rainemak> #info <Jolla> 1 high quality bug reports now recorded internally and tagged as "tracked"
08:48:25 <rainemak> #info <Jolla> 2 bug reports tagged as fixed.
08:48:27 <rainemak> #info <Jolla> As always, big thanks to the bug coordination team!
08:49:30 <flypig> Great work, but as this is fewer than usual, does that mean that all the bugs are now classified?
08:49:31 <rainemak> not seeing thigg but seeing pherjung[m] <- thanks once again
08:50:17 <rainemak> flypig, cannot be so that all are classified -> I'm having hard time to believe that
08:50:36 <flypig> My too, but it would be the dream :)
08:50:41 <rainemak> Let's move on to the general discussion.
08:50:41 <flypig> *Me too
08:50:47 <rainemak> #topic General discussion (5 min)
08:51:29 <Keto> regarding the browser question, was that about two different things, https://developer.mozilla.org/en-US/docs/Web/API/notification and https://developer.mozilla.org/en-US/docs/Web/API/Push_API ?
08:52:02 <rainemak> Whole PWA is different that web notifications
08:52:14 <flypig> For this topic I was also wondering if this material still looks valid? The page is old, but the links seem to go to more recent and active material.
08:52:15 <flypig> https://wiki.mozilla.org/Firefox/Push_Notifications
08:52:39 <rainemak> I think this is better link to follow https://developer.mozilla.org/en-US/docs/Web/Progressive_web_apps
08:53:23 <flypig> Thanks!
08:53:25 <b100dian[m]> I believe is the "Notification - Web APIs" link that I asked about. Permission to send notifications, created by a servicee worker
08:53:42 <rainemak> Zyuc2G, you asked about the nephros' piggy-back question.
08:54:41 <Zyuc2G> yes, that's right
08:54:54 <nephros> I'm here, and also interested :)
08:55:07 <poetaster> (sorry, very late)
08:55:08 <sledges> b100dian[m]: Web Push is when you close the tab that subscribed you to notifications. Web Notification API is when the tab is still open (a.k.a. In-App notifications)
08:55:11 <rainemak> #info <Jolla> We'll get back to OSS components when time is right.
08:56:18 <rainemak> I could repeat previous answer as well
08:56:28 <nephros> It's fine, thanks.
08:56:34 <rainemak> #info <Jolla> For now, please give us time for the strategy work.
08:56:54 <b100dian[m]> That sounds like a yes, but later?
08:57:30 <rainemak> Strategy work first.
08:58:02 <b100dian[m]> sledges: Web Notifications API is a good first step, for an app packaging a webview. PWAs are an "entire roadmap" work indeed
08:58:12 <nephros> About the topic of PWAs, this work looks interesting: https://github.com/filips123/PWAsForFirefox
08:58:13 <rainemak> b100dian[m], I'll take a personal note regarding those previous web notification branches
08:58:26 <nephros> IT requires newer Mozilla components, but still.
08:58:50 <b100dian[m]> rainemak: thanks!
08:59:36 <rainemak> let's schedule quickly next meeting
08:59:44 <sledges> b100dian[m]: very true
08:59:49 <rainemak> #topic Next meeting time and date (1 min)
08:59:49 <rainemak> Proposing Thursday 21st December at 08:00am UTC.
08:59:49 <rainemak> Is this too close to Christmas break?
09:00:08 <ExTechOp> works4me
09:00:11 <flypig> +1
09:00:27 <poetaster> +1
09:00:44 <rainemak> that's it then
09:00:47 <rainemak> settled
09:00:55 <ExTechOp> Thanks, everyone!
09:00:55 <rainemak> #info Next meeting will be held on Thursday 21st December 2023 at 08:00am UTC: 2023-12-21T0800Z
09:00:58 <rainemak> Thank you everyone for the meeting!
09:01:02 <rainemak> #endmeeting