08:00:11 <rainemak> #startmeeting Sailfish OS, open source, collaboration -- 21st Dec 2023
08:00:11 <sailbot_> Meeting started Thu Dec 21 08:00:11 2023 UTC. The chair is rainemak. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:11 <sailbot_> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:11 <rainemak> #info Meeting information and agenda can be found here:
08:00:11 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-irc-21st-december-2023/17546
08:00:11 <rainemak> I am the meeting's chairperson today, and will be doing my best to keep time and order. Please respect the timings and bee-hive.
08:00:13 <rainemak> #topic Brief introduction (5 min). Please prefix your name/handle with #info
08:01:00 <ViGe> #info Ville Nummela - sailor @ Jolla
08:01:09 <direc85[m]> #info Matti Viljanen - community
08:01:22 <rainemak> #info Raine Mäkeläinen - sailor @ Jolla, chairperson today
08:01:35 <ExTechOp> #info Otto Mäkelä, community
08:01:39 <voidanix[m]> #info voidanix - lurking virtuoso
08:02:18 <rainemak> voidanix[m], you're lurking too much as you raised two good topics.
08:02:22 <rainemak> you're not
08:02:37 <voidanix[m]> ;)
08:02:54 <rubdos[m]> #info Ruben De Smet - community
08:03:12 <flypig> #info David Llewellyn-Jones - community
08:03:33 <Keto> #info Pami Ketolainen - Sailor @ Jolla
08:04:19 <Keto> (in a train, so might be online or not)
08:04:45 <rainemak> Whilst going through introduction, I'm pleased to see good amount of topics raised. Unfortunately two of them were late submissions. Let these two topics drive us to a great start of the next year.
08:05:37 <rainemak> participation goes to community :-)
08:05:46 <rainemak> #topic Status of VoLTE packages availability (10mins -- asked by voidanix)
08:06:01 <rainemak> #info <voidanix> another SFOS release is supposedly behind the corner and many
08:06:01 <rainemak> #info <voidanix> carriers have been shutting down their 3G/2G infrastructures
08:06:01 <rainemak> #info <voidanix> this year. What is blocking Jolla from releasing the (currently
08:06:01 <rainemak> #info <voidanix> proprietary) VoLTE packages to public repositories, similarly
08:06:01 <rainemak> #info <voidanix> to how sailfish-fpd/sailfish-fpd-slave-binder are available,
08:06:02 <rainemak> #info <voidanix> for the next release? Even if possibly incompatible with other
08:06:04 <rainemak> #info <voidanix> devices, they would be of great use with ports whose
08:06:06 <rainemak> #info <voidanix> architecture is close to the ones of the SFOS X supported
08:06:10 <rainemak> #info <voidanix> devices (Qualcomm in general).
08:06:21 <rainemak> Hopefully alignment is better now Keto ;-)
08:06:37 <rainemak> #info <Jolla> Guess you’re referring to public OBS repositories. In theory that
08:06:37 <rainemak> #info <Jolla> should be doable. Difference to sailfish-fpd /
08:06:37 <rainemak> #info <Jolla> sailfish-fpd-slave-binder is that those are based on binder
08:06:37 <rainemak> #info <Jolla> interface whereas VoLTE is not based on similar common interface.
08:06:38 <rainemak> #info <Jolla> Rather being hardware specific. So logically VoLTE belongs to
08:06:40 <rainemak> #info <Jolla> adaptation repository. That said, let’s see what we could do.
08:06:42 <rainemak> #info <Jolla> This was added to our internal issue tracker as well.
08:08:03 <direc85[m]> My first thought was that perhaps a common interface could be built on top of the adaptation packages.
08:08:32 <rainemak> As far as I understand, those VoLTE packages are not necessarily easy make adaptation agnostic
08:08:58 <voidanix[m]> thank you for the update; i raised this because we recently got a FOSS volte implementation on android
08:09:08 <voidanix[m]> you can find the code at https://github.com/phhusson/ims
08:09:17 <rainemak> I vaguely remember that there were some fundamental differences between xperia 10 II and xperia 10 III versions
08:10:23 <nephros> #info Peter G., late community lurker
08:10:25 <rainemak> After next adaptation after xperia 10 III I'd assume that common interface idea would become clearer
08:11:02 <rainemak> #info <<voidanix> Thank you for the update; i raised this because we recently got a FOSS volte implementation on android
08:11:21 <rainemak> #info <voidanix> you can find the code at https://github.com/phhusson/ims
08:11:22 <ExTechOp> rainemak Does this difference have any connection to the way Xperia 10 III does not have functional echo cancellation in voice communication?
08:11:30 <rainemak> #link https://github.com/phhusson/ims
08:11:54 <voidanix[m]> ExTechOp, no, that should be related to broken ACDB
08:11:54 <rainemak> ExTechOp, I doubt it have
08:12:07 <flypig> voidanix[m], the Android implementation looks interesting, but the repo is a bit sparse on details. Is there any more info about it anywhere?
08:12:24 <rainemak> 3 minutes
08:12:43 <voidanix[m]> flypig not yet, the first volte calls on samsung w/ custom ROM were done very recently
08:12:56 <rainemak> voidanix[m], I agree with flypig. Indeed looks interesting.
08:13:09 <voidanix[m]> after it becomes stable, community could use this for ports through some middleware
08:13:09 <flypig> Okay, so I guess it's a work-in-progress. Hopefully more info soon then!
08:14:06 <direc85[m]> Does anyone know if any other FOSS mobile OS has a working VoLTE? Is there a possibility of joining forces?
08:14:07 <rainemak> #info <voidanix> The first volte calls on samsung w/ custom ROM were done very recently with FOSS volte implementation on Android
08:14:45 <voidanix[m]> i have heard ubports was working on it very hard some time ago, no idea what happened to that effort
08:14:46 <flypig> Certainly UBports is working on something, but I'm not sure of the current status.
08:14:53 <rainemak> ub ports had plans some time back but haven't followed that progress
08:15:23 <rainemak> voidanix[m], faster :-)
08:15:33 <flypig> ditto :)
08:16:02 <rainemak> I think that's about it. Good discussion. Thank you.
08:16:16 <rainemak> Let's move on to next topic
08:16:21 <rainemak> #topic Status of OpenSSL (5mins -- asked by voidanix)
08:16:27 <rainemak> #info <voidanix> OpenSSL 1.1.1 has reached EOL in September this year. Is Jolla
08:16:28 <rainemak> #info <voidanix> already working internally on an upgrade to the latest 3.1 (or
08:16:28 <rainemak> #info <voidanix> even better, 3.2) version? If not, should we expect it for the
08:16:28 <rainemak> #info <voidanix> release following the next one?
08:16:39 <rainemak> #info <Jolla> Yes, we’re preparing & working on OpenSSL 3.1 upgrade, and target
08:16:39 <rainemak> #info <Jolla> is to get it for the next release. We have done a great amount of
08:16:39 <rainemak> #info <Jolla> package updates due to various reasons. With the updated packages
08:16:39 <rainemak> #info <Jolla> hopefully, we are not hitting too many builds errors when removing
08:16:39 <rainemak> #info <Jolla> deprecated OpenSSL 1.0 functions. Fixing this is a requirement to
08:16:40 <rainemak> #info <Jolla> go to 3.1. If we miss the next release, then target would be the
08:16:42 <rainemak> #info <Jolla> release after next.
08:18:32 <voidanix[m]> this is awesome, thank you; you guys should consider putting up WIP/draft PRs or just another branch for extra transparency
08:18:43 <direc85[m]> I would like to also poke at Sailfish SDK installer :)
08:19:02 <rubdos[m]> (Whisperfishers are whisteling innocently in the back of the room, vendoring OpenSSL like it's on Christmas sale)
08:19:54 <nephros> BTW, OpenSSL 1.1.1 does get security updates for paying customers. Like Redhat.
08:21:11 <rainemak> Certainly voidanix[m], transparency is good and may inspire others to help with the efforts.
08:21:54 <voidanix[m]> that also prevents these kind of questions on community meetings ;)
08:22:10 <direc85[m]> Happy to hear there's a lot of updates coming up - that means less technical debt!
08:22:15 <rainemak> I think this was a good question
08:22:16 <ViGe> direc85[m]: The SDK installer is a different story. The reason it hasn't been updated (yet) is that it has to work on all three platforms. And switching to a more recent openssl version requires updating ifw, which is always a lot of work.
08:22:41 <rainemak> time to move one...
08:22:48 <rainemak> Next topic is close to me heart as I earlier promised to look into it. Hopefully this time we can unblock the development. Thank you rubdos for pushing this. Let's keep the dialog open. Took a liberty to extend the next topic to 10mins.
08:23:03 <rainemak> #topic cross-packages (10mins -- asked by rubdos and direc85)
08:23:14 <rainemak> #info <rubdos> Since 2022-12-14, several packages (including rust and cargo) have
08:23:14 <rainemak> #info <rubdos> build dependencies on cross-{armv7hl,aarch64}-{gcc,binutils,as,glibc}
08:23:14 <rainemak> #info <rubdos> and some more. I assume some refactoring has been done in the
08:23:14 <rainemak> #info <rubdos> packaging, since before that time, we could build rust etc.
08:23:14 <rainemak> #info <rubdos> ourselves on the Platform SDK. These packages are nowhere to be
08:23:16 <rainemak> #info <rubdos> found, nor can we find a way to build them ourselves, currently.
08:23:17 <rainemak> #info <rubdos> This makes it difficult to contribute patches to Rust (and gcc
08:23:19 <rainemak> #info <rubdos> and gecko, cc flypig), especially in terms of testing the
08:23:21 <rainemak> #info <rubdos> resulting compiler.
08:23:23 <rainemak> #info <rubdos>
08:23:25 <rainemak> #info <rubdos> Would it be possible for Jolla to provide us with some insight,
08:23:27 <rainemak> #info <rubdos> sources and/or binaries for these missing dependencies? We have
08:23:29 <rainemak> #info <rubdos> asked mal on IRC a few times, to which the understandable answer
08:23:31 <rainemak> #info <rubdos> was that he could test the build on OBS. This is however not a
08:23:33 <rainemak> #info <rubdos> sustainable process, especially since we currently don’t get our
08:23:35 <rainemak> #info <rubdos> hands on the resulting 1.72 compiler.
08:23:39 <rainemak> #info <rubdos>
08:23:41 <rainemak> #info <rubdos> rainemak already said in the previous meeting to have a look at
08:23:43 <rainemak> #info <rubdos> this, but I’d like to formalize the request here. Thank you!
08:23:51 <rainemak> #info <Jolla> Short answer, yes it is possible that we provide insight. Whilst we
08:23:51 <rainemak> #info <Jolla> were looking into this we noticed that testing the OBS build was
08:23:51 <rainemak> #info <Jolla> ok. As answer ended up being too long to irc meeting, we posted it
08:23:52 <rainemak> #info <Jolla> to the forum already. That should be a good baseline to continue
08:23:53 <rainemak> #info <Jolla> the discussion.
08:23:55 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-irc-21st-december-2023/17546/11
08:23:57 <rainemak> #info <Jolla>
08:23:59 <rainemak> #info <Jolla> Due to this question, we should create an article to the
08:24:01 <rainemak> #info <Jolla> docs.sailfishos.org out of this explanation. Please do not hesitate
08:24:03 <rainemak> #info <Jolla> to reach for example rainemak in some channel if you’re still
08:24:05 <rainemak> #info <Jolla> facing issues.
08:24:39 <rainemak> I think we should fork the community meeting reply out to a separate thread and continue updating there
08:25:12 <rainemak> alternatively or even parallel, we create the first docs.sailfishos.org article that would be a baseline
08:25:54 <rubdos[m]> Oh I could've done my homework 22 hours ago
08:26:15 <direc85[m]> Same here..!
08:26:29 <rainemak> rubdos[m], I tested on 4.5.0.18 rustc tarball building with the instructions... and at least that looked good
08:26:39 <rainemak> no worries rubdos[m] & direc85[m]
08:27:45 <rubdos[m]> Bit weird that you have to revert the cross compiler buildrequires patch (which I also tried, by they way, but possibly on a too old SDK)
08:27:51 <rubdos[m]> Thanks for the answer!
08:28:22 <rainemak> that cross buildreq is for OBS only
08:28:22 <ViGe> hmm
08:28:27 <rubdos[m]> Maybe it's an idea to keep the README up-to-date with build instructions in the rust repo? I think it'd make even more sense there than on docs.sailfishos.org
08:28:58 <rainemak> idea was that we put also big notes to the spec directly next to the block
08:29:01 <rubdos[m]> rainemak: That's quite unfortunate, honestly. It makes me think that there's a discrepancy between what OBS uses to build vs. what we can use to build.
08:29:11 <rubdos[m]> rainemak: That's a good start I think :)
08:29:40 <rainemak> rubdos[m], this is on the same magnitude level as xulrunner
08:29:58 <rainemak> and some insights are easily needed
08:30:20 <rainemak> rubdos[m], I like the idea of repo README as well
08:30:31 <rainemak> #action <Jolla> Create an article to the docs.sailfishos.org regarding this topic
08:30:42 <direc85[m]> That's quite a reply indeed! I'll have to go through it with though later today and try it out.
08:31:12 <rainemak> It's time to move on
08:31:13 <flypig> Thanks also for linking to the dumb package building instructions. That always causes a mess for me with sfdk.
08:31:31 <rubdos[m]> This sounds like we might have Whisperfish on 1.72 by EONW, that would be very helpful. We might stop shipping OpenSSL 1.1.1 even! Thanks, let's move on :)
08:31:46 <rainemak> Next topic was raised already to the previous meeting by cquence but as a bit late submission. So, let's cover it now.
08:31:46 <rainemak> #topic What are the plans to enable 5G connectivity? (5mins -- asked by TNZ & cquence)
08:32:00 <rainemak> #info <cquence> I remember some work taking place a while ago. Any update you
08:32:00 <rainemak> #info <cquence> can share would be great! P.S. Well done on the restructuring
08:32:00 <rainemak> #info <cquence> and fair winds ahead! I probably won’t be able to attend due to
08:32:00 <rainemak> #info <cquence> work commitments but will read the logs afterwards.
08:32:08 <rainemak> #info <Jolla> There are 3-5 major stories which we’d still like to sort out for
08:32:08 <rainemak> #info <Jolla> the next release and 5G is one of them. So far 5G works on
08:32:08 <rainemak> #info <Jolla> Sailfish OS side but AppSupport plugin is not yet finalized. Half
08:32:09 <rainemak> #info <Jolla> cooked version is bad as that would break mobile data with
08:32:11 <rainemak> #info <Jolla> AppSupport. If we miss the next release, then target would be the
08:32:13 <rainemak> #info <Jolla> release after next.
08:33:06 <rubdos[m]> That's a very concrete and hopeful reply, I would say.
08:33:52 <flypig> Are any of the 5G changes in open repos? I'm just thinking knowing this would help to follow along (I'm assuming the AppSupport changes won't be).
08:34:06 <direc85[m]> That's indeed a motivating reply to read - along with the previous ones!
08:34:59 <rainemak> flypig, I guess some went already in way back
08:35:19 <rainemak> on the enabler side afair
08:35:48 <flypig> rainemak, thanks; I guess there's nothing particular to look at then. But this will be a wonderful update when it drops :)
08:35:56 <rainemak> #link https://github.com/mer-hybris/ofono-binder-plugin/pull/28
08:35:58 <rainemak> for example
08:36:16 <flypig> Nice; thank you!
08:36:36 <rainemak> this is similar https://github.com/sailfishos/ofono/pull/40
08:37:04 <flypig> It looks like magic to me :)
08:38:06 <voidanix[m]> surprised these PRs haven't been mentioned anywhere AFAIK
08:38:10 <rainemak> let's move to the open PR discussion.. we can continue on the general discussion at the end
08:38:24 <flypig> voidanix[m], I'm certain they will have made it into dcaliste's roundups at some point.
08:38:29 <rainemak> I guess damien picked them up back then
08:38:35 <rainemak> :-)
08:38:36 <flypig> :D
08:38:52 <rainemak> #topic Open PR discussion (10 mins -- asked by Jolla)
08:38:52 <rainemak> #info <Jolla> Any open PRs to discuss?
08:39:11 <direc85[m]> rainemak: perhaps #link the second PR too?
08:39:17 <direc85[m]> (a bit late tho)
08:39:20 <rainemak> :-)
08:39:37 <rainemak> direc85[m], I'll relink them to the general
08:41:50 <rainemak> Let's move and safe time for the general discussion...
08:42:03 <rainemak> #info <topic> Bug reports by the community bug coordination team (5 min -- asked by Jolla)
08:42:03 <rainemak> #info <Jolla> No bug reports for this community meeting. Merry Christmas for the
08:42:03 <rainemak> #info <Jolla> whole Community Bug Coordination Team and happy new year! You have
08:42:03 <rainemak> #info <Jolla> done fantastic job the year!
08:42:22 <rainemak> #info <topic> Bug reports by the community bug coordination team (5 min -- asked by Jolla)
08:42:51 <rainemak> sailbot_, huhuu ?
08:43:17 <ExTechOp> He's Dead, Jim.
08:43:21 <rainemak> # Bug reports by the community bug coordination team (5 min -- asked by Jolla)
08:43:24 <rainemak> #topic Bug reports by the community bug coordination team (5 min -- asked by Jolla)
08:43:35 <rainemak> it was my typo
08:43:39 <voidanix[m]> rest in pepperoni sailbot :<
08:43:43 <rainemak> #info <Jolla> No bug reports for this community meeting. Merry Christmas for the
08:43:43 <rainemak> #info <Jolla> whole Community Bug Coordination Team and happy new year! You have
08:43:43 <rainemak> #info <Jolla> done fantastic job the year!
08:44:22 <rainemak> Let's move on to the general discussion.
08:44:27 <rainemak> #topic General discussion (10 min)
08:44:29 <flypig> The Taiga board from the Bug Coordination Team is a sight to behold.
08:44:41 <ExTechOp> Now that we've been informed that several major changes and upgrades have been scheduled for the next release (or the one after that), is there a coarse schedule of when releases would occur?
08:44:53 <rainemak> #info Some 5G related PRs
08:44:54 <rainemak> #link https://github.com/sailfishos/ofono/pull/40
08:44:54 <rainemak> #link https://github.com/mer-hybris/ofono-binder-plugin/pull/28
08:44:54 <rainemak> #link https://github.com/sailfishos/libqofonoext/pull/3
08:44:54 <rainemak> #link https://github.com/sailfishos/libgofono/pull/2
08:44:59 <flypig> Let me just say what a phenomenal job the BCT done through the entire year. I take my hat off to them.
08:45:31 <ViGe> rainemak: Also this: https://github.com/mer-hybris/libgbinder-radio/pull/27
08:45:32 <rainemak> ExTechOp, what I have learned is that whatever I'd say aloud it will get misinterpreted
08:46:14 <rainemak> ExTechOp, Thus, better not to say even a coarse schedule regarding the release
08:46:29 <ExTechOp> Failing that, is there even a meta-date when you'd be able to tell when the next release is due?
08:46:32 <flypig> Thanks for all those links; that's quite a collection.
08:46:38 <flypig> From the 5G discussion, I'm just now discovering (from looking at the code) that "5G NR" stands for "New Radio" (as opposed to 4G LTE = Long Term Evolution"). Makes me wonder what the acronym for 6G will be!
08:46:39 <ViGe> the release will occur when it's ready ;)
08:46:44 <rainemak> ExTechOp, funny
08:46:54 <rainemak> #info <Jolla> If you’re interested in testing CLAT with latest changes, please
08:46:54 <rainemak> #info <Jolla> read from here https://forum.sailfishos.org/t/testing-clat-for-ipv6-only-mobile-networks/14520/175
08:46:54 <rainemak> #link https://forum.sailfishos.org/t/testing-clat-for-ipv6-only-mobile-networks/14520/175
08:47:29 <rainemak> #info <Jolla> The release will occur when it's ready ;)
08:47:54 <flypig> We'll hold you to that!
08:48:52 <ExTechOp> By the way, I'd like to say thank you to the Jolla/Jollyboys team for staying through these difficult times, and hopefully 2024 will be more steady sailing through calmer waters!
08:48:58 <rainemak> Generally and frankly speaking, everybody is behaving well in the community meetings
08:49:23 <rainemak> and tone of voice is good I think
08:50:23 <rainemak> #info <Jolla> We wish you all Merry Christmas and Happy new year! This is the last community meeting of this year.
08:50:50 <direc85[m]> I'm interested in the Rust update: There's 1.61.0 in master already so that's given, are there plans to get 1.72.1 merged for the next/next+1 release? If we can compile it ourselves now, that's more than enough really, just bumping that PR up (I typed too slow earlier)
08:50:50 <rubdos[m]> Have a great end of year, all of you! Thanks for the meeting :)
08:50:59 <flypig> ExTechOp, totally agreed. Thanks to all the Jolla/Jollyboys team for all of your hard work this year.
08:51:56 <rainemak> direc85[m], I think we shouldn't rule out rust update from the next release - window is still open let's say
08:53:04 <rainemak> direc85[m], given that xulrunner builds fine against newer rust (1.72.1 even) and works and your tests are all fine => Probably could go in.
08:53:32 <rainemak> xulrunner being the only platform dependency
08:53:45 <direc85[m]> Great news!
08:53:57 <rubdos[m]> I might try rebasing on 1.73/1.74 then even, because that will even ship an edition update iirc
08:54:04 <rubdos[m]> That could be worth the effort...
08:54:17 <rubdos[m]> Great news either way!
08:54:34 <direc85[m]> Wasn't there LLVM update required too?
08:54:42 <rainemak> rubdos[m], once there's something that builds, I can webhook it to the OBS
08:54:56 <rainemak> I think mal poken LLVM update at point
08:54:58 <direc85[m]> Oh, it's already at 14. Nice!
08:55:33 <rubdos[m]> that, and I have LLVM 15 and 16 laying around iirc
08:55:49 <rainemak> Before final merry xmas wishes... let's schedule next community meeting
08:55:51 <direc85[m]> Yes, those PR's are ready :)
08:56:07 <rainemak> #topic Next meeting time and date (5 mins)
08:56:31 <rainemak> Proposing Thursday 11th January at 08:00am UTC.
08:57:16 <ExTechOp> Works4Me. I guess 2024-01-04 is too early, people still on Christmas vacation?
08:57:21 <direc85[m]> That works for me
08:57:28 <rainemak> We have community newsletter planned for 4th Jan which might be a stretched goal.
08:58:42 <rainemak> ExTechOp, that was exactly behind thinking as well
08:58:53 <flypig> I'm hoping for a flurry of app development over the Christmas break to go in the newsletter :)
09:00:01 <ExTechOp> I've said this before, it'd be nice to have mosh available on Chum :-D
09:00:01 <rainemak> sounds that we have a date for the first 2024 community meeting
09:00:24 <rainemak> #info Next meeting will be held on Thursday 11th January 2023 at 08:00am UTC: 2024-01-11T0800Z
09:00:57 <ExTechOp> Thank you, everyone!
09:01:13 <rainemak> I want to thank you all on my behalf for this year! What a great community we have here!
09:01:14 <flypig> Thank you rainemak, all!
09:01:33 <voidanix[m]> ditto, thanks for the meeting and merry xmas+happy new year
09:01:34 <direc85[m]> Thank you! What a nice ending to the year!
09:01:46 <flypig> Yes, same. Merry Christmas everyone! Roll on 2024!
09:02:38 <ViGe> Merry Christmas everyone! And a note to Santa, as you are reading the meeting notes, please take a note on how well everyone here behaves!
09:02:48 <direc85[m]> Merry Christmas everyone! Let 2024 come, we're ready for it :)
09:03:16 <rainemak> #endmeeting