#sailfishos-meeting: Sailfish OS, open source, collaboration -- 14th March 2024

Meeting started by rainemak at 08:00:00 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: (rainemak, 08:00:00)
    2. https://forum.sailfishos.org/t/community-meeting-on-14th-march-2024/18132 (rainemak, 08:00:00)

  1. Brief introduction (5 min). Please prefix your name/handle with #info (rainemak, 08:00:00)
    1. Raine Mäkeläinen, sailor @ Jolla, chairperson today (rainemak, 08:00:40)
    2. nephros, community desktop portal poodle (nephros, 08:00:46)
    3. Ville Nummela - community (ViGe, 08:00:54)
    4. tuplasuhveli, community (tuplasuhveli[m], 08:01:12)
    5. Andrew Branson, sailing by (abr, 08:01:15)
    6. voidanix - community, i think (voidanix[m], 08:01:21)
    7. David Llewellyn-Jones, community (flypig, 08:01:30)
    8. Pekka Vuorela, Jolla (pvuorela, 08:01:46)
    9. Jetset (Jetset, 08:03:15)
    10. Matti Viljanen, community (direc85[m], 08:03:44)
    11. Crabster - lurker (Crabster, 08:03:56)

  2. Increased root partition size on older devices (5mins -- asked by jojomen) (rainemak, 08:05:08)
    1. <jojomen> There are numerous threads here and in the old forum about people (rainemak, 08:05:20)
    2. <jojomen> running into trouble after filling up their root partition. (rainemak, 08:05:20)
    3. <jojomen> @olf has written a good guide on resizing it. However, it’s (rainemak, 08:05:20)
    4. <jojomen> tedious work on top of the already somewhat convoluted flashing (rainemak, 08:05:20)
    5. <jojomen> procedure, and low-level work on the storage config can be scary. (rainemak, 08:05:20)
    6. <jojomen> (rainemak, 08:05:21)
    7. <jojomen> Link to guide, that also has some links to forum topics about (rainemak, 08:05:23)
    8. <jojomen> resizing: (rainemak, 08:05:25)
    9. https://forum.sailfishos.org/t/problems-when-trying-to-resize-the-root-partition/10563/12 (rainemak, 08:05:27)
    10. <jojomen> Having the SFOS installation image default to a 4 GB root (rainemak, 08:05:30)
    11. <jojomen> partition (same as newer devices) would make things easier, and - (rainemak, 08:05:32)
    12. <jojomen> as olf’s guide points out - an SD card can compensate for the 1.5 (rainemak, 08:05:34)
    13. <jojomen> GB lost from the home partition. (rainemak, 08:05:36)
    14. <jojomen> (rainemak, 08:05:38)
    15. <jojomen> Would Jolla consider making this change or, if not, what are the (rainemak, 08:05:40)
    16. <jojomen> key factors against it? (rainemak, 08:05:42)
    17. <jojomen> (rainemak, 08:05:44)
    18. <jojomen> A comment from olf (rainemak, 08:05:48)
    19. <jojomen> …, but not automatically altering partition sizes on extant (rainemak, 08:05:50)
    20. <jojomen> SailfishOS installations. (rainemak, 08:05:52)
    21. <jojomen> (rainemak, 08:05:54)
    22. <jojomen> IMO, this simply requires changing two characters in a (rainemak, 08:05:56)
    23. Otto Mäkelä. community (ExTechOp, 08:05:58)
    24. <jojomen> configuration file and no extra quality assurance beyond review (rainemak, 08:05:58)
    25. <jojomen> and checking for typos, because the space on internal mass storage (rainemak, 08:06:00)
    26. <jojomen> (FLASH memory) is always sufficient for this on all supported (rainemak, 08:06:02)
    27. <jojomen> Xperia models. (rainemak, 08:06:04)
    28. <jojomen> (rainemak, 08:06:06)
    29. <jojomen> This measure would alleviate a very common failure mode for (rainemak, 08:06:08)
    30. <jojomen> SailfishOS upgrades and installing SailfishOS-native software: no (rainemak, 08:06:10)
    31. <jojomen> space left on root volume. (rainemak, 08:06:12)
    32. <Jolla> Let’s start from the problem. We’d like to first understand how (rainemak, 08:06:18)
    33. <Jolla> people end up running out space. What’s causing it? There shouldn’t (rainemak, 08:06:20)
    34. <Jolla> be anything blocking to increase root partition size for older (rainemak, 08:06:22)
    35. <Jolla> devices but only for flashable image (no resizing during upgrade). (rainemak, 08:06:24)
    36. <Jolla> Something similar that we did for newer devices. (rainemak, 08:06:26)
    37. <Jolla> (rainemak, 08:06:28)
    38. <Jolla> There are few scenarios that are easy to foresee / understand. (rainemak, 08:06:30)
    39. <Jolla> (rainemak, 08:06:32)
    40. <Jolla> From platform developer point of view root partition size can be (rainemak, 08:06:34)
    41. <Jolla> problematic especially if you’re working on large project(s) and (rainemak, 08:06:36)
    42. <Jolla> need debug symbols. First thing is to toggle on “Settings -> (rainemak, 08:06:38)
    43. <Jolla> Developer Mode -> Store debug symbols to home (rainemak, 08:06:40)
    44. <Jolla> partition” (alternative you can install package (rainemak, 08:06:42)
    45. <Jolla> jolla-developer-mode-home-debug-location). This way debug symbols (rainemak, 08:06:44)
    46. <Jolla> won’t consume space from root partition. (rainemak, 08:06:48)
    47. <Jolla> (rainemak, 08:06:50)
    48. <Jolla> Secondly using alternative Sailfish app stores might cause (rainemak, 08:06:52)
    49. <Jolla> problems. Of course, also just installing tons of apps. (rainemak, 08:06:54)
    50. <Jolla> (rainemak, 08:06:56)
    51. <Jolla> For apps we are considering something like /opt/apps/<app-name>/ (rainemak, 08:06:58)
    52. <Jolla> application root path that would be out of root partition. Under (rainemak, 08:07:00)
    53. <Jolla> this application root path, developers should still use & follow (rainemak, 08:07:02)
    54. <Jolla> Filesystem Hierarchy Standard (FHS) for example like: (rainemak, 08:07:04)
    55. <Jolla> (rainemak, 08:07:06)
    56. <Jolla> /opt/apps/<app_name>/usr/bin/<app_name> (rainemak, 08:07:08)
    57. <Jolla> /opt/apps/<app_name>/usr/share/<app_name>/ (rainemak, 08:07:10)
    58. <Jolla> /opt/apps/<app_name>/usr/share/applications/<app_name>.desktop (rainemak, 08:07:12)
    59. <Jolla> (rainemak, 08:07:14)
    60. <Jolla> There are two related goals that should be kept in mind: (rainemak, 08:07:18)
    61. <Jolla> 1) apps should not be installed to the root partition (rainemak, 08:07:20)
    62. <Jolla> 2) root partition should eventually be readonly (rainemak, 08:07:22)
    63. <Jolla> (rainemak, 08:07:24)
    64. <Jolla> If both of these would be met, then size of root partition would (rainemak, 08:07:26)
    65. <Jolla> not be that big of an issue. For time being maybe we just adjust (rainemak, 08:07:28)
    66. <Jolla> root partition for the older devices – we’ll comment this more a (rainemak, 08:07:30)
    67. <Jolla> bit later. (rainemak, 08:07:32)
    68. Björn Bidar - Sailor @ Jolla (Thaodan, 08:13:26)
    69. Extended topic by 5mins (rainemak, 08:14:34)
    70. Damien Caliste, community (dcaliste, 08:17:56)

  3. RCS Messenging (5mins -- asked by Cryx) (rainemak, 08:20:28)
    1. <jojomen> RCS seems to be at least the new Standard as Apple jumps on that (rainemak, 08:20:39)
    2. <jojomen> train too (forced by the DMA of course…). On the long road RCS (rainemak, 08:20:39)
    3. <jojomen> will be the successor of SMS/MMS services. What’s the status for (rainemak, 08:20:39)
    4. <jojomen> RCS support on Sailfish OS? (rainemak, 08:20:39)
    5. <jojomen> (rainemak, 08:20:39)
    6. <jojomen> We brought that topic on from time to time here in the forum (not (rainemak, 08:20:41)
    7. <jojomen> just my me…), but it seems we never had that in a community (rainemak, 08:20:42)
    8. <jojomen> meeting. So, the main questions are if there was any (rainemak, 08:20:44)
    9. <jojomen> thinking/investigation if and how these services could be added (rainemak, 08:20:48)
    10. <jojomen> to SFOS. (rainemak, 08:20:50)
    11. <jojomen> (rainemak, 08:20:52)
    12. <jojomen> To my mind it’s an interesting topic to also now if this might be (rainemak, 08:20:54)
    13. <jojomen> possible as an implemented always on service like phone and SMS (rainemak, 08:20:56)
    14. <jojomen> (as, we all know that other native messengers need to run in (rainemak, 08:20:58)
    15. <jojomen> background to receive messages). (rainemak, 08:21:00)
    16. <jojomen> (rainemak, 08:21:02)
    17. <jojomen> As said above I’ll probably won’t make it into the meeting, but (rainemak, 08:21:04)
    18. <jojomen> in fact I’m just user and no dev and might not really help in the (rainemak, 08:21:06)
    19. <jojomen> discussion at all. (rainemak, 08:21:08)
    20. <Jolla> Thank pherjung for your checking what other distributions are doing (rainemak, 08:21:10)
    21. <Jolla> to enable Rich Communication Services (RCS). No findings. (rainemak, 08:21:12)
    22. <Jolla> (rainemak, 08:21:14)
    23. <Jolla> Apple’s jump was not forced by Digital Markets Act (DMA) as (rainemak, 08:21:18)
    24. <Jolla> iMessage was not deemed as gatekeeper by the European Commission. (rainemak, 08:21:20)
    25. <Jolla> Actually, Rich Communication Services (RCS) is not even mentioned (rainemak, 08:21:22)
    26. <Jolla> there. (rainemak, 08:21:24)
    27. https://ec.europa.eu/commission/presscorner/detail/en/mex_24_785 (rainemak, 08:21:26)
    28. <Jolla> (rainemak, 08:21:28)
    29. <Jolla> The Rich Communication Services (RCS) has been “coming” around 15 (rainemak, 08:21:30)
    30. <Jolla> years. Maybe now with Apple’s push it could really lift off and (rainemak, 08:21:32)
    31. <Jolla> GSMA will agree on standard. That said, it’s still a phone carrier (rainemak, 08:21:34)
    32. <Jolla> protocol just like SMS with similar security model. (rainemak, 08:21:36)
    33. https://en.wikipedia.org/wiki/Rich_Communication_Services (rainemak, 08:21:38)
    34. https://www.eff.org/deeplinks/2024/01/what-apples-promise-support-rcs-means-text-messaging (rainemak, 08:21:40)
    35. <Jolla> (rainemak, 08:21:43)
    36. <Jolla> We have been looking into this but so far always seen this as not (rainemak, 08:21:45)
    37. <Jolla> yet mandatory. Effort wise this is huge. Whether RCS would be (rainemak, 08:21:49)
    38. <Jolla> compatible with current messaging architecture is another big (rainemak, 08:21:51)
    39. <Jolla> topic. (rainemak, 08:21:53)
    40. <Jolla> Further, we should think & compare RCS to Signal for example. (rainemak, 08:21:55)
    41. <Jolla> Could/Should we somehow facilitate deeper Whisperfish integration – (rainemak, 08:21:57)
    42. <Jolla> maybe we should? (rainemak, 08:21:59)

  4. XDG Desktop Portals (10mins -- asked by nephros) (rainemak, 08:30:50)
    1. <nephros> Sorry for the wall-of text below. Most of it is informational (rainemak, 08:30:50)
    2. <nephros> -only/General Discussion, specific questions to Jollyboys in (rainemak, 08:30:50)
    3. <nephros> Part 2, below. (rainemak, 08:30:50)
    4. <Jolla> Too long post, so here’s a link to the post: (rainemak, 08:30:50)
    5. https://forum.sailfishos.org/t/community-meeting-on-14th-march-2024/18132/7 (rainemak, 08:30:51)
    6. <Jolla> Part 1 Informational: State of the PoC (rainemak, 08:31:36)
    7. <Jolla> Good to see progress! (rainemak, 08:31:36)
    8. <Jolla> Part 2 Questions to Jollyboys (rainemak, 08:31:36)
    9. <Jolla> a) Regarding naming, we’d propose to go with Sailfish as the (rainemak, 08:31:36)
    10. <Jolla> implementation will eventually be Sailfish OS specific. Whilst this (rainemak, 08:31:36)
    11. <Jolla> link regarding coding conventions points to apps it applies well (rainemak, 08:31:37)
    12. <Jolla> for platform development as well. (rainemak, 08:31:39)
    13. https://docs.sailfishos.org/Develop/Apps/Coding_Conventions/ (rainemak, 08:31:41)
    14. <Jolla> So, D-Bus names org.sailfishos -prefix, use namespace Sailfish (rainemak, 08:31:43)
    15. <Jolla> Amber is meant for platform agnostic components. (rainemak, 08:31:45)
    16. <Jolla> (rainemak, 08:31:49)
    17. <Jolla> b) At this point LGPLv3+ is still problematic. If plausible, would (rainemak, 08:31:51)
    18. <Jolla> be simpler to rewrite those sources pulling in LGPLv3+ and go with (rainemak, 08:31:53)
    19. <Jolla> a compatible license. (rainemak, 08:31:55)
    20. <Jolla> (rainemak, 08:31:57)
    21. <Jolla> c) It should go to /var/lib/environment/nemo/[dd]-name.conf that (rainemak, 08:31:59)
    22. <Jolla> then gets included by user@.service (rainemak, 08:32:01)
    23. <Jolla> (rainemak, 08:32:03)
    24. <Jolla> d) Sounds like PartOf=user-session.target might be applicable. (rainemak, 08:32:05)
    25. <Jolla> Alternatively: Many services (e.g. ngfd) utilize “preinstalled” (rainemak, 08:32:07)
    26. <Jolla> WantedBy= user-session.target symlinks in (rainemak, 08:32:09)
    27. <Jolla> user-session.target.wants -directory. (rainemak, 08:32:11)
    28. <Jolla> (rainemak, 08:32:13)
    29. <Jolla> e) Not really at this point (rainemak, 08:32:17)
    30. <Jolla> (rainemak, 08:32:19)
    31. <Jolla> Part 3 Questions to everybody (rainemak, 08:32:21)
    32. <Jolla> 1. Given that license is sorted out we could take this to the (rainemak, 08:32:23)
    33. <Jolla> github.com/sailfishos (rainemak, 08:32:25)
    34. <Jolla> 2. Other important things to add? (rainemak, 08:32:27)
    35. <Jolla> (rainemak, 08:32:29)
    36. <Jolla> Part 4 Informational: Future outlook and challenges (rainemak, 08:32:31)

  5. Release of adaptation repos for devices dropped in SFOS 4.6 (2-3mins -- asked by nephros) (rainemak, 08:41:06)
    1. <nephros> Any chance of making available the necessary materials needed for (rainemak, 08:41:13)
    2. <nephros> community ports of devices whose support has been dropped for (rainemak, 08:41:13)
    3. <nephros> SFOS 4.6? (rainemak, 08:41:13)
    4. <nephros> (rainemak, 08:41:13)
    5. <nephros> Community porters may be able to continue support for older (rainemak, 08:41:13)
    6. <nephros> devices if enabled to do so. (rainemak, 08:41:15)
    7. <nephros> (rainemak, 08:41:18)
    8. <nephros> It would also be a nice legacy for the Jolla Tablet if it could (rainemak, 08:41:20)
    9. <nephros> live on a bit, something that was unfortunately not possible for (rainemak, 08:41:22)
    10. <nephros> the original Jolla phone. (Although I fear, of all the dropped (rainemak, 08:41:24)
    11. <nephros> devices, the chance for getting the Tablet materials is the (rainemak, 08:41:26)
    12. <nephros> slimmest.) (rainemak, 08:41:28)
    13. <Jolla> Jolla C & Tablet are tricky as there were some proprietary sources. (rainemak, 08:41:30)
    14. <Jolla> Sony Xperia X repositories are already available. (rainemak, 08:41:32)

  6. Migrating alphabetical scrollbar to Silica (10mins -- asked by tuplasuhveli) (rainemak, 08:43:17)
    1. <tuplasuhveli> This idea rose from a conversation regarding Flowplayer 2, (rainemak, 08:43:29)
    2. <tuplasuhveli> but other SFOS apps could also benefit from the neat (rainemak, 08:43:29)
    3. <tuplasuhveli> scrollbar presented in SFOS People app. Could Jolla consider (rainemak, 08:43:29)
    4. <tuplasuhveli> adding the scrollbar into the Silica components? (rainemak, 08:43:29)
    5. https://github.com/sailfishos-applications/flowplayer (rainemak, 08:43:29)
    6. <Jolla> Yes, this could well be something to consider. It has some (rainemak, 08:43:38)
    7. <Jolla> references to contacts that should be cut before it could be even (rainemak, 08:43:38)
    8. <Jolla> considered to be moved to Silica. Very good suggestion! Needs more (rainemak, 08:43:38)
    9. <Jolla> thinking and planning. (rainemak, 08:43:38)

  7. Qt version (5mins -- asked by KeeperoftheKeys) (rainemak, 08:45:06)
    1. <KeeperoftheKeys> Sorry if this was recently discussed - I was just looking (rainemak, 08:45:10)
    2. <KeeperoftheKeys> up some documentation on certain QML elements and (rainemak, 08:45:10)
    3. <KeeperoftheKeys> realized that the oldest version of Qt that still has (rainemak, 08:45:10)
    4. <KeeperoftheKeys> documentation available is 5.15, while the Sailfish (rainemak, 08:45:10)
    5. <KeeperoftheKeys> documentation is very far from complete and relies on the (rainemak, 08:45:10)
    6. <KeeperoftheKeys> official Qt documentation. Though the documentation (rainemak, 08:45:11)
    7. <KeeperoftheKeys> thankfully still notes when things were added all in all (rainemak, 08:45:13)
    8. <KeeperoftheKeys> the situation to continue developing on much older (rainemak, 08:45:17)
    9. <KeeperoftheKeys> versions is getting worse also from the point of view of (rainemak, 08:45:19)
    10. <KeeperoftheKeys> being able to open docs and understanding what behaviour (rainemak, 08:45:21)
    11. <KeeperoftheKeys> should be. (rainemak, 08:45:23)
    12. <Jolla> You can find Qt 5.6 documentation here. (rainemak, 08:45:25)
    13. https://doc.qt.io/archives/qt-5.6/index.html (rainemak, 08:45:27)

  8. Open PR discussion (5 mins -- asked by Jolla) (rainemak, 08:46:12)
    1. <Jolla> Any open PRs to discuss? (rainemak, 08:46:17)
    2. ACTION: Check voidanix[m] comment, talking about backporting, what about kernel upgrades? https://github.com/mer-hybris/android_kernel_sony_msm/pull/136 (rainemak, 08:51:46)

  9. General discussion (6 min) (rainemak, 08:52:28)
    1. https://docs.sailfishos.org/Develop/L10n/#coordinators (rainemak, 08:52:45)
    2. https://forum.sailfishos.org/t/sailfish-community-news-7th-march-2024-eula/18184 (rainemak, 08:57:17)

  10. Next meeting time and date (1 mins) (rainemak, 08:59:35)
    1. Next meeting will be held on Thursday 28th March 2024 at 08:00am UTC: 2024-03-28T0800Z (rainemak, 09:01:25)


Meeting ended at 09:01:30 UTC (full logs).

Action items

  1. Check voidanix[m] comment, talking about backporting, what about kernel upgrades? https://github.com/mer-hybris/android_kernel_sony_msm/pull/136


Action items, by person

  1. voidanix[m]
    1. Check voidanix[m] comment, talking about backporting, what about kernel upgrades? https://github.com/mer-hybris/android_kernel_sony_msm/pull/136


People present (lines said)

  1. rainemak (276)
  2. Thaodan (39)
  3. nephros (24)
  4. abr (20)
  5. direc85[m] (18)
  6. voidanix[m] (14)
  7. flypig (12)
  8. ExTechOp (10)
  9. ViGe (4)
  10. sailbot (2)
  11. tuplasuhveli[m] (2)
  12. dcaliste (2)
  13. pvuorela (1)
  14. Jetset (1)
  15. Crabster (1)
  16. sebix[m] (1)
  17. piggz (1)


Generated by MeetBot 0.1.4.