08:00:15 <rainemak> #startmeeting Sailfish OS, open source, collaboration -- 16th January 2025
08:00:15 <sailbot> Meeting started Thu Jan 16 08:00:15 2025 UTC. The chair is rainemak. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:15 <sailbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:27 <rainemak> #info Meeting information and agenda can be found here:
08:00:27 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-16th-january-2025/21489
08:00:27 <rainemak> I am the meeting's chairperson today, and will be doing my best to keep time and order. Please respect the timings and bee-hive.
08:00:27 <rainemak> #topic Brief introduction (5 min). Please prefix your name/handle with #info
08:00:37 <rainemak> #info Raine Mäkeläinen, Jolla
08:01:00 <tfinn> #info tfinn , Community
08:02:46 <flypig> #info David Llewellyn-Jones, Community
08:03:12 <direc85[m]> #info Matti Viljanen, Jolla
08:03:25 <direc85[m]> and good morning
08:03:31 <pvuorela> #info Pekka Vuorela, Jolla
08:03:58 <abr> #info Andrew Branson, sailing by
08:04:38 <rainemak> #info Happy new year 2025. 1st community meeting of the year!
08:05:29 <rainemak> let's get going
08:05:36 <rainemak> #topic WPA3 Support any plans/news? (5-10 mins -- asked by tfinn)
08:05:44 <rainemak> #info <tfinn> Support for WPA3 in Sailfisch OS are there any plans for it at
08:05:44 <rainemak> #info <tfinn> all? Would be useful to know, because the use of WPA3 is increasing.
08:05:44 <rainemak> #link https://forum.sailfishos.org/t/does-sailfishos-not-support-wpa3/17980
08:06:03 <rainemak> #info <Jolla> The WPA3 support has not been worked on actively. However,
08:06:03 <rainemak> #info <Jolla> Simultaneous Authentication of Equals (SAE), WPA3-Personal is
08:06:03 <rainemak> #info <Jolla> enabled in the wpa_supplicant. It is not yet supported in connman.
08:06:03 <rainemak> #info <Jolla> On top of that we need user interface integration.
08:06:03 <rainemak> #info <Jolla>
08:06:06 <rainemak> #info <Jolla> As you are rightfully noting that use of WPA3 is increasing, we
08:06:08 <rainemak> #info <Jolla> should consider finalizing WPA3 support. Good input for planning.
08:06:10 <rainemak> #link https://github.com/sailfishos/wpa_supplicant/blob/master/rpm/build-config#L252
08:09:51 <direc85[m]> I have a WPA2+WPA3 mixed config on my home WLAN, and will have for a long time...
08:10:22 <tfinn> Yeah I also have it configured this way after finding out that WPA § is not supported
08:10:36 <tfinn> *3
08:12:39 <flypig> How much of this could be contributed to by the community? Is it fair to say that the connman support could be (all open source), but the UI changes maybe not (some non-QML closed source)?
08:13:09 <rainemak> flypig, that's a correct assessment
08:14:05 <rainemak> I didn't manage to get details regarding what's missing from connman
08:14:21 <flypig> It would be interesting to know if it's supported by upstream connman.
08:14:33 <flypig> The connman side could be looked at without the UI I think (can probably be tested using dbus), so there's scope to do something as a community here. Given time and energy!
08:15:57 <rainemak> correct... I think it's exactly like that. D-Bus version could already be used for testing but surely UI could show misleading infos... but testable
08:17:06 <rainemak> we should open more details in https://forum.sailfishos.org/t/does-sailfishos-not-support-wpa3/17980 on what's actually missing and what kind of an approach could be taken
08:18:18 <rainemak> I'll give 5 extra mins for this topic... so ending in 2mins
08:20:16 <dcaliste> #info Damien Caliste, community
08:20:21 <rainemak> #action Elaborate missing wpa3 support bits on connman @  https://forum.sailfishos.org/t/does-sailfishos-not-support-wpa3/17980
08:20:28 <dcaliste> Sorry to be late…
08:20:32 <rainemak> no worry
08:20:39 <rainemak> let's move to open PRs
08:20:42 <rainemak> #topic Open PR discussion (5 mins -- asked by Jolla)
08:21:54 <rainemak> anything dcaliste, flypig, pvuorela, direc85[m], abr, others ?
08:21:58 <dcaliste> Just would like to thank pvuorela for his work on https://github.com/sailfishos/messagingframework/pull/20 about upstream SSO integration.
08:22:53 <pvuorela> dcaliste: bigger thanks to you, you've been the one actually doing it :) great stuff!
08:23:40 <dcaliste> Yeh, but I highly appreciate your reviews and suggestions. Hopefully I'm not introducing too many regressions…
08:25:16 <flypig> That looks like a lot of work from both of you!
08:27:16 <rainemak> let's move to general discussion
08:27:20 <rainemak> #topic General discussion (10 mins)
08:27:45 <tfinn> I would have some suggestions for Jolla if someone could please take them to the right people.
08:27:46 <dcaliste> flypig: still remains the libaccount patch to be sorted out how to somehow mix it with upstream, and after we'll just have some localised patches remaining in Sailfish OS integration.
08:27:59 <tfinn> It would also be good if you could communicate a little bit about what decisions led to using Android 14 and on the current plans or status for The Xperia 10 IV and Xperia 10 V. There are some people on the Forums just annoyed by not being given any Info or enough.
08:28:06 <tfinn> It would also help if you could give some info or clarification out, in a better way that the Jolla Mind 2 is not taking away People who are working on Sailfish OS and that the Venho AI Team is all new People. Because you just don’t know it clearly if you don’t look into it. (Correct me if I’m wrong)
08:28:32 <rainemak> tfinn, sorry to say but there's newer enough info
08:28:58 <tfinn> Yeah I know but not clearly visible if you are not looking for it
08:29:33 <rainemak> s/newer/never/
08:29:45 <flypig> dcaliste, good luck with all those changes. It sounds like a good outcome in the works.
08:30:07 <rubdos[m]> Another motion from me to have Jolla publish an updated ICS file to import in our calendar applications to display community meetings and other important events.
08:30:11 <rainemak> tfinn, that Sony 10 IV and 10 V saga is indeed annoying.
08:30:32 <rubdos[m]> #info Ruben De Smet, community
08:30:56 <rainemak> Anybody going to FOSDEM?
08:31:15 <rainemak> We should organize a community meetup. Would somebody like to help organizing -- something simple?
08:31:18 <rubdos[m]> o/
08:31:32 <flypig> rudbos[m], do you know of good services for providing a public calendar like that (that isn't Google Calendar)?
08:32:03 <rubdos[m]> flypig: https and an ICS file would probably suffice as a public interface
08:32:38 <flypig> Yes, I'll be at FOSDEM; really looking forward to it.
08:32:40 <rubdos[m]> but e.g. a nextcloud instance can be used to manage such thing, I'd say. Or someone with Thunderbird that pushes the export button now and then
08:32:47 <rubdos[m]> I'll be on FOSDEM on saturday only
08:33:39 <flypig> We'll have Sailfish on the Linux on Mobile Stand (K1-C-6); please come say Hi if you're around!
08:34:54 <rubdos[m]> absolutely, that's the number one attraction for me :)
08:35:57 <flypig> Good to hear it! I'll be evangelising about Whisperfish of course as well :)
08:36:13 <flypig> (sorry for mistyping your handle earlier rubdos).
08:36:30 <rubdos[m]> Don't worry about my silly nick :'-)
08:36:46 <dcaliste> For general information, pvuorela and I have been contacted by people from UBPort (Mike Gabriel and Guido Berhörster). They are integrating Dekko (a mail client based on an old fork of QMF) into Debian and would like to rebase on upstream version of QMF.
08:37:23 <rubdos[m]> that ics file could, for example, also have an entry for the FOSDEM Linux-on-Mobile stand, and any event that is organised around FOSDEM
08:37:48 <abr> what no fosdem app this year? :)
08:38:05 <flypig> Oh, yes, I still had the fosdem app on my task list.
08:38:05 <dcaliste> That's a good news in my opinion about having a second consumer for QMF. They are already reporting issues and trying to find upstreamable fix for them.
08:38:06 <direc85[m]> Ruben, that starts to sound like a Sailfish Community Calendar :)
08:38:24 <rubdos[m]> That's exactly what I'm after!
08:38:37 <flypig> Does discourse have a calendar that anyone could contribute to?
08:38:38 <abr> that's a good idea. get these meetings on it too.
08:39:03 <abr> as it's read only, it really could just be an exported ics on an http server somewhere
08:39:12 <rubdos[m]> yes yes yes! Exactly! :-)
08:39:18 <abr> keep it simple etc
08:39:24 <rubdos[m]> amen to that!
08:39:32 <rubdos[m]> and I won't miss community meetings anymore! Imagine ;D
08:39:38 <rainemak> direc85[m], I think it could be something like Sailfish Community calendar
08:40:32 <abr> yeah i'm sure it would increase attendance (though i think maybe we should think about moving it to later in the day as we're a bit light on australians these days and maybe some americans would come)
08:41:28 <rubdos[m]> you could consider rotating the hour around, to allow multiple time zones, but still allow people to check in in the morning if they prefer? (I know I do)
08:43:23 <rainemak> would somebody like to take an action on the ics file?
08:44:46 <abr> I could have a look at that, if you want to publish it on a jolla http server somewhere. that would make it 'official'
08:45:08 <rubdos[m]> I'd really prefer it to be official or officially endorsed indeed
08:45:27 <rainemak> abr, thanks => sailfishos.org or jolla.com would work
08:45:57 <abr> yeah sailfishos.org would be perfect
08:45:59 <flypig> Bravo! Great initiative :) This will be super-helpful.
08:46:34 <rainemak> maybe jolla.com would actually be better so that we could advertise other kind of events
08:46:46 <rainemak> abr, let's sort it out
08:47:32 <abr> yeah talk to you after. need to finalize this microg fix too.
08:48:02 <rainemak> abr, yeap! that microg fix will be great
08:49:28 <rainemak> let's schedule next meeting => hopefully that'll already be in community calendar :-)
08:49:34 <rainemak> #topic Next meeting time and date (2 mins)
08:49:40 <rainemak> Proposing Thursday 30th Janaury at 08:00am UTC
08:50:00 <rainemak> January
08:50:42 <flypig> Sadly I'll have to skip but will catch up with the logs.
08:51:06 <abr> lgtm
08:51:13 <rainemak> I may have a bit of overlap there as well but I'd like to have one right before FOSDEM
08:51:46 <flypig> Yeah, I can see it makes sense.
08:51:49 <abr> maybe later if you both need?
08:52:04 <dcaliste> Ok for me also, at 8:00 UTC or later.
08:53:34 <rubdos[m]> <rainemak> "maybe jolla.com would actually..." <- Maybe split it in two then, but that's a minor nitpick
08:54:03 <rubdos[m]> <abr> "yeah talk to you after. need..." <- that sounds very promising <3
08:54:18 <rainemak> Overlap comes from yrityspäivät where we'd like to attend but that's not yet confirmed => Maybe I take community meeting live from the stand
08:54:58 <abr> rubdos[m]: I do like a tease sorry :D
08:54:59 <rainemak> rubdos[m], I have also one todo from you :-)
08:55:28 <rainemak> 08:00am UTC it is
08:55:36 <rainemak> #info Next meeting will be held on Thursday 30th January 2025 at 08:00am UTC: 2025-01-30T0800Z
08:55:36 <flypig> Maybe a live student interview from the show floor :)
08:55:45 <rubdos[m]> looking forward to the outcome of that one, rainemak ;-)
08:55:46 <rainemak> flypig, something like that
08:56:09 <rainemak> alright, thank you all
08:56:29 <flypig> Bye! Thanks all!
08:56:33 <direc85[m]> Thank you everyone!
08:56:38 <abr> bye!
08:56:41 <rubdos[m]> o/ thanks
08:57:10 <rainemak> #endmeeting