#sailfishos-meeting: Sailfish OS, open source, collaboration -- 14th August 2025

Meeting started by rainemak at 16:00:00 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: (rainemak, 16:00:14)
    2. https://forum.sailfishos.org/t/community-meeting-on-14th-august-2025-new-time-slot/23669 (rainemak, 16:00:14)

  1. Brief introduction (5 min). Please prefix your name/handle with #info (rainemak, 16:00:14)
    1. Raine Mäkeläinen, Jolla (rainemak, 16:00:59)
    2. mal, Jolla (mal, 16:01:14)
    3. Matti Viljanen, Jolla (direc85[m], 16:01:29)
    4. Affe Null, community (AffeNull[m], 16:01:36)
    5. pherjung, community (pherjung[m], 16:01:46)

  2. new camera wrapper API - where to start? (20 mins -- affe_null) (rainemak, 16:05:15)
    1. <affe_null> In the last meeting, @mal suggested that a new camera API (rainemak, 16:05:24)
    2. <affe_null> could be developed to replace the existing QtMultimedia one. (rainemak, 16:05:24)
    3. <affe_null> This could be very useful both for implementing an advanced (rainemak, 16:05:24)
    4. <affe_null> camera app and for supporting ports based on libcamera. (rainemak, 16:05:24)
    5. <affe_null> I recently got libcamera working on the Jolla C2 with a (rainemak, 16:05:25)
    6. <affe_null> close-to-mainline kernel and can help with testing this. (rainemak, 16:05:26)
    7. <affe_null> I would also like to collect some ideas about the new API, e.g. (rainemak, 16:05:28)
    8. <affe_null> * should it still be based on gstreamer? (rainemak, 16:05:30)
    9. <affe_null> * should it still use the old GstPhotography API? (rainemak, 16:05:32)
    10. <affe_null> * should it be Sailfish-specific or can it be shared with (rainemak, 16:05:34)
    11. <affe_null> other mobile Linux projects? should it be Qt-specific? (rainemak, 16:05:36)
    12. <affe_null> * which features need to be supported that are missing in the (rainemak, 16:05:38)
    13. <Jolla> Let’s start from needs/requirements. (rainemak, 16:05:42)
    14. <Jolla> * Faster Camera startup -> What are current bottlenecks? (rainemak, 16:05:44)
    15. <Jolla> * Something easier to maintain and extend (rainemak, 16:05:48)
    16. <Jolla> * Upstream should be hosted @ github.com/sailfishos but end result (rainemak, 16:05:50)
    17. <Jolla> * Can be shared with other mobile Linux projects (rainemak, 16:05:57)
    18. <Jolla> * Preferably Qt-less so C/C++, thin QML wrapper should be sufficient (rainemak, 16:05:59)
    19. <Jolla> * Support different low level camera things like gst-droid vs libcamera (rainemak, 16:06:01)
    20. <Jolla> * Consider PipeWire compatability (whatever that means from implementation point of view) (rainemak, 16:06:03)
    21. ACTION: Create Forum topic regarding camera feature wishlist (rainemak, 16:18:02)

  3. Open PR discussion (5 mins -- asked by Jolla) (rainemak, 16:35:54)
  4. General discussion (10 mins) (rainemak, 16:40:11)
  5. Next meeting time and date (5 mins) (rainemak, 16:50:25)
    1. Next meeting will be held on Thursday 28th August 2025 at 04:00pm UTC: 2025-08-28T1600Z (rainemak, 16:54:58)


Meeting ended at 16:56:21 UTC (full logs).

Action items

  1. Create Forum topic regarding camera feature wishlist


People present (lines said)

  1. rainemak (83)
  2. mal (16)
  3. AffeNull[m] (15)
  4. CLMA31[m] (7)
  5. sailbot (2)
  6. direc85[m] (2)
  7. pherjung[m] (1)


Generated by MeetBot 0.1.4.