16:08:59 <rainemak> #startmeeting Sailfish OS, open source, collaboration -- 21st May 2026
16:08:59 <sailbot> Meeting started Thu May 21 16:08:59 2026 UTC. The chair is rainemak. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:08:59 <sailbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:08:59 <rainemak> #info Meeting information and agenda can be found here:
16:08:59 <rainemak> #link https://forum.sailfishos.org/t/29498
16:08:59 <rainemak> I am the meeting's chairperson today, and will be doing my best to keep time and order. Please respect the timings and bee-hive.
16:08:59 <rainemak> #topic Brief introduction (5 min). Please prefix your name/handle with #info
16:09:07 <rainemak> #info Raine Mäkeläinen, Jolla
16:09:25 <CLMA31[m]> #info CLMA31, community
16:09:32 <attah> #info Anton Thomasson, community
16:09:38 <ThijssjihT> Thijs Janssen, community
16:10:13 <Keto> #info Pami Ketolainen, Jolla
16:12:50 <abr> #info Andrew Branson, Jolla
16:12:55 <rainemak> #topic Tracking of non-resolved Community Meeting topics
16:12:55 <rainemak> #action Community task board
16:12:55 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-23rd-april-2026/29030/3
16:12:55 <rainemak> #action Jolla to update regarding recommended charging cables and chargers.
16:12:56 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-7th-may-2026/29253/2
16:12:57 <rainemak> #info No actions taken yet regarding community task board nor charger / cables.
16:13:24 <rainemak> Pushed one question to next meeting.
16:13:35 <rainemak> Let's get going
16:13:37 <rainemak> #topic General question regarding the timeline of 5.1 and AAS bluetooth support (5 mins -- CLMA31)
16:13:37 <rainemak> #info <CLMA31> Firstly, sorry for very late topic, but I thought that maybe
16:13:37 <rainemak> #info <CLMA31> this subject could be answered even without preparation. I
16:13:37 <rainemak> #info <CLMA31> don’t want to rush things, but I’m interested to know what
16:13:37 <rainemak> #info <CLMA31> does the timelines of 5.1 and AAS bluetooth releases look
16:13:39 <rainemak> #info <CLMA31> like? 5.1 has sounded like it will land soon, but can the
16:13:41 <rainemak> #info <CLMA31> bluetooth support for AAS side also be released at the same
16:13:43 <rainemak> #info <CLMA31> time?
16:13:45 <rainemak> #info <Jolla> Yes, Sailfish OS 5.1 is looking good. The first version of the
16:13:47 <rainemak> #info <Jolla> Bluetooth for AppSupport can be considered as beta and will be
16:13:49 <rainemak> #info <Jolla> delivered first via Jolla Store. This way you can easily also
16:13:51 <rainemak> #info <Jolla> uninstall. Later on down the road, Bluetooth for AppSupport
16:13:53 <rainemak> #info <Jolla> should be integrated to the AppSupport itself.
16:13:57 <rainemak> #info <Jolla>
16:13:59 <rainemak> #info <Jolla> We are targetting to release it next week.
16:14:38 <CLMA31[m]> Next week for both?
16:14:49 <rainemak> We are targetting to release it next week. == Sailfish OS 5.1
16:14:49 <CLMA31[m]> Or only for 5.1?
16:15:09 <CLMA31[m]> Thanks for clarification, any timeline guess for Bluetooth?
16:15:13 <rainemak> AppSupport opens to Store more or less same time
16:15:29 <CLMA31[m]> Great to hear!
16:16:10 <CLMA31[m]> No further question, but I want to thank you for doing the developer early access!
16:17:23 <rainemak> Let's move on
16:17:28 <rainemak> #topic Open Pull Requests (PRs) to discussion (5 mins -- asked by Jolla)
16:17:28 <rainemak> #info Open PRs raised by nephros
16:17:28 <rainemak> #link https://github.com/sailfishos/ncurses/pull/3/
16:17:28 <rainemak> #link https://github.com/sailfishos/readline/pull/3
16:19:22 <rainemak> Thank you for raising PRs before hand
16:23:29 <rainemak> let's move on
16:23:38 <rainemak> #topic General discussion (15 mins)
16:23:38 <rainemak> #info Jolla Phone update - The Other Half spec
16:23:38 <rainemak> #link https://forum.sailfishos.org/t/29701
16:23:38 <rainemak> #info Please note that any details at the TOH spec page are still under development and subject to change without notice.
16:26:04 <CLMA31[m]> Wow great job! Good that community has a little bit time to tinker :)
16:26:28 <attah> Indeed very ice to see. Hope STL files follow soon.
16:26:56 <rainemak> We'll push more content as get them ready
16:27:14 <Maighstir> Nice to see.
16:27:30 <CLMA31[m]> How does the Jolla phone generally look like?
16:28:30 <Dante_> Can the TOH power input function as an UPS, as in allowing swapping the main battery with another one?
16:28:32 <rainemak> Looks and feels awesome!
16:28:52 <CLMA31[m]> Can't wait it!
16:29:10 <rainemak> Dante_, nope
16:29:33 <attah> Dante_: Battery would be behind any normal-sized TOH anyway.
16:29:51 <rainemak> attah, correct
16:30:37 <ThijssjihT> Looking forward to July 8th. Hopefully with a printed TOH. No ideas yet, but I like printing and electronics, so hopefully an idea will come to me.
16:30:40 <abr> I guess you could clamp something just over the pins. I don't think phone hardware really likes having its battery removed when it's switched on though
16:31:19 <ThijssjihT> One could design a TOH with a battery hole perhaps?
16:31:24 <abr> I wouldn't try switching a battery when the phone is connected to a charger either!
16:31:32 <abr> which I guess is the same thing
16:31:53 <CLMA31[m]> Within your internal testing, has the location improvements in 5.1 allow you to get approximate location lock even inside the building? Meaning probably mostly the Beacon
16:31:56 <ThijssjihT> But still, the phone has to support live battery removal
16:32:12 <Maighstir> A charger could supply more than 1A though.
16:32:29 <abr> CLMA31[m]: i've got a sfos stumbler in the works to gather data for beacondb!
16:32:58 <rainemak> ThijssjihT, that could a hole for tap to pay i.e. for your credit card
16:33:33 <attah> ThijssjihT: Has to?
16:34:06 <CLMA31[m]> abr: I have also used android phone to collect data for that :)
16:34:25 <rainemak> ThijssjihT, why do you think so?
16:34:36 <ThijssjihT> I mean, if you would want a TOH to supply power to be able to remove the battery as suggested. In that it would have to.
16:35:02 <rainemak> In that case yes
16:35:40 <ThijssjihT> I really don't care about battery removal. As long as I can replace the battery when it has gone old and bad I am very happy.
16:35:55 <attah> It would have to; but may well not.
16:36:02 <abr> who would have thought that such a thing would ever be considered a privilege
16:36:56 <attah> indeed
16:36:57 <rainemak> attah, it takes a bit that we publish STLs -- the first version at least.
16:37:22 <ThijssjihT> Before july 8th?
16:37:36 <rainemak> of course
16:37:43 <CLMA31[m]> Could Jolla provide STEP files so those would be easier to modify?
16:37:47 <rainemak> maybe even during next week
16:38:03 <rainemak> I'm not sure about the formmat
16:38:04 <attah> One would think that they by definition must exist to produce the phone - if in another format and for another process
16:38:31 <abr> but you have to be sure they won't change again...
16:38:42 <abr> or else there'll be some pissed off toh makers
16:39:01 <CLMA31[m]> For sure
16:39:04 <CLMA31[m]> Have to wait and see
16:39:39 <attah> Though i think an early unoptimized version with appropriate disclaimer is a good middle ground
16:39:59 <rainemak> abr, it's about communication. if there are changes expected, then we'll communicate that... and so on.
16:40:14 <rainemak> attah, we're thinking the same
16:40:28 <attah> :)
16:40:45 <abr> yeah but people will still start building things anyway. i would.
16:40:57 <attah> I sort of even see some 3d printing afficionado PR:ing an improvement
16:41:24 <attah> Would not surprise me with this cool community
16:42:02 <rainemak> I think we are ready to schedule a next meeting
16:42:24 <rainemak> #topic Next meeting time and date (2 mins)
16:42:24 <rainemak> Proposing Thursday 4th June at 04:00 PM UTC
16:42:24 <rainemak> #info Next meeting will be held on Thursday 4th June 2026 at 04:00pm UTC: 2026-06-04T1600Z
16:42:44 <rainemak> oops, too many lines copied :-)
16:43:04 <rainemak> in two weeks and same time
16:43:07 <attah> Well decided
16:43:17 <CLMA31[m]> Normal two week interwall, sounds good
16:43:31 <rainemak> that's it then
16:43:38 <rainemak> settled
16:43:43 <Maighstir> Sounds good.
16:43:44 <rainemak> thank you all!
16:43:51 <ThijssjihT> Thank you!
16:43:57 <rainemak> #endmeeting