16:00:45 <rainemak> #startmeeting Sailfish OS, open source, collaboration -- 18th June 2026
16:00:45 <sailbot> Meeting started Thu Jul  2 16:00:45 2026 UTC. The chair is rainemak. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:45 <sailbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:45 <rainemak> #info Meeting information and agenda can be found here:
16:00:45 <rainemak> #link https://forum.sailfishos.org/t/29888
16:00:45 <rainemak> I am the meeting's chairperson today, and will be doing my best to keep time and order. Please respect the timings and bee-hive.
16:00:45 <rainemak> #topic Brief introduction (5 min). Please prefix your name/handle with #info
16:00:56 <extechop[m]> #info Otto Mäkelä, community
16:01:08 <rainemak> #info Raine Mäkeläinen, Jolla
16:01:15 <direc85[m]> #info Matti Viljanen, Jolla
16:01:18 <AffeNull[m]> #info Affe Null, community
16:01:23 <attah> #info Anton Thomasson, community
16:02:35 <Keto> #info Pami Ketolainen, Jolla
16:02:44 <mettska> #info mettska, Community waiting for J2 ;-)
16:03:52 <extechop[m]> (aren't we all?)
16:04:50 <attah> My 10 III now has both superglue and tape. J2 will be very welcome.
16:05:25 <rainemak> let's get started
16:05:34 <rainemak> #topic Tracking of non-resolved Community Meeting topics
16:05:34 <rainemak> #action Community task board
16:05:34 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-23rd-april-2026/29030/3
16:05:34 <rainemak> #action Jolla to update regarding recommended charging cables and chargers.
16:05:34 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-7th-may-2026/29253/2
16:05:36 <rainemak> #info No actions taken yet regarding community task board nor charger / cables.
16:05:37 <rainemak> Hopefully we'd soon have time for these tasks. Frankly, goes after summer
16:05:38 <sebix[m]> #info sebix, community
16:05:39 <rainemak> and/or Jolla Phone Day1 celebration event.
16:05:56 <alsahio> #info alsahio, community
16:09:14 <Venty[m]> #info Venty, Community Member
16:09:24 <rainemak> next one
16:09:26 <rainemak> #topic Individuals that ordered multiple items and charged multiple shipping fee’s (10 mins -- jollus)
16:09:26 <rainemak> #info <jollus> Multiple invoices and shipping fee’s have been sent to people
16:09:26 <rainemak> #info <jollus> that ordered multiple phones. Jolla mentioned that multiple
16:09:26 <rainemak> #info <jollus> shipping fee’s will be reimbursed. Will a new invoice with one
16:09:26 <rainemak> #info <jollus> shipping fee be sent with one package containing the multiple #info <jollus> items?
16:09:29 <rainemak> #info <jollus>
16:09:31 <rainemak> #info <jollus> We will need to know if a new invoice with all the items in one
16:09:33 <rainemak> #info <jollus> package will be sent so we can upload it. Some of us have
16:09:35 <rainemak> #info <jollus> uploaded the individual invoices to a forwarding address.
16:09:37 <rainemak> #info <jollus> If Jolla sends one package with multiple phones without letting
16:09:39 <rainemak> #info <jollus> us know, the receiver may keep some items since it doesn’t
16:09:41 <rainemak> #info <jollus> match the invoice uploaded or send back to Jolla.
16:09:43 <rainemak> #info <Jolla> We'll bundle orders and refund extra shipping costs. When it
16:09:45 <rainemak> #info <Jolla> comes to newly created invoices, it won't happen -- almost
16:09:47 <rainemak> #info <Jolla> certainly we don't do that. It's a way too laboursome effort for
16:09:49 <rainemak> #info <Jolla> our team.
16:15:57 <rainemak> I guess topic creator already understood him-/herself this thigh position.
16:19:48 <rainemak> let's move on
16:19:58 <rainemak> #topic HID-over-I2C-over-TOH (10mins -- asked by ReturN900)
16:19:58 <rainemak> #info <ReturN900> Having used my N900 for a number of years and unfortunately
16:19:58 <rainemak> #info <ReturN900> missed out on the N9, N950, and the earlier Jolla phones,
16:19:58 <rainemak> #info <ReturN900> I’m looking forward to getting back to a true Linux phone,
16:19:58 <rainemak> #info <ReturN900> and in particular the potential to have a hardware keyboard
16:20:00 <rainemak> #info <ReturN900> (like the original TOHKBD and the TOHKBD 2).
16:20:01 <rainemak> #info <ReturN900>
16:20:03 <rainemak> #info <ReturN900> If I could design a module that complied with the HID-over-
16:20:05 <rainemak> #info <ReturN900> I2C protocol, is the Interrupt pin of the TOH interface
16:20:07 <rainemak> #info <ReturN900> connected to the AP in such a way that it can act as an IRQ?
16:20:09 <rainemak> #info <ReturN900>
16:20:11 <rainemak> #info <ReturN900> If so, will the default Jolla Phone kernel include the
16:20:13 <rainemak> #info <ReturN900> necessary drivers to interface with a HID-over-I2C out of
16:20:15 <rainemak> #info <ReturN900> the box.
16:20:17 <rainemak> #info <ReturN900>
16:20:19 <rainemak> #info <ReturN900> If not, are there others with a background in kernel/driver
16:20:21 <rainemak> #info <ReturN900> development that would be interested in collaborating.
16:20:25 <rainemak> #info <Jolla> Could you, Sailfish OS Community, elaborate a bit more. What
16:20:27 <rainemak> #info <Jolla> you are looking for?
16:21:32 <CLMA31[m]> #info CLMA31, community and late....
16:22:30 <attah> How did the original TOHKBD hook up software-wise?
16:22:47 <attah> Bespoke or hid-over-i2c?
16:22:49 <attah> https://www.kernel.org/doc/Documentation/devicetree/bindings/input/hid-over-i2c.txt
16:23:06 <attah> Not sure what exactly that entails... but standards are always good
16:23:38 <rainemak> TOH keyboard probably works -- we haven't tested
16:23:42 <extechop[m]> There are so many to choose from! (ref. xkcd and competing standards)
16:24:33 <rainemak> HID is a very big thingie in itself
16:24:56 <AffeNull[m]> anything on the kernel side would probably require adding nodes to the device tree
16:25:07 <rainemak> yeap
16:25:37 <AffeNull[m]> it would be nice if TOHs were allowed to supply device tree overlays
16:28:39 <rainemak> I think this is covered, let's move on
16:29:08 <rainemak> #topic About the Jolla J2 The Other Half. (10mins -- asked by Polatbirdal)
16:29:08 <rainemak> #info <Polatbirdal> Hello, I had asked this before, but I was told that you
16:29:08 <rainemak> #info <Polatbirdal> were still working on it and that it wasn’t fully clear
16:29:08 <rainemak> #info <Polatbirdal> yet. My question was this: regarding The Other Half, will
16:29:08 <rainemak> #info <Polatbirdal> you sell modules such as keyboard modules, solar-powered
16:29:10 <rainemak> #info <Polatbirdal> modules, or modules for wireless connectivity? Or have 3D-
16:29:11 <rainemak> #info <Polatbirdal> printable modules been prepared? How much progress has
16:29:13 <rainemak> #info <Polatbirdal> been made on The Other Half, and exactly what kind of
16:29:13 <CLMA31[m]> Let's ask this way, if someone from community would start to develop keyboard TOH (or why not any TOH), could Jolla name contact person who developer could contact?
16:29:15 <rainemak> #info <Polatbirdal> progress will be achieved with it?
16:29:17 <rainemak> #info <Jolla> The Other Half is an innovation platform you all. Currently, our
16:29:19 <rainemak> #info <Jolla> plans do not include keyboards and such but you should be able
16:29:21 <rainemak> #info <Jolla> to innovate such.
16:29:25 <rainemak> for you all
16:30:20 <rainemak> CLMA31[m], back in original Jolla Phone everybody know TOH keyboard creators -> this time we shall do the same
16:31:06 <ReturN900> Sorry, just joined. Sorry if I missed my slot.
16:31:15 <rainemak> no worry
16:32:30 <ReturN900> Was the topic regarding TOH support for HID-over-I2C covered?
16:32:46 <rainemak> yes, we moved on already
16:34:06 <Keto> rainemak: I assume the question was more wether there will be some contact person on Jolla side to respond to TOH related things
16:34:33 <rainemak> Forum is the best for each and everybody
16:34:43 <Keto> yes
16:35:11 <Keto> probably we can even add TOH category there, or something like that
16:36:12 <rainemak> that's a good idea
16:36:20 <rainemak> #action Jolla to add TOH category
16:36:28 <rainemak> #action Jolla to add TOH category to Sailfish OS Forum
16:36:42 <attah> https://forum.sailfishos.org/t/add-the-other-half-as-a-category/30364
16:36:51 <rainemak> +1
16:37:18 <direc85[m]> +1
16:38:01 <Keto> of course if someone will be making a comercial TOH that requires some special OS side things, then we probabably need to collaborate on that on different level
16:38:35 <rainemak> very much correct
16:40:25 <rainemak> next topic
16:40:30 <rainemak> #topic Jolla Phone (2026) accessories and repairability (15mins -- asked by alsahio)
16:40:30 <rainemak> #info <alsahio> Hi :slight_smile: I was wondering whether acessories for Jolla
16:40:30 <rainemak> #info <alsahio> Phone (2026) will become available for purchase before the
16:40:30 <rainemak> #info <alsahio> celebration event, and whether those who order these will get
16:40:30 <rainemak> #info <alsahio> it in the event? The commerce page estimates June 2026 as the
16:40:32 <rainemak> #info <alsahio> availability date, so that is why I am wondering. Also, will
16:40:33 <rainemak> #info <alsahio> things such as camera modules, USB-C modules, etc be a part of
16:40:35 <rainemak> #info <alsahio> these accessories, and will they be user replaceable? Thank
16:40:37 <rainemak> #info <alsahio> you.
16:40:39 <rainemak> #info <Jolla> At the event, let's see what we have. Eventually, there will be
16:40:41 <rainemak> #info <Jolla> spare batteries and camera lenses maybe something more. Please
16:40:43 <rainemak> #info <Jolla> let us work on those.
16:43:28 <rainemak> All in all, let's work on those items. We're really stretching all our team efforts to be able to serve all kind of questions and answers. Let us work on those.
16:44:06 <zhasha> I don't know how the phone is built internally but I've replaced the USB port daughterboard on my gf's Xperia 10 III once and been very close to having to do it 3 more times but gotten away with flooding it with alcohol
16:44:26 <zhasha> if you have a USB daughterboard it would be fantastic if we could eventually buy them as spares
16:45:02 <rainemak> Let's see how it develops
16:46:39 <AffeNull[m]> +1, having spare parts is important for repairability
16:47:24 <rainemak> regarding camera lens we can already say that those are covered and relatively simple to change
16:47:36 <rainemak> or lenses actually
16:48:54 <rainemak> sounds that this is covered as well
16:49:01 <rainemak> no comments / questions
16:49:38 <rainemak> #topic Jolla Phone Day1 celebration event - spectators, +1? (10 mins -- asked by alsahio)
16:49:38 <rainemak> #info <alsahio> Hi again, maybe this is a bad question, because of physical
16:49:38 <rainemak> #info <alsahio> venue limitations and such, but are there any plans to make
16:49:38 <rainemak> #info <alsahio> the event more open for the public? Like introduce something
16:49:38 <rainemak> #info <alsahio> like a (paid) spectator ticket, where people who haven’t
16:49:40 <rainemak> #info <alsahio> ordered the phone can still hangout with the whole community
16:49:41 <rainemak> #info <alsahio> and maybe try out these phones in hand. Make them experience
16:49:43 <rainemak> #info <alsahio> Sailfish OS and understand why these phones have a firm place
16:49:45 <rainemak> #info <alsahio> in the smartphone market. I think it could be a nice publicity
16:49:47 <rainemak> #info <alsahio> stunt, but it’s just an idea, maybe far fetched. Also, for
16:49:49 <rainemak> #info <alsahio> those who ordered the phone and got the ticket, are they
16:49:51 <rainemak> #info <alsahio> allowed to enter the event with a second person? Thank you
16:49:55 <rainemak> #info <alsahio> very much
16:49:57 <rainemak> #info <Jolla> Whatever happens before door opening is public for everybody.
16:49:59 <rainemak> #info <Jolla> Other than that, we're not making Jolla Phone Day1 celebration
16:50:01 <rainemak> #info <Jolla> event more public.
16:51:45 <CLMA31[m]> So just to underline for everyone: no +1s, one ticket = one person
16:52:29 <rainemak> Correct, thank you for underlining
16:53:19 <rainemak> if you are not coming, please let us know https://forum.sailfishos.org/t/jolla-phone-day1-is-approaching-fast/30376
16:54:33 <rainemak> there are others waiting to have a ticket
16:55:27 <rainemak> alright, moving on it sounds
16:55:32 <rainemak> #topic Open Pull Requests (PRs) to discussion (5 mins -- asked by Jolla)
16:55:43 <rainemak> Name/IRC nick: nephros, @attah, @zhasha
16:55:44 <rainemak> Open PR URL: Enable bluez5-gstreamer by attah · Pull Request #10 · sailfishos/pulseaudio · GitHub
16:55:44 <rainemak> #link https://github.com/sailfishos/pulseaudio/pull/10
16:55:44 <rainemak> with related:
16:55:44 <rainemak> [gst-plugins-bad] Add support for AptX (bluetooth) by nephros · Pull Request #12 · sailfishos/gst-plugins-bad · GitHub
16:55:46 <rainemak> [gst-plugins-bad] Add support for ldac (bluetooth) by nephros · Pull Request #13 · sailfishos/gst-plugins-bad · GitHub
16:55:49 <rainemak> #link https://github.com/sailfishos/gst-plugins-bad/pull/12
16:55:51 <rainemak> #link https://github.com/sailfishos/gst-plugins-bad/pull/13
16:55:55 <rainemak> and references/links:
16:55:57 <rainemak> Support for higher quality bluetooth A2DP audio codecs in sailfishos
16:55:59 <rainemak> Tuesday, 2026-06-23
16:56:01 <rainemak> #link https://forum.sailfishos.org/t/5812/
16:56:03 <rainemak> #link https://irclogs.sailfishos.org/logs/%23sailfishos/2026/%23sailfishos.2026-06-23.log.html
16:56:23 <zhasha> I think we can safely assume this isn't making it into 5.2?
16:57:48 <zhasha> I guess I have a related question: should I be doing more to figure out how to select wideband bt in pulseaudio-modules-droid* or is someone at Jolla looking into it?
17:00:26 <Keto> won't make it to 5.2... or maybe to some later hotfix release, but lets see. we have not planned the future releases much yet
17:00:51 <rainemak> yes, indeed
17:01:38 <zhasha> The mSBC fix for phone calls is a bigger ticket item IMO. It makes a comparatively enormous difference
17:02:14 <zhasha> but I never really finished the work since I still don't have a working build setup
17:03:05 <zhasha> and I feel bad just leaving it like that, but I don't really have much time to spare at the moment so if you've already picked it up internally then maybe I won't feel so guilty about taking a step back
17:04:19 <rainemak> I believe we haven't looked it too thoroughly as we have been super busy
17:04:30 <rainemak> super busy really means that
17:04:43 <zhasha> oh I believe you
17:05:11 <Keto> that is already great effort in testing the things and all that, so no need to feel bad :)
17:05:17 <direc85[m]> exciting to see community working on this
17:06:53 <Polatbirdal> I think I'm late =/
17:06:59 <rainemak> Keto, you're absolute right, no need to feel bad
17:07:13 <rainemak> Polatbirdal, yes, you are
17:07:31 <mal> changes to pulseaudio-modules-droid are a bit more difficult to test anyway
17:07:47 <Polatbirdal> Will I be able to see my question explained in the summaries later?
17:08:04 <rainemak> There are full logs available as well
17:08:07 <rainemak> So, yes
17:08:14 <Polatbirdal> thanks =)
17:08:21 <mal> Polatbirdal: https://irclogs.sailfishos.org/meetings/sailfishos-meeting/2026/sailfishos-meeting.2026-07-02-16.00.log.txt you can check logs here and then ask in general topic at the end
17:08:36 <rainemak> +1
17:08:41 <rainemak> let's move to general
17:08:43 <rainemak> #topic General discussion (15 mins)
17:08:54 <attah> How is the production coming along?
17:09:08 <attah> We are super eager for an update
17:09:10 <rainemak> Two topics came very much late
17:09:30 <rainemak> attah, I can image
17:09:49 <rainemak> attah, no news piece today
17:09:51 <extechop[m]> And do you feel you will survive Day1, at least with most of your sanity intact?
17:10:22 <rainemak> extechop[m], sanity is there, trust me
17:10:51 <extechop[m]> I'm sure you have it backed up somewhere.
17:11:15 <rainemak> I'm quite certain that it's super difficult to image how crazy it has been
17:11:28 <Polatbirdal> So how is the phone in terms of optimization? Does it have problems, or is it quite smooth and trouble-free?
17:11:36 <rainemak> have you people noticed those tone videos?
17:11:59 <attah> yes, might have one left to watch tho
17:12:06 <rainemak> Polatbirdal, makes me smile quite frequently :-)
17:13:23 <duskull[m]> How is the camera quality overall?
17:13:44 <duskull[m]> I mean on the J2
17:15:02 <Polatbirdal> Actually, the camera being good is more related to software. I wonder if they worked on it. Is the 5.2 camera app problem-free?
17:15:06 <rainemak> We ironed out startup time and got quite nice results.
17:15:52 <rainemak> Shutter can be improved further -- a challenge for Sailfish Community?
17:16:00 <Polatbirdal> As far as I remember, there was a snow photo in the forums you shared while introducing the J2. If it takes photos at that kind of quality, that would be nice.
17:16:14 <CLMA31[m]> Is it realistic that Jolla starts to ship first batch of phones end of next week?
17:16:40 <rainemak> First get their devices in the events, we'll start shipping after the event
17:17:13 <rainemak> but hey, we also need to take at some point a bit of time off
17:17:15 <extechop[m]> Please do explain/link "tone video" to someone who just hasn't had time to browse through every single posting the forums?
17:17:36 <rainemak> extechop[m], I'll dig it
17:17:38 <Polatbirdal> CLMA31 is genuinely very exciting =) Thank you, you’re making me excited about a phone after many years.
17:17:47 <zhasha> extechop[m]: go nuts https://www.youtube.com/@jolla/shorts
17:18:05 <CLMA31[m]> I for sure am!
17:18:19 <rainemak> #link https://www.youtube.com/shorts/7nvZxgxpPKc
17:18:22 <rainemak> ^first
17:18:37 <rainemak> #link https://www.youtube.com/shorts/6gW0XGtxhFg
17:18:38 <CLMA31[m]> rainemak: Which is well deserved! I'm just super excited to have Jolla phone :)
17:18:41 <rainemak> ^ second
17:18:56 <rainemak> #link https://www.youtube.com/shorts/pI9XajKLHOM
17:19:03 <Polatbirdal> We've already watched the rain video, we're waiting for new videos :D
17:19:04 <rainemak> ^ third
17:19:32 <rainemak> Polatbirdal, next one maybe tomorrow :-)
17:20:07 <Polatbirdal> Yes, another exciting video is coming; we got this one here :D
17:20:18 <rainemak> also note that you can find them from peertube from https://friprogramvarusyndikatet.tv/
17:21:03 <rainemak> are we done?
17:21:17 <rainemak> Welcome everybody who's joining to the event
17:21:54 <Polatbirdal> The time is approaching, I wish you success at the launch in advance.
17:21:56 <extechop[m]> Anyone working on making native HSL routing apps (like JollaOpas or a spin-off) work properly, instead of every user having to get HSL API keys and figure out how to access map services?
17:23:17 <rainemak> I don't know, please ask in the Jolla Phone Day1 event topic
17:23:20 <CLMA31[m]> rainemak: I assume Jolla will publish the recording of event in youtube/peertube?
17:23:33 <mal> extechop[m]: would be nice to get the maps works again
17:23:43 <mal> otherwise it seems to work
17:23:59 <rainemak> CLMA31[m], we do what we can.
17:24:08 <CLMA31[m]> rainemak: Thank you!
17:24:41 <rainemak> let's schedule next meeting
17:24:42 <Polatbirdal> thanks rain
17:24:54 <rainemak> #topic Next meeting time and date (2 mins)
17:24:54 <rainemak> Proposing Thursday 16th July at 04:00 PM UTC
17:25:08 <CLMA31[m]> Super sad that I couldn't come, finally superb Finnish company doing special launch in Finland that I would be super interested!
17:25:17 <CLMA31[m]> Works
17:25:25 <Polatbirdal> 16 july nice
17:25:45 <rainemak> normal 2week schedule
17:25:45 <duskull[m]> +1
17:25:51 <extechop[m]> Standard 2 week timing seems appropriate
17:25:59 <direc85[m]> +1
17:26:05 <rainemak> settled
17:26:06 <rainemak> #info Next meeting will be held on Thursday 16th July 2026 at 04:00pm UTC: 2026-07-16T1600Z
17:26:07 <Polatbirdal> +111111111111111111111111
17:26:22 <rainemak> thank you all
17:26:28 <rainemak> #endmeeting