16:00:19 <rainemak> #startmeeting Sailfish OS, open source, collaboration -- 3rd September 2026
16:00:19 <sailbot> Meeting started Thu Sep  3 16:00:19 2026 UTC. The chair is rainemak. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:19 <sailbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:19 <rainemak> #info Meeting information and agenda can be found here:
16:00:19 <rainemak> #link https://forum.sailfishos.org/t/32224
16:00:19 <rainemak> I am the meeting's chairperson today, and will be doing my best to keep time and order. Please respect the timings and bee-hive.
16:00:19 <rainemak> #topic Brief introduction (5 min). Please prefix your name/handle with #info
16:00:21 <rainemak> #info Raine Mäkeläinen, Jolla
16:00:43 <rubdos[m]> #info Ruben De Smet - rubdos - community
16:01:06 <jmerono> #info Julio Meroño (jmerono) - community
16:01:35 <abr> #info Andrew Branson - Jolla
16:01:44 <renTTu> #info Juhani Virtanen (renTTu) - community
16:02:17 <CLMA31[m]> #info CLMA31, community
16:02:22 <Cryx[m]> #info: Cryx - community
16:02:38 <mal> #info mal, Jolla
16:03:11 <attah> #info Anton Thomasson - community
16:03:44 <Keto> #info Pami Ketolainen, Jolla
16:05:17 <Polatbirdal> hello
16:05:19 <rainemak> nice amount of participants
16:05:21 <rainemak> hello
16:05:31 <Certina> #info Certina - community
16:05:35 <rainemak> let's start
16:05:36 <rainemak> #topic Tracking of non-resolved Community Meeting topics
16:05:36 <rainemak> #action Community task board
16:05:36 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-23rd-april-2026/29030/3
16:05:36 <rainemak> #action Jolla to update regarding recommended charging cables and chargers.
16:05:37 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-7th-may-2026/29253/2
16:05:38 <rainemak> #action The Privacy Switch in relation to Ambiances
16:05:40 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-july-16-2026/30378/7
16:05:42 <rainemak> #info No actions taken yet regarding community task board nor charger / cables.
16:06:54 <rainemak> #topic AppSupport on other community ports (particularly on the Xperia 1 and 5 IV) (5 mins -- @jmerono)
16:06:55 <rainemak> #info <jmerono> Following what was mentioned in the previous community meeting
16:06:55 <rainemak> #info <jmerono> regarding the Xperia 10 IV and V, I wondered if there were any
16:06:55 <rainemak> #info <jmerono> plans to extend that to other well-supported ports (like on
16:06:55 <rainemak> #info <jmerono> @rinigus‘s Nagara ports). If so, I understand the team may be
16:06:58 <rainemak> #info <jmerono> busy with the JP2026 among other things, but may we have an
16:07:00 <rainemak> #info <jmerono> estimate of when we will have it?
16:07:02 <rainemak> #info <Jolla> Let us start with Xperia 10 IV and 10 V (surely jointly with
16:07:04 <rainemak> #info <Jolla> Sharks and others). Once we have AppSupport working with 10 IV
16:07:06 <rainemak> #info <Jolla> and 10 V we certainly know more. After reaching that target, we
16:07:08 <rainemak> #info <Jolla> have more solid ground to start planning how to expand or
16:07:10 <rainemak> #info <Jolla> whether to expand.
16:08:11 <jmerono> i see, i'm glad to hear it's something thay could be considered, thanks!
16:08:36 <jmerono> i'm also really happy to see that the Xperia 10 IV and V are getting AppSupport <3
16:09:04 <jmerono> i also understand it's probably too soon to talk about how would it be expanded, right?
16:09:33 <rainemak> Please also understand that it's hard to commit to other ports yet. Or whether that's even feasible or how it could be made feasible.
16:09:56 <jmerono> i understand that, i'm just glad that it could happen ;)
16:10:04 <jmerono> thank you for your answer!
16:10:07 <Polatbirdal> Actually, now that newer models are gradually coming in, the 10 IV and V should definitely be introduced to the market as recommended devices.
16:12:41 <attah> Something feels lost in translation here.
16:13:56 <Polatbirdal> What I meant was, people want the 10 IV and 10 V to be as optimized as the 10 III, and since newer models like the JP26 and C2 are already out, I meant that Sony’s newer models should also be brought more into the spotlight.
16:14:33 <rubdos[m]> Newer models being 10 IV and V, as in more recent than III, you mean?
16:16:06 <Polatbirdal> Yes, by “newer” I mean that optimizing the later models would make the 10 IV and 10 V much better options to recommend. After all, right now we’re telling most people to buy the 10 III.
16:16:26 <rainemak> shall we move forward... points noted
16:16:34 <rubdos[m]> That clarifies your statement a lot for me :)
16:17:08 <rainemak> #topic OBS dependencies in tooling/chroot (10 mins -- rubdos / Ruben De Smet)
16:17:08 <rainemak> #info <rubdos> To build Whisperfish, we often require a version of Rust and
16:17:08 <rainemak> #info <rubdos> LLVM that leads the version provided by Jolla. I build and host
16:17:08 <rainemak> #info <rubdos> these packages on my home server, such that our CI system can
16:17:08 <rainemak> #info <rubdos> build them, and the resulting RPMs end up on OpenRepos. I’d
16:17:09 <rainemak> #info <rubdos> like to offer Whisperfish on Chum, however. This means we’d
16:17:11 <rainemak> #info <rubdos> need to compile Rust/LLVM on Chum, such that I can build-depend
16:17:13 <rainemak> #info <rubdos> on them. However, Rust builds through an sb2 shim, which means
16:17:15 <rainemak> #info <rubdos> that the actual rustc and cargo dependencies need to be
16:17:17 <rainemak> #info <rubdos> available in the tooling and even in the chroot. See our
16:17:19 <rainemak> #info <rubdos> Dockerfile for exact prereqs. As far as I understand, this is
16:17:21 <rainemak> #info <rubdos> not currently possible to specify in OBS. More context at Show
16:17:23 <rainemak> #info <rubdos> home:rubdos:whisperfish / Rust - SailfishOS Open Build Service
16:17:25 <rainemak> #info <rubdos> and Show home:rubdos:whisperfish / llvm - SailfishOS Open Build
16:17:29 <rainemak> #info <rubdos> Service. Would it be possible to get some help to get this
16:17:31 <rainemak> #info <rubdos> going? I’m not entirely sure whether I can hack this in myself,
16:17:33 <rainemak> #info <rubdos> or whether I need Jolla’s or the community’s help on this.
16:17:35 <rainemak> #link https://gitlab.com/whisperfish/sailo-rs/-/blob/master/Dockerfile.rust?ref_type=heads
16:17:37 <rainemak> #link https://build.sailfishos.org/package/show/home:rubdos:whisperfish/Rust
16:17:39 <rainemak> #link https://build.sailfishos.org/package/show/home:rubdos:whisperfish/llvm
16:17:41 <rainemak> #info <Jolla> Thank you for asking. We do have Rust 1.95 and LLVM 20 PRs
16:17:43 <rainemak> #info <Jolla> ready. That should help with Whisperfish development for some
16:17:45 <rainemak> #info <Jolla> time. There should be room to bump up Rust to 1.97.1 and LLVM to
16:17:47 <rainemak> #info <Jolla> 22.1.8. Surely, this does not solve generic OBS issue that you
16:17:49 <rainemak> #info <Jolla> are referring to. When we reach up-to-date Gecko ESR version
16:17:51 <rainemak> #info <Jolla> that should also help us all to keep Rust and LLVM up-to-date as
16:17:53 <rainemak> #info <Jolla> well and serving better Whisperfish development needs.
16:17:55 <rainemak> Those Rust 1.95 and LLVM 20 are meant have been upgraded along with newer Gecko engine work
16:17:59 <rainemak> s/are meant//
16:18:51 <mal> it theory it should be possible to build rust and friends on community obs but the cross builds need some special things which for some reason have some difficulties there
16:19:10 <rubdos[m]> Yeh I think my question is more pertaining to the generic question than the PRs. I've seen them pass by today indeed, and are greatly appreciated of course. But I feel that for the next few months or maybe years, Whisperfish may have to lead Rust and LLVM over ESR...
16:19:54 <rubdos[m]> If you're up to it, I'd be happy to work together to get something running on the community OBS, because it's really blocking me for getting Whisperfish out on Chum... where it'd honestly belong :)
16:20:47 <rubdos[m]> mal those "special things", that's the ability to inject some tooling package dependencies which I'm referring to?
16:20:48 <mal> I had some testing with cross builds related to scratchbox2 on community obs and encountered some issues, need to discuss those with Keto
16:21:00 <mal> rubdos[m]: sb2-tools etc
16:21:05 <mal> mainly
16:21:46 <rubdos[m]> Feel free to ping me any time on #sailfishos if you want something tested or so, will be happy to collab on this.
16:22:15 <Polatbirdal> I’m a bit of a newbie, but if there are any beginner tasks, I’d like to help out with something too.
16:22:23 <mal> the sb2 testing was about getting the community Qt builds to work
16:22:51 <mal> but the same procedure is needed for rust also
16:23:06 <rubdos[m]> Polatbirdal: I'm afraid that this issue is among the most non-beginner-friendly things that exists in Sailfish haha :')
16:23:19 <rubdos[m]> Oh so there's precedence. That's always great.
16:23:44 <rubdos[m]> Thing is, I'm mostly in the dark, so I'm not even sure whether I can or can't do some/anything.
16:24:15 <Polatbirdal> Then good luck with your work :D
16:25:17 <mal> rubdos[m]: do you have some test project on obs with those packages you need?
16:25:29 <mal> maybe I could tinker a bit there when I have time
16:25:45 <rubdos[m]> I'll be happy to bump the deps on https://build.sailfishos.org/package/view_file/home:rubdos/Taak/_service:tar_git:harbour-taak.spec?expand=1 :-)
16:26:26 <rubdos[m]> Basically, s/1.52/1.95 and we're golden?
16:26:41 <rubdos[m]> It should compile trivially under that anyway.
16:28:33 <rubdos[m]> Either way: if you ping me, rubdos_/rubdos or if you write "whisperfish", you'll get my attention if you want to play with something..
16:29:07 <mal> the cross build things with sb2-tools on obs are not really documented anywhere, not easy to figure those out without existing info
16:29:14 <rubdos[m]> (especially the one without underscore, now that I think about it)
16:30:13 <rubdos[m]> Yeh, didn't find anything obvious indeed. And I did search quite a bit before posting my question. I hoped to find some info in our old conversations about Rust version bumps, or in gecko/llvm/rust/xulrunner... spec files, but alas
16:30:13 <rainemak> let's move on
16:30:24 <rainemak> ah, we're still goin
16:30:47 <mal> I think we are done with this, further discussion can happen elsewhere
16:30:57 <rainemak> yeap
16:30:58 <rainemak> #topic Murray and Zambezi community ports - what are the next steps for AppSupport? (10mins -- asked by Sharks)
16:30:58 <rainemak> #info <Sharks> We are all very excited at the announcement from the previous
16:30:58 <rainemak> #info <Sharks> community meeting regarding Jolla’s confirmation that
16:30:59 <rainemak> #info <Sharks> AppSupport for the community ports for Xperia 10IV and V is
16:31:01 <rainemak> #info <Sharks> still on the cards. As the port maintainer, I would like to
16:31:03 <rainemak> #info <Sharks> know what is required of me to ensure that AppSupport for this
16:31:05 <rubdos[m]> Agree, thanks!
16:31:05 <rainemak> #info <Sharks> port can be delivered to users as soon as possible. Initial
16:31:07 <rainemak> #info <Sharks> testing from users shows the existing AppSupport binaries do
16:31:09 <rainemak> #info <Sharks> not work out of the box currently. Given we know community
16:31:11 <rainemak> #info <Sharks> ports have been able to run AppSupport binaries in the past
16:31:13 <rainemak> #info <Sharks> (see: Nagara) is this a port-specific problem (eg. something I
16:31:15 <rainemak> #info <Sharks> haven’t done right like kernel configs), or a Jolla-side
16:31:17 <rainemak> #info <Sharks> problem (AppSupport binaries need updating to be compatible
16:31:19 <rainemak> #info <Sharks> with Android 15 base)? Is there a preferred way to open a line
16:31:21 <rainemak> #info <Sharks> of dialogue on this topic between myself / any other willing
16:31:23 <rainemak> #info <Sharks> community developer(s) and Jolla so that we can work towards a
16:31:25 <rainemak> #info <Sharks> functioning solution? Noting that I live on the wrong side of
16:31:29 <rainemak> #info <Sharks> the world (GMT+10) and have a day job.
16:31:31 <rainemak> #info <Jolla> Likely next steps for AppSupport is that we first adapt
16:31:33 <rainemak> #info <Jolla> AppSupport 15 to Jolla C2. Let's see who do we have from Jolla
16:31:35 <rainemak> #info <Jolla> team to comment on more technical parts of this.
16:31:37 <rainemak> Let's think who should be organize an open line for dialogue. I think we could use the #sailfishos or #sailfishos-porters channels.
16:33:56 <Polatbirdal> It would be really nice if the C2 supported Android 15.
16:38:02 <rainemak> anything comments regarding the discussion channel?
16:39:29 <rainemak> I guess not... we can start with #sailfishos channel
16:39:40 <rainemak> #topic Official Xperia 10 IV/V Jolla Ports: Latest internal tests based on which blobs, how far from feature complete, can we help get it done? (5 mins -- asked by @yusssufff)
16:39:40 <rainemak> #info <yusssufff> I know that some community ports are being developped.
16:39:40 <rainemak> #info <yusssufff> Nevertheless, I am personally very keep on offical ports,
16:39:40 <rainemak> #info <yusssufff> especially as I prefer to entrust @jolla for coding such
16:39:40 <rainemak> #info <yusssufff> sensitive software.
16:39:42 <rainemak> #info <yusssufff> A company is a liability.
16:39:44 <rainemak> #info <yusssufff>
16:39:46 <rainemak> #info <yusssufff> Therefore I wished to know how far did went the latest tests
16:39:48 <rainemak> #info <yusssufff> @mal and @jolla did with the 10 V. About a year ago @mal
16:39:50 <rainemak> #info <yusssufff> mentionned camera and audio finally working against ‘‘latest
16:39:52 <rainemak> #info <yusssufff> blobs’’, that fingerprint was to be skipped, and that VoLTE
16:39:54 <rainemak> #info <yusssufff> had new configs that came along with the new blobs and that
16:39:58 <rainemak> #info <yusssufff> it was now a hard nut to crack…
16:40:00 <rainemak> #info <yusssufff>
16:40:02 <rainemak> #info <yusssufff> I wish to know which ‘latest’ blobs specifically were used
16:40:04 <rainemak> #info <yusssufff> back then, and how much work is still missing (sure giving
16:40:06 <rainemak> #info <yusssufff> up on fingerprint, that’s a given) to get it all mostly set
16:40:08 <rainemak> #info <yusssufff> up (only volte left to work on?). Could community help crack
16:40:10 <rainemak> #info <yusssufff> this nut, if you share with us the exact piece of work still
16:40:12 <rainemak> #info <yusssufff> needed to be achieved?
16:40:14 <rainemak> #info <yusssufff> Would be so lovely to get the last push for that official
16:40:16 <rainemak> #info <yusssufff> Xperia port :blush:.
16:40:18 <rainemak> #info <Jolla> The official Jolla ports for 10 IV and 10 V were left pretty
16:40:20 <rainemak> #info <Jolla> much to state we communicated earlier. If mal is around, he
16:40:22 <rainemak> #info <Jolla> could comment more.
16:41:10 <mal> camera worked partially, I think 2 out of 4 cameras, volte had some issues even with the aidl support code I wrote
16:42:02 <mal> also some issues with suspending, something changed which needs some further investigation, I did solve some of the issues causing suspend issues but not all
16:43:02 <mal> as mentioned in some previous meeting, the audio routing fixed for headphone jack for example are not tied to blobs
16:45:42 <rainemak> thanks mal for covering this one
16:45:54 <rainemak> #topic Sound/microphone issue with audio/video recordings. (5 mins -- asked by Cryx)
16:45:54 <rainemak> #info <Cryx> sound in audio and video recordings is very bad, details get
16:45:54 <rainemak> #info <Cryx> lost. This may be related to a possible noise cancellation
16:45:54 <rainemak> #info <Cryx> process what is good for calls, but very bad for recordings with
16:45:54 <rainemak> #info <Cryx> camera or audiorecorder. See some more details in the linked
16:45:55 <rainemak> #info <Cryx> thread below.
16:45:59 <rainemak> #info <Cryx>
16:46:01 <rainemak> #info <Cryx> What’s the reason for that, is there a possible solution that can
16:46:03 <rainemak> #info <Cryx> be implemented like disabeling noise cancellation (if that’s the
16:46:05 <rainemak> #info <Cryx> reason) for recordings, maybe even with a toggle in camera and
16:46:07 <rainemak> #info <Cryx> audiorecorder or their settings?
16:46:09 <rainemak> #link https://forum.sailfishos.org/t/very-bad-sound-in-recordings-from-jolla-phone-2026/32800
16:46:11 <rainemak> #info <Jolla> Thank you for asking. Needs more investigation. Let's have open
16:46:13 <rainemak> #info <Jolla> discussion.
16:46:51 <mal> does the audio recording seem low volume or something else?
16:47:36 <Polatbirdal> Also, is there any chance we could get something like noise filtering during calls as well? I think it’s pretty much in the same category as this issue.
16:47:53 <Cryx[m]> Okay. Ned to say yhat I didn't notice similar behavior on other SFOS phones, but other users reported that too.
16:48:14 <Cryx[m]> Some in the forum said noise cancellation may be the problem...
16:48:36 <Cryx[m]> So is there a noise cancellation for calls?
16:49:05 <rubdos[m]> Some few drops from my side's JP2026: I seldom really call, but I did take a few calls this week and all participants were complaining that I'm not clear. So maybe it's not just outside of calls?
16:49:13 <Cryx[m]> mal malno, volume seems okay. But missing details.
16:49:21 <Polatbirdal> No, I don’t think there is. I mean, if it even picks up the wind noise outside?
16:49:44 <mal> ok, maybe also could be bad recording format or bitrate? needs some investigation
16:49:49 <rubdos[m]> (all my own calls were inside, most recent one in well isolated environment)
16:50:08 <mal> rubdos[m]: 2g or 4g calls?
16:50:55 <rainemak> I am calling quite a lot and only had audio quality issues on 2G network -> left that enabled accidentally after testing things
16:51:11 <CLMA31[m]> I can also report that during phone calls others have reported not hearing my voice well. In my case phone reported low 4G before call, didn't check during it. But my guess would have that phone defaulted on 2G
16:51:13 <mal> there should be noise cancelling unless it has some issues
16:51:20 <rubdos[m]> mal: I suspect 4G, mal, but I'll pay attention at any next time
16:51:43 <rubdos[m]> I'll check the volte checkmark right now
16:51:49 <Cryx[m]> I also don't do much calls, I'm also not sure if it could also be a hardware problem. But as said, calls were okay.
16:51:55 <rubdos[m]> volte is registered :)
16:52:14 <mal> there is the thread on forum about 2g call audio issue
16:52:45 <Polatbirdal> Well, isn’t this problem basically because there’s no filtering feature? That’s what I think.
16:52:46 <CLMA31[m]> I also remember reading from forum that when recording phone calls the other participant voice is much lower
16:53:38 <rainemak> mal, I don't think so but honestly thinking that it might have been just a bandwidth issue
16:55:03 <mal> needs more testing anyway
16:55:04 <rainemak> let's move on...
16:55:19 <rainemak> #topic The Jolla phone 2026 screen may not have a software problem. (10 mins -- asked by Polatbirdal)
16:55:19 <rainemak> #info <Polatbirdal> Hello, this issue was also discussed on August 20, but the
16:55:19 <rainemak> #info <Polatbirdal> exact cause still hadn’t been properly investigated. After
16:55:19 <rainemak> #info <Polatbirdal> that meeting, some people opened new threads, and we came
16:55:19 <rainemak> #info <Polatbirdal> across some interesting information.
16:55:21 <rainemak> #info <Polatbirdal>
16:55:23 <rainemak> #info <Polatbirdal> Some people who bought the Jolla Phone 2026 were able to
16:55:25 <rainemak> #info <Polatbirdal> pass every screen color test without any issues at all.
16:55:29 <rainemak> #info <Polatbirdal> However, others experienced problems regardless of which
16:55:31 <rainemak> #info <Polatbirdal> color test they ran. Some described it as looking like a
16:55:33 <rainemak> #info <Polatbirdal> “Mexico filter,” while others saw a shadowy green tint
16:55:35 <rainemak> #info <Polatbirdal> appearing over black areas, or shading near the very top
16:55:37 <rainemak> #info <Polatbirdal> of the screen with orange and red colors.
16:55:39 <rainemak> #info <Polatbirdal>
16:55:41 <rainemak> #info <Polatbirdal> At first, before we had this kind of evidence, most people
16:55:43 <rainemak> #info <Polatbirdal> thought the issue was software-related. But now that some
16:55:45 <rainemak> #info <Polatbirdal> users experience it while others don’t experience it at
16:55:47 <rainemak> #info <Polatbirdal> all, it has made the issue even more interesting and
16:55:49 <rainemak> #info <Polatbirdal> raised more questions.
16:55:51 <rainemak> #info <Polatbirdal>
16:55:53 <rainemak> #info <Polatbirdal> Has any further investigation been done on this? At this
16:55:55 <rainemak> #info <Polatbirdal> point, it doesn’t really seem like a software-related
16:55:59 <rainemak> #info <Polatbirdal> issue anymore.
16:56:01 <rainemak> #info <Jolla> If there are hardware defects, those are covered by warranty.
16:56:03 <rainemak> #info <Jolla> Whether you have a hardware defect that is another story.
16:56:25 <CLMA31[m]> I made the phone calls from our summer cottage in Ylöjärvi. Around 20-25min from Jolla office and haven't had any problems there before with other phones. But in case there is bug with 2G calls, I'm sure it will get fixed :)
16:57:48 <rubdos[m]> (is this also the time to ask about the LCD-like appearance at night/when dark?)
16:57:50 <Polatbirdal> What I meant was, this isn’t a hardware issue like the front camera dust problem, right? Of course you’re the ones doing the tests; I just wanted to mention it because quite a lot of people seem to be experiencing it.
16:58:51 <CLMA31[m]> rubdos[m]: I think topic is about exactly this
16:58:56 <Polatbirdal> rubdos, yes, there’s also something like what you’re talking about. Some people are experiencing it right now, while others don’t experience it at all. We haven’t been able to make sense of it.
17:00:26 <rainemak> rubdos[m], what do you mean by LCD-like appearance
17:00:31 <rubdos[m]> Is it worth leaving https://forum.sailfishos.org/t/display-is-not-colour-managed-vendor-srgb-colour-mode-exists-but-sailfish-never-selects-it/31537?u=rubdos <- that link here, then?
17:00:46 <rubdos[m]> I mean: at night, minimum brightness, anything that I expect to be black is a washed out gray
17:01:03 <rubdos[m]> all the colours neatly smushed and compressed together into one gray abyss.
17:01:11 <rubdos[m]> (I am exaggerating a bit there)
17:01:21 <rubdos[m]> From skimming the link I just pasted, it looked like that was it
17:01:41 <rainemak> #link https://forum.sailfishos.org/t/display-is-not-colour-managed-vendor-srgb-colour-mode-exists-but-sailfish-never-selects-it/31537
17:02:12 <rubdos[m]> I needed a bit of time to find the link, the forum search can be really troublesome...
17:02:19 <rainemak> also color profiles we enable / implement
17:02:59 <rubdos[m]> This too I guess https://forum.sailfishos.org/t/jolla-phone-2026-black-crush-below-a-certain-brightness-threshold/32771
17:03:35 <Polatbirdal> So, um, this wouldn’t be a hardware issue that everyone could potentially experience, right? When posts like this started appearing, we thought it might be like the front camera issue.
17:03:49 <CLMA31[m]> rainemak: Black isn't really black. It has that kind of greenish glow in the background, which is easiest to spot in complete darkness and with lowest brightness level on screen
17:04:15 <rainemak> yeah, people experience these kind of things differently
17:04:17 <rubdos[m]> yes, greenish gray here too. Definitely not black, as in no light as you'd expect from an OLED panel.
17:04:52 <Polatbirdal> CLMA31, I agree. Has the cause of this ever been investigated? What do you think is causing it?
17:06:50 <CLMA31[m]> I'm not a expert so can't really say
17:08:16 <rainemak> this goes into too speculative... if no objection, let's move to next topic.
17:08:21 <CLMA31[m]> I would like to think it is software bug unless proven otherwise
17:08:46 <rainemak> took a liberty to extend next topic to 10mins
17:09:08 <rubdos[m]> Would be good to have some statement about the display grays and colors from Jolla at some point though.
17:09:12 <CLMA31[m]> +1
17:09:19 <Polatbirdal> At least it would be good if some of the devices that have been shipped were tested, just to see whether this problem affects a lot of people or whether it’s completely software-related.
17:10:00 <rainemak> rubdos[m], noted that
17:10:08 <rainemak> #topic Camera Quality and resolution of new Jolla Phone (10 mins -- asked by Cryx)
17:10:08 <rainemak> #info <Cryx> The forum starts to discuss about the capabilities and problems
17:10:08 <rainemak> #info <Cryx> with the camera. One point is the resolution of pictures taken
17:10:08 <rainemak> #info <Cryx> with the native SFOS camera that just seems to use half of the
17:10:08 <rainemak> #info <Cryx> possible resolution compared to Advanced Camera or even Android
17:10:09 <rainemak> #info <Cryx> camera apps.
17:10:11 <rainemak> #info <Cryx>
17:10:13 <rainemak> #info <Cryx> SFOS has a max of 4096 with both back cameras, while Advanced
17:10:15 <rainemak> #info <Cryx> Camera has a max 4096 and 8192 for the different back cameras.
17:10:17 <rainemak> #info <Cryx>
17:10:19 <rainemak> #info <Cryx> Front camera resoltion is a little bit more then double with
17:10:21 <rainemak> #info <Cryx> Advanced camera compared to SFOS stock camera.
17:10:23 <rainemak> #info <Cryx>
17:10:23 <rubdos[m]> thank you raine, appreciate it.
17:10:25 <rainemak> #info <Cryx> Also the max video resolution is 1440 in all apps - but as the
17:10:27 <CLMA31[m]> As someone living in Tampere, I can come and demonstrare the thing easily :)
17:10:29 <rainemak> #info <Cryx> camera module is/was also used in Sony’s Xperia Range (if we got
17:10:31 <rainemak> #info <Cryx> that right) and capable of recording 4k videos even with an
17:10:33 <rainemak> #info <Cryx> Xperia 10 III it should be possible to do 4k videos on the much
17:10:35 <rainemak> #info <Cryx> better hardware of the new Jolla Phone too.
17:10:37 <rainemak> #info <Cryx>
17:10:39 <rainemak> #info <Cryx> Some dome concrete questions:
17:10:41 <rainemak> #info <Cryx>
17:10:43 <rainemak> #info <Cryx> - Why does the SFOS camera app not use the max resolution for the main (1.0) camera?
17:10:46 <rainemak> #info <Cryx> - Is the Jolla Phone capable to take 4K videos from the hardware
17:10:48 <rainemak> #info <Cryx>   side (especially camera modules and processor)? If yes, what
17:10:50 <rainemak> #info <Cryx>   must be done to enable this?
17:10:52 <rainemak> #info <Cryx> - We had filters on other devices (that were still in Xperia 10
17:10:54 <rainemak> #info <Cryx>   III but not working) and now are completely missing on the new
17:10:58 <rainemak> #info <Cryx>   Jolla Phone. Are there plans to bring that feature back with a
17:11:00 <rainemak> #info <Cryx>   future update?
17:11:02 <rubdos[m]> CLMA31[m]: hehe I'd fly in to come and show it.
17:11:02 <rainemak> #info <Cryx> - Several people notice a fisheye effect especially with the
17:11:04 <rainemak> #info <Cryx>   (0.5) camera in 4:3. Listening to some people this is caused by
17:11:06 <rainemak> #info <Cryx>   the picture processing. Is there a plan to improve that (maybe
17:11:08 <rainemak> #info <Cryx>   with Camera API 2 (if I’m right even the new Jolla Phone still
17:11:10 <rainemak> #info <Cryx>   uses API 1)?
17:11:29 <rainemak> let's continue that display topic in general discussion at the end
17:11:36 <rainemak> #info <Jolla> Thank you asking. We opened Camera app wishlist on January and
17:11:36 <rainemak> #info <Jolla> Camera app itself has been open for quite some time already.
17:11:36 <rainemak> #info <Jolla> Contributions welcome ;-).
17:11:36 <rainemak> #link https://forum.sailfishos.org/t/sailfish-camera-app-wishlist/24497
17:11:36 <rainemak> #info <Jolla> In all seriousness, we all want to get improvements to Camera
17:11:37 <rainemak> #info <Jolla> app. Firstly, we need a fix for the max resolution. Further,
17:11:39 <rainemak> #info <Jolla> we should have more selections for resolution setting. Also
17:11:41 <rainemak> #info <Jolla> people tend to understand megapixels so there could be an easy
17:11:43 <rainemak> #info <Jolla> way to select image quality. Maybe nowadays selecting lower
17:11:45 <rainemak> #info <Jolla> image quality due to storage usage is not that big of issue but
17:11:47 <rainemak> #info <Jolla> there can be other factors like capturing speed that needs to be
17:11:49 <rainemak> #info <Jolla> taken into account.
17:12:44 <rubdos[m]> rainemak: Ack. DNG output PR incoming.
17:12:57 * rubdos[m] braces.
17:13:02 <rubdos_> (that's citing "contributions welcome")
17:13:10 <rainemak> And also there have been good development in Camera 2 API front to enable some more advanced features for camera
17:13:47 <rainemak> rubdos_, nice
17:14:05 <rubdos[m]> haha let's see how far I get though.
17:14:20 <Polatbirdal> Let me put it this way: SFOS devices in general are a bit behind when it comes to image detail. Do you think this will improve that? Will we finally be able to see more detail when we zoom into photos?
17:15:53 <rubdos[m]> Re Camera 2 API, any useful links to share regarding that? Especially git links? ;-)
17:16:18 <rainemak> Polatbirdal, that's the target. We should reach that relatively easily. Same level as if you'd take a photo with Open Camera -- Android app that you can download from F-Droid. That's using Camera 2 API and has all sorts of options.
17:17:20 <rainemak> let's say complex part comes after that when camera tunings need to be adjusted
17:17:28 <Polatbirdal> rubdos, try talking to Juha. I can sometimes get some info out of him by spamming him :D I don’t know if he’d help for free though.
17:18:09 <rubdos[m]> Looks like raw output really needs Camera2 though :')
17:18:32 <rainemak> again +1 for Camera2
17:19:13 <Polatbirdal> <rainemak> Then that’s great news. When users try the camera on the Android side, it seems to handle depth and shadows better. I’m sure some really nice results will come out of this =)
17:19:53 <rainemak> As a backup it's not bad to have Open Camera from F-Droid
17:20:44 <rainemak> as a summary, we all want improvements for camera :-)
17:21:06 <abr> there was another android one people tried that seemed very good too. did more post-processing than opencamera
17:21:12 <abr> can't remember the name
17:21:22 <rubdos[m]> Sounds like we all just want Camera2 because of some reason
17:21:25 <Polatbirdal> %1
17:21:35 <Polatbirdal> +1
17:21:36 <rubdos[m]> When MVP? :D
17:21:50 <rainemak> abr, please share if you recall it
17:21:59 <abr> i don't think camera2 will solve the quality issues. just give more tweaking options.
17:22:11 <rainemak> correct
17:22:40 <abr> Polatbirdal: can you remember that other camera app people were testing with?
17:22:40 <rainemak> but cranking up resolution and highest possible quality may take as already a bit forward
17:22:54 <abr> i can only find you mentioning it as 'hedge camera' but I don't think that was the name
17:23:00 <rainemak> s/as/us/
17:23:17 <rainemak> 2mins more for this
17:23:36 <rainemak> rubdos[m], no dates as usual
17:23:53 <Cryx[m]> What about filters?
17:24:10 <rainemak> Cryx[m], more filters will be available through camera2
17:24:21 <Cryx[m]> Completely missing for Jolla Phone...
17:24:21 <rainemak> thus, can be made available for ui as well
17:25:03 <rainemak> let's carry on
17:25:07 <rainemak> #topic Open Pull Requests (PRs) to discussion (5 mins -- asked by Jolla)
17:25:07 <Polatbirdal> yes ı remember
17:25:57 <Polatbirdal> HedgeCam 2 apps
17:26:10 <Polatbirdal> Yeah, I remember. It was a photo of a Tesla. In the photo taken with the native camera, the depth and the background were a bit blurry, but in the photo he said he took with the app that guy recommended, the shadows on the car had more detail, and the trees in the background looked more naturally pixelated rather than digitally pixelated.
17:26:28 <abr> that's it! thanks
17:26:39 <abr> hedgecam
17:26:52 <mal> need to check jpeg compression and other things
17:27:25 <Polatbirdal> https://forum.sailfishos.org/t/jolla-phone-camera-too-many-details-are-lost/32717/35?u=polatbirdal  hedgecam vs default camera
17:29:04 <rainemak> let's continue camera discussion as well in general
17:29:12 <rainemak> any pull requests that you'd like to discuss
17:30:03 <Polatbirdal> As far as I know, this phone’s main camera uses the camera from a Sony Xperia 1 IV, which is a flagship. I don’t know if I’m exaggerating, but if we can really get this thing properly sorted out, I think we could absolutely smoke most phone cameras.
17:30:47 <rainemak> please, stay within the topic
17:31:11 <rainemak> #topic General discussion (10 mins)
17:31:39 <rubdos[m]> (if you try Open Camera: open settings and change Camera API to Camera2. No idea why it's not default. I have a DNG open in Darktable meanwhile!)
17:31:39 <rainemak> #link  https://forum.sailfishos.org/t/jolla-phone-camera-too-many-details-are-lost/32717/35
17:31:55 <rainemak> rubdos[m], :-)
17:32:18 <Polatbirdal> :D
17:32:48 <Cryx[m]> Some info on possible 4K video recording? That question was left behind above ...
17:33:18 <Cryx[m]> Or also related to API2?
17:33:36 <rainemak> Cryx[m], I don't think that's Camera2 related
17:33:40 <rubdos[m]> Is someone working to get the lenses submitted to lensfun? 👀
17:35:17 <Polatbirdal> Speaking of general discussion, how far have you gotten with shipments now? Have you reached 4,000 units yet?
17:35:19 <abr> i think the camera backend would have to support h265 to do 4k videos, and I don't think it does or whether we have a license for it to do that either
17:35:36 <rainemak> Polatbirdal, as you should know, no comments
17:36:36 <Polatbirdal> =)
17:37:08 <Cryx[m]> abr: Does webm also need to be licensed? Have that on 10 III, but not on Jolla Phone...
17:37:30 <mal> currently main camera reports 2560x1440 as maximum video resolution
17:37:34 <abr> Cryx[m]: has to be a hardware codec available on the device
17:37:50 <rainemak> mal, and that needs fixing
17:37:56 <mal> if possible
17:38:02 <rainemak> if possible yes
17:38:04 <abr> because it's too much data for software codecs to keep up with
17:38:28 <rainemak> makes sense
17:39:04 <rainemak> 4 mins to go
17:39:37 <Cryx[m]> So no chance or just not enabled/usable by system software?
17:39:51 <Polatbirdal> Everyone’s giving the main camera so much attention :D the ultrawide is feeling left out =/
17:40:02 <rubdos[m]> I love the ultrawide!
17:40:09 <Cryx[m]> Panorama ... ;-)
17:40:18 <rubdos[m]> Makes me want a 10mm or so for my ICLE.
17:41:05 <rubdos[m]> I'll have a look around to whether I can submit some samples for the Lensfun db. Then we can abuse that already in Darktable when the DNGs get released :D
17:41:13 <rubdos[m]> unleashed*
17:43:03 <abr> camera app really needs some sw processing. like panorama and bracketing
17:43:24 <abr> opencamera has a lot of cool stuff that could be used for inspiration
17:43:57 <Cryx[m]> Do the actual shipped phones already have the upgraded TOH board?
17:45:04 <Polatbirdal> yes ı3c speed ?
17:45:38 <rainemak> Cryx[m], could you be more specific, which actual shipped phones you are referring to?
17:47:06 <CLMA31[m]> I think what Cryx is wondering, what phones had the I2C bug and from which date onwards phones had fixed board for I3C
17:47:09 <rainemak> we'll give a separate i3c update soonish
17:47:17 <Cryx[m]> rainemak: First batch had the wromg boards was what you said. Did perhaps miss an info if tbat was changed after that fault was discoverd..
17:47:47 <rainemak> shall we schedule next meeting
17:48:06 <rainemak> #topic Next meeting time and date (2 mins)
17:48:06 <rainemak> Proposing Thursday 17th September at 04:00 PM UTC
17:48:37 <CLMA31[m]> Normal interval, sounds good
17:48:42 <Polatbirdal> Thanks for taking the time for us, and thanks to everyone here as well. It was a nice meeting.
17:48:47 <rubdos[m]> Thanks! This was a good one!
17:49:00 <rainemak> #info Next meeting will be held on Thursday 17th September 2026 at 04:00pm UTC: 2026-09-17T1600Z
17:49:22 <rainemak> thank you all! once again a good one indeed!
17:49:28 <rainemak> #endmeeting