16:00:03 <Keto> #startmeeting Sailfish OS, open source, collaboration -- October 1, 2026
16:00:03 <sailbot> Meeting started Thu Oct  1 16:00:03 2026 UTC. The chair is Keto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:03 <sailbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:07 <pherjung[m]> Hello everyone :)
16:00:18 <rainemak> #info Meeting information and agenda can be found here:
16:00:19 <rainemak> #link https://forum.sailfishos.org/t/33735
16:00:37 <rainemak> I am the meeting's co-chairperson today with Keto, and will be doing my best to keep time and order. Please respect the timings and bee-hive.
16:00:37 <rainemak> #topic Brief introduction (5 min). Please prefix your name/handle with #info
16:00:45 <extechop[m]> #info Otto Mäkelä, community
16:00:50 <rainemak> #info Raine Mäkeläinen, Jolla
16:00:55 <pherjung[m]> #info pherjung, community
16:01:07 <MiPal75> #info Michal Kasík, community, Jolla Phone 2026 user
16:01:27 <Keto> #info Pami Ketolainen, Jolla
16:02:43 <Nico> #info Nico, community
16:03:45 <abr> #info Andrew Branson, sailing by
16:04:52 <rainemak> let's start in a moment and check action points
16:05:10 <rainemak> #topic Tracking of non-resolved Community Meeting topics
16:05:10 <rainemak> #action Community task board
16:05:10 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-23rd-april-2026/29030/3
16:05:10 <rainemak> #action Jolla to update regarding recommended charging cables and chargers.
16:05:10 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-7th-may-2026/29253/2
16:05:13 <rainemak> #action The Privacy Switch in relation to Ambiances
16:05:15 <rainemak> #link https://forum.sailfishos.org/t/community-meeting-on-july-16-2026/30378/7
16:05:17 <rainemak> #info No actions taken yet regarding community task board nor charger / cables.
16:06:43 <rainemak> one moment, I think Keto needs to redo above
16:07:35 <Keto> well, they are now in first topic, lets just move on
16:07:47 <Keto> #topic Quick app switching gesture (5 mins -- jojomen)
16:09:02 <rainemak> #info <jojomen> The Quick App Switching gesture works really well and I find
16:09:02 <rainemak> #info <jojomen> it essential in my everyday phone usage. Apparently, I’m not
16:09:02 <rainemak> #info <jojomen> alone in this: Switching between 2 apps more easilly (eg
16:09:02 <rainemak> #info <jojomen> password manager)
16:09:02 <rainemak> #info <jojomen>
16:09:04 <rainemak> #info <jojomen> Edit: This has also been frequently requested by many new
16:09:05 <rainemak> #info <jojomen> members brought here by the Jolla Phone.
16:09:07 <rainemak> #info <jojomen>
16:09:09 <rainemak> #info <jojomen> However, to enable the gesture one has to issue a dconf
16:09:13 <rainemak> #info <jojomen> command in the terminal. Please, could we have a toggle for
16:09:15 <rainemak> #info <jojomen> this gesture in the Settings app, section Gestures?
16:09:17 <rainemak> #info <jojomen>
16:09:19 <rainemak> #info <jojomen> (It can also be set from the pulley menu of the Edge Swipe
16:09:21 <rainemak> #info <jojomen> Control app by @nephros, but it is still pretty hidden.)
16:09:23 <rainemak> #info <Jolla> Yes, we should have hidden used configuration values visible
16:09:25 <rainemak> #info <Jolla> somewhere. Not a high priority item thou.
16:09:27 <rainemak> I'm personally using quick app switching as well.
16:09:46 <nephros> #info nephros, community, observing...
16:10:53 <rainemak> Let's see how we should handle this... I'm thinking open source Settings plugin. Maybe Sailfish Labs or such.
16:11:05 <nephros> Exposing UI should be relatively simple addition to Setttings. Community could do it.
16:11:17 <nephros> Question is where to send the fils.
16:11:20 <nephros> *files.
16:11:23 <Nico> Yeah, I do use the quick switch as well and it seems like a shame, that it isn't exposed currently to more users :D
16:11:27 <pherjung[m]> open-sourcing settings plugin would be awesome
16:11:45 <Keto> is there somereason to not just add it to the gestures settings?
16:12:22 <nephros> Keto: yea, seems like 1 TextSwitch and 7 lines of code or so.
16:12:23 <rainemak> imo, can go there as well...  but that's closed
16:12:44 <extechop[m]> Is there a specific reason it needs to be closed?
16:12:44 <rainemak> I think this more broadly as we have tons of these
16:13:35 <extechop[m]> I'm not quite sure I understand the scope of what Patchmanager can and can't do, could it make the appropriate additions there?
16:13:45 <nephros> OK, so maybe "github.com:sailfishos/sailfish-settings-labs" , and we put Setting entrie sand things there for review?
16:13:53 <rainemak> I have 12 in my list
16:14:00 <nephros> extechop[m]: yes, that's trivial.
16:14:16 <rainemak> nephros, something like that
16:14:38 <rainemak> we could there have sections like Gestures, App Grip, Animations, etc...
16:14:49 <rainemak> or even sub-pages
16:15:03 <abr> 12! I only know that one and the LPM
16:15:20 <abr> something like the utilities app maybe
16:15:24 <abr> or even part of that
16:15:26 <pherjung[m]> or use patchmanager and once it's mature merge to the system?
16:15:41 <abr> in fact utilities is already open
16:15:43 <rainemak> pherjung[m], I'd rather not use patchmanager
16:15:57 <rainemak> abr, that's wrong direction as well
16:16:31 <extechop[m]> But wouldn't Patchmanager make a good light-weight "proof of concept" and people could try the feature out?
16:16:46 <rainemak> there is no proof-of-concept
16:17:00 <rainemak> more like x number of dconf keys
16:17:34 <nephros> Well, here's one PoC: https://github.com/nephros/peekfilter-button/blob/master/jolla-settings/pages/peekfilter-button/AdvancedPage.qml
16:17:45 <extechop[m]> In this case, a test to see if people would want to have feature X.
16:18:09 <pherjung[m]> or start a debate what should be improved
16:18:11 <rainemak> nephros, it's exactly what I'm thinking with this Labs
16:18:21 <rainemak> experimental features
16:19:06 <pherjung[m]> I'm curious, what are the issues to use patchmanager to provide experimental features?
16:19:09 <abr> i'm surprised there isn't already an app to set these values
16:19:17 <rainemak> pherjung[m], it's not for everybody
16:19:31 <pherjung[m]> not sure to understand
16:19:33 <rainemak> I'd like to get these values for broader use
16:19:35 <abr> I think the features are already implemented, so patchmanager isn't really needed
16:19:42 <abr> it's just config that's missing
16:19:43 <nephros> abr: there's a couple of patchmanager patches out there, some use these dconf keys.
16:19:49 <extechop[m]> Experimental features surely are not for everyone.
16:20:16 <pherjung[m]> oh, that make sense. But it means such features would be already mature to not break the system?
16:20:16 <rainemak> extechop[m], you miss the point
16:20:36 <rainemak> trying out "Quick app switching" and make it simple enough
16:20:59 <nephros> Without mice and lab assistants, what's the use of an experimental feature? :)
16:21:42 <extechop[m]> We need to write it down, otherwise it's just messing around, like the Mythbusters said.
16:21:43 <rainemak> "Experimental Features" <- from the above peekfilter-button
16:21:46 <pherjung[m]> perhaps the word experimental is not the good one
16:22:07 <rainemak> no need to decide it here
16:22:11 <rainemak> it's matter of open PR
16:22:28 <rainemak> if you are happy with sailfish-settings-labs -> then I'll create one
16:22:36 <rainemak> and BSD-3 license
16:22:37 <abr> +1
16:22:41 <pherjung[m]> +1
16:22:42 <muhnschein> +1 <3
16:22:43 <nephros> Heh just spotted a bug in that peekfilter-button page.
16:23:11 <rainemak> #action Jolla to create sailfish-settings-labs
16:23:21 <rainemak> let's move on
16:23:31 <nephros> ^ Oh yeah! I have two or three "apps" that go there, and I guess there's a selection of patchmanager patches as well.
16:23:31 <rainemak> Keto, next topic
16:23:33 <Keto> #topic Harbour policy: allowing a bundled helper executable (10 mins -- muhnschein)
16:23:46 <rainemak> #info <muhnschein> Harbour only allows ELF files at /usr/bin/<NAME> or as .so
16:23:46 <rainemak> #info <muhnschein> libraries under /usr/share/<NAME>/lib/. This blocks apps
16:23:46 <rainemak> #info <muhnschein> like Piirit that bundle an upstream helper binary and run
16:23:46 <rainemak> #info <muhnschein> it as a subprocess. There are many legitimate use cases for
16:23:46 <rainemak> #info <muhnschein> this.
16:23:48 <rainemak> #info <muhnschein>
16:23:49 <rainemak> #info <muhnschein> Proposal: allow ELF executables in an app-private directory
16:23:51 <rainemak> #info <muhnschein> (e.g. /usr/libexec/<NAME>/), under the same conditions as
16:23:53 <rainemak> #info <muhnschein> the main binary (no setuid/setgid, no group/world-writable
16:23:55 <rainemak> #info <muhnschein> modes, dynamic libraries on the allow-list).
16:23:57 <rainemak> #info <muhnschein>
16:23:59 <rainemak> #info <muhnschein> More context: Harbour policy: allowing a bundled helper
16:24:01 <rainemak> #info <muhnschein> executable (re Piirit).
16:24:03 <rainemak> #link https://forum.sailfishos.org/t/33807
16:24:05 <rainemak> #info <Jolla> Open discussion on this.
16:24:44 <muhnschein> May I? First-timer, bear with me.
16:25:08 <muhnschein> Basically what it says on the tin.
16:25:09 <rainemak> please do
16:25:13 <muhnschein> work on Piirit, a messenger based on Delta Chat. Piirit bundles Delta Chat's official `deltachat-rpc-server` companion binary, as is recommended by them. (The alternatives are a deprecated upstream interface or one that upstream does not recommend themselves.)
16:25:22 <muhnschein> Harbour allows only one executable per app, and this helper binary is in /usr/libexec/harbour-piirit/deltachat-rpc-server;  so validation obviously fails (3 errors overall).
16:25:42 <muhnschein> Proposal therefore, as stated above: Allow ELF executables in a single app-private directory, e.g., /usr/libexec/<NAME>/, and adjust the validator accordingly.
16:25:50 <rainemak> background daemon discussion has been long lasting topic
16:25:54 <muhnschein> (As a bonus, vige already said this could work and offered to prepare the validator PR. *cough* :-) )
16:26:09 <muhnschein> rainemak: Yup, this is not that though.
16:26:30 <muhnschein> This is only supposed to run while the app is running. Gone when app is gone.
16:26:42 <rainemak> but should work with a sandbox and I think be compatible
16:27:01 <rainemak> those kind of sailjail rules could be created
16:27:27 <abr> yeah i guess it would be invoked by the app, so runs in the sandbox with it?
16:27:41 <rainemak> abr, that's what I'm thinking
16:27:42 <muhnschein> Yup, that's the idea, same namespace
16:28:24 <abr> sounds good to me
16:28:30 <rainemak> any other thoughts...
16:28:53 <muhnschein> thats all from my end. i'd appreciate the change.
16:28:56 <rainemak> light-weight steps towards real background daemons
16:29:00 <abr> yeah
16:29:17 <abr> though i wouldn't like to say those could be any binary
16:29:48 <muhnschein> abr: agreed. if these would come with a more involved harbour review, that'd be fine by me.
16:30:28 <abr> we'd have to make sure that closing the app also terminated the sandbox until then. i think it might do already
16:31:20 <nephros> No biggie, but if that dir were /usr/share/appname/bin instead of /usr/libexec/appname, this would make apps easier to "relocate", i.e. change the installation root path.
16:31:25 <rainemak> doesn't sound too bad too me either
16:31:43 <rainemak> nephros, +1
16:31:52 <rainemak> or /opt
16:32:07 <abr> binaries in /usr/share though?
16:32:24 <nephros> abr: it's iffy, but already allowed and the case.
16:32:38 <rainemak> let's take that separately. I think we have common understanding that we could have 2nd binary with an app
16:32:49 <muhnschein> <3
16:33:04 <muhnschein> nice, thanks
16:33:43 <rainemak> #action Iron out bundled helper executable (https://forum.sailfishos.org/t/community-meeting-on-october-1-2026/33735/4)
16:33:59 <rainemak> let's move... sorry this went long as ewll
16:34:01 <rainemak> well
16:34:12 <rainemak> ^ Keto
16:34:18 <Keto> #topic Touchscreen nearby taps detected as drag gesture (bug?) (5mins -- asked by nicov84)
16:34:33 <rainemak> #info <nicov84> As per BUG report by @HtheB, the touchscreen seems to detect
16:34:33 <rainemak> #info <nicov84> subsequent, close distance taps as drags. This causes some
16:34:33 <rainemak> #info <nicov84> apps (standard keyboard, futo keyboard) to misbehave.
16:34:33 <rainemak> #info <nicov84> For the standard keyboard, this results in sudden layout
16:34:33 <rainemak> #info <nicov84> changes. For futo, in problematic swiping and typos.
16:34:34 <rainemak> #info <nicov84> Is this a hardware issue or can the sensitivity/behavior be
16:34:36 <rainemak> #info <nicov84> tuned in software?
16:34:38 <rainemak> #info <nicov84> Two near-simultaneous taps with different fingers are
16:34:40 <rainemak> #info <nicov84> delivered as a single touch point dragging between them
16:34:44 <rainemak> #link https://forum.sailfishos.org/t/33237
16:34:54 <rainemak> #info <Jolla> This is more like a bug report. Not much to discuss.
16:34:54 <rainemak> #info <Jolla> Doubt that two different fingers are treated as a single touch
16:34:54 <rainemak> #info <Jolla> point. Gesture it could probably trigger. Impossible to comment
16:34:55 <rainemak> #info <Jolla> about a single use case / error. We'll note this to internal
16:34:56 <rainemak> #info <Jolla> issue tracker.
16:35:06 <rainemak> I think I have seen this with Sailfish virtual keyboard whilst typing but it is long time since I saw it. When this happens with Sailfish vkb, it triggers keyboard layout change.
16:35:34 <rainemak> there are few event filters maybe those are causing some issues
16:36:05 <extechop[m]> I suspect I've seen this under Android apps like c:geo where occasionally a tap is suddenly read as a very quick swipe, and your map suddenly goes flying past you.
16:36:38 <rainemak> I don't think we create synthetic touch events
16:37:04 <rainemak> thus, it should be different event
16:37:42 <rainemak> #action Issue to be reported
16:37:48 <rainemak> let's move on
16:38:12 <rainemak> Keto, next please :-)
16:38:26 <rainemak> next one is quick one, no need to spend time there
16:38:51 <Keto> I have noticed dragging with mouse in android apps goes wild sometimes, don't know if related in any way
16:39:20 <rainemak> mouse event could actually be
16:39:39 <abr> switching keyboard layouts too easily too
16:40:01 <rainemak> abr, that's the issue that I'm seeing... or have seen
16:40:58 <Keto> anyhow, needs investigation. moving on
16:41:23 <Keto> #topic  Visibility of spare parts for the Jolla Phone at commerce.jolla.com (5 mins -- asked by jojomen)
16:41:40 <rainemak> #info <jojomen> I didn’t find the spare parts in the new shop and assumed they
16:41:40 <rainemak> #info <jojomen> were just not available yet. But then I stumbled upon this
16:41:40 <rainemak> #info <jojomen> comment Are the Jolla phones not shipping to the USA? - #26 by
16:41:42 <rainemak> #info <jojomen> makrolon, where it turns out they are just a bit hidden.
16:41:43 <rainemak> #info <jojomen>
16:41:45 <rainemak> #info <jojomen> Could we have all items visible by default in the online shop,
16:41:47 <rainemak> #info <jojomen> please? Or, if that would be too cluttered, at least a clearly
16:41:49 <rainemak> #info <jojomen> visible option to show the different categories/collections
16:41:51 <rainemak> #info <jojomen> you have defined.
16:41:53 <rainemak> #info <jojomen>
16:41:56 <rainemak> #info <jojomen> more comments and suggestions: Are the Jolla phones not
16:41:57 <rainemak> #info <jojomen> shipping to the USA? - #27 by teleshoes.
16:41:59 <rainemak> #link https://forum.sailfishos.org/t/are-the-jolla-phones-not-shipping-to-the-usa/28756/26
16:42:01 <rainemak> #link https://commerce.jolla.com/collections/jolla-phone-accessories
16:42:03 <rainemak> #info <Jolla> Know improvement topic. Noted.
16:42:05 <rainemak> Known
16:42:44 <rainemak> Let's move on.
16:43:30 <Keto> #topic Jolla Store: Fix screenshot presentation (5 mins -- asked by muhnschein)
16:43:49 <rainemak> #info <muhnschein> Jolla Store seems to crop screenshots submitted via
16:43:49 <rainemak> #info <muhnschein> Harbour. Without having measured them, these seem like the
16:43:49 <rainemak> #info <muhnschein> screen dimensions of the original Jolla Phone. Screenshots
16:43:49 <rainemak> #info <muhnschein> with other dimensions are cropped so that top and bottom
16:43:49 <rainemak> #info <muhnschein> are missing.
16:43:50 <rainemak> #info <muhnschein>
16:43:52 <rainemak> #info <muhnschein> While some work around this with letterboxing, this is
16:43:54 <rainemak> #info <muhnschein> evident in most of the apps recently added to the store:
16:43:56 <rainemak> #info <muhnschein>
16:43:58 <rainemak> #info <muhnschein>    Sail Prompt
16:44:00 <rainemak> #info <muhnschein>    Straps
16:44:02 <rainemak> #info <muhnschein>    Cookbook
16:44:04 <rainemak> #info <muhnschein>    Radar (Find my Device)
16:44:06 <rainemak> #info <muhnschein>    BitSailor
16:44:08 <rainemak> #info <muhnschein>    Meliona
16:44:12 <rainemak> #info <muhnschein>    Frostlife
16:44:14 <rainemak> #info <muhnschein>    Sailstream for Plex
16:44:16 <rainemak> #info <muhnschein>
16:44:18 <rainemak> #info <muhnschein> This is neither mentioned in the Harbour interface nor
16:44:20 <rainemak> #info <muhnschein> strictly necessary - and rather unfortunate for the
16:44:22 <rainemak> #info <muhnschein> developers.
16:44:24 <rainemak> #info <muhnschein>
16:44:26 <rainemak> #info <muhnschein> I’m kindly asking for this to be fixed and hope that this
16:44:28 <rainemak> #info <muhnschein> is the right place.
16:44:30 <rainemak> #info <Jolla> Thank you for raising this one. We'll create an internal issue.
16:44:32 <rainemak> We are working on Android apk intake improvements. This was asked by MikkoTenhunen in follow up comment.
16:45:02 <muhnschein> Great to hear, thanks. In that case I don't think I have much more to add.
16:45:40 <muhnschein> Can I kindly ask that whatever you decide on (scale-to-fit, letterbox, desired dimensions) I also clearly mentioned in Harbour?
16:45:43 <abr> well spotted
16:46:15 <muhnschein> *is
16:47:48 <rainemak> indeed, well spotted
16:48:54 <rainemak> alright, let's move on
16:49:23 <rainemak> Keto, ^
16:49:37 <Keto> #topic Android App Support: PIN Code and Authentication Issues (10 mins -- asked by MikkoTenhunen)
16:50:06 <abr> ooh
16:50:23 <rainemak> #info <MikkoTenhunen> Many Android applications that rely on secure
16:50:23 <rainemak> #info <MikkoTenhunen> authentication methods appear to have problems inside
16:50:23 <rainemak> #info <MikkoTenhunen> Sailfish OS Android App Support. I would like to know
16:50:23 <rainemak> #info <MikkoTenhunen> whether Jolla has made progress on fixing Android PIN
16:50:23 <rainemak> #info <MikkoTenhunen> code, biometric authentication, and secure credential
16:50:24 <rainemak> #info <MikkoTenhunen> storage related issues.
16:50:26 <rainemak> #info <MikkoTenhunen>
16:50:28 <rainemak> #info <MikkoTenhunen> In particular:
16:50:30 <rainemak> #info <MikkoTenhunen>  - Do banking applications now support PIN code
16:50:32 <rainemak> #info <MikkoTenhunen>    authentication correctly?
16:50:34 <rainemak> #info <MikkoTenhunen>  - Do authenticator applications (2FA/TOTP apps) work
16:50:36 <rainemak> #info <MikkoTenhunen>    reliably with device security features?
16:50:38 <rainemak> #info <MikkoTenhunen>  - Are there known limitations in Android App Support
16:50:40 <rainemak> #info <MikkoTenhunen>    regarding Android Keystore, biometric APIs, or PIN
16:50:44 <rainemak> #info <MikkoTenhunen>    protected authentication?
16:50:46 <rainemak> #info <MikkoTenhunen>  - Is there an estimated roadmap or planned improvements
16:50:48 <rainemak> #info <MikkoTenhunen>    for banking and authentication apps?
16:50:50 <rainemak> #info <MikkoTenhunen>
16:50:52 <rainemak> #info <MikkoTenhunen> This information would help users understand the current
16:50:54 <rainemak> #info <MikkoTenhunen> status of Android application compatibility and security
16:50:56 <rainemak> #info <MikkoTenhunen> related functionality on Sailfish OS.
16:50:58 <rainemak> #info <Jolla> We are looking into this. Too early to comment. Let's hope that
16:51:00 <rainemak> #info <Jolla> we'd have some improvements integrated for Sailfish OS 5.3
16:51:02 <rainemak> #info <Jolla> release.
16:51:09 <abr> ooh
16:51:10 <rainemak> We said in hacking that 5.3 could go to CBeta by end of October
16:51:34 <MikkoTenhunen[m]> 👍️ Hopefully soon this fix
16:52:35 <rainemak> There are many components involved and touching device lock and friends cannot really lock people out from their device
16:52:54 <rainemak> MikkoTenhunen[m], tricky task
16:54:23 <abr> yeah i think it's a lot more complex than it seems. not just some sort of 'passthrough'
16:54:37 <rainemak> abr, indeed
16:55:11 <rainemak> let's see what can we make for 5.3
16:56:12 <rainemak> let's move on
16:56:25 <Keto> #topic Community Port - X10V and X10IV AAS update (5 mins -- asked by sharks)
16:56:30 <jojomen> #info jojomen, community
16:56:40 <jojomen> hi everyone, sorry I'm late to the party
16:56:46 <rainemak> no worry
16:56:47 <rainemak> #info <sharks> Per the 03/09/26 community meeting, I’ve attempted reaching out
16:56:47 <rainemak> #info <sharks> a few times over the last month on #sailfishos on IRC to see if
16:56:47 <rainemak> #info <sharks> anyone from Jolla can let me know what is required of me to
16:56:47 <rainemak> #info <sharks> assist / accelerate AAS progress for the community port.
16:56:48 <rainemak> #info <sharks>
16:56:49 <rainemak> #info <sharks> Given I’ve not received any reply, I am reaching out again
16:56:51 <rainemak> #info <sharks> here. Are you able to give us any news? After all, the squeaky
16:56:53 <rainemak> #info <sharks> wheel gets the grease.
16:56:55 <rainemak> #info <Jolla> We understand the desire for this. However, we haven't had
16:56:57 <rainemak> #info <Jolla> chance to test this yet. For Xperia 10 IV and 10 V communinity
16:56:59 <rainemak> #info <Jolla> ports we'd need AppSupport that is Android 15 based (simplest
16:57:01 <rainemak> #info <Jolla> this way). Along with Sailfish OS 5.2 we should get AppSupport
16:57:03 <rainemak> #info <Jolla> upgraded for Jolla C2 to Android 15 base. This should pawe the
16:57:05 <rainemak> #info <Jolla> way towards getting AppSupport for 10IV and 10V community ports.
16:57:07 <rainemak> #info <Jolla> Bear with us and give us a bit more time on this.
16:58:24 <jojomen> Good news/forecast/no-promises for the C2!
16:58:47 <rainemak> It should be already there
16:59:21 <jojomen> :)
17:00:52 <rainemak> we could move to next topic I think
17:00:57 <abr> didn't anyone notice?
17:01:13 <rainemak> abr, notice what?
17:01:24 <rainemak> C2 AppSupport15 is not yet public
17:01:39 <abr> ooh ssh
17:01:48 <jojomen> Damn, just switching mine on to update ;)
17:01:52 <abr> xD
17:02:33 <Keto> soon
17:02:35 <rainemak> public release for all supported devices should be too far
17:02:49 <rainemak> great
17:03:18 <Keto> #topic Jolla Phone 2026 Wi-Fi hardware: 1x1 or 2x2 MIMO? (5 mins -- asked by MiPal75)
17:03:41 <rainemak> #info <MiPal75> Could Jolla please confirm one specific hardware specification
17:03:42 <rainemak> #info <MiPal75> of the Jolla Phone 2026 WLAN subsystem:
17:03:42 <rainemak> #info <MiPal75>
17:03:43 <rainemak> #info <MiPal75> Is the Jolla Phone 2026 physically designed for 1x1 or 2x2 Wi-Fi MIMO?
17:03:45 <rainemak> #info <MiPal75>
17:03:47 <rainemak> #info <MiPal75> Several real-world tests indicate that the Jolla Phone 2026
17:03:49 <rainemak> #info <MiPal75> currently operates using only one spatial stream. This has
17:03:51 <rainemak> #info <MiPal75> been reproduced by more than one user and with different
17:03:53 <rainemak> #info <MiPal75> access points. At the same time, iw phy phy0 info advertises
17:03:55 <rainemak> #info <MiPal75> HE MCS support for both NSS 1 and NSS 2.
17:03:57 <rainemak> #info <MiPal75>
17:03:59 <rainemak> #info <MiPal75> There is an existing forum discussion with measurements here:
17:04:01 <rainemak> #info <MiPal75>
17:04:03 <rainemak> #info <MiPal75> I have also asked Jolla Customer Care for clarification but
17:04:05 <rainemak> #info <MiPal75> have not received an answer.
17:04:07 <rainemak> #info <MiPal75>
17:04:09 <rainemak> #info <MiPal75> I am specifically not asking whether the current Wi-Fi
17:04:13 <rainemak> #info <MiPal75> connection happens to operate as 1x1. I would like to clarify
17:04:15 <rainemak> #info <MiPal75> the physical design of the phone:
17:04:17 <rainemak> #info <MiPal75>
17:04:19 <rainemak> #info <MiPal75>    If the WLAN hardware/RF/antenna design is 1x1, then the
17:04:21 <rainemak> #info <MiPal75>    observed behaviour is expected and the question is
17:04:23 <rainemak> #info <MiPal75>    answered.
17:04:25 <rainemak> #info <MiPal75>
17:04:27 <rainemak> #info <MiPal75>    If the phone is physically designed for 2x2, then the fact
17:04:29 <rainemak> #info <MiPal75>    that multiple devices appear to operate as 1x1 may warrant
17:04:31 <rainemak> #info <MiPal75>    investigation of the driver, firmware or configuration.
17:04:33 <rainemak> #info <MiPal75>
17:04:35 <rainemak> #info <MiPal75> A confirmation from the Jolla hardware team of “1x1” or “2x2”
17:04:37 <rainemak> #info <MiPal75> would therefore be sufficient.
17:04:39 <rainemak> #link https://forum.sailfishos.org/t/jolla-phone-2026-wi-fi-6-throughput-appears-limited-to-400-mbit-s-480-mbit-s-phy/32719
17:04:44 <rainemak> #info <Jolla> Jolla Phone 2026 has 1x1 MIMO
17:05:29 <MiPal75> Thank you for the clear answer, that resolves it for me.
17:06:07 <rainemak> Great thank
17:06:29 <jojomen> Is the limitation in the SoC or somewhere else, like antenna
17:06:31 <jojomen> Is the limitation in the SoC or somewhere else, like antenna?
17:08:07 <rainemak> jojomen, unfortunately I don't have an answer for that
17:08:19 <jojomen> That's fine, was just curious :)
17:08:27 <Keto> I don't even know what MIMO means :b
17:08:42 <jojomen> Multiple Input Multiple Opinions ;)
17:09:01 <extechop[m]> https://en.wikipedia.org/wiki/MIMO
17:09:11 <abr> I think they're one of the eurovision entries
17:09:26 <jojomen> abr :D
17:09:59 <rainemak> and I'm in Transit :-)
17:10:01 <jojomen> You're not thinking of t.A.T.u?
17:10:17 <rainemak> ok, let's move on
17:10:24 <Keto> #topic Open Pull Requests (PRs) to discussion (5 mins -- asked by Jolla)
17:10:57 <rainemak> esr153 PRs were merged... we should give a look to PRs from nephros next
17:10:59 <abr> rainemak: no you're in A Transit
17:11:49 <rainemak> I'll post a photo to the IRC minutes
17:12:07 <jojomen> Nice work on the browser!
17:12:33 <abr> pretty cool how people are creating their own browsers on top of the new engine
17:12:37 <abr> that's how it should be
17:12:50 <abr> browsers everywhere and no chromium :P
17:12:55 <rainemak> yeap, some awesome
17:13:01 <jojomen> +1
17:13:09 <rainemak> s/some//
17:14:41 <rainemak> 4 PRs from nephros that we should check after new browser lands
17:15:27 <MiPal75> Thanks all, I have to leave now. Have a nice evening!
17:15:39 <jojomen> You too!
17:15:42 <rainemak> MiPal75, thanks... welcome to join next time as well
17:16:15 <rainemak> let's move on
17:16:38 <Keto> #topic General discussion (10 mins)
17:17:11 <extechop[m]> Just installed 5.2.0.18 and it at least booted!
17:17:27 <rainemak> extechop[m], which device
17:18:11 <extechop[m]> Jolla Phone 2026
17:18:16 <rainemak> +1
17:19:05 <jojomen> Updated one of my JPs. Was smooth sailing, completely uneventful. There's a significant speedup in boot-to-UI
17:19:28 <jojomen> ...which is really nice!
17:19:40 <rainemak> and AppSupport audio fixes are nice
17:21:46 <jojomen> I have a (recurring) question about recurring subscriptions.
17:22:24 <rainemak> please ask
17:22:27 <jojomen> Brought up in a previous meeting that recurring subscription doesn't seem to work for me. They always end up on-shot
17:22:54 <jojomen> Is there anything on you can suggest for troubleshooting this?
17:23:11 <rainemak> Let's take this offline for example in Forum PM
17:23:25 <jojomen> I have other recurring payments/donations registered, and they work.
17:23:40 <jojomen> OK, works for me :)
17:23:46 <rainemak> Thanks
17:24:26 <rainemak> ah, that community meeting in Stockholm
17:24:52 <rainemak> there's now a date poll: https://forum.sailfishos.org/t/roadshow-potential-community-meeting-stockholm-oct-21/34246
17:25:13 <jojomen> Yes! Happy to see you suggesting a couple of dates that would work (and sad that I don't think I will make it)
17:26:10 <rainemak> please join if you happen to be around, and vote for your preference
17:26:28 <rainemak> that event is not yet carved into a stone
17:27:00 <rainemak> I think it's time for final topic
17:27:50 <Keto> #topic Next meeting time and date (2 mins)
17:28:09 <rainemak> Proposing Thursday 15th October at 04:00 PM UTC
17:28:14 <rainemak> usual schedule
17:29:47 <jojomen> looks ok for me, but things change on short notice here, sooo
17:30:32 <rainemak> I think that's it then
17:30:38 <rainemak> #info Next meeting will be held on Thursday 15th October 2026 at 04:00pm UTC: 2026-10-15T1600Z
17:30:47 <rainemak> thank you all!
17:31:07 <Keto> #endmeeting