#mer-meeting: SailfishOS, open source, collaboration: 25-November @ 15:00 UTC
Meeting started by cybette at 15:00:18 UTC
(full logs).
Meeting summary
- 
  - Welcome to another week of SailfishOS OSS and
    collaboration meeting (cybette,
    15:00:32)
- Kimmo Lindholm, TOH-tailor, tohkbd-team.
    Community member. (kimmoli,
    15:00:34)
- Meeting info and agenda:
    https://lists.sailfishos.org/pipermail/devel/2014-November/005276.html
    (cybette,
    15:00:47)
 
 
- Brief introductions (5 min), prefix your information with #info (cybette, 15:00:59)
  - Kimmo Lindholm, TOH-tailor, tohkbd-team.
    Community member. (kimmoli,
    15:01:04)
- Simonas Leleiva, community sailor, sailfish for
    everyone (porting to android devices) (sledges,
    15:01:10)
- Jonathan Frederickson, community member
    (ryukafalz,
    15:01:14)
- Thomas B. Ruecker, community member
    (tbr,
    15:01:16)
- Martin Kolman, community, modRana
    developer (M4rtinK_jolla_,
    15:01:16)
- Lucien Xu, community member and dev
    (SK_work,
    15:01:23)
- Carol Chen, Community Chief at Jolla, hatless
    chair today (cybette,
    15:01:23)
- Andrea Bernabei, Nemomobile contributor,
    Sailfish community member (faenil,
    15:01:24)
- Siteshwar, community (situ,
    15:01:27)
- Thomas A., app developer (Armadillo,
    15:01:28)
- Carsten Munk, Chief Research Engineer @
    Jolla (Stskeeps,
    15:01:32)
- Steph Gosling, community (stephg,
    15:01:38)
- François, community member, dev-wannabe
    (daitheflu,
    15:01:51)
- Bernd Wachter, Release Guy and other stuff @
    Jolla (Aard,
    15:01:58)
- Christophe Chapuis, community member, qml
    dev (Tofe,
    15:01:59)
- Basil Semuonov, community member (BasilSemuonov_,
    15:02:01)
- Julius-Paul Jann, community (Nokius,
    15:02:03)
- Stephan Hagen, community member (shfit,
    15:02:15)
- Reto Zingg, Sailor @ Jolla (kontio,
    15:02:45)
- Jonni Nakari, community member, app
    developer (Wnt,
    15:02:46)
- Giulio Camuffo, developer at Jolla (giucam,
    15:02:53)
- Raine M�kel�inen, developer @ Jolla
    (rainemak,
    15:03:01)
- Alejandro Exojo, Qt and Jolla user (suy,
    15:03:04)
- Jürg Billeter, community member (juergbi,
    15:03:07)
- Jarkko Lehtoranta, developer @ Jolla
    (Jare,
    15:03:12)
- Mohammed Hassan. Hacker and Sailor (Mostly
    listening) (MSameer,
    15:03:36)
- Tim Klocke, community member (Taaeem,
    15:03:38)
- Pami Ketolainen, developer @ Jolla (pketolai,
    15:03:40)
- Soumya Bijjal program manager at Jolla
    (bijjal,
    15:04:05)
- Iekku Pylkk�, develoeper-care + harbour qa @
    jolla (iekku,
    15:04:11)
- Islam Amer, developer @ jolla (phaeron,
    15:04:13)
- Kaj-Michael Lang, community member, app
    developer (oniongarlic,
    15:04:14)
- Val�rio, sailor @ Jolla (VDVsx,
    15:04:49)
 
 
- Hot news: store API update - bijjal and kontio (15 min) (cybette, 15:05:40)
  - https://github.com/sailfish-sdk/sdk-harbour-rpmvalidator/commits/master
    (sledges,
    15:09:29)
- Starting with Update 10, a few new APIs will be
    allowed in Harbour. For details see log and above link (cybette,
    15:10:31)
- kimmoli summarized the git commits: shortly
    list of new allowed: libssl, libcrypto, liblzma, libxml2, libogg,
    libvorbis, QtGraphicalEffects (tbr,
    15:16:49)
- Demand for Positioning API noted and will be
    sorted/clarified inhouse (cybette,
    15:17:16)
- https://github.com/sailfish-sdk/sdk-harbour-rpmvalidator/pull/20
    ? (kimmoli,
    15:17:29)
 
 
- Generic info about Jolla Tablet - SK_work or Armadillo (20 min) (cybette, 15:20:25)
  - Idea is for Jolla to share a bit more info
    about the Jolla tablet followed by Q&A (cybette,
    15:20:33)
- Will the bootloader be open? -
    <+Stskeeps> we built sailfishos on open devices. it doesn't
    make sense to deny that ability to others. (tbr,
    15:25:14)
- We built SailfishOS on open devices, and do not
    plan to deny this ability to others. Together we'll find a solution
    balancing privacy and security with the aim to install alternative
    OS'es (cybette,
    15:25:44)
- ACTION: cybette to
    get jolla.com/tablet updated with USB OTG info (cybette,
    15:31:46)
- Regarding Sailfish OS progress for phone and
    tablet, please see
    https://together.jolla.com/question/63989/jolla-tablet-sailfishos-2-what-about-update-9/#post-id-64196
    (cybette,
    15:36:19)
- http://commonsware.com/blog/2013/11/21/libhoudini-what-it-means-for-developers.html
    is what intel devices normally use; but how that works without
    android runtime is a bit unknown. also, a lot of processes are more
    GPU bound. (Stskeeps,
    15:38:02)
 
 
- Is SailfishOS Open Source - SK_work or tbr (20 min) (cybette, 15:40:30)
  - So, recently there were a few obvious mistakes
    in the usage of the term "open source" by Jolla marketing. This is
    causing unnecessary tension and discussion and poisons the
    atmosphere between Jolla and the open source community. We'd like to
    remind Jolla about its roots and to respect the community on which
    its success is built. (tbr,
    15:40:51)
- TL;DR - Stskeeps providing a look at how things
    are inside Jolla the company and Jolla Sailors/engineers as part of
    the open source community. For more details, please read log.
    (cybette,
    15:52:36)
 
 
- How to test for different devices with SDK - Armadillo (15 min) (cybette, 16:05:46)
  - Sailfish OS SDK uses targets, so there'll be a
    target per device. Multi-arch is already supported with the target
    design. (cybette,
    16:09:25)
 
 
- Generic info on how's going inside Jolla about topic discussed before - SK_work (10 min) (cybette, 16:21:16)
  - After the testruns with opt-in we had for
    hotfix + u9 we decided now to make updates available as opt-in when
    we're qa-wise ready to release from our side, and will push it  to
    the general public about 1 week later (having fixed critical issues,
    if found during that time) (cybette,
    16:24:06)
- you opt in once, and that's valid until you opt
    out. you won't be able to opt out when there's an opt-in update
    pushed out to avoid downgrading issues. (cybette,
    16:25:30)
- Mer-Nemo merging status: currently, xulrunner
    compilation issue is blocking. Next: git repos moving and bugzilla
    stuff (SK_work,
    16:26:38)
 
 
- Wrap up and next meeting (5 min) (cybette, 16:31:49)
  - "Special" meeting next week Tues Dec-2 @ 15:00
    UTC, Chairperson tbr (tentative) (cybette,
    16:37:55)
- Next regular meeting Tues Dec-16 @ 15:00 UTC,
    Chairperson cybette (cybette,
    16:38:00)
- ACTION: tbr to create
    specific TJC item for next week's special meeting (cybette,
    16:38:27)
- ACTION: cybette to
    change channel topic for next meetings (cybette,
    16:38:40)
 
Meeting ended at 16:40:53 UTC
(full logs).
Action items
  - cybette to get jolla.com/tablet updated with USB OTG info
- tbr to create specific TJC item for next week's special meeting
- cybette to change channel topic for next meetings
Action items, by person
  -  cybette 
    - cybette to get jolla.com/tablet updated with USB OTG info
- cybette to change channel topic for next meetings
 
-  tbr 
    - tbr to create specific TJC item for next week's special meeting
 
People present (lines said)
  - SK_work (129)
- Stskeeps (79)
- cybette (66)
- tbr (56)
- M4rtinK_jolla_ (42)
- lbt (42)
- faenil (37)
- kontio (26)
- Armadillo (25)
- kimmoli (20)
- ryukafalz (20)
- stephg (15)
- Aard (11)
- daitheflu (10)
- Wnt (9)
- VDVsx (9)
- Tofe (9)
- shfit (8)
- sledges (8)
- iekku (8)
- Nokius (8)
- javispedro (7)
- MSameer (5)
- deztructor (5)
- phaeron (5)
- jmlich (5)
- Merbot (3)
- locusf (3)
- juergbi (3)
- oniongarlic (3)
- Jare (2)
- suy (2)
- BasilSemuonov_ (2)
- bijjal (2)
- reviewjolla (1)
- pketolai (1)
- situ (1)
- leinir (1)
- rainemak (1)
- giucam (1)
- Sail0r (1)
- tadzik (1)
- Taaeem (1)
Generated by MeetBot 0.1.4.