#mer-meeting: SailfishOS, open source, collaboration: 17-Dec @ 14:30 UTC

Meeting started by cybette at 14:30:12 UTC (full logs).

Meeting summary

    1. Welcome to another week of SailfishOS OSS and collaboration meeting (cybette, 14:30:17)
    2. Meeting info and agenda: http://lists.sailfishos.org/pipermail/devel/2015-December/006817.html (cybette, 14:30:23)

  1. Brief introductions (5 min), prefix your information with #info (cybette, 14:30:38)
    1. Andrey Kozhevnikov, community coderus (coderus, 14:30:44)
    2. Kimmo Lindholm, Community ..... (kimmoli, 14:30:45)
    3. Christophe Chapuis, Community member (Tofe, 14:30:51)
    4. Rüdiger Schiller, Maemo Community e.V. Board (chem|st, 14:30:57)
    5. Carol Chen, community member, hatless meeting chair today (cybette, 14:30:57)
    6. Lucien Xu community SfietKonstantinW (SfietKonstantinW, 14:30:57)
    7. Fabio Isgrò, community ... (dr_gogeta86, 14:30:57)
    8. Eugenio Paolantonio, community member (eugenio, 14:31:00)
    9. Urja Rannikko, community (urjaman, 14:31:00)
    10. Cedric Heintz, community member (ced117, 14:31:00)
    11. Iekku Pylkk�, community member (iekku, 14:31:06)
    12. Steph Gosling, community (stephg, 14:31:06)
    13. François, Community (daitheflu, 14:31:08)
    14. pavi community member (pavi, 14:31:08)
    15. Claudio Campeggi, community member (c-la, 14:31:11)
    16. Dirk van Leersum, community (dirkvl, 14:31:19)
    17. Tommi Keisala, community (JvD__, 14:31:29)
    18. Tatu, community & low on battery (tathhu, 14:31:31)
    19. Jakub Kozisek, community member (nodevel, 14:31:33)
    20. Eetu Kahelin, community (eekkelund, 14:31:33)
    21. Lewis Rockliffe, community (r0kk3rz, 14:31:40)
    22. John Pietrzak, community member (Copernicus, 14:31:42)
    23. fravaccaro, community (fravaccaro, 14:31:44)
    24. Fellfrosch, community (Fellfrosch, 14:32:04)
    25. Vesa-Matti Hartikainen, SW Program manager, Jolla (veskuh_, 14:32:13)
    26. Lim Yuen Hoe, community (moofang, 14:32:22)
    27. Julius-Paul Jann, community (Nokius_work, 14:32:37)
    28. Raine M�kel�inen, SW Engineer, Jolla (rainemak, 14:32:37)
    29. Juhani Lassila, Head of Communications, Jolla (jlassila, 14:32:40)
    30. Pami Ketolainen, backend dev @ Jolla (pketo, 14:32:49)
    31. Chris Peake, customer care @ Jolla (cccpeake, 14:33:10)
    32. tortoisedoc Developer & community supporter (tortoisedoc, 14:33:23)
    33. Martin Kolman, community member, modRana developer (M4rtinK, 14:33:36)
    34. Chris Ng, community fans~ (chrisx2ds, 14:33:41)
    35. Carmen Fdez. (cfb014, 14:34:18)
    36. Andrew Zhilin, community member, TOHKBD and stuff (wazd, 14:34:33)
    37. Topias Vainio, jollafanclub telegram group founder (toxxip, 14:34:59)
    38. Peter Danek, community member (pdanek, 14:35:02)
    39. https://www.youtube.com/watch?v=94dY-QxjDiE (tortoisedoc, 14:35:23)

  2. Status update on the delivery of Jolla Tablets + general Jolla status - Antti Saarnio (10 min) (cybette, 14:35:37)
    1. Joshua Strobl, community (JoshStrobl, 14:36:53)
    2. https://www.youtube.com/watch?v=O4GnHcFBDj4 (sledges, 14:39:01)
    3. Jolla has received financing to continue the development of Sailfish OS. More info on the news will be shared in blog post tomorrow. Merry Christmas :) (cybette, 14:41:13)
    4. Regarding tablets, as the financing was only confirmed yesterday, Jolla is now analysing alternatives for "TabletGate" (cybette, 14:45:07)
    5. Intex project will continue, there is confirmation yesterday that new Sailfish OS phone will be coming (cybette, 14:48:25)
    6. Sales of Jolla tablets on taobao has nothing to do with Jolla. The production partner in China had stock and they stated selling them, Jolla is discussing with them to stop sales immediately. (cybette, 14:50:37)
    7. Antti has spoken: The Force Awakens :) (cybette, 14:52:39)

  3. Bluetooth tethering re-introduction - c-la/moofang (10 min) (cybette, 14:54:03)
    1. With 1.1.7 update bluetooth tethering got disabled, probably by mistake by an undetected regression. Discussion about the effort needed to restore it in next SFOS release. (cybette, 14:54:11)
    2. https://together.jolla.com/question/107787/11728-bluetooth-tethering-via-connman-no-longer-supported/ (cybette, 14:54:16)
    3. https://together.jolla.com/question/99680/bt-tethering-11724/ (cybette, 14:54:21)
    4. Support for bluetooth was broken when fixing connman/BT bootup, and due to the complexity of connman codebase, no solution has been found (cybette, 14:57:32)
    5. unfortunately the developer specializing in the area is no longer with Jolla, so there's no ETA for fix (cybette, 14:58:52)
    6. http://pastebin.com/DmbpbNvx (veskuh_, 15:00:16)
    7. Comment from internal bug http://pastebin.com/DmbpbNvx (cybette, 15:00:54)
    8. https://git.merproject.org/mer-core/connman/tree/master/connman (ced117, 15:02:20)
    9. https://git.merproject.org/mer-core/connman/blob/master/connman/src/technology.c (cybette, 15:03:50)
    10. https://git.merproject.org/mer-core/connman/tree/master/connman (ced117, 15:04:20)

  4. Inclusion of Bluetooth LE libraries - c-la (10 min) (cybette, 15:04:43)
    1. the needed libraries useful to use BTLE (QtBluetooth 5.4) have been backported to jolla kernel few months ago, some harbour apps have them included in their app. (cybette, 15:04:51)
    2. Discussion about the possibility to have them included in SFOS. BTLE support is necessary to use some new wearables and headphones with Jolla. (cybette, 15:04:57)
    3. https://together.jolla.com/question/64317/request-jolla-tablet-bluetooth-le-low-energy-software-support-wearable/ (cybette, 15:05:04)
    4. https://together.jolla.com/question/8589/proper-bluetooth-le-support/ (cybette, 15:05:10)
    5. bijjal and rainisto's comments in here are still valid https://together.jolla.com/question/64317/request-jolla-tablet-bluetooth-le-low-energy-software-support-wearable/ (cybette, 15:07:11)
    6. The amount of work is non-trivial, with a lot of testing and possibly reapplying bluetooth certification for existing devices. (cybette, 15:08:08)
    7. Need more study on this keeping in mind that resources are still quite tight (cybette, 15:14:36)

  5. Email client bug when opening a draft no text - c-la (10 min) (cybette, 15:14:56)
    1. there is a longtime bug in the email client: when opening a draft the email has no text (body) even if there is text. The first words of the body are shown in the email preview when viewing drafts folder, (cybette, 15:15:03)
    2. but the text of the body is not copied in the email. This makes editing and sending an email "on the fly" impossible on jolla. (cybette, 15:15:08)
    3. request estimation about time needed to fix it and its inclusion in future SFOS release (cybette, 15:15:12)
    4. https://together.jolla.com/question/75380/the-body-of-an-email-draft-is-cleared/ (cybette, 15:15:16)
    5. ACTION: veskuh_ to check internal bugzilla for this and will file bug if there isn't existing one (cybette, 15:17:43)
    6. ACTION: cybette to come up with clearer guidelines for proposing topics to the community collaboration meeting (cybette, 15:18:53)

  6. Status of SDL2 support & SDL2 apps in Harbor - MartinK (10 min) (cybette, 15:20:23)
    1. Even though the SDL2 multimedia library has been allowed for Harbor applications since January 2015, it seems to be horrendously broken and all requests for it to be fixed seem to be ignored. Moreover apps working around the breakage are rejected by Harbor QA for spurious reasons. Can something be done about this? (cybette, 15:20:39)
    2. https://together.jolla.com/question/70821/request-support-sdl-landscape-mode/ see comment nr. 4 for the question (cybette, 15:20:44)
    3. Importance of SDL is acknowledged, however Jolla hasn't had time to properly solve this (cybette, 15:24:49)
    4. IDEA: Establish some firm guidelines (at least for the time being) so that people can publish their SDL using apps (cybette, 15:25:47)

  7. Out of band updates to allowed libraries for Harbor - MartinK (5 min) (cybette, 15:29:20)
    1. In the previous meeting, coderus raised the point that sometimes important libraries are left out from the list of allowed libs by mistake even though they are stable and already included in the released update. (cybette, 15:29:26)
    2. The current practice seems to be that the list of allowed libraries is only updated when a new SDK is released. This introduces a big delay, that will probably only be significantly worse now due to the limited resources prolonging SDK development and QA phases, effectively blocking app developers from the default apps store due to process limitations. (cybette, 15:29:32)
    3. Can this be changed so that allowed library list updates covering already released stuff take effect immediately ? (cybette, 15:29:37)
    4. topic 4 in last meeting http://merproject.org/meetings/mer-meeting/2015/mer-meeting.2015-12-09-14.30.html (cybette, 15:31:33)
    5. It might be doable with relatively minor effort, but status have not been checkd with Harbour QA yet (cybette, 15:34:41)
    6. integrating rpm-validator to harbour binary upload is on the todo-list, so probably in that case it could be updated independent of the releases (cybette, 15:35:22)

  8. Community helping out - MartinK (15 min) (cybette, 15:35:49)
    1. Jolla/Sailfish OS seems to be in crisis and community members might want to help make the ship turn around, but there don't seem to be many concrete and widely accessible ways to do that at the moment: (cybette, 15:35:54)
    2. one can buy another Jolla phone and that's about it. Are there some low-hanging-fruit (considering the expected current lack of resources at Jolla) aspects of Sailfish OS that community members can help out with ? (cybette, 15:35:58)
    3. This has been touched on in the last meeting as well, topics 3 and 6 - http://merproject.org/meetings/mer-meeting/2015/mer-meeting.2015-12-09-14.30.html (cybette, 15:37:59)
    4. community has already helped in amazing ways e.g. Helsinki office move and viral campaigns like the one by JoshStrobl (cybette, 15:39:55)
    5. there are more/different expertise in the community that can be used to help Jolla, in additional to technical capacity (cybette, 15:40:46)
    6. JoshStrobl has just started a Thunderclap campaign, more info available via #ISupportJolla twitter hashtag and isupportjolla.com (cybette, 15:41:58)
    7. other suggestions include localisation, testing, bug triage, documentation, helping novice users, as well as answering questions on TJC (cybette, 15:42:46)
    8. https://fedoraproject.org/wiki/Join (M4rtinK, 15:45:34)
    9. one way to help - Keyboard contributions https://together.jolla.com/question/124266/keyboard-contributions-for-inclusion-in-sfos/ (cybette, 15:46:08)
    10. IDEA: collaborate and gather support on isupportjola.com or someplace similar (cybette, 15:47:03)
    11. Unofficial l10n project https://www.transifex.com/kenya888/unofficial-jolla-translations/ (cybette, 15:50:06)
    12. Community pootle was stalled quite close to going public due to the financial situation, hopefully this can move forward sometime soon (cybette, 15:50:31)

  9. General discussions, wrap up, and next meeting - everyone (10 min) (cybette, 15:51:10)
    1. Jolla is quite close to getting the next Sailfish OS update for early access users (cybette, 15:53:00)
    2. Next meeting Thurs Jan-7 @ 14:30 UTC, Chairperson stephg (cybette, 15:58:50)
    3. ACTION: cybette to send some guidelines for chairing meeting to stephg and JoshStrobl (cybette, 15:59:02)


Meeting ended at 16:00:26 UTC (full logs).

Action items

  1. veskuh_ to check internal bugzilla for this and will file bug if there isn't existing one
  2. cybette to come up with clearer guidelines for proposing topics to the community collaboration meeting
  3. cybette to send some guidelines for chairing meeting to stephg and JoshStrobl


Action items, by person

  1. cybette
    1. cybette to come up with clearer guidelines for proposing topics to the community collaboration meeting
    2. cybette to send some guidelines for chairing meeting to stephg and JoshStrobl
  2. JoshStrobl
    1. cybette to send some guidelines for chairing meeting to stephg and JoshStrobl
  3. stephg
    1. cybette to send some guidelines for chairing meeting to stephg and JoshStrobl
  4. veskuh_
    1. veskuh_ to check internal bugzilla for this and will file bug if there isn't existing one


People present (lines said)

  1. cybette (123)
  2. M4rtinK (52)
  3. c-la (40)
  4. tortoisedoc (37)
  5. veskuh_ (29)
  6. ApBBB_ (27)
  7. ced117 (26)
  8. AnttiSaarnio (22)
  9. javispedro (18)
  10. fravaccaro (18)
  11. stephg (17)
  12. JoshStrobl (16)
  13. chrisx2ds (14)
  14. dr_gogeta86 (14)
  15. coderus (13)
  16. r0kk3rz (13)
  17. kimmoli (10)
  18. SfietKonstantinW (9)
  19. daitheflu (9)
  20. nodevel (8)
  21. dirkvl (8)
  22. chem|st (7)
  23. iekku (7)
  24. urjaman (7)
  25. pketo (6)
  26. eugenio (6)
  27. wazd (6)
  28. Tofe (6)
  29. moofang (5)
  30. mhall119 (5)
  31. pavi (4)
  32. cfb014 (3)
  33. nsuffys (3)
  34. merbot (3)
  35. rainemak (3)
  36. eekkelund (3)
  37. tdb- (3)
  38. JvD__ (3)
  39. Copernicus (2)
  40. Nokius_work (2)
  41. sledges (2)
  42. yestoall (2)
  43. Aciid (2)
  44. tathhu (2)
  45. Antonino (2)
  46. toxxip (2)
  47. pdanek (2)
  48. Fellfrosch (2)
  49. TylerTemp (2)
  50. jlassila (1)
  51. spatialbits (1)
  52. Myrtti (1)
  53. cccpeake (1)
  54. rpiwa (1)
  55. coley (1)
  56. ghosalmartin (1)
  57. Naranek (1)
  58. Sailor11073 (1)


Generated by MeetBot 0.1.4.