#mer-meeting: SailfishOS, open source, collaboration: 22-May @ 10:00 UTC

Meeting started by cybette at 10:00:30 UTC (full logs).

Meeting summary

    1. Welcome to another week of SailfishOS OSS and collaboration meeting (cybette, 10:00:40)
    2. Meeting info and agenda: https://lists.sailfishos.org/pipermail/devel/2014-May/004227.html (cybette, 10:00:46)

  1. Brief introductions (5 min), prefix your information with #info (cybette, 10:01:00)
    1. martin brook, community member doing device adaptation work (vgrade__, 10:01:11)
    2. Filip Kłębczyk (fk_lx, 10:01:11)
    3. Carol Chen, Community chief at Jolla, hatless meeting chair for today. (cybette, 10:01:26)
    4. Aleksi Suomalainen (locusf, 10:01:27)
    5. Andrea Bernabei, Nemo contributor and Jolla user (faenil, 10:01:34)
    6. carsten munk, chief research engineer @ jolla, on really crap connectivity (Stskeeps, 10:01:36)
    7. Steph Gosling, community (stephg, 10:02:08)
    8. Jonni Rainisto, Security @ Jolla (Jonni, 10:02:14)
    9. Mohammed Hassan (FOSS hacker who happened to work for Jolla ;-)) (MSameer, 10:02:15)
    10. Philippe De Swert, HW adaptation engineer @Jolla (phdeswer, 10:02:15)
    11. Vesa-Matti Hartikainen, Browser @ Jolla (veskuh, 10:02:25)
    12. jake9xx, SailfishOS SDK lead, sailor (jake9xx, 10:02:26)
    13. robin, qt-centric hacker of all things, at jolla during the day (w00t, 10:02:30)
    14. iekku pylkk�, head of developer affairs @ jolla, mer and nemo community member (iekku, 10:02:31)
    15. Lucien, dev, SFOS enthusiast, community (SK_work, 10:03:00)
    16. (take2) Jarko Vihriälä, SailfishOS SDK lead, sailor@jolla (jake9xx, 10:03:11)
    17. Fabio Isgrò, Jolla user and os enthusiast (dr_gogeta86, 10:03:11)
    18. Thomas Perl, sailor and community member (thp, 10:03:16)
    19. Marko Saukko, mer&nemo contributor in the past, now working for Jolla. (Sage_, 10:03:35)
    20. Valerio, FOSS contributor/comunity member, working at Jolla (VDVsx, 10:03:39)
    21. Steve Jayna, infrastructure @ Jolla (sdjayna, 10:04:09)
    22. David - Mer guy and sailor (lbt, 10:04:15)
    23. Denis Zalevskiy, engineer@jolla, but in this meeting - a private person and community member (deztructor, 10:04:40)
    24. Erkki Seppälä, random bystander (flux, 10:05:03)
    25. Stefano Mosconi, CTO and co-foiunder @ Jolla (stezz, 10:05:04)
    26. Pami Ketolainen, Bugzilla guy @ Jolla (pketolai, 10:05:11)
    27. Marko Mattila media, sailor @ jolla (zchydem, 10:05:12)
    28. Kalle Jokiniemi, kernel guy at Jolla (kjokinie, 10:05:22)
    29. Gunnar Sletta, working primarily on Qt stuff @ Jolla, just listening in (sletta, 10:05:39)
    30. Giulio camuffo, mainly Qt, Wayland gut @ Jolla (giucam, 10:06:18)

  2. Documentation of open-source components (20 min) (cybette, 10:06:22)
    1. (from SK_work) we need to involve (MW) devs to write docs to make access to knowledge easier, and enable contribution (cybette, 10:06:47)
    2. Basil Semuonov, developer (BasilSemuonov, 10:07:07)
    3. I think having MW guys write documents (be it an overview of the module or API, my opinion is an overview + internals of the modules has much higher priority overy API) will also be an incentive to try settle down and make more longlasting API choices (otherwise, it will always be "yeah, use that API, we can always change it later since there's no doc to change etc") (faenil, 10:10:16)
    4. < SK_work> first priority I would say is to setup a doc repo and have docs autogenerated (cybette, 10:10:23)
    5. AGREED: use Autodoc for API (cybette, 10:22:10)
    6. http://rickfoosusa.blogspot.fi/2011/10/howto-use-doxygen-with-github.html (deztructor, 10:22:21)
    7. http://rickfoosusa.blogspot.fi/2011/10/howto-use-doxygen-with-github.html (SK_work, 10:22:31)
    8. ACTION: have the same state of autodocs that those used in Jolla internally (SK_work, 10:25:53)

  3. Alleged abuse/discrimination from Jolla (20 min) (cybette, 10:27:16)
    1. Initial email from fk_lx https://lists.sailfishos.org/pipermail/devel/2014-May/004187.html (cybette, 10:27:26)
    2. http://www.oxforddictionaries.com/definition/english/abuse (stezz, 10:41:32)
    3. http://www.oxforddictionaries.com/definition/english/discrimination?q=discrimination (stezz, 10:41:54)
    4. Event mentioned in this case is organized by Metalab, not Jolla. fk_lx claimed that Jolla is discriminating against him. From related chat logs and posts, it can be shown that this isn't the case. Conclusion from Jolla: (cybette, 10:44:40)
    5. a) Jolla as a company has nothing to do with it this issue (cybette, 10:45:03)
    6. b) there is no trace that thp has requested Filip to be excluded he just said that if Filip is coming he is not and in saying that he acted as a very long term and influential member of Metalab rather than a Jolla developer (as Christian has validated) (cybette, 10:45:12)
    7. c) thp has reasons to avoid Filip and Filip seems to know why and acknowledged that in his mail (cybette, 10:45:22)
    8. d) no abuse or discrimination was done by thp, Carsten or any other Jolla employee towards Filip (cybette, 10:45:59)
    9. e) Jolla did not ignore Filip nor his emails at the time (cybette, 10:46:08)

  4. Updates on the Mer/nemo merge (10 min) (cybette, 10:50:52)
    1. kernel.org uses git graft to not carry around 80mb of history (Stskeeps, 10:55:58)
    2. w00t and dr_gogeta86 can help in migrating repositories (cybette, 10:58:39)
    3. ACTION: come up with proper plan and start one repository at a time (cybette, 11:00:51)

  5. Updates on other proposals made in previous meetings (15 min) (cybette, 11:01:43)
    1. e.g. docs, nemo mw help for contributors, security framework (cybette, 11:01:59)
    2. security: we're currently doing some brainstorming about technical feasibility of some bits (putting processes into separate control groups, integration of the whole thing with systemd, if/where selinux can come in). it's a bit tricky due to the way we launch apps to save memory, we'll need to document and publish that eventually (SK_work, 11:07:21)
    3. extending this topic timeslot for 5 min (until 11:20 UTC) to include MTP discussion (cybette, 11:14:00)
    4. <+phdeswer> I could make a guide to do some mass-storage with usb_moded for a solution that might just work if somebody is interested. (cybette, 11:21:18)

  6. Scheduling of future meetings (5 min) (cybette, 11:25:01)
    1. Weekdays, especially during "work hours" (European time zones), may not be optimal. Some have proposed to have these meetings on weekends (cybette, 11:25:52)
    2. Next meeting Tues May-27 @ 15:00 UTC (cybette, 11:30:52)
    3. ACTION: cybette to inform on TJC about this series of meetings to make it more visible (cybette, 11:32:34)


Meeting ended at 11:34:09 UTC (full logs).

Action items

  1. have the same state of autodocs that those used in Jolla internally
  2. come up with proper plan and start one repository at a time
  3. cybette to inform on TJC about this series of meetings to make it more visible


Action items, by person

  1. cybette
    1. cybette to inform on TJC about this series of meetings to make it more visible
  2. UNASSIGNED
    1. have the same state of autodocs that those used in Jolla internally
    2. come up with proper plan and start one repository at a time


People present (lines said)

  1. cybette (81)
  2. SK_work (77)
  3. stezz (63)
  4. Stskeeps (47)
  5. faenil (43)
  6. lbt (37)
  7. NSA-rep (27)
  8. dr_gogeta86 (23)
  9. Aard (19)
  10. w00t (19)
  11. meegobit (17)
  12. MSameer (16)
  13. phdeswer (15)
  14. tbr (13)
  15. jake9xx (12)
  16. chriadam|meeting (12)
  17. deztructor (11)
  18. fk_lx (10)
  19. iekku (10)
  20. Morpog_Jolla (8)
  21. stephg (8)
  22. veskuh (7)
  23. Merbot` (3)
  24. BasilSemuonov (3)
  25. netzvieh_ (3)
  26. VDVsx (2)
  27. Sage_ (2)
  28. Frye (2)
  29. sdjayna (1)
  30. special (1)
  31. kjokinie (1)
  32. giucam (1)
  33. sletta (1)
  34. pketolai (1)
  35. plundstr (1)
  36. vgrade__ (1)
  37. Jonni (1)
  38. zchydem (1)
  39. thp (1)
  40. flux (1)
  41. locusf (1)


Generated by MeetBot 0.1.4.