#mer-meeting: SailfishOS, open source, collaboration: 10-June @ 15:00 UTC

Meeting started by cybette at 15:00:10 UTC (full logs).

Meeting summary

    1. Welcome to another week of SailfishOS OSS and collaboration meeting (cybette, 15:00:19)
    2. Meeting info and agenda: https://lists.sailfishos.org/pipermail/devel/2014-June/004515.html (cybette, 15:00:25)

  1. Brief introductions (5 min), prefix your information with #info (cybette, 15:00:37)
    1. netzvieh, Community member (netzvieh, 15:00:39)
    2. Artem Marchenko: supporting all dev programs possible and Get-Mitakuuluu-to-app-store! (artemma, 15:00:50)
    3. Carol Chen, Community chief at Jolla, hatless chair today (cybette, 15:00:56)
    4. Steph Gosling, community (stephg, 15:01:19)
    5. kimmoli, community guy, usually just fuzzing around (kimmoli_sailing, 15:01:30)
    6. Morpog_PC__ Community member, part time nemo contributor, graphics guy as hobby (Morpog_PC__, 15:01:42)
    7. Lucien XU, SF dev, community, device breaker :D (SK_work, 15:01:57)
    8. Andrey Kozhevnokov. coderus. (coderus, 15:02:02)
    9. Andrea Bernabei, community member, nemomobile UI contributor (faenil, 15:02:05)
    10. Jozef Mlich - foursail developer, community member (xmlich02, 15:02:39)
    11. iekku Pylkk�, developer community & developer-care@ sailor @ jolla, mer bugzilla maintainer (iekku, 15:03:18)
    12. Andrey Kozhevnikov. OpenSource contributor, Mitakuuluu developer. (coderus, 15:03:46)
    13. Petr Rockai, on-off devel, curious onlooker, user (mornfall, 15:04:09)

  2. API documentation for nemomobile and own Sailfish component (15 min) (cybette, 15:05:39)
    1. coderus proposed this topic and would like to discuss ways to communicate with maintainers (cybette, 15:05:57)
    2. Simonas Leleiva being late (sledges, 15:07:21)
    3. Juho Hämäläinen, developing audio/policy etc for jolla, sorry for being late (jusa_, 15:08:21)
    4. Jolla will consider if there is more efficient way to contact maintainers and devs, in the meantime developer-care is the best way (cybette, 15:21:20)

  3. Accepting community opensource applications which cannot pass Harbour (15 min) (cybette, 15:22:23)
    1. from coderus: "accepting community opensource applications which cannot pass Harbour validator, but full opensource projects." (cybette, 15:22:30)
    2. "Allowing Jolla/Harbour QA to build, test, and release applications with own channels and keep maintainer information" (cybette, 15:22:38)
    3. work ongoing to get beta-channel at Store, no ETA yet. Harbour QA will provide light quality check (iekku, 15:23:48)

  4. Accepting community opensource applications which cannot pass Harbour (7 min left) (cybette, 15:33:16)
    1. summary of proposal: beta opt-in inside store with warning about os updates and auto blocking of beta apps after os update. Developers in beta channel should be able to join beta testing of SF OS next version to prepare an apps update (cybette, 15:37:44)
    2. early warning system about API changes could be a mailing list for registered developers only (iekku, 15:39:41)
    3. early warning system about API changes could be sent to sailfish os devel mailing list (iekku, 15:40:18)
    4. ACTION: iekku to talk with service sailors about this and hopefully get some ETA soon (iekku, 15:40:57)

  5. More advanced "Developer mode" or "3rd party sources" features (15 min) (cybette, 15:41:36)
    1. from coderus: "Enabling UI for managing packages, displaying all package information, repositories, showing update notifications for 3rd party repositories." (cybette, 15:41:40)
    2. "Functionality probably maintained by community, can depends on (2) if so, provide full source code for Jolla for review and building as part of OS mode tools." (cybette, 15:41:45)
    3. "Discussing main points of future development. Jolla can introduce peoples, who can help with API side and other important information." (cybette, 15:41:49)

  6. Update on community guidelines/moderation (15 min) (cybette, 15:56:39)
    1. Draft of community guidelines http://piratepad.net/sailfish-community-guidelines (cybette, 15:57:01)
    2. please add your comments to http://piratepad.net/sailfish-community-guidelines (cybette, 16:09:58)

  7. Feedback on Jolla communication (10 min) (cybette, 16:11:22)
    1. from SK_work "This topic comes to my mind because of recent events in the community, and some / many? community members think that Jolla communication is one of their weaker point." (cybette, 16:11:27)
    2. http://dontbreakthesails.blogspot.fr/2014/04/sailfish-silica-half-open (SK_work, 16:12:53)
    3. http://paste.kde.org/pwblblkim (SK_work, 16:13:58)
    4. http://paste.kde.org/pwblblkim (cybette, 16:14:09)
    5. http://paste.kde.org/piiojrafg (SK_work, 16:15:23)
    6. http://paste.kde.org/piiojrafg (SK_work, 16:15:48)

  8. Chum repo process and its policies (3 min) (cybette, 16:25:02)
    1. xmlich02's opinion here: http://piratepad.net/iVW0lrOKXF - please comment directly to the pirate pad (cybette, 16:25:08)

  9. Next meeting (cybette, 16:28:38)
    1. Next meeting Tues June-17 @ 10:00 UTC, (cybette, 16:30:16)


Meeting ended at 16:31:13 UTC (full logs).

Action items

  1. iekku to talk with service sailors about this and hopefully get some ETA soon


Action items, by person

  1. iekku
    1. iekku to talk with service sailors about this and hopefully get some ETA soon


People present (lines said)

  1. coderus (100)
  2. cybette (94)
  3. SK_work (92)
  4. mornfall (69)
  5. iekku (61)
  6. artemma (58)
  7. netzvieh (24)
  8. Morpog_PC__ (21)
  9. M4rtinK_jolla_ (20)
  10. faenil (16)
  11. sledges (15)
  12. stephg (11)
  13. phaeron (11)
  14. xmlich02 (9)
  15. Halo2_ (5)
  16. Halo2 (4)
  17. kimmoli_sailing (4)
  18. andorreta (3)
  19. Sage_ (3)
  20. xmlich02-jolla (2)
  21. Merbot (2)
  22. javispedro (2)
  23. meegobit (1)
  24. Stskeeps (1)
  25. Khertan (1)
  26. jusa_ (1)


Generated by MeetBot 0.1.4.