#mer-meeting: SailfishOS, open source, collaboration: 6-Oct @ 14:30 UTC
Meeting started by cybette at 14:31:45 UTC
(full logs).
Meeting summary
-
- Welcome to a new season of SailfishOS OSS and
collaboration meetings! (cybette,
14:32:44)
- Meeting info and agenda:
http://lists.sailfishos.org/pipermail/devel/2015-October/006578.html
(cybette,
14:33:08)
- Simonas Leleiva, sailor, porters and
pootles (sledges,
14:33:09)
- Brief introductions (10 min), prefix your information with #info (cybette, 14:33:31)
- Jonathan Frederickson, community member
(jfred,
14:33:40)
- Kimmo Lindholm, TOHs et.al. , community
(kimmoli,
14:33:43)
- Christophe Chapuis, community member
(Tofe,
14:33:46)
- David Greaves: sailor and Mer guy (lbt,
14:33:49)
- Richard Rondu, community member & app
developer (lainwir3d,
14:34:04)
- Steph Gosling, community (stephg,
14:34:05)
- Simonas Leleiva, sailor, porters and pootles,
limited presence today due to vkb and afk (sledges,
14:34:07)
- Carol Chen, Community chief at Jolla, hatless
meeting chair today (cybette,
14:34:10)
- Urja Rannikko, sometimes helps out with
TOHKBD (urjaman,
14:34:12)
- iekku Pylkk�, developer-community sailor at
Jolla (iekku,
14:34:23)
- Eugenio Paolantonio, community member, patch
developer, professional lurker (eugenio,
14:34:25)
- Martin Kolman, community member, modRana
developer (M4rtinK,
14:34:26)
- Bob Summerwill, community member, CEO
http://doublethink.co (bobsummerwill_,
14:34:59)
- Andrew Penkrat, community member and app
developer (Aldrog,
14:35:06)
- Lukas Vogel, community member, app dev
(lukedirwalker,
14:35:11)
- Pami Ketolainen, backend developer @
Jolla (pketolai,
14:35:19)
- François, community member, app dev
(daitheflu,
14:35:22)
- Julius-Paul Jann, community member (Nokius_work,
14:35:22)
- Lucien Xu, community member and dev
(SfietKonstantinW,
14:36:29)
- Aleksi Suomalainen, community member
(locusf,
14:37:18)
- Olavi Haapala, community member and dev
(olpe,
14:38:31)
- Martin Brook, community porter (vgrade_w,
14:39:44)
- Igor Korolyuk, community member (IgorSK,
14:40:48)
- Moritz Thiele, community member, tester of all
openrepos (MoritzJT,
14:41:26)
- How to ease 3rd party contribution to SailfishOS/Mer Middleware OSS components - locusf (30 min) (cybette, 14:43:26)
- Fabio Isgrò , community member, StuntMan
(dr_gogeta86,
14:43:31)
- It is apparently not very well known how to
contribute to the components in the topic. See for example:
https://github.com/sailfishos/sailfish-utilities/pull/33
(cybette,
14:43:34)
- Namely the commit message must conform to a
specific form only. This is not well known information to other
contributors who might have changes to the OSS components, wether
Mer Middleware or SailfishOS. (cybette,
14:43:40)
- would be good to have contribution guidelines
written up and put in the open. question: where? mer wiki, TJC,
sailfishos.org? (cybette,
14:53:37)
- ACTION: iekku and lbt
to organize the required info and find best location for it
(cybette,
14:54:45)
- also need more detailed info on packaging
process in addition to guidelines (cybette,
14:59:22)
- Situation update about the Mer Middleware merger from Nemo Middleware - locusf (20 min) (cybette, 15:02:32)
- http://www.mail-archive.com/mer-general@lists.merproject.org/msg01557.html
(cybette,
15:02:41)
- Message to Mer mailing list suggested that this
is started but ongoing. A small status update would help Nemo
community decide on its roadmap. (cybette,
15:02:47)
- http://www.merproject.org/dash2/
(cybette,
15:04:05)
- main issue is being in mid-migration,
maintainers have been asked to move stuff but it's not
happening (cybette,
15:07:13)
- lbt is in the process of updating Maintainer
file and will probably take over maintainer role for neglected
projects (cybette,
15:10:23)
- volunteer to be a maintainer - which basically
means submit patches, get stuff working, show you're responsible and
eventually get told it's yours. simply say "I'd like to maintain
<blah>" (cybette,
15:16:08)
- ACTION: lbt and iekku
to add the above to guidelines (cybette,
15:16:50)
- moving mer-core git packages from 'dumb' to
tar_git is a chore. Help would be appreciated here. Talk to lbt in
#mer about it. First step is actually help writing the HOWTO
(lbt,
15:21:46)
- Request more information on Roadmap for open-sourcing more of Sailfish - bobsummerwill (20 min) (cybette, 15:23:08)
- It has been mentioned on several occasions that
there is a plan with regard to further open-sourcing of components
within Sailfish. It would be great to have some more public
information on that. (cybette,
15:23:19)
- In particular, the status of Silica is a
constant 'sore point'. With the company split and the move towards
licensing of Sailfish 2.0, perhaps there is an opportunity to
restore some lost faith in Jolla with regard to licensing.
(cybette,
15:23:25)
- we will revisit this topic in next meeting, and
get answers to questions brought up here (cybette,
15:30:34)
- Update on localization status (keyboards and translation tool) - ApBBB (5 min) (cybette, 15:32:43)
- For translation tool, work is progressing
nicely and we are already testing it in-house. We will be able to
deploy it in the open once any remaining rough edges have been
polished and all infra is in place (cybette,
15:35:12)
- Jolla is working on a community translation
tool (based on Pootle localization server) to enable community to
contribute to Sailfish OS translations (cybette,
15:38:40)
- General discussions - everyone (15 min) (cybette, 15:41:03)
- Check #sailfishos-porters if you're interested
in finding the progress of SFOS ports to Nexus and other
devices (cybette,
15:45:08)
- Wrap up and next meeting (10 min) (cybette, 15:56:11)
- Next meeting Thurs Oct-22 @ 14:30 UTC,
Chairperson iekku (cybette,
16:04:21)
Meeting ended at 16:06:11 UTC
(full logs).
Action items
- iekku and lbt to organize the required info and find best location for it
- lbt and iekku to add the above to guidelines
Action items, by person
- iekku
- iekku and lbt to organize the required info and find best location for it
- lbt and iekku to add the above to guidelines
- lbt
- iekku and lbt to organize the required info and find best location for it
- lbt and iekku to add the above to guidelines
People present (lines said)
- cybette (82)
- lbt (61)
- locusf (34)
- stephg (31)
- bobsummerwill_ (28)
- iekku (27)
- urjaman (14)
- sledges (13)
- M4rtinK (12)
- nh1402 (11)
- kimmoli (10)
- dr_gogeta86 (9)
- SfietKonstantinW (7)
- jfred (5)
- Mikaela (4)
- MoritzJT (3)
- ericcc (3)
- pvuorela (3)
- Aard (2)
- merbot (2)
- pketolai (2)
- daitheflu (2)
- vgrade_w (2)
- Aldrog (2)
- lukedirwalker (1)
- olpe (1)
- Nokius_work (1)
- eugenio (1)
- lainwir3d (1)
- IgorSK (1)
- Tofe (1)
Generated by MeetBot 0.1.4.