#mer-meeting: Sailfish OS, open source, collaboration – September 20th 2017

Meeting started by sledges at 07:59:59 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: https://together.jolla.com/question/54157/sailfishos-open-source-collaboration-meeting-planning/ (sledges, 08:00:43)

  1. Brief introduction (5 min). Please prefix your name/handle with # info (sledges, 08:01:15)
    1. nh1402, community member (nh1402, 08:01:40)
    2. Steph Gosling, community, porter (stephg, 08:01:55)
    3. Chris Adams, developer at Jolla (chriadam_, 08:02:03)
    4. vknecht, community (vknecht, 08:03:53)
    5. Fabio Isgrò, community (dr_gogeta86, 08:04:23)
    6. lantern, community (lantern1, 08:04:45)
    7. Mister_Magister, mad porter/community (Mister_Magister, 08:05:45)
    8. Damien Caliste, community (dcaliste, 08:05:51)
    9. Jens Müller, Sailor / community (jenix, 08:05:56)
    10. Kimmo Lindholm, community (kimmoli, 08:06:13)
    11. Simonas Leleiva, sledge, chair, and sailor (sledges, 08:06:53)

  2. Vulkan support in Sailfish (Asked by nh1402 - 10 min) (sledges, 08:07:54)
    1. You now have 2 official devices that support Vulkan. The argument before was that there wasn't Vulkan support for the Android driver for the tablet, but it seems that has now changed. (sledges, 08:08:29)
    2. http://www.phoronix.com/scan.php?page=news_item&px=Android-ANV-Vulkan-Support (sledges, 08:08:34)
    3. schmittlauch, community member sorry for being late (M-schmittlauch, 08:09:30)
    4. It is not on Jolla's roadmap, but creating TJC question is a good way to keep track of that! (sledges, 08:15:02)
    5. Xperia X adaptation will be open sourced and then community can as well look into it (sledges, 08:15:28)
    6. http://blog.qt.io/blog/2017/06/06/vulkan-support-qt-5-10-part-1/ ... (vknecht, 08:19:53)
    7. chriadam suspects that the Qt scenegraph would have to be updated to support a Vulkan rather than OpenGL backend. Completely different draw calls etc (sledges, 08:20:21)
    8. http://blog.qt.io/blog/2017/06/06/vulkan-support-qt-5-10-part-1/ (sledges, 08:20:27)

  3. open sourcing of Sailfish OS components (Asked by c_la - 30 minutes) (sledges, 08:21:23)
    1. during the last community meeting (September, 6th) it was discussed the idea of implementing multiscreen or PiP but it was turned down because key components of SFOS are not opensourced and thus the community can't do much. (sledges, 08:21:44)
    2. Many community members believe Jolla should urgently release a list of components that will be open sourced otherwise the community can't help Jolla improve sailfish. (sledges, 08:21:49)

  4. General discussion (20 min) (sledges, 08:51:19)
    1. ACTION: dcaliste (from previous topic) To open TJC wiki this afternoon listing closed parts and which one community would love to see OSS and potential contributions (sledges, 08:54:42)

  5. Next meeting date (sledges, 09:16:02)
    1. http://merproject.org/logs/%23sailfishos/%23sailfishos.2017-09-13.log.html#t2017-09-13T08:59:19 (nh1402, 09:17:07)
    2. Next meeting date in two weeks: Wednesday, 4th of October 2017, 08:00 GMT (sledges, 09:18:30)


Meeting ended at 09:20:36 UTC (full logs).

Action items

  1. dcaliste (from previous topic) To open TJC wiki this afternoon listing closed parts and which one community would love to see OSS and potential contributions


Action items, by person

  1. dcaliste
    1. dcaliste (from previous topic) To open TJC wiki this afternoon listing closed parts and which one community would love to see OSS and potential contributions


People present (lines said)

  1. sledges (71)
  2. leszek (38)
  3. nh1402 (33)
  4. jenix (23)
  5. M-schmittlauch (23)
  6. abranson (23)
  7. chriadam_ (16)
  8. Mister_Magister (9)
  9. dcaliste (8)
  10. mal (3)
  11. lantern1 (3)
  12. r0kk3rz (3)
  13. vknecht (3)
  14. merbot (2)
  15. PurePremium (2)
  16. stephg (2)
  17. kimmoli (1)
  18. dr_gogeta86 (1)
  19. Max-Might (1)


Generated by MeetBot 0.1.4.