#mer-meeting: Sailfish OS, open source, collaboration 5th April 2018

Meeting started by sledges at 09:00:25 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2018-April/008355.html (sledges, 09:00:48)

  1. Brief introduction (5 min). Please prefix your name/handle with # info (sledges, 09:01:17)
    1. Leif-Jöran Olsson, community (ljo, 09:01:31)
    2. Martin Kolman, modRana developer and community member (M4rtinK_phone_, 09:01:41)
    3. peperjohnny, community (peperjohnny, 09:01:43)
    4. David Greaves, sailor and Mer guy (lbt-, 09:01:48)
    5. Leszek Lesner, Community Member & Dev (leszek, 09:01:48)
    6. Chris Adams, developer at Jolla (chriadam__, 09:01:52)
    7. au7ogeek, community (au7ogeek, 09:02:03)
    8. Joona Petrell, developer at Jolla (jpetrell, 09:02:05)
    9. Simonas Leleiva, sailor and chair (sledges, 09:02:14)
    10. vgrade, community (vgrade, 09:02:27)
    11. lolek, just a user?:) (lolek, 09:02:47)
    12. Pami Ketolainen, sailor @ Jolla (pketo, 09:02:55)
    13. Matti Lehtimäki, community porter etc (mal, 09:02:58)
    14. Vesa-Matti Hartikainen, Program Manager @ Jolla (veskuh, 09:03:16)
    15. Marko Saukko, sailor @ Jolla (Sage__, 09:03:40)

  2. : Xperia XA2 support details (10min - asked by au7ogeek) (sledges, 09:06:22)
    1. Which version of the Xperia XA2 will be supported exactly (model number)? There are many different variations across markets and single/dual-sim types, etc. Will the dual-sim version be supported (initially or maybe eventually)? Single sim versions are already difficult to find (in Sweden) while dual-sim versions are readily available. How about the Xperia XA2 Ultra? This is even more popular an (sledges, 09:06:29)
    2. ...and readily available. It has the same chipset as the XA2 but a different screen size. I feel it is important to clarify such questions now as the devices being supported may be hard to find later on when Sailfish XA2 goes on sale. (sledges, 09:06:57)
    3. Currently Jolla is working with Single SIM (H3113) and Dual SIM (H4113) models, but the final supported models will be annouced later. (sledges, 09:08:49)

  3. Community solutions to long standing problems (mapping and text prediction) and how to get them on all phones (10mins - asked by ApBBB) (sledges, 09:18:17)
    1. The community has developed solutions for both mapping (which sucks) and text prediction (which isn't available to every language). And we need them on the store or integrated in the OS. So how the community can help speed things up and who from jolla has to get things moving. (sledges, 09:18:24)
    2. The team responsible for making libsystemd decision and integrating it is currently busy, let us postpone the question to the next meeting (sledges, 09:24:27)
    3. https://github.com/sailfishos/sdk-harbour-rpmvalidator/issues/102#issuecomment-367373788 (sledges, 09:24:31)
    4. Text prediction (presage-based) could be collaborated the same way like community has been submitting the keyboard layouts, but we need to review the working model, as more variables are involved (sledges, 09:25:31)
    5. ACTION: discuss libsystemd and presage integration internally (sledges, 09:27:34)

  4. Design UI/UX of Sailfish 3 (15mins - asked by ApBBB) (sledges, 09:28:40)
    1. From the MWC video some of the community complains seems to have been fixed, however there are things that are not shown in the video and might be a good time to discuss. Closing multiple apps, tactile and aural feedback, inconsistencies, long reach of some elements, etc etc. (sledges, 09:29:31)
    2. we at Jolla are super busy working on getting 2.2.0 feature complete, the Sailfish 3 work has been put on hold for a moment so not much progress to report (sledges, 09:29:52)
    3. community's giving feedback on UX usability, please read logs :) (sledges, 09:38:54)

  5. #info bits from earlier "Community solutions to long standing problems" (sledges, 09:45:50)
    1. < ljo> We are working on supporting further languages with the open text prediction plugin. This means I am working on adaptation to language specific settings and also some suggestion selection adaptations. But there is also a lot of work getting ICU-provided functionality integrated for full unicode support which was precursory investigated by rinigus. (sledges, 09:46:11)
    2. < jpetrell> if the quality of OSS prediction engine is good I wouldn't mind seeing it integrated to core OS instead of having it in Store, especially for languages not currently covered by our Nuance contract (sledges, 09:46:25)
    3. < jpetrell> we are working contribution agreement template that would allow giving community developer access to the needed private repos, helping develop things like integrating different prediction engines to Sailfish OS keyboard (sledges, 09:46:34)

  6. Sailfish security (10mins - asked by lolek) (sledges, 09:46:54)
    1. It seems that currently the OS is pure simple Linux with only very basic permission structure. There's no SElinux/Apparmor, no application permissions. For example pictures made by the jolla-camera app has got 644 permissions which means every single other app can access it. Based on the fact that Jolla is secure (as of some statement on one of the Jolla webpages) this doesn't look like. (sledges, 09:47:10)
    2. Also same problem is with the very old web browser which is very dated (Firefox 38?). According to official information, this year we should see system encryption but what with the rest? Unlocked bootloader message is also something not very welcome, but I think this is more related to Sony. (sledges, 09:47:16)
    3. It would be also great to have some more secure unlock screen. Current one is very fragile for example video recording i.e. someone can record when we input the pw to unlock our phones. Regarding Jolla account I'm missing option to remotely wipe out my phone from account.jolla.com. (sledges, 09:47:24)
    4. This is somehow a trade of between privacy and security as Jolla would need to have access for my phone but it can be made as opt-in. (sledges, 09:47:29)
    5. Jolla is having several things in place, but continue to work in this area: (sledges, 09:52:20)
    6. Most importantly we don’t track you - all your info stays on your phone. (sledges, 09:53:54)
    7. We continue to provide SW updates to OS even to our first product and in each update we provide several CVE fixes and other security fixes and updates. (sledges, 09:53:59)
    8. Base of the OS in Open Source and the repositories are open to check what is going on. (sledges, 09:54:04)
    9. The Android Runtime has limitations on access and you can disble it completely. Similarly native apps have some limititations (permissions, priviledged). (sledges, 09:54:10)
    10. We know that there is room to improve and are working on better security framework to provide better access control for apps, and we are also developing many new security related features. (sledges, 09:54:17)
    11. We have been planning [browser] engine update, and there also some other developments going on at the browser area. (sledges, 09:57:20)
    12. We are planning on Qt upgrade and that would probably make QtWebEngine also available for developers (sledges, 09:58:18)

  7. General discussion (15 min) (sledges, 10:00:08)
  8. Next meeting’s time and date (5 min) (sledges, 10:14:49)
    1. Next meeting will be held on Thursday, 08:00 UTC 19th April 2018 (sledges, 10:19:28)


Meeting ended at 10:19:35 UTC (full logs).

Action items

  1. discuss libsystemd and presage integration internally


People present (lines said)

  1. sledges (89)
  2. ApBBB (44)
  3. M4rtinK_phone_ (33)
  4. leszek (32)
  5. lolek (26)
  6. jpetrell (22)
  7. veskuh (12)
  8. au7ogeek (9)
  9. chriadam__ (4)
  10. Sage__ (4)
  11. piggz (4)
  12. ljo (4)
  13. nekron_work (4)
  14. mal (3)
  15. merbot (2)
  16. peperjohnny (2)
  17. vgrade (1)
  18. kimmoli (1)
  19. abranson (1)
  20. richrboo (1)
  21. pketo (1)
  22. physkets (1)
  23. lbt- (1)
  24. Guest84654 (1)
  25. jvd_ (1)


Generated by MeetBot 0.1.4.