#sailfishos-meeting: Sailfish OS, open source, collaboration -- 31st March 2022

Meeting started by flypig at 07:00:19 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: (flypig, 07:00:27)
    2. https://forum.sailfishos.org/t/community-meeting-on-irc-31st-march-2022/10714 (flypig, 07:00:31)

  1. Brief introduction (5 min). Please prefix your name/handle with #info (flypig, 07:00:44)
    1. thigg - community dev (thilo[m], 07:01:41)
    2. David Llewellyn-Jones - sailor@jolla (flypig, 07:01:56)
    3. lolek - just a regular user (lolek, 07:01:56)
    4. pherjung - community (pherjung, 07:02:01)
    5. Björn Bidar - Sailor@Jolla (Thaodan, 07:02:08)
    6. Otto Mäkelä - community (ExTechOp, 07:02:16)
    7. Eric Ric9k - user (Ric9k, 07:03:41)
    8. Andrew Branson - sailor (abr, 07:03:44)
    9. Simonas Leleiva - privateer (sledges, 07:05:37)
    10. Sebix - community member (sebix[m], 07:06:02)

  2. Better tracking of bug report (15 min -- asked by pherjung) (flypig, 07:06:50)
    1. <pherjung> I noticed some bug report written by the community on the forum are not always followed up by Jolla and only become tracked so once they mentioned in a community meeting. (flypig, 07:06:56)
    2. <pherjung> Couldn't a system like the translation one be set up? Some members of the community implicated in the community could act as bridge with Jolla. (flypig, 07:07:04)
    3. <pherjung> So various member could be in charge to verify bug reports, test them, get more information if necessary and ping Jolla to fill up a bug report on their own bug tracking system. (flypig, 07:07:12)
    4. <pherjung> Or even easier, these people could have access to Jolla's bug tracking system. (flypig, 07:07:20)
    5. <Jolla> We do our best to keep track and follow up on bug reports noted on the forum, and the fact we addressed at least 33 bugs reported this way in the 4.4.0 release is a good sign. (flypig, 07:07:54)
    6. <Jolla> However, you're right that we could improve the process, and more support from the community would help. (flypig, 07:08:02)
    7. <Jolla> As a proposal, would you, pherjung, be willing to take a lead on this? Initially, one way to proceed would be for you to provide a list of bugs at the next community meeting that aren't tracked, but which are well-formed enough for us to log internally? (flypig, 07:08:14)
    8. <Jolla> Minimum requirements would be that the bug is in the correct format, with a clear description, clear version info, and with steps to reproduce it. (flypig, 07:08:24)
    9. <Jolla> If this works out, we can look to refine the process. (flypig, 07:08:30)
    10. <thilo[m]> thus I identify the task as: get all bug reports, filter already tracked, filter non well formed (flypig, 07:15:16)
    11. piggz, community, late to the party (piggz, 07:16:16)
    12. Damien Caliste, community (dcaliste, 07:17:32)
    13. Carmen F.B. sfos user (cfb014, 07:21:45)
    14. ACTION: flypig to look into a "Bug noted for meeting" tag. (flypig, 07:22:16)
    15. ACTION: flypig to look into forum tag permissions. (flypig, 07:31:35)
    16. Decided process: "encourage people to split out their bugs into a separate report and tag bug reports that are well-formed. For a meeting a list is compiled from the tagged ones. After the meeting all processed bug reports a re linked to the meeting. Is that correct?" (flypig, 07:33:26)
    17. thilo[m] and pherjung will coordinate. (flypig, 07:33:30)

  3. What's Jolla's position on financial participation in the company? (15 min -- asked by pherjung) (flypig, 07:34:04)
    1. <pherjung> Some users would be interested to invest in the company. (flypig, 07:34:11)
    2. <pherjung> See this topic: https://forum.sailfishos.org/t/interest-to-create-a-cooperative/10799 (flypig, 07:34:17)
    3. https://forum.sailfishos.org/t/interest-to-create-a-cooperative/10799 (flypig, 07:34:21)
    4. <pherjung> Another possibility would be for the community to fund features. (flypig, 07:34:24)
    5. <Jolla> Thank you for your question, it's great to see that the community is so willing to engage with Jolla. We have taken the matter to top management for consideration. (flypig, 07:34:39)
    6. <Jolla> However, we are not able to move further with this issue until the new ownership structure of Jolla has been resolved on a wider scale and we have a clearer view of the future. (flypig, 07:34:46)

  4. BlackBerry picture password license (10 min -- asked by lolek) (flypig, 07:51:32)
    1. <lolek> on previous meeting I got informed that Jolla is unable to implement picture password like the one from BBOS10 because BlackBerry has patent on it. (flypig, 07:51:46)
    2. <lolek> So my question is if maybe it would be possible to get this type of a lock as a paid option as part of Sailfish license? (flypig, 07:51:51)
    3. <lolek> Then maybe it would be possible to just pay the fee to BB for this but at least a decent and a secure lock screen would be available. (flypig, 07:51:56)
    4. <lolek> If it's for me, this would be a key point to finally buy an SFOS license cause right now I see no point in doing so. (flypig, 07:52:03)
    5. <lolek> BB is no longer manufacturing any phones not any other company for them from what I understand, so maybe it's worth asking them? (flypig, 07:52:10)
    6. <lolek> More info: https://forum.sailfishos.org/t/community-meeting-on-irc-20th-january-2022/9549/4?u=lolek (flypig, 07:52:14)
    7. https://forum.sailfishos.org/t/community-meeting-on-irc-20th-january-2022/9549/4?u=lolek (flypig, 07:52:17)
    8. <Jolla> Thanks for raising this issue again. We're still open to exploring good alternatives, but as we mentioned last time, an important consideration is that any alternative must fit with the existing authentication components and UI. (flypig, 07:52:38)
    9. <Jolla> So making any change like this requires a great deal of care. (flypig, 07:52:44)
    10. <Jolla> Our feeling is that our focus would be more usefully spent on providing a better mechanism in the OS for installing additional authentication methods and letting users choose what they prefer. (flypig, 07:52:49)
    11. <Jolla> This would then allow a third-party developer to implement the picture password approach. (flypig, 07:52:54)
    12. <Jolla> Nevertheless we of course welcome discussion on the topic. (flypig, 07:52:59)
    13. <pherjung> "coderus wrote a patch implemeting an alternative. It doesn't work anymore" (flypig, 08:02:08)
    14. https://github.com/CODeRUS/sailfishos-mazelock-patch (flypig, 08:02:16)
    15. <dcalsite> "not that I volunteer to do it, my todo list is alreday full ;) But that could be a nice exercice for interested community devs" (flypig, 08:05:33)

  5. General discussion (15 min) (flypig, 08:06:19)
    1. thilo[m] created the a post in relation to the community bug coordination. (flypig, 08:17:39)
    2. https://forum.sailfishos.org/t/new-role-community-bug-coordinator/10935 (flypig, 08:17:46)

  6. Next meeting time and date (5 min) (flypig, 08:23:32)
    1. Next meeting will be held on Thursday 14th April 2022 at 07:00am UTC: 2022-04-14T0700Z (flypig, 08:26:41)


Meeting ended at 08:27:00 UTC (full logs).

Action items

  1. flypig to look into a "Bug noted for meeting" tag.
  2. flypig to look into forum tag permissions.


Action items, by person

  1. flypig
    1. flypig to look into a "Bug noted for meeting" tag.
    2. flypig to look into forum tag permissions.


People present (lines said)

  1. flypig (118)
  2. thilo[m] (43)
  3. pherjung (29)
  4. lolek (20)
  5. Thaodan (13)
  6. sebix[m] (13)
  7. dcaliste (12)
  8. ExTechOp (9)
  9. cfb014 (8)
  10. abr (6)
  11. Ric9k (5)
  12. sledges (3)
  13. johnny (3)
  14. sailbot (2)
  15. piggz (1)


Generated by MeetBot 0.1.4.