#sailfishos-meeting: Sailfish OS, open source, collaboration -- 7th Dec 2023

Meeting started by rainemak at 08:00:00 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: (rainemak, 08:00:31)
    2. https://forum.sailfishos.org/t/community-meeting-on-irc-7th-december-2023/17429 (rainemak, 08:00:31)

  1. Brief introduction (5 min). Please prefix your name/handle with #info (rainemak, 08:00:31)
    1. Otto Mäkelä, community (ExTechOp, 08:00:33)
    2. Raine Mäkeläinen, sailor @ Jolla, chairperson today (rainemak, 08:00:57)
    3. Zyuc2G, community/dev (Zyuc2G, 08:01:07)
    4. Crabster - lurker (Crabster, 08:01:29)
    5. Lukáš Karas - community developer (karry, 08:01:39)
    6. Pami Ketolainen, sailor @ Jolla (Keto, 08:01:41)
    7. Simonas Leleiva -- privateer for wotsits:) (sledges, 08:01:45)
    8. Vlad G., community (b100dian[m], 08:01:49)
    9. Damien Caliste, community (dcaliste, 08:05:06)
    10. Peter G., community (nephros, 08:05:41)

  2. Future of Jolla (8mins -- asked by Valorsoguerriero97) (rainemak, 08:05:52)
    1. <Valorsoguerriero97> There are ongoing rumors, docs and newspaper citing that (rainemak, 08:05:52)
    2. <Valorsoguerriero97> Jolla is under debt restoration, how it is going? The plan (rainemak, 08:05:52)
    3. <Valorsoguerriero97> is accepted? What we can do to help? What are the consequences (rainemak, 08:05:52)
    4. <Valorsoguerriero97> for SFOS and supported devices? (rainemak, 08:05:52)
    5. <Jolla> A solution was finally found on November 24, 2023 as the local District Court (rainemak, 08:06:22)
    6. <Jolla> decided on the restructuring program and obligated a complete sale of the business (rainemak, 08:06:22)
    7. <Jolla> to another company. The entire business and staff of Jolla Ltd. has now transferred (rainemak, 08:06:22)
    8. <Jolla> to a new company in whole. (rainemak, 08:06:22)
    9. <Jolla> (rainemak, 08:06:23)
    10. <Jolla> The new legal entity was named Jollyboys Ltd, but as it has now acquired the Jolla and (rainemak, 08:06:25)
    11. <Jolla> Sailfish brands and trademarks, you may consider the legal entity name to be secondary (rainemak, 08:06:28)
    12. <Jolla> - it’s the new Jolla anyway. (rainemak, 08:06:31)
    13. <Jolla> (rainemak, 08:06:42)
    14. <Jolla> No consequences for Sailfish OS as entire business and staff were transferred to another (rainemak, 08:06:42)
    15. <Jolla> company. Similarly, Sailfish X program continued as part of business transfer. (rainemak, 08:06:42)
    16. <Jolla> (rainemak, 08:06:44)
    17. <Jolla> Let’s keep on sailing together! (rainemak, 08:06:46)
    18. <Jolla> (rainemak, 08:06:48)
    19. https://forum.sailfishos.org/t/sailfish-community-news-30th-november-jolla-reborn/17473 (rainemak, 08:06:50)
    20. tuplasuhveli, community (late and currently at work) (tuplasuhveli[m], 08:09:05)

  3. Drain on Xperia 10 III (3mins -- asked by Valorsoguerriero97) (rainemak, 08:17:52)
    1. <Valorsoguerriero97> There are some bug reports citing that the 10 III is having battery (rainemak, 08:17:57)
    2. <Valorsoguerriero97> drain, what’s the point of solving those issues? (rainemak, 08:17:57)
    3. <Jolla> These has been some investigation into the battery drain but no obvious reason (rainemak, 08:18:03)
    4. <Jolla> has been found yet. (rainemak, 08:18:03)
    5. https://forum.sailfishos.org/t/high-battery-drainage-xperia-10-iii/12393 (rainemak, 08:18:03)

  4. OBS tar_git support of fileserver (5mins -- asked by vlagged / b100dian) (rainemak, 08:20:15)
    1. <vlagged / b100dian> There is at least a tar_git copy on github which supports (rainemak, 08:20:24)
    2. <vlagged / b100dian> a command-line param called “fileserver” 1. This would allow (rainemak, 08:20:24)
    3. <vlagged / b100dian> a build to start by downloading an internet resource of a known (rainemak, 08:20:24)
    4. <vlagged / b100dian> SHA-1 if listed in a _sources file. (rainemak, 08:20:24)
    5. <vlagged / b100dian> (rainemak, 08:20:24)
    6. <vlagged / b100dian> This is however not listed in the service spec now. (rainemak, 08:20:26)
    7. <vlagged / b100dian> (rainemak, 08:20:27)
    8. <vlagged / b100dian> The use case is for example software built with npm or yarn which cannot (rainemak, 08:20:29)
    9. <vlagged / b100dian> run on OBS (network access) or has a very high cache size (think 500MiB (rainemak, 08:20:32)
    10. <vlagged / b100dian> cache for a 5MiB build output) - however can be easily be built in other (rainemak, 08:20:35)
    11. <vlagged / b100dian> CI systems such as github/gitlab/codeberg’s. (rainemak, 08:20:38)
    12. <vlagged / b100dian> (rainemak, 08:20:42)
    13. <vlagged / b100dian> It would be useful to use the output of a such build automatically in (rainemak, 08:20:44)
    14. <vlagged / b100dian> an OBS build (which would do the non-nodejs part such as qml, c++ rpm (rainemak, 08:20:47)
    15. <vlagged / b100dian> packages) by specifying the URL to download & the expected SHA-1 sum, (rainemak, 08:20:50)
    16. <vlagged / b100dian> just as fileserver param is doing. (rainemak, 08:20:53)
    17. https://github.com/MeeGoIntegration/obs-service-tar-git/blob/master/tar_git#L69 (rainemak, 08:20:55)
    18. <Jolla> The fileserver parameter in tar_git is not listed in the service spec because it allows (rainemak, 08:20:57)
    19. <Jolla> access to local files. So it would require some modifications before enabling. (rainemak, 08:21:00)
    20. <Jolla> (rainemak, 08:21:02)
    21. <Jolla> There are also other OBS source services which provide similar functionality and which (rainemak, 08:21:04)
    22. <Jolla> we could consider enabling (rainemak, 08:21:07)
    23. https://github.com/openSUSE/obs-service-download_files (rainemak, 08:21:09)
    24. https://github.com/openSUSE/obs-service-download_url (rainemak, 08:21:13)
    25. <Jolla> Those do not seem to have checksum verification for the downloaded file, but otherwise (rainemak, 08:21:15)
    26. <Jolla> should be fit for the purpose. (rainemak, 08:21:18)

  5. PWA / Web Push notifications (10mins -- asked by vlagged / b100dian) (rainemak, 08:29:25)
    1. <vlagged / b100dian> Web push notifications are usually available when service workers are. (rainemak, 08:29:25)
    2. <vlagged / b100dian> This allows a running browser/webview app to get messages from websocket (rainemak, 08:29:25)
    3. <vlagged / b100dian> connections and pass them to the host OS as native notifications. (rainemak, 08:29:25)
    4. <vlagged / b100dian> (rainemak, 08:29:26)
    5. <vlagged / b100dian> Currently sailfish-browser doesn’t pass HTML5 Web Notifications (rainemak, 08:29:28)
    6. <vlagged / b100dian> Test - Bennish.net (no popup for permission => denied). Is there any (rainemak, 08:29:30)
    7. <vlagged / b100dian> specific place this could is tweaked to “say no” and where would a (rainemak, 08:29:32)
    8. <vlagged / b100dian> browser/webview patch need to look at first to enable these? (rainemak, 08:29:35)
    9. https://developer.mozilla.org/en-US/docs/Web/API/Push_API (rainemak, 08:29:37)
    10. https://www.bennish.net/web-notifications.html (rainemak, 08:29:39)
    11. <Jolla> Web push notifications need support at least to sailfish-components-webview and (rainemak, 08:30:02)
    12. <Jolla> embedlite-components and possibly browser or other components but it is not a huge (rainemak, 08:30:02)
    13. <Jolla> task but still takes quite an amount of work. PWAs i.e. progressive web apps are (rainemak, 08:30:02)
    14. <Jolla> apps that run using web engine but appear as regular apps and thus need a lot more (rainemak, 08:30:02)
    15. <Jolla> such as launcher integration, handling of installation/uninstallation and (rainemak, 08:30:03)
    16. <Jolla> many other changes and therefore is a lot bigger task. (rainemak, 08:30:05)
    17. <Jolla> (rainemak, 08:30:07)
    18. <Jolla> In general, progressive web apps are something that we should look in the light (rainemak, 08:30:09)
    19. <Jolla> of new technology development. Mozilla’s developer network has a good article (rainemak, 08:30:13)
    20. <Jolla> regarding progressive web apps – worth reading if you’re not familiar with (rainemak, 08:30:15)
    21. <Jolla> progressive web apps. (rainemak, 08:30:17)
    22. https://developer.mozilla.org/en-US/docs/Web/Progressive_web_apps (rainemak, 08:30:19)
    23. ACTION: Jolla to check whether we could resurrect past web notification work (rainemak, 08:37:52)

  6. New ownership and opensourcing/GPLv3 (10mins -- asked by Zyuc2G) (rainemak, 08:41:07)
    1. <Zyuc2G> Given SailfishOS proprietary assets are under new ownership, is there any renewed (rainemak, 08:41:07)
    2. <Zyuc2G> effort to release them under FOSS licensing (in particular Silica)? (rainemak, 08:41:07)
    3. <Jolla> This question relates to the strategy work of the new Jolla. We will come back (rainemak, 08:41:22)
    4. <Jolla> to you asking questions. For now, please give us time for the strategy work. (rainemak, 08:41:22)

  7. Open PR discussion (10 mins -- asked by Jolla) (rainemak, 08:45:18)
    1. <Jolla> Any open PRs to discuss? (rainemak, 08:45:26)
    2. <topic> Bug reports by the community bug coordination team (5 min -- asked by thigg) (rainemak, 08:48:22)
    3. https://forum.sailfishos.org/t/new-role-community-bug-coordinator/10935 (rainemak, 08:48:22)
    4. https://forum.sailfishos.org/t/community-meeting-on-irc-7th-december-2023/17429/9 (rainemak, 08:48:22)
    5. <thigg> Only got a few items prepared this time (rainemak, 08:48:22)
    6. <Jolla> As a result of the work, we now have: (rainemak, 08:48:22)
    7. <Jolla> 1 high quality bug reports now recorded internally and tagged as "tracked" (rainemak, 08:48:24)
    8. <Jolla> 2 bug reports tagged as fixed. (rainemak, 08:48:25)
    9. <Jolla> As always, big thanks to the bug coordination team! (rainemak, 08:48:27)

  8. General discussion (5 min) (rainemak, 08:50:47)
    1. https://wiki.mozilla.org/Firefox/Push_Notifications (flypig, 08:52:15)
    2. <Jolla> We'll get back to OSS components when time is right. (rainemak, 08:55:11)
    3. <Jolla> For now, please give us time for the strategy work. (rainemak, 08:56:34)

  9. Next meeting time and date (1 min) (rainemak, 08:59:49)
    1. Next meeting will be held on Thursday 21st December 2023 at 08:00am UTC: 2023-12-21T0800Z (rainemak, 09:00:55)


Meeting ended at 09:01:02 UTC (full logs).

Action items

  1. Jolla to check whether we could resurrect past web notification work


People present (lines said)

  1. rainemak (164)
  2. b100dian[m] (27)
  3. sledges (12)
  4. Keto (8)
  5. flypig (7)
  6. ExTechOp (6)
  7. nephros (5)
  8. Zyuc2G (4)
  9. sailbot_ (2)
  10. dcaliste (2)
  11. poetaster (2)
  12. Crabster (1)
  13. karry (1)
  14. tuplasuhveli[m] (1)
  15. sebix[m] (1)


Generated by MeetBot 0.1.4.