#sailfishos-meeting: Sailfish OS, open source, collaboration -- 21st Dec 2023

Meeting started by rainemak at 08:00:11 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: (rainemak, 08:00:11)
    2. https://forum.sailfishos.org/t/community-meeting-on-irc-21st-december-2023/17546 (rainemak, 08:00:11)

  1. Brief introduction (5 min). Please prefix your name/handle with #info (rainemak, 08:00:13)
    1. Ville Nummela - sailor @ Jolla (ViGe, 08:01:00)
    2. Matti Viljanen - community (direc85[m], 08:01:09)
    3. Raine Mäkeläinen - sailor @ Jolla, chairperson today (rainemak, 08:01:22)
    4. Otto Mäkelä, community (ExTechOp, 08:01:35)
    5. voidanix - lurking virtuoso (voidanix[m], 08:01:39)
    6. Ruben De Smet - community (rubdos[m], 08:02:54)
    7. David Llewellyn-Jones - community (flypig, 08:03:12)
    8. Pami Ketolainen - Sailor @ Jolla (Keto, 08:03:33)

  2. Status of VoLTE packages availability (10mins -- asked by voidanix) (rainemak, 08:05:46)
    1. <voidanix> another SFOS release is supposedly behind the corner and many (rainemak, 08:06:01)
    2. <voidanix> carriers have been shutting down their 3G/2G infrastructures (rainemak, 08:06:01)
    3. <voidanix> this year. What is blocking Jolla from releasing the (currently (rainemak, 08:06:01)
    4. <voidanix> proprietary) VoLTE packages to public repositories, similarly (rainemak, 08:06:01)
    5. <voidanix> to how sailfish-fpd/sailfish-fpd-slave-binder are available, (rainemak, 08:06:01)
    6. <voidanix> for the next release? Even if possibly incompatible with other (rainemak, 08:06:02)
    7. <voidanix> devices, they would be of great use with ports whose (rainemak, 08:06:04)
    8. <voidanix> architecture is close to the ones of the SFOS X supported (rainemak, 08:06:06)
    9. <voidanix> devices (Qualcomm in general). (rainemak, 08:06:10)
    10. <Jolla> Guess you’re referring to public OBS repositories. In theory that (rainemak, 08:06:37)
    11. <Jolla> should be doable. Difference to sailfish-fpd / (rainemak, 08:06:37)
    12. <Jolla> sailfish-fpd-slave-binder is that those are based on binder (rainemak, 08:06:37)
    13. <Jolla> interface whereas VoLTE is not based on similar common interface. (rainemak, 08:06:37)
    14. <Jolla> Rather being hardware specific. So logically VoLTE belongs to (rainemak, 08:06:38)
    15. <Jolla> adaptation repository. That said, let’s see what we could do. (rainemak, 08:06:40)
    16. <Jolla> This was added to our internal issue tracker as well. (rainemak, 08:06:42)
    17. Peter G., late community lurker (nephros, 08:10:23)
    18. <<voidanix> Thank you for the update; i raised this because we recently got a FOSS volte implementation on android (rainemak, 08:11:02)
    19. <voidanix> you can find the code at https://github.com/phhusson/ims (rainemak, 08:11:21)
    20. https://github.com/phhusson/ims (rainemak, 08:11:30)
    21. <voidanix> The first volte calls on samsung w/ custom ROM were done very recently with FOSS volte implementation on Android (rainemak, 08:14:07)

  3. Status of OpenSSL (5mins -- asked by voidanix) (rainemak, 08:16:21)
    1. <voidanix> OpenSSL 1.1.1 has reached EOL in September this year. Is Jolla (rainemak, 08:16:27)
    2. <voidanix> already working internally on an upgrade to the latest 3.1 (or (rainemak, 08:16:28)
    3. <voidanix> even better, 3.2) version? If not, should we expect it for the (rainemak, 08:16:28)
    4. <voidanix> release following the next one? (rainemak, 08:16:28)
    5. <Jolla> Yes, we’re preparing & working on OpenSSL 3.1 upgrade, and target (rainemak, 08:16:39)
    6. <Jolla> is to get it for the next release. We have done a great amount of (rainemak, 08:16:39)
    7. <Jolla> package updates due to various reasons. With the updated packages (rainemak, 08:16:39)
    8. <Jolla> hopefully, we are not hitting too many builds errors when removing (rainemak, 08:16:39)
    9. <Jolla> deprecated OpenSSL 1.0 functions. Fixing this is a requirement to (rainemak, 08:16:39)
    10. <Jolla> go to 3.1. If we miss the next release, then target would be the (rainemak, 08:16:40)
    11. <Jolla> release after next. (rainemak, 08:16:42)

  4. cross-packages (10mins -- asked by rubdos and direc85) (rainemak, 08:23:03)
    1. <rubdos> Since 2022-12-14, several packages (including rust and cargo) have (rainemak, 08:23:14)
    2. <rubdos> build dependencies on cross-{armv7hl,aarch64}-{gcc,binutils,as,glibc} (rainemak, 08:23:14)
    3. <rubdos> and some more. I assume some refactoring has been done in the (rainemak, 08:23:14)
    4. <rubdos> packaging, since before that time, we could build rust etc. (rainemak, 08:23:14)
    5. <rubdos> ourselves on the Platform SDK. These packages are nowhere to be (rainemak, 08:23:14)
    6. <rubdos> found, nor can we find a way to build them ourselves, currently. (rainemak, 08:23:16)
    7. <rubdos> This makes it difficult to contribute patches to Rust (and gcc (rainemak, 08:23:17)
    8. <rubdos> and gecko, cc flypig), especially in terms of testing the (rainemak, 08:23:19)
    9. <rubdos> resulting compiler. (rainemak, 08:23:21)
    10. <rubdos> (rainemak, 08:23:23)
    11. <rubdos> Would it be possible for Jolla to provide us with some insight, (rainemak, 08:23:25)
    12. <rubdos> sources and/or binaries for these missing dependencies? We have (rainemak, 08:23:27)
    13. <rubdos> asked mal on IRC a few times, to which the understandable answer (rainemak, 08:23:29)
    14. <rubdos> was that he could test the build on OBS. This is however not a (rainemak, 08:23:31)
    15. <rubdos> sustainable process, especially since we currently don’t get our (rainemak, 08:23:33)
    16. <rubdos> hands on the resulting 1.72 compiler. (rainemak, 08:23:35)
    17. <rubdos> (rainemak, 08:23:39)
    18. <rubdos> rainemak already said in the previous meeting to have a look at (rainemak, 08:23:41)
    19. <rubdos> this, but I’d like to formalize the request here. Thank you! (rainemak, 08:23:43)
    20. <Jolla> Short answer, yes it is possible that we provide insight. Whilst we (rainemak, 08:23:51)
    21. <Jolla> were looking into this we noticed that testing the OBS build was (rainemak, 08:23:51)
    22. <Jolla> ok. As answer ended up being too long to irc meeting, we posted it (rainemak, 08:23:51)
    23. <Jolla> to the forum already. That should be a good baseline to continue (rainemak, 08:23:52)
    24. <Jolla> the discussion. (rainemak, 08:23:53)
    25. https://forum.sailfishos.org/t/community-meeting-on-irc-21st-december-2023/17546/11 (rainemak, 08:23:55)
    26. <Jolla> (rainemak, 08:23:57)
    27. <Jolla> Due to this question, we should create an article to the (rainemak, 08:23:59)
    28. <Jolla> docs.sailfishos.org out of this explanation. Please do not hesitate (rainemak, 08:24:01)
    29. <Jolla> to reach for example rainemak in some channel if you’re still (rainemak, 08:24:03)
    30. <Jolla> facing issues. (rainemak, 08:24:05)
    31. ACTION: <Jolla> Create an article to the docs.sailfishos.org regarding this topic (rainemak, 08:30:31)

  5. What are the plans to enable 5G connectivity? (5mins -- asked by TNZ & cquence) (rainemak, 08:31:46)
    1. <cquence> I remember some work taking place a while ago. Any update you (rainemak, 08:32:00)
    2. <cquence> can share would be great! P.S. Well done on the restructuring (rainemak, 08:32:00)
    3. <cquence> and fair winds ahead! I probably won’t be able to attend due to (rainemak, 08:32:00)
    4. <cquence> work commitments but will read the logs afterwards. (rainemak, 08:32:00)
    5. <Jolla> There are 3-5 major stories which we’d still like to sort out for (rainemak, 08:32:08)
    6. <Jolla> the next release and 5G is one of them. So far 5G works on (rainemak, 08:32:08)
    7. <Jolla> Sailfish OS side but AppSupport plugin is not yet finalized. Half (rainemak, 08:32:08)
    8. <Jolla> cooked version is bad as that would break mobile data with (rainemak, 08:32:09)
    9. <Jolla> AppSupport. If we miss the next release, then target would be the (rainemak, 08:32:11)
    10. <Jolla> release after next. (rainemak, 08:32:13)
    11. https://github.com/mer-hybris/ofono-binder-plugin/pull/28 (rainemak, 08:35:56)

  6. Open PR discussion (10 mins -- asked by Jolla) (rainemak, 08:38:52)
    1. <Jolla> Any open PRs to discuss? (rainemak, 08:38:52)
    2. <topic> Bug reports by the community bug coordination team (5 min -- asked by Jolla) (rainemak, 08:42:03)
    3. <Jolla> No bug reports for this community meeting. Merry Christmas for the (rainemak, 08:42:03)
    4. <Jolla> whole Community Bug Coordination Team and happy new year! You have (rainemak, 08:42:03)
    5. <Jolla> done fantastic job the year! (rainemak, 08:42:03)
    6. <topic> Bug reports by the community bug coordination team (5 min -- asked by Jolla) (rainemak, 08:42:22)

  7. Bug reports by the community bug coordination team (5 min -- asked by Jolla) (rainemak, 08:43:24)
    1. <Jolla> No bug reports for this community meeting. Merry Christmas for the (rainemak, 08:43:43)
    2. <Jolla> whole Community Bug Coordination Team and happy new year! You have (rainemak, 08:43:43)
    3. <Jolla> done fantastic job the year! (rainemak, 08:43:43)

  8. General discussion (10 min) (rainemak, 08:44:27)
    1. Some 5G related PRs (rainemak, 08:44:53)
    2. https://github.com/sailfishos/ofono/pull/40 (rainemak, 08:44:54)
    3. https://github.com/mer-hybris/ofono-binder-plugin/pull/28 (rainemak, 08:44:54)
    4. https://github.com/sailfishos/libqofonoext/pull/3 (rainemak, 08:44:54)
    5. https://github.com/sailfishos/libgofono/pull/2 (rainemak, 08:44:54)
    6. <Jolla> If you’re interested in testing CLAT with latest changes, please (rainemak, 08:46:54)
    7. <Jolla> read from here https://forum.sailfishos.org/t/testing-clat-for-ipv6-only-mobile-networks/14520/175 (rainemak, 08:46:54)
    8. https://forum.sailfishos.org/t/testing-clat-for-ipv6-only-mobile-networks/14520/175 (rainemak, 08:46:54)
    9. <Jolla> The release will occur when it's ready ;) (rainemak, 08:47:29)
    10. <Jolla> We wish you all Merry Christmas and Happy new year! This is the last community meeting of this year. (rainemak, 08:50:23)

  9. Next meeting time and date (5 mins) (rainemak, 08:56:07)
    1. Next meeting will be held on Thursday 11th January 2023 at 08:00am UTC: 2024-01-11T0800Z (rainemak, 09:00:24)


Meeting ended at 09:03:16 UTC (full logs).

Action items

  1. <Jolla> Create an article to the docs.sailfishos.org regarding this topic


People present (lines said)

  1. rainemak (168)
  2. flypig (21)
  3. direc85[m] (18)
  4. rubdos[m] (15)
  5. voidanix[m] (13)
  6. ExTechOp (9)
  7. ViGe (6)
  8. sailbot_ (2)
  9. Keto (2)
  10. nephros (2)


Generated by MeetBot 0.1.4.