#sailfishos-meeting: Sailfish OS, open source, collaboration -- 23rd April 2026

Meeting started by rainemak at 16:00:09 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: (rainemak, 16:00:09)
    2. https://forum.sailfishos.org/t/29030/3 (rainemak, 16:00:09)

  1. Brief introduction (5 min). Please prefix your name/handle with #info (rainemak, 16:00:09)
    1. Otto Mäkelä, community (extechop[m], 16:00:16)
    2. Raine Mäkeläinen, Jolla (rainemak, 16:00:22)
    3. Nico, community (Nico, 16:00:27)
    4. Andrea Scarpino, community (Guest6720, 16:00:35)
    5. Matti Viljanen, Jolla (direc85[m], 16:01:03)
    6. mal, Jolla (mal, 16:04:41)
    7. Niels, Community (fingus, 16:04:48)
    8. frankps, Community (frankps, 16:05:03)

  2. Keyboard and predictive text (5 mins -- Kanthal) (rainemak, 16:05:06)
    1. <Kanthal> Hello! (rainemak, 16:05:06)
    2. <Kanthal> I am curious if there are any plans to modernize the whole (rainemak, 16:05:06)
    3. <Kanthal> keyboard experience, especially since there will be a lot of new (rainemak, 16:05:06)
    4. <Kanthal> users with J2. (rainemak, 16:05:06)
    5. <Kanthal> As an example I struggle to type on a keyboard that doesn’t have (rainemak, 16:05:07)
    6. <Kanthal> borders around the letters, suggestions, autocorrect (didn’t have (rainemak, 16:05:09)
    7. <Kanthal> that in my language even with XT9). (rainemak, 16:05:11)
    8. <Kanthal> Features like OTP codes being shown as a autofill suggestion when (rainemak, 16:05:13)
    9. <Kanthal> you receive them in sms/email are also very helpful and pretty (rainemak, 16:05:15)
    10. <Kanthal> much standard on other platforms. (rainemak, 16:05:17)
    11. <Kanthal> (rainemak, 16:05:19)
    12. <Kanthal> So I would like to know if reworking the keyboard is on the (rainemak, 16:05:21)
    13. <Kanthal> horizon. (rainemak, 16:05:23)
    14. <Kanthal> Thanks in advance! (rainemak, 16:05:27)
    15. <Jolla> Thank you for your question. Prediction is something that we're (rainemak, 16:05:29)
    16. <Jolla> thinking about. Earlier we mentioned presage as an option. We (rainemak, 16:05:31)
    17. <Jolla> should investigate if we could do something with hunspell. Let's (rainemak, 16:05:33)
    18. <Jolla> see what can we make for Sailfish OS 5.2. (rainemak, 16:05:35)

  3. Community Tasks Board (10 mins -- nephros) (rainemak, 16:11:51)
    1. https://forum.sailfishos.org/t/community-meeting-on-23rd-april-2026/29030/3 (rainemak, 16:11:51)
    2. <Jolla> What an excellent topic. We have been steering this all towards (rainemak, 16:13:01)
    3. <Jolla> GitHub Sailfish OS issues. Same time we are opening issues from the (rainemak, 16:13:01)
    4. <Jolla> internal issue tracker to public -- let us do it in our own phase. (rainemak, 16:13:01)
    5. <Jolla> It'll take time. Espacially regarding components that are already (rainemak, 16:13:01)
    6. <Jolla> open sourced. (rainemak, 16:13:01)
    7. <Jolla> (rainemak, 16:13:03)
    8. <Jolla> We're open to new plugins for GitHub, let's avoid intoducting (rainemak, 16:13:04)
    9. <Jolla> something completely new. (rainemak, 16:13:06)
    10. ACTION: We need to improve / figure community task board (rainemak, 16:21:01)

  4. Tracking of non-resolved Community Meeting topics (10 mins -- nephros) (rainemak, 16:22:05)
    1. <nephros> While these meetings offer a nice and welcome opportunity for the (rainemak, 16:22:05)
    2. <nephros> Community to discuss topics, the results of the meetings tend to (rainemak, 16:22:05)
    3. <nephros> be very non-committal/consequential. Words like “later”, “we will (rainemak, 16:22:05)
    4. <nephros> come back to this” etc. (rainemak, 16:22:05)
    5. <nephros> This is fine - however, often things that should have received an (rainemak, 16:22:07)
    6. <nephros> answer “later” are lost in time/memory/the meeting logs. (rainemak, 16:22:08)
    7. <nephros> As the Meeting bot has the capability of creating "action items’, (rainemak, 16:22:10)
    8. <nephros> I propose using that to record things that should be revisited (rainemak, 16:22:12)
    9. <nephros> “later”. (rainemak, 16:22:14)
    10. <nephros> (rainemak, 16:22:16)
    11. <nephros> At the start of each subsequent meeting, if there were updates to (rainemak, 16:22:18)
    12. <nephros> a previous Action Item, this should be presented briefly. (rainemak, 16:22:20)
    13. <nephros> (rainemak, 16:22:22)
    14. <nephros> Action Items should only be added if they have some resemblance (rainemak, 16:22:26)
    15. <nephros> of importance. Not every unresolved topic needs to be an action (rainemak, 16:22:28)
    16. <nephros> item. (rainemak, 16:22:30)
    17. <nephros> Whether something is an Action Item or not is decided by the (rainemak, 16:22:32)
    18. <nephros> Meeting Chair Person only. (rainemak, 16:22:34)
    19. <Jolla> This we should tackle the soonest. Proposal would be that Meeting (rainemak, 16:22:41)
    20. <Jolla> Chair Person keeps track on the action items. We could repeat open (rainemak, 16:22:41)
    21. <Jolla> actions as a first item after intro. That's in itself is an (rainemak, 16:22:42)
    22. <Jolla> action point for rainemak. Like requested, let's focus on the how (rainemak, 16:22:44)
    23. <Jolla> part. (rainemak, 16:22:46)
    24. <Jolla> Meeting Chair should flag actions as suggested. (rainemak, 16:23:21)
    25. ACTION: Actions to be followed up meeting by meeting (rainemak, 16:24:31)
    26. ACTION: Jolla to adjust meeting template (rainemak, 16:33:07)

  5. user-replaceable battery on the Jolla J2 site (5 mins -- PolatBirdal) (rainemak, 16:33:55)
    1. <PolatBirdal> Hello, there is a statement on your site saying “user- (rainemak, 16:33:55)
    2. <PolatBirdal> replaceable battery,” but recently when we examined the (rainemak, 16:33:55)
    3. <PolatBirdal> phones with friends in the group, the phone’s battery was (rainemak, 16:33:55)
    4. <PolatBirdal> under a protective plate, and the protective plate was (rainemak, 16:33:55)
    5. <PolatBirdal> screwed to the case. Logically, how can it be replaced by the (rainemak, 16:33:56)
    6. <PolatBirdal> user? (rainemak, 16:33:58)
    7. <Jolla> Yes, you need to open the screws to replace battery. The battery #info <Jolla> won't be glued so no need for heater. (rainemak, 16:34:00)

  6. details of the return conditions regarding the product (5 mins -- PolatBirdal) (rainemak, 16:40:06)
    1. <PolatBirdal> Hello, I asked before as well, yes, but I forgot to ask for (rainemak, 16:40:06)
    2. <PolatBirdal> the details, so you answered according to the situation I (rainemak, 16:40:06)
    3. <PolatBirdal> asked about. I could not fully explain the situation in the (rainemak, 16:40:06)
    4. <PolatBirdal> community chat. The exact issue is this: of course, we also (rainemak, 16:40:06)
    5. <PolatBirdal> know this device is a European device, meaning it is expected (rainemak, 16:40:07)
    6. <PolatBirdal> to be marketed within Europe, but as people who like Jolla, (rainemak, 16:40:08)
    7. <PolatBirdal> we accepted this difficulty and prepared shipping companies (rainemak, 16:40:10)
    8. <PolatBirdal> like forward2me. In this sense, what kinds of problems that (rainemak, 16:40:12)
    9. <PolatBirdal> may arise from handing it over to a shipping company are we (rainemak, 16:40:14)
    10. <PolatBirdal> responsible for? If a problem comes up during the shipping (rainemak, 16:40:16)
    11. <PolatBirdal> process and the shipping company has the product but is not (rainemak, 16:40:18)
    12. <PolatBirdal> sending it, are we free to use our return option at that (rainemak, 16:40:20)
    13. <PolatBirdal> moment, or since we have already given this product to the (rainemak, 16:40:22)
    14. <PolatBirdal> shipping company, do we no longer have any return right at (rainemak, 16:40:26)
    15. <PolatBirdal> all under any circumstances? (rainemak, 16:40:28)
    16. <Jolla> This should be covered in forum already. Anything missing? (rainemak, 16:40:30)
    17. https://forum.sailfishos.org/t/community-meeting-on-23rd-april-2026/29030/9 (rainemak, 16:40:32)

  7. Some love for Harbour (5 mins -- ilpianista) (rainemak, 16:44:14)
    1. <ilpianista> I read several topics about what API are missing in Harbour so (rainemak, 16:44:14)
    2. <ilpianista> that we get more apps into it, however none is talking about (rainemak, 16:44:15)
    3. <ilpianista> the Harbour “dev experience”. I’m sorry, but from my point of (rainemak, 16:44:15)
    4. <ilpianista> view: it s*cks. We are waiting for a wave of new users, but (rainemak, 16:44:15)
    5. <ilpianista> there could be developers among them as well. I would like to (rainemak, 16:44:16)
    6. <ilpianista> see these things implemented in harbour ASAP: 1) notifications (rainemak, 16:44:18)
    7. <ilpianista> for approved/rejected apps, 2) notifications for comments and (rainemak, 16:44:20)
    8. <ilpianista> 3) two factor authentication, as I’m concerned about supply (rainemak, 16:44:22)
    9. <ilpianista> chain attacks which are quite popular and successful. (rainemak, 16:44:26)
    10. <Jolla> Good points. Let's have open discussion on the topic. (rainemak, 16:44:28)

  8. Batterys for Jolla C2 and more (5 mins -- asked by fingus) (rainemak, 16:55:24)
    1. <fingus> The first shipped Jolla C2 units (including mine) are now about (rainemak, 16:55:24)
    2. <fingus> 1,5 years old, and I think this is a good time to start (rainemak, 16:55:24)
    3. <fingus> considering the supply of spare batteries for them. The (rainemak, 16:55:25)
    4. <fingus> possibility of getting Reeder S19 Max Pro S batteries in Europe (rainemak, 16:55:26)
    5. <fingus> looks bad, so this seems to be an important issue to resolve. I (rainemak, 16:55:28)
    6. <fingus> also contacted our spare-parts distributor (https://www.aswo.de, (rainemak, 16:55:30)
    7. <fingus> they are reliable, fast, have been on the market for a long time (rainemak, 16:55:32)
    8. <fingus> and have a good reputation.), from whom we purchase a large number (rainemak, 16:55:34)
    9. <fingus> of spare parts for the notebooks, tablets, and smartphones we sell (rainemak, 16:55:36)
    10. <fingus> at the company where I work. We have been working with them for (rainemak, 16:55:38)
    11. <fingus> the last 24 years and they provide a good service. I explained the (rainemak, 16:55:40)
    12. <fingus> situation with the new Jolla phones and gave them (german parent (rainemak, 16:55:42)
    13. <fingus> company) your contact information, so you (or reeder) might be (rainemak, 16:55:44)
    14. <fingus> able to form a joint venture for spare parts. The goals of this (rainemak, 16:55:46)
    15. <fingus> idea are availability, lower-cost and faster shipping and leave (rainemak, 16:55:48)
    16. <fingus> out this kind of work for your employees. I also offered to stay (rainemak, 16:55:50)
    17. <fingus> in contact with them about this matter to provide further (rainemak, 16:55:52)
    18. <fingus> information as a German native speaker with a technical background (rainemak, 16:55:56)
    19. <fingus> and as a community spokesperson. (rainemak, 16:55:58)
    20. <fingus> (rainemak, 16:56:00)
    21. <fingus> I’ll try to attend, but no promises (when stuck in traffic jam), (rainemak, 16:56:02)
    22. <fingus> maybe shift this topic to latest slot. (rainemak, 16:56:04)
    23. <Jolla> Currently we are lacking spare batteries for Jolla C2. We do have (rainemak, 16:56:06)
    24. <Jolla> replacement units though. Further, swapping battery on Jolla C2 is (rainemak, 16:56:08)
    25. <Jolla> not straight-forward as you need in practice heat the back plate to (rainemak, 16:56:10)
    26. <Jolla> get it properly detached (without breaking it). It's not (rainemak, 16:56:12)
    27. <Jolla> recommended to try to swap Jolla C2 battery yourself. (rainemak, 16:56:14)

  9. Open Pull Requests (PRs) to discussion (5 mins -- asked by Jolla) (rainemak, 17:05:20)
  10. General discussion (10 mins) (rainemak, 17:14:45)
  11. Next meeting time and date (2 mins) (rainemak, 17:26:45)
    1. Next meeting will be held on Thursday 7th May 2026 at 04:00pm UTC: 2026-05-07T1600Z (rainemak, 17:28:55)


Meeting ended at 17:29:29 UTC (full logs).

Action items

  1. We need to improve / figure community task board
  2. Actions to be followed up meeting by meeting
  3. Jolla to adjust meeting template


People present (lines said)

  1. rainemak (237)
  2. fingus (36)
  3. Nico (30)
  4. Guest6720 (15)
  5. Polatbirdal (13)
  6. extechop[m] (7)
  7. direc85[m] (6)
  8. frankps (4)
  9. poetaster (4)
  10. sailbot (2)
  11. mal (2)
  12. Keto (2)
  13. tuplasuhveli[m] (1)


Generated by MeetBot 0.1.4.