#sailfishos-meeting: Sailfish OS, open source, collaboration -- 18th June 2026

Meeting started by rainemak at 16:00:26 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: (rainemak, 16:00:26)
    2. https://forum.sailfishos.org/t/29888 (rainemak, 16:00:26)

  1. Brief introduction (5 min). Please prefix your name/handle with #info (rainemak, 16:00:26)
    1. Raine Mäkeläinen, Jolla (rainemak, 16:00:32)
    2. Otto Mäkelä, community (extechop[m], 16:00:40)
    3. mal, Jolla (mal, 16:01:02)
    4. nephros, community, proxying for peterleinchen (nephros_, 16:01:15)
    5. piggz community (piggz[m], 16:01:22)
    6. Matti Viljanen, Jolla (direc85[m], 16:01:37)
    7. jojomen community (jojomen, 16:02:12)
    8. Morugan community (Morugan[m], 16:03:07)
    9. polat (Polatbirdal, 16:05:03)

  2. Tracking of non-resolved Community Meeting topics (rainemak, 16:05:24)
    1. ACTION: Community task board (rainemak, 16:05:24)
    2. https://forum.sailfishos.org/t/community-meeting-on-23rd-april-2026/29030/3 (rainemak, 16:05:24)
    3. ACTION: Jolla to update regarding recommended charging cables and chargers. (rainemak, 16:05:24)
    4. https://forum.sailfishos.org/t/community-meeting-on-7th-may-2026/29253/2 (rainemak, 16:05:24)
    5. No actions taken yet regarding community task board nor charger / cables. (rainemak, 16:05:25)
    6. Venty Longtime SFOS User (Venty[m], 16:05:46)
    7. Nico Community, user, and interested in the Mind2 situation :D (PublicNico, 16:06:34)

  3. Defender and it’s Harbour compliance, Benefit for all new users, expected to come soon™ (25 mins -- peterleinchen) (rainemak, 16:07:25)
    1. <peterleinchen> harbour-defender, the privacy guard is a tool that (rainemak, 16:07:25)
    2. <peterleinchen> (rainemak, 16:07:25)
    3. <peterleinchen> - Let the user choose from a list of internet #info #info <peterleinchen> available ad-blocker (rainemak, 16:07:25)
    4. <peterleinchen> - It works on domain based blocking via /etc/hosts. (rainemak, 16:07:26)
    5. <peterleinchen> For this it needs -obviously- to modify the hosts #info <peterleinchen> file. This is not allowed AFAIK, so for this it would (rainemak, 16:07:28)
    6. <peterleinchen> need an exception! (rainemak, 16:07:33)
    7. <peterleinchen> - It is a pure qml app ( with a one-liner cpp) running (rainemak, 16:07:35)
    8. <peterleinchen> as defaultuser (nemo) and does not have and does not (rainemak, 16:07:37)
    9. <peterleinchen> need root rights. (rainemak, 16:07:39)
    10. <peterleinchen> - (Root, where needed) functionality is purely (rainemak, 16:07:41)
    11. <peterleinchen> implemented in python and only available as function (rainemak, 16:07:43)
    12. <peterleinchen> calls. (rainemak, 16:07:45)
    13. <peterleinchen> - Furthermore it deals with the sailfish-browser (rainemak, 16:07:47)
    14. <peterleinchen> cookies.sqlite DB file. It can delete cookies from (rainemak, 16:07:49)
    15. <peterleinchen> blacklist (or not whitelisted). And persist the DB by (rainemak, 16:07:51)
    16. <peterleinchen> setting the file to read-only. Most probably another (rainemak, 16:07:53)
    17. <peterleinchen> exception needed! (rainemak, 16:07:55)
    18. <peterleinchen> - Setting the domain blocking in /etc/hosts works as (rainemak, 16:07:57)
    19. <peterleinchen> well for AlienDalvik/AppSupport. Which of course means (rainemak, 16:08:01)
    20. <peterleinchen> its /system/etc/hosts is modified also. The service (rainemak, 16:08:03)
    21. <peterleinchen> can be restarted via menu item. (rainemak, 16:08:05)
    22. <peterleinchen> - PublicDir and browser is used for error messages. (rainemak, 16:08:07)
    23. <peterleinchen> - Right now I still use /var/log and /tmp but could (rainemak, 16:08:09)
    24. <peterleinchen> relocate those files to .config or .cache?? (rainemak, 16:08:11)
    25. <peterleinchen> - A config file written to /etc (on purpose, so that (rainemak, 16:08:13)
    26. <peterleinchen> Jane Doe cannot modify) (rainemak, 16:08:15)
    27. <peterleinchen> - Ah, and one more: the update is scheduled with a (rainemak, 16:08:17)
    28. <peterleinchen> timer service (which should be okay, or?) (rainemak, 16:08:19)
    29. <Jolla> Very nice idea! We have been thinkering something similar. (rainemak, 16:08:21)
    30. <Jolla> How it looks now with this input is that architectural (rainemak, 16:08:23)
    31. <Jolla> changes are needed. A container based solution where we'd use (rainemak, 16:08:25)
    32. <Jolla> something pi-hole could probably tackle good amount of these (rainemak, 16:08:27)
    33. <Jolla> things (surely not all). It's good to use existing solution (rainemak, 16:08:31)
    34. <Jolla> wherever possible, not invented here is not good. Bare (rainemak, 16:08:33)
    35. <Jolla> minimum is that we have a daemon as an access control (rainemak, 16:08:35)
    36. <Jolla> component. In between of the lines it looks that python (rainemak, 16:08:37)
    37. <Jolla> thingie already acts as a daemon, is that correct? Time for (rainemak, 16:08:39)
    38. <Jolla> open discussion. (rainemak, 16:08:41)

  4. Status of Mind2 (10mins -- asked by CLMA31) (rainemak, 16:33:07)
    1. <Jolla> No news update, we'll update as we proceed. SoonTM. (rainemak, 16:33:09)
    2. <CLMA31> I have not ordered Mind2, so I’m more like a messenger here (rainemak, 16:34:56)
    3. <CLMA31> (I know I’m late). This comment summarises the situation (rainemak, 16:34:56)
    4. <CLMA31> well: Community meeting on 18th June 2026 - #5 by fridlmue. (rainemak, 16:34:56)
    5. <CLMA31> There are some members in community who has ordered Mind2 (rainemak, 16:34:56)
    6. <CLMA31> over 1 year ago without getting the device. There also (rainemak, 16:34:56)
    7. <CLMA31> hasn’t been any software releases for existing owners (to my (rainemak, 16:34:57)
    8. <CLMA31> knowledge). To my knowledge, there hasn’t been any (rainemak, 16:35:01)
    9. <CLMA31> information send to current owners and the ones who have (rainemak, 16:35:03)
    10. <CLMA31> ordered the device, but not received it. It would be good to (rainemak, 16:35:05)
    11. <CLMA31> get Antti or someone from Venho team to clarify the (rainemak, 16:35:07)
    12. <CLMA31> situation. There should be some kind of roadmap that sticks. (rainemak, 16:35:09)
    13. <Jolla> No news update, we'll update as we proceed. SoonTM. (rainemak, 16:35:11)
    14. https://forum.sailfishos.org/t/community-meeting-on-18th-june-2026/29888/5 (rainemak, 16:36:12)

  5. Jolla Mind2 delivery at Jolla Phone Day 1? (10mins -- asked by jojomen) (rainemak, 16:45:48)
    1. <jojomen> - Would it be possible to have the Jolla Mind2 delivered at (rainemak, 16:45:48)
    2. <jojomen> the meeting in Helsinki on July 8th? (rainemak, 16:45:48)
    3. <jojomen> - This is for those who have so far decided to hold off (rainemak, 16:45:48)
    4. <jojomen> delivery, waiting for software maturity. (rainemak, 16:45:48)
    5. <jojomen> - Given that the anniversary of the la(te)st release of (rainemak, 16:45:49)
    6. <jojomen> Venho.ai will happen before the Jolla Phone Day, maybe it’s (rainemak, 16:45:51)
    7. <jojomen> better to get the device and put it to whatever use is (rainemak, 16:45:53)
    8. <jojomen> enabled by Sailfish OS Core than to wait for Venho.ai to (rainemak, 16:45:55)
    9. <jojomen> come out of pre-alpha. (rainemak, 16:45:57)
    10. <Jolla> Firstly, it's a Jolla Phone Day1 (note, without space in (rainemak, 16:46:01)
    11. <Jolla> Day1). So, likely not going to happen that we have other (rainemak, 16:46:03)
    12. <Jolla> products there as well. (rainemak, 16:46:05)
    13. <Jolla> (rainemak, 16:46:07)
    14. <Jolla> Regarding other questions see above answer. (rainemak, 16:46:09)

  6. Jolla phone day 1, 8.7.26 (5mins -- asked by CLMA31) (rainemak, 16:50:21)
    1. <CLMA31> I’m again messenger only, but there has been quite a lot of (rainemak, 16:50:21)
    2. <CLMA31> conversation regarding the launch event here in the forum. (rainemak, 16:50:21)
    3. <CLMA31> Example https://forum.sailfishos.org/t/jolla-phone-day1-celebration-event-global-topic/28841/78 (rainemak, 16:50:21)
    4. <CLMA31> Could Jolla give somekind of information package regarding (rainemak, 16:50:21)
    5. <CLMA31> the event? It is confirmed that it will be streamed. Where is (rainemak, 16:50:23)
    6. <CLMA31> event held? Around what time will it start and end etc.? (rainemak, 16:50:25)
    7. <Jolla> Info package will come -- stay tuned and carry on. (rainemak, 16:50:44)
    8. <Jolla> There will be a stream. We can all feel the excitement. (rainemak, 16:50:45)
    9. <Jolla> Currently we are preparing it but nothing to announce yet. (rainemak, 16:50:45)
    10. <Jolla> What we can say is that it won't be a morning even. (rainemak, 16:50:45)
    11. <Jolla> Afternoon June 8. You can book your flights, accommodation, (rainemak, 16:50:45)
    12. <Jolla> etc accordingly. (rainemak, 16:50:45)

  7. Open Pull Requests (PRs) to discussion (5 mins -- asked by Jolla) (rainemak, 16:56:20)
  8. General discussion (15 mins) (rainemak, 17:00:41)
    1. https://forum.sailfishos.org/t/29751 - 5.1. Pispala finally out for all (rainemak, 17:16:14)
    2. https://forum.sailfishos.org/t//30094 <- like 7h ago (rainemak, 17:17:14)

  9. Next meeting time and date (2 mins) (rainemak, 17:25:19)
    1. Next meeting will be held on Thursday 2nd July 2026 at 04:00pm UTC: 2026-07-02T1600Z (rainemak, 17:27:34)


Meeting ended at 17:30:00 UTC (full logs).

Action items

  1. Community task board
  2. Jolla to update regarding recommended charging cables and chargers.


People present (lines said)

  1. rainemak (206)
  2. PublicNico (25)
  3. nephros_ (24)
  4. extechop[m] (18)
  5. Polatbirdal (13)
  6. jojomen (8)
  7. umayer[m] (6)
  8. direc85[m] (5)
  9. JacobLS (4)
  10. CLMA31[m] (4)
  11. duskull[m] (3)
  12. sailbot (2)
  13. mal (2)
  14. piggz[m] (2)
  15. Venty[m] (2)
  16. Morugan[m] (1)
  17. frankps (1)


Generated by MeetBot 0.1.4.