#sailfishos-meeting: Sailfish OS, open source, collaboration -- 18th June 2026

Meeting started by rainemak at 16:00:45 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: (rainemak, 16:00:45)
    2. https://forum.sailfishos.org/t/29888 (rainemak, 16:00:45)

  1. Brief introduction (5 min). Please prefix your name/handle with #info (rainemak, 16:00:45)
    1. Otto Mäkelä, community (extechop[m], 16:00:56)
    2. Raine Mäkeläinen, Jolla (rainemak, 16:01:08)
    3. Matti Viljanen, Jolla (direc85[m], 16:01:15)
    4. Affe Null, community (AffeNull[m], 16:01:18)
    5. Anton Thomasson, community (attah, 16:01:23)
    6. Pami Ketolainen, Jolla (Keto, 16:02:35)
    7. mettska, Community waiting for J2 ;-) (mettska, 16:02:44)

  2. Tracking of non-resolved Community Meeting topics (rainemak, 16:05:34)
    1. ACTION: Community task board (rainemak, 16:05:34)
    2. https://forum.sailfishos.org/t/community-meeting-on-23rd-april-2026/29030/3 (rainemak, 16:05:34)
    3. ACTION: Jolla to update regarding recommended charging cables and chargers. (rainemak, 16:05:34)
    4. https://forum.sailfishos.org/t/community-meeting-on-7th-may-2026/29253/2 (rainemak, 16:05:34)
    5. No actions taken yet regarding community task board nor charger / cables. (rainemak, 16:05:36)
    6. sebix, community (sebix[m], 16:05:38)
    7. alsahio, community (alsahio, 16:05:56)
    8. Venty, Community Member (Venty[m], 16:09:14)

  3. Individuals that ordered multiple items and charged multiple shipping fee’s (10 mins -- jollus) (rainemak, 16:09:26)
    1. <jollus> Multiple invoices and shipping fee’s have been sent to people (rainemak, 16:09:26)
    2. <jollus> that ordered multiple phones. Jolla mentioned that multiple (rainemak, 16:09:26)
    3. <jollus> shipping fee’s will be reimbursed. Will a new invoice with one (rainemak, 16:09:26)
    4. <jollus> shipping fee be sent with one package containing the multiple #info <jollus> items? (rainemak, 16:09:26)
    5. <jollus> (rainemak, 16:09:29)
    6. <jollus> We will need to know if a new invoice with all the items in one (rainemak, 16:09:31)
    7. <jollus> package will be sent so we can upload it. Some of us have (rainemak, 16:09:33)
    8. <jollus> uploaded the individual invoices to a forwarding address. (rainemak, 16:09:35)
    9. <jollus> If Jolla sends one package with multiple phones without letting (rainemak, 16:09:37)
    10. <jollus> us know, the receiver may keep some items since it doesn’t (rainemak, 16:09:39)
    11. <jollus> match the invoice uploaded or send back to Jolla. (rainemak, 16:09:41)
    12. <Jolla> We'll bundle orders and refund extra shipping costs. When it (rainemak, 16:09:43)
    13. <Jolla> comes to newly created invoices, it won't happen -- almost (rainemak, 16:09:45)
    14. <Jolla> certainly we don't do that. It's a way too laboursome effort for (rainemak, 16:09:47)
    15. <Jolla> our team. (rainemak, 16:09:49)

  4. HID-over-I2C-over-TOH (10mins -- asked by ReturN900) (rainemak, 16:19:58)
    1. <ReturN900> Having used my N900 for a number of years and unfortunately (rainemak, 16:19:58)
    2. <ReturN900> missed out on the N9, N950, and the earlier Jolla phones, (rainemak, 16:19:58)
    3. <ReturN900> I’m looking forward to getting back to a true Linux phone, (rainemak, 16:19:58)
    4. <ReturN900> and in particular the potential to have a hardware keyboard (rainemak, 16:19:58)
    5. <ReturN900> (like the original TOHKBD and the TOHKBD 2). (rainemak, 16:20:00)
    6. <ReturN900> (rainemak, 16:20:01)
    7. <ReturN900> If I could design a module that complied with the HID-over- (rainemak, 16:20:03)
    8. <ReturN900> I2C protocol, is the Interrupt pin of the TOH interface (rainemak, 16:20:05)
    9. <ReturN900> connected to the AP in such a way that it can act as an IRQ? (rainemak, 16:20:07)
    10. <ReturN900> (rainemak, 16:20:09)
    11. <ReturN900> If so, will the default Jolla Phone kernel include the (rainemak, 16:20:11)
    12. <ReturN900> necessary drivers to interface with a HID-over-I2C out of (rainemak, 16:20:13)
    13. <ReturN900> the box. (rainemak, 16:20:15)
    14. <ReturN900> (rainemak, 16:20:17)
    15. <ReturN900> If not, are there others with a background in kernel/driver (rainemak, 16:20:19)
    16. <ReturN900> development that would be interested in collaborating. (rainemak, 16:20:21)
    17. <Jolla> Could you, Sailfish OS Community, elaborate a bit more. What (rainemak, 16:20:25)
    18. <Jolla> you are looking for? (rainemak, 16:20:27)
    19. CLMA31, community and late.... (CLMA31[m], 16:21:32)
    20. https://www.kernel.org/doc/Documentation/devicetree/bindings/input/hid-over-i2c.txt (attah, 16:22:49)

  5. About the Jolla J2 The Other Half. (10mins -- asked by Polatbirdal) (rainemak, 16:29:08)
    1. <Polatbirdal> Hello, I had asked this before, but I was told that you (rainemak, 16:29:08)
    2. <Polatbirdal> were still working on it and that it wasn’t fully clear (rainemak, 16:29:08)
    3. <Polatbirdal> yet. My question was this: regarding The Other Half, will (rainemak, 16:29:08)
    4. <Polatbirdal> you sell modules such as keyboard modules, solar-powered (rainemak, 16:29:08)
    5. <Polatbirdal> modules, or modules for wireless connectivity? Or have 3D- (rainemak, 16:29:10)
    6. <Polatbirdal> printable modules been prepared? How much progress has (rainemak, 16:29:11)
    7. <Polatbirdal> been made on The Other Half, and exactly what kind of (rainemak, 16:29:13)
    8. <Polatbirdal> progress will be achieved with it? (rainemak, 16:29:15)
    9. <Jolla> The Other Half is an innovation platform you all. Currently, our (rainemak, 16:29:17)
    10. <Jolla> plans do not include keyboards and such but you should be able (rainemak, 16:29:19)
    11. <Jolla> to innovate such. (rainemak, 16:29:21)
    12. ACTION: Jolla to add TOH category (rainemak, 16:36:20)
    13. ACTION: Jolla to add TOH category to Sailfish OS Forum (rainemak, 16:36:28)
    14. https://forum.sailfishos.org/t/add-the-other-half-as-a-category/30364 (attah, 16:36:42)

  6. Jolla Phone (2026) accessories and repairability (15mins -- asked by alsahio) (rainemak, 16:40:30)
    1. <alsahio> Hi :slight_smile: I was wondering whether acessories for Jolla (rainemak, 16:40:30)
    2. <alsahio> Phone (2026) will become available for purchase before the (rainemak, 16:40:30)
    3. <alsahio> celebration event, and whether those who order these will get (rainemak, 16:40:30)
    4. <alsahio> it in the event? The commerce page estimates June 2026 as the (rainemak, 16:40:30)
    5. <alsahio> availability date, so that is why I am wondering. Also, will (rainemak, 16:40:32)
    6. <alsahio> things such as camera modules, USB-C modules, etc be a part of (rainemak, 16:40:33)
    7. <alsahio> these accessories, and will they be user replaceable? Thank (rainemak, 16:40:35)
    8. <alsahio> you. (rainemak, 16:40:37)
    9. <Jolla> At the event, let's see what we have. Eventually, there will be (rainemak, 16:40:39)
    10. <Jolla> spare batteries and camera lenses maybe something more. Please (rainemak, 16:40:41)
    11. <Jolla> let us work on those. (rainemak, 16:40:43)

  7. Jolla Phone Day1 celebration event - spectators, +1? (10 mins -- asked by alsahio) (rainemak, 16:49:38)
    1. <alsahio> Hi again, maybe this is a bad question, because of physical (rainemak, 16:49:38)
    2. <alsahio> venue limitations and such, but are there any plans to make (rainemak, 16:49:38)
    3. <alsahio> the event more open for the public? Like introduce something (rainemak, 16:49:38)
    4. <alsahio> like a (paid) spectator ticket, where people who haven’t (rainemak, 16:49:38)
    5. <alsahio> ordered the phone can still hangout with the whole community (rainemak, 16:49:40)
    6. <alsahio> and maybe try out these phones in hand. Make them experience (rainemak, 16:49:41)
    7. <alsahio> Sailfish OS and understand why these phones have a firm place (rainemak, 16:49:43)
    8. <alsahio> in the smartphone market. I think it could be a nice publicity (rainemak, 16:49:45)
    9. <alsahio> stunt, but it’s just an idea, maybe far fetched. Also, for (rainemak, 16:49:47)
    10. <alsahio> those who ordered the phone and got the ticket, are they (rainemak, 16:49:49)
    11. <alsahio> allowed to enter the event with a second person? Thank you (rainemak, 16:49:51)
    12. <alsahio> very much (rainemak, 16:49:55)
    13. <Jolla> Whatever happens before door opening is public for everybody. (rainemak, 16:49:57)
    14. <Jolla> Other than that, we're not making Jolla Phone Day1 celebration (rainemak, 16:49:59)
    15. <Jolla> event more public. (rainemak, 16:50:01)

  8. Open Pull Requests (PRs) to discussion (5 mins -- asked by Jolla) (rainemak, 16:55:32)
    1. https://github.com/sailfishos/pulseaudio/pull/10 (rainemak, 16:55:44)
    2. https://github.com/sailfishos/gst-plugins-bad/pull/12 (rainemak, 16:55:49)
    3. https://github.com/sailfishos/gst-plugins-bad/pull/13 (rainemak, 16:55:51)
    4. https://forum.sailfishos.org/t/5812/ (rainemak, 16:56:01)
    5. https://irclogs.sailfishos.org/logs/%23sailfishos/2026/%23sailfishos.2026-06-23.log.html (rainemak, 16:56:03)

  9. General discussion (15 mins) (rainemak, 17:08:43)
    1. https://www.youtube.com/shorts/7nvZxgxpPKc (rainemak, 17:18:19)
    2. https://www.youtube.com/shorts/6gW0XGtxhFg (rainemak, 17:18:37)
    3. https://www.youtube.com/shorts/pI9XajKLHOM (rainemak, 17:18:56)

  10. Next meeting time and date (2 mins) (rainemak, 17:24:54)
    1. Next meeting will be held on Thursday 16th July 2026 at 04:00pm UTC: 2026-07-16T1600Z (rainemak, 17:26:06)


Meeting ended at 17:26:28 UTC (full logs).

Action items

  1. Community task board
  2. Jolla to update regarding recommended charging cables and chargers.
  3. Jolla to add TOH category
  4. Jolla to add TOH category to Sailfish OS Forum


People present (lines said)

  1. rainemak (174)
  2. Polatbirdal (13)
  3. attah (10)
  4. CLMA31[m] (10)
  5. zhasha (9)
  6. extechop[m] (8)
  7. Keto (7)
  8. direc85[m] (4)
  9. AffeNull[m] (4)
  10. mal (4)
  11. duskull[m] (3)
  12. sailbot (2)
  13. ReturN900 (2)
  14. mettska (1)
  15. sebix[m] (1)
  16. alsahio (1)
  17. Venty[m] (1)


Generated by MeetBot 0.1.4.