#sailfishos-meeting: Sailfish OS, open source, collaboration -- 16th July 2026

Meeting started by rainemak at 16:00:26 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: (rainemak, 16:00:26)
    2. https://forum.sailfishos.org/t/30378 (rainemak, 16:00:26)

  1. Brief introduction (5 min). Please prefix your name/handle with #info (rainemak, 16:00:26)
    1. Raine Mäkeläinen, Jolla (rainemak, 16:00:28)
    2. nephros, community (nephros, 16:01:24)
    3. Nico, community (Nico, 16:02:30)
    4. emva, community (emva, 16:02:38)
    5. polat (Polatbirdal, 16:02:47)
    6. Pami Ketolainen, Jolla (Keto, 16:03:20)
    7. jan, community (blackei, 16:03:44)
    8. CLMA31, community (CLMA31[m], 16:05:25)

  2. Tracking of non-resolved Community Meeting topics (rainemak, 16:06:05)
    1. ACTION: Community task board (rainemak, 16:06:05)
    2. https://forum.sailfishos.org/t/community-meeting-on-23rd-april-2026/29030/3 (rainemak, 16:06:05)
    3. ACTION: Jolla to update regarding recommended charging cables and chargers. (rainemak, 16:06:05)
    4. https://forum.sailfishos.org/t/community-meeting-on-7th-may-2026/29253/2 (rainemak, 16:06:05)
    5. No actions taken yet regarding community task board nor charger / cables. (rainemak, 16:06:07)

  3. Development lang proliferation: Updated rust 1.85 & availbility of golang (10 mins -- b100dian) (rainemak, 16:06:26)
    1. <b100dian> I am sure that there are some apps that would soon require a (rainemak, 16:06:26)
    2. <b100dian> newer rust (would be nice if Wisperfish would make it to (rainemak, 16:06:26)
    3. <b100dian> store, wouldn’t it?) and one of these is librespot, the (rainemak, 16:06:26)
    4. <b100dian> spotify client. It has been a while since that stopped (rainemak, 16:06:26)
    5. <b100dian> working and the new code requires a newer rust. (rainemak, 16:06:28)
    6. <b100dian> In the same vein, there are other projects (such as netbird (rainemak, 16:06:30)
    7. <b100dian> wireguard networking) which are coded in go and they aren’t (rainemak, 16:06:32)
    8. <b100dian> easy to build on community OBS if golang is not available. (rainemak, 16:06:34)
    9. <b100dian> As someone who build dlang to be able to build a onedrive (rainemak, 16:06:36)
    10. <b100dian> client, I do not think I would be able to do that with two (rainemak, 16:06:38)
    11. <b100dian> more languages + runtimes & devtools and do that in a (rainemak, 16:06:40)
    12. <b100dian> sustainable way. (rainemak, 16:06:42)
    13. <b100dian> I hoped that 5.1 or 5.2 would bring at least the rust update (rainemak, 16:06:44)
    14. <b100dian> but there isn’t one… (rainemak, 16:06:46)
    15. <b100dian> Are there any plans to make these available? (rainemak, 16:06:48)
    16. <Jolla> Some backporting needed for Gecko ESR115 when updating Rust but (rainemak, 16:06:50)
    17. <Jolla> should be doable. Along with Sailfish OS 5.2 we didn't have time (rainemak, 16:06:54)
    18. <Jolla> to update Rust. There are already good point that could justify (rainemak, 16:06:56)
    19. <Jolla> Rust upgrade like Whisperfish or librespot but let's see how far (rainemak, 16:06:58)
    20. <Jolla> it goes. Contributions welcome. Go we have in quite a good shape (rainemak, 16:07:00)
    21. <Jolla> already. Do we have direc85 or rubdos around to comment (rainemak, 16:07:02)
    22. <Jolla> Whisperfish needs? (rainemak, 16:07:04)

  4. Sailfish for Feature Phones (10 mins -- Sharks) (rainemak, 16:15:13)
    1. <Sharks> With the announcement of the Commodore Callback there is (rainemak, 16:15:13)
    2. <Sharks> potentially a ‘new’ avenue for SFOS on feature phones. At (rainemak, 16:15:13)
    3. <Sharks> Mobile World Congress 2018, Sailfish was shown on a feature (rainemak, 16:15:13)
    4. <Sharks> phone, but we never heard any more about it until now. Given (rainemak, 16:15:13)
    5. <Sharks> the renewed interest, is it possible that we (the community) (rainemak, 16:15:15)
    6. <Sharks> may be able to port Sailfish to feature phones and use it (rainemak, 16:15:16)
    7. <Sharks> successfully soon™? Eg. a Nokia 8000 port was attempted a few (rainemak, 16:15:18)
    8. <Sharks> years ago (New Nokia 8000 4G port - feature phone UI?) but was (rainemak, 16:15:20)
    9. <Sharks> not able to be completed due to missing software (rainemak, 16:15:24)
    10. <Sharks> implementations for d-pad navigation, t9 typing etc. (rainemak, 16:15:26)
    11. <Sharks> I appreciate this is a late topic and I apologise, it was just (rainemak, 16:15:28)
    12. <Sharks> a thought that occured to me today. Please hold onto it for the (rainemak, 16:15:30)
    13. <Sharks> next meeting if required. (rainemak, 16:15:32)
    14. <Sharks> As before I would love to attend the meeting but I am unable (rainemak, 16:15:34)
    15. <Sharks> due to it occurring at 2AM my time, but I hope this topic may (rainemak, 16:15:36)
    16. <Sharks> generate some discussion if there are any other parties curious (rainemak, 16:15:38)
    17. <Sharks> about what you can tell us regarding the Commodore (rainemak, 16:15:40)
    18. <Sharks> implementation / collaboration. (rainemak, 16:15:42)
    19. https://forum.sailfishos.org/t/new-nokia-8000-4g-port-feature-phone-ui/19075 (rainemak, 16:15:44)
    20. <Jolla> Yes, intergrated platform features should eventually help with (rainemak, 16:15:46)
    21. <Jolla> feature phone porting as well. (rainemak, 16:15:48)

  5. Suggested update to online User Guide (10mins -- asked by jojomen) (rainemak, 16:21:20)
    1. <jojomen> This is more a heads-up than a question. (rainemak, 16:21:20)
    2. <jojomen> (rainemak, 16:21:20)
    3. <jojomen> Some questions to the Jolla Phone (rainemak, 16:21:20)
    4. <jojomen> Quick start guide (rainemak, 16:21:20)
    5. <jojomen> The url to a user guide http://jolla.com/phone/userguide leads (rainemak, 16:21:23)
    6. <jojomen> to a SailFishOS general description https://sailfishos.org/design/ux-framework (rainemak, 16:21:25)
    7. <jojomen> Not like a quick guide how to start up first time, buttons, (rainemak, 16:21:27)
    8. <jojomen> install SIM, charging, etc.. (rainemak, 16:21:29)
    9. <jojomen> (rainemak, 16:21:31)
    10. <jojomen> Adapted from post by @JacobLS here Jolla Phone Day1 (rainemak, 16:21:33)
    11. <jojomen> celebration event July 8 6pm at Narinkkatori! - practical info (rainemak, 16:21:35)
    12. <jojomen> & FAQ - #199 by JacobLS (rainemak, 16:21:37)
    13. <jojomen> (rainemak, 16:21:39)
    14. <jojomen> 1. The Home page screenshot there shows an app grid, not (rainemak, 16:21:41)
    15. <jojomen> covers for running apps. I’d suggest using a screenshot with (rainemak, 16:21:43)
    16. <jojomen> OSM Scout, Calendar, Media Player and other apps showcasing (rainemak, 16:21:45)
    17. <jojomen> Cover actions. Maybe include some well-known Android app just (rainemak, 16:21:47)
    18. <jojomen> to hint at the possibility? (rainemak, 16:21:49)
    19. <jojomen> 2. Maybe the App Grid description should mention pinning the (rainemak, 16:21:51)
    20. <jojomen> grid at less than full extension. (rainemak, 16:21:55)
    21. <jojomen> 3. Specifically for the JP2026, like Jacob noted in his post, (rainemak, 16:21:57)
    22. <jojomen> should there be a card in the box about installing SIM, (rainemak, 16:21:59)
    23. <jojomen> charging and first boot? (rainemak, 16:22:01)
    24. https://forum.sailfishos.org/t/jolla-phone-day1-celebration-event-july-8-6pm-at-narinkkatori-practical-info-faq/30183/199 (rainemak, 16:22:03)
    25. <Jolla> Thank you for raising this. (rainemak, 16:22:08)
    26. <Jolla> 1. Known / noted issue (rainemak, 16:22:10)
    27. <Jolla> 2. Good addition and rather handy (rainemak, 16:22:12)
    28. <Jolla> 3. Thanks for asking, people have been using phones quite a (rainemak, 16:22:14)
    29. <Jolla> while. Thus, we did not see a reason for this kind how-to. (rainemak, 16:22:16)

  6. Additional Ambiance controls (10mins -- asked by jojomen) (rainemak, 16:30:53)
    1. <jojomen> Currently, Ambiances can only control various sounds and the (rainemak, 16:30:53)
    2. <jojomen> background image used. I use the Situations app to also e.g. (rainemak, 16:30:53)
    3. <jojomen> turn on Flightmode when I select my “Going to the Theatre” (rainemak, 16:30:54)
    4. <jojomen> ambiance. This works, but is more convoluted than I’d like. (rainemak, 16:30:56)
    5. <jojomen> (rainemak, 16:30:58)
    6. <jojomen> Instead, I would like to add any combination of the toggles (rainemak, 16:31:00)
    7. <jojomen> that we can have in the top menu to an Ambiance. This would be (rainemak, 16:31:02)
    8. <jojomen> a logical extension to current functionality. (I’m not (rainemak, 16:31:04)
    9. <jojomen> suggesting putting all the features of Situations in the (rainemak, 16:31:06)
    10. <jojomen> Ambiance system, although I think closer integration would be (rainemak, 16:31:08)
    11. <jojomen> interesting.) (rainemak, 16:31:10)
    12. <jojomen> (rainemak, 16:31:12)
    13. <jojomen> Jolla, what do you think of such an extension to Ambiances? (rainemak, 16:31:14)
    14. <Jolla> We intentionally removed coupling to ringtones back in the days (rainemak, 16:31:16)
    15. <Jolla> after people got confused and didn't realize that ringtone (rainemak, 16:31:18)
    16. <Jolla> changed. This is far trickier problem than you can imagine from (rainemak, 16:31:20)
    17. <Jolla> the first glimpse. (rainemak, 16:31:24)

  7. The Privacy Switch in relation to Ambiances (15mins -- asked by jojomen) (rainemak, 16:43:15)
    1. <jojomen> There is currently a list of things the switch can control, (rainemak, 16:43:15)
    2. <jojomen> and we have an interesting discussion here The free (rainemak, 16:43:15)
    3. <jojomen> association Privacy Toggle thread . (rainemak, 16:43:15)
    4. <jojomen> (rainemak, 16:43:15)
    5. <jojomen> I foresee a growing list of options in the settings for the (rainemak, 16:43:17)
    6. <jojomen> Privacy switch, and an ever-growing list of requests for (rainemak, 16:43:18)
    7. <jojomen> options to add. The subset that makes it into the settings (rainemak, 16:43:20)
    8. <jojomen> will always be limited and a bit arbitrary. (rainemak, 16:43:24)
    9. <jojomen> (rainemak, 16:43:26)
    10. <jojomen> I think Ambiances provide a good foundation for the UI (rainemak, 16:43:28)
    11. <jojomen> connected to the Privacy Switch, even more so with the (rainemak, 16:43:30)
    12. <jojomen> extensions I discussed in the previous topic. (rainemak, 16:43:32)
    13. <jojomen> (rainemak, 16:43:34)
    14. <jojomen> My suggestion would be to (rainemak, 16:43:36)
    15. <jojomen> (rainemak, 16:43:38)
    16. <jojomen> 1. Make new top-menu toggles for things that aren’t already (rainemak, 16:43:40)
    17. <jojomen> (e.g. microphone?) (rainemak, 16:43:42)
    18. <jojomen> 2. Have a mode, where the Privacy switch is a shortcut for (rainemak, 16:43:44)
    19. <jojomen> any single top-menu toggle (rainemak, 16:43:46)
    20. <jojomen> 3. Have a mode, where the switch selects an Ambiance (and (rainemak, 16:43:48)
    21. <jojomen> returns to the previous ambience when the switch is (rainemak, 16:43:50)
    22. <jojomen> disengaged). Use the extended Ambiance system as UI to (rainemak, 16:43:54)
    23. <jojomen> control any combination of sounds and toggles. (In my example (rainemak, 16:43:56)
    24. <jojomen> above: silent+flightmode.) (rainemak, 16:43:58)
    25. <jojomen> 4. Have a mode, where a selected app receives signals when (rainemak, 16:44:00)
    26. <jojomen> the switch changes. Or broadcast these changes always (rainemak, 16:44:02)
    27. <jojomen> to anyone who listens. (E.g. Situations integration of (rainemak, 16:44:04)
    28. <jojomen> the Privacy Switch.) (rainemak, 16:44:06)
    29. <jojomen> (rainemak, 16:44:08)
    30. <jojomen> This way, Settings | Ambiances would provide a unified UI for (rainemak, 16:44:10)
    31. <jojomen> the more complex cases, and the Settings | Privacy Switch (rainemak, 16:44:12)
    32. <jojomen> would provide the UI for simple cases. (rainemak, 16:44:14)
    33. <jojomen> (rainemak, 16:44:16)
    34. <jojomen> It also would play well with the ideas you shared during the (rainemak, 16:44:18)
    35. <jojomen> Day1 event, where TOH controls the phone’s various modes of (rainemak, 16:44:20)
    36. <jojomen> operation. Use the Ambiance system as the UI for composing the (rainemak, 16:44:24)
    37. <jojomen> settings that make up a mode of operation, and let users (rainemak, 16:44:26)
    38. <jojomen> select the current mode by top menu, Privacy switch or TOH. (rainemak, 16:44:28)
    39. <jojomen> (rainemak, 16:44:30)
    40. <jojomen> edit: As a side note, I think Ambiances provide better (rainemak, 16:44:32)
    41. <jojomen> feedback than any of the small indicators at the top of the (rainemak, 16:44:34)
    42. <jojomen> Home screen. A quick glance immediately tells me if I’m still (rainemak, 16:44:36)
    43. <jojomen> in “Going to the Theatre” mode or not. (rainemak, 16:44:38)
    44. <jojomen> (rainemak, 16:44:40)
    45. <jojomen> Jolla, does this make sense to you? What would be the (rainemak, 16:44:42)
    46. <jojomen> challenges with this ide? (rainemak, 16:44:44)
    47. https://forum.sailfishos.org/t/the-free-association-privacy-toggle-thread/30620 (rainemak, 16:44:46)
    48. <Jolla> Thank for your ideas. Some brings added complexity which is (rainemak, 16:44:48)
    49. <Jolla> easily confusing. Let's have an open discussion on this and (rainemak, 16:44:50)
    50. <Jolla> we'll note this to the action board. (rainemak, 16:44:54)
    51. ACTION: The Privacy Switch in relation to Ambiances (rainemak, 16:44:56)
    52. https://forum.sailfishos.org/t/community-meeting-on-july-16-2026/30378/7 (rainemak, 16:44:58)

  8. Guidance for Jolla Phone Roadshow location scouting (5mins -- asked by nephros) (rainemak, 16:57:16)
    1. <nephros> The latest Community News ( Sailfish Community News, July 10, (rainemak, 16:57:16)
    2. <nephros> 2026 - Jolla Phone Day1) states that there are more events (rainemak, 16:57:16)
    3. <nephros> like JollaPhoneDay1 planned, with a call to community to help (rainemak, 16:57:16)
    4. <nephros> with organizing them. (rainemak, 16:57:16)
    5. <nephros> Please specify briefly what the characteristics of such event (rainemak, 16:57:17)
    6. <nephros> locations should be. How many people should the venue hold, (rainemak, 16:57:19)
    7. <nephros> what are infrastructure requirements, do you want a local (rainemak, 16:57:21)
    8. <nephros> event organizing firm or do you have your own, … (rainemak, 16:57:25)
    9. <nephros> (rainemak, 16:57:27)
    10. <nephros> An approximate Budget for renting a venue would also be very (rainemak, 16:57:29)
    11. <nephros> helpful - understandable if we won’t get that info from (rainemak, 16:57:31)
    12. <nephros> you :slight_smile: (rainemak, 16:57:33)
    13. https://forum.sailfishos.org/t/sailfish-community-news-july-10-2026-jolla-phone-day1/30490/33 (rainemak, 16:57:35)
    14. <Jolla> Thanks for asking. Did we said that that Jolla Phone Day1 like (rainemak, 16:57:38)
    15. <Jolla> events? If so that is a mistake. Hmm, more like Jolla Phone (rainemak, 16:57:40)
    16. <Jolla> roadshow not really launch party which happens to be the first (rainemak, 16:57:42)
    17. <Jolla> event. Events should be lighter than Day1 event otherwise it (rainemak, 16:57:44)
    18. <Jolla> gets too heavy to organize. More like usual Community events (rainemak, 16:57:46)
    19. <Jolla> with Jolla Phone roadshow twist. For example, no need for (rainemak, 16:57:48)
    20. <Jolla> streaming, food can be self ordered, not necessarily need for (rainemak, 16:57:50)
    21. <Jolla> drink / snack tickets, etc. Something reachable where people can (rainemak, 16:57:54)
    22. <Jolla> easily join and discuss with each other and share ideas. (rainemak, 16:57:56)

  9. Is it possible to change the color selection after placing the order? (3mins -- asked by Polatbirdal) (rainemak, 17:08:20)
    1. <Polatbirdal> I chose the orange silicone case for my order, but I’ve (rainemak, 17:08:20)
    2. <Polatbirdal> changed my mind and would like to switch it to the black #info <Polatbirdal> one instead. Is that possible? I can’t find any option to (rainemak, 17:08:20)
    3. <Polatbirdal> change it on the website. (rainemak, 17:08:20)
    4. <Jolla> Yes, but not recommended and we may miss your question. Think (rainemak, 17:08:21)
    5. <Jolla> twice when selecting your colour. (rainemak, 17:08:25)

  10. CAD model of TOHs (3min -- asked by Nico) (rainemak, 17:17:05)
    1. <Nico> While some measurements exist in the official documentation, it (rainemak, 17:17:05)
    2. <Nico> would be great to have a CAD model of the new other half (for 3d (rainemak, 17:17:05)
    3. <Nico> printing and starting point for custom designs). Additionally a (rainemak, 17:17:05)
    4. <Nico> model of the phone backside with the pogo pins could be useful (rainemak, 17:17:05)
    5. <Nico> to model mating the pins properly. Could those be shared (rainemak, 17:17:07)
    6. <Nico> somewhat soon, so that we can start having fun with that? (rainemak, 17:17:08)
    7. <Jolla> Coming as well. Haven't had time yet but soon^TM. (rainemak, 17:17:10)
    8. ACTION: Can Jolla provide both .step and .stl files for CAD models? (rainemak, 17:20:03)

  11. Open Pull Requests (PRs) to discussion (5 mins -- asked by Jolla) (rainemak, 17:22:34)
  12. General discussion (15 mins) (rainemak, 17:24:06)
  13. Next meeting time and date (2 mins) (rainemak, 17:37:28)
    1. Next something (meeting / newsletter) will be held on Thursday 13th August 2026 at 04:00pm UTC: 2026-08-13T1600Z (rainemak, 17:41:15)


Meeting ended at 17:43:12 UTC (full logs).

Action items

  1. Community task board
  2. Jolla to update regarding recommended charging cables and chargers.
  3. The Privacy Switch in relation to Ambiances
  4. Can Jolla provide both .step and .stl files for CAD models?


People present (lines said)

  1. rainemak (291)
  2. nephros (35)
  3. CLMA31[m] (25)
  4. Polatbirdal (18)
  5. Keto (12)
  6. Nico (4)
  7. sailbot (2)
  8. emva (1)
  9. blackei (1)


Generated by MeetBot 0.1.4.