#sailfishos-meeting: Sailfish OS, open source, collaboration -- 3rd September 2026

Meeting started by rainemak at 16:00:19 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: (rainemak, 16:00:19)
    2. https://forum.sailfishos.org/t/32224 (rainemak, 16:00:19)

  1. Brief introduction (5 min). Please prefix your name/handle with #info (rainemak, 16:00:19)
    1. Raine Mäkeläinen, Jolla (rainemak, 16:00:21)
    2. Ruben De Smet - rubdos - community (rubdos[m], 16:00:43)
    3. Julio Meroño (jmerono) - community (jmerono, 16:01:06)
    4. Andrew Branson - Jolla (abr, 16:01:35)
    5. Juhani Virtanen (renTTu) - community (renTTu, 16:01:44)
    6. CLMA31, community (CLMA31[m], 16:02:17)
    7. : Cryx - community (Cryx[m], 16:02:22)
    8. mal, Jolla (mal, 16:02:38)
    9. Anton Thomasson - community (attah, 16:03:11)
    10. Pami Ketolainen, Jolla (Keto, 16:03:44)
    11. Certina - community (Certina, 16:05:31)

  2. Tracking of non-resolved Community Meeting topics (rainemak, 16:05:36)
    1. ACTION: Community task board (rainemak, 16:05:36)
    2. https://forum.sailfishos.org/t/community-meeting-on-23rd-april-2026/29030/3 (rainemak, 16:05:36)
    3. ACTION: Jolla to update regarding recommended charging cables and chargers. (rainemak, 16:05:36)
    4. https://forum.sailfishos.org/t/community-meeting-on-7th-may-2026/29253/2 (rainemak, 16:05:37)
    5. ACTION: The Privacy Switch in relation to Ambiances (rainemak, 16:05:38)
    6. https://forum.sailfishos.org/t/community-meeting-on-july-16-2026/30378/7 (rainemak, 16:05:40)
    7. No actions taken yet regarding community task board nor charger / cables. (rainemak, 16:05:42)

  3. AppSupport on other community ports (particularly on the Xperia 1 and 5 IV) (5 mins -- @jmerono) (rainemak, 16:06:54)
    1. <jmerono> Following what was mentioned in the previous community meeting (rainemak, 16:06:55)
    2. <jmerono> regarding the Xperia 10 IV and V, I wondered if there were any (rainemak, 16:06:55)
    3. <jmerono> plans to extend that to other well-supported ports (like on (rainemak, 16:06:55)
    4. <jmerono> @rinigus‘s Nagara ports). If so, I understand the team may be (rainemak, 16:06:55)
    5. <jmerono> busy with the JP2026 among other things, but may we have an (rainemak, 16:06:58)
    6. <jmerono> estimate of when we will have it? (rainemak, 16:07:00)
    7. <Jolla> Let us start with Xperia 10 IV and 10 V (surely jointly with (rainemak, 16:07:02)
    8. <Jolla> Sharks and others). Once we have AppSupport working with 10 IV (rainemak, 16:07:04)
    9. <Jolla> and 10 V we certainly know more. After reaching that target, we (rainemak, 16:07:06)
    10. <Jolla> have more solid ground to start planning how to expand or (rainemak, 16:07:08)
    11. <Jolla> whether to expand. (rainemak, 16:07:10)

  4. OBS dependencies in tooling/chroot (10 mins -- rubdos / Ruben De Smet) (rainemak, 16:17:08)
    1. <rubdos> To build Whisperfish, we often require a version of Rust and (rainemak, 16:17:08)
    2. <rubdos> LLVM that leads the version provided by Jolla. I build and host (rainemak, 16:17:08)
    3. <rubdos> these packages on my home server, such that our CI system can (rainemak, 16:17:08)
    4. <rubdos> build them, and the resulting RPMs end up on OpenRepos. I’d (rainemak, 16:17:08)
    5. <rubdos> like to offer Whisperfish on Chum, however. This means we’d (rainemak, 16:17:09)
    6. <rubdos> need to compile Rust/LLVM on Chum, such that I can build-depend (rainemak, 16:17:11)
    7. <rubdos> on them. However, Rust builds through an sb2 shim, which means (rainemak, 16:17:13)
    8. <rubdos> that the actual rustc and cargo dependencies need to be (rainemak, 16:17:15)
    9. <rubdos> available in the tooling and even in the chroot. See our (rainemak, 16:17:17)
    10. <rubdos> Dockerfile for exact prereqs. As far as I understand, this is (rainemak, 16:17:19)
    11. <rubdos> not currently possible to specify in OBS. More context at Show (rainemak, 16:17:21)
    12. <rubdos> home:rubdos:whisperfish / Rust - SailfishOS Open Build Service (rainemak, 16:17:23)
    13. <rubdos> and Show home:rubdos:whisperfish / llvm - SailfishOS Open Build (rainemak, 16:17:25)
    14. <rubdos> Service. Would it be possible to get some help to get this (rainemak, 16:17:29)
    15. <rubdos> going? I’m not entirely sure whether I can hack this in myself, (rainemak, 16:17:31)
    16. <rubdos> or whether I need Jolla’s or the community’s help on this. (rainemak, 16:17:33)
    17. https://gitlab.com/whisperfish/sailo-rs/-/blob/master/Dockerfile.rust?ref_type=heads (rainemak, 16:17:35)
    18. https://build.sailfishos.org/package/show/home:rubdos:whisperfish/Rust (rainemak, 16:17:37)
    19. https://build.sailfishos.org/package/show/home:rubdos:whisperfish/llvm (rainemak, 16:17:39)
    20. <Jolla> Thank you for asking. We do have Rust 1.95 and LLVM 20 PRs (rainemak, 16:17:41)
    21. <Jolla> ready. That should help with Whisperfish development for some (rainemak, 16:17:43)
    22. <Jolla> time. There should be room to bump up Rust to 1.97.1 and LLVM to (rainemak, 16:17:45)
    23. <Jolla> 22.1.8. Surely, this does not solve generic OBS issue that you (rainemak, 16:17:47)
    24. <Jolla> are referring to. When we reach up-to-date Gecko ESR version (rainemak, 16:17:49)
    25. <Jolla> that should also help us all to keep Rust and LLVM up-to-date as (rainemak, 16:17:51)
    26. <Jolla> well and serving better Whisperfish development needs. (rainemak, 16:17:53)

  5. Murray and Zambezi community ports - what are the next steps for AppSupport? (10mins -- asked by Sharks) (rainemak, 16:30:58)
    1. <Sharks> We are all very excited at the announcement from the previous (rainemak, 16:30:58)
    2. <Sharks> community meeting regarding Jolla’s confirmation that (rainemak, 16:30:58)
    3. <Sharks> AppSupport for the community ports for Xperia 10IV and V is (rainemak, 16:30:59)
    4. <Sharks> still on the cards. As the port maintainer, I would like to (rainemak, 16:31:01)
    5. <Sharks> know what is required of me to ensure that AppSupport for this (rainemak, 16:31:03)
    6. <Sharks> port can be delivered to users as soon as possible. Initial (rainemak, 16:31:05)
    7. <Sharks> testing from users shows the existing AppSupport binaries do (rainemak, 16:31:07)
    8. <Sharks> not work out of the box currently. Given we know community (rainemak, 16:31:09)
    9. <Sharks> ports have been able to run AppSupport binaries in the past (rainemak, 16:31:11)
    10. <Sharks> (see: Nagara) is this a port-specific problem (eg. something I (rainemak, 16:31:13)
    11. <Sharks> haven’t done right like kernel configs), or a Jolla-side (rainemak, 16:31:15)
    12. <Sharks> problem (AppSupport binaries need updating to be compatible (rainemak, 16:31:17)
    13. <Sharks> with Android 15 base)? Is there a preferred way to open a line (rainemak, 16:31:19)
    14. <Sharks> of dialogue on this topic between myself / any other willing (rainemak, 16:31:21)
    15. <Sharks> community developer(s) and Jolla so that we can work towards a (rainemak, 16:31:23)
    16. <Sharks> functioning solution? Noting that I live on the wrong side of (rainemak, 16:31:25)
    17. <Sharks> the world (GMT+10) and have a day job. (rainemak, 16:31:29)
    18. <Jolla> Likely next steps for AppSupport is that we first adapt (rainemak, 16:31:31)
    19. <Jolla> AppSupport 15 to Jolla C2. Let's see who do we have from Jolla (rainemak, 16:31:33)
    20. <Jolla> team to comment on more technical parts of this. (rainemak, 16:31:35)

  6. Official Xperia 10 IV/V Jolla Ports: Latest internal tests based on which blobs, how far from feature complete, can we help get it done? (5 mins -- asked by @yusssufff) (rainemak, 16:39:40)
    1. <yusssufff> I know that some community ports are being developped. (rainemak, 16:39:40)
    2. <yusssufff> Nevertheless, I am personally very keep on offical ports, (rainemak, 16:39:40)
    3. <yusssufff> especially as I prefer to entrust @jolla for coding such (rainemak, 16:39:40)
    4. <yusssufff> sensitive software. (rainemak, 16:39:40)
    5. <yusssufff> A company is a liability. (rainemak, 16:39:42)
    6. <yusssufff> (rainemak, 16:39:44)
    7. <yusssufff> Therefore I wished to know how far did went the latest tests (rainemak, 16:39:46)
    8. <yusssufff> @mal and @jolla did with the 10 V. About a year ago @mal (rainemak, 16:39:48)
    9. <yusssufff> mentionned camera and audio finally working against ‘‘latest (rainemak, 16:39:50)
    10. <yusssufff> blobs’’, that fingerprint was to be skipped, and that VoLTE (rainemak, 16:39:52)
    11. <yusssufff> had new configs that came along with the new blobs and that (rainemak, 16:39:54)
    12. <yusssufff> it was now a hard nut to crack… (rainemak, 16:39:58)
    13. <yusssufff> (rainemak, 16:40:00)
    14. <yusssufff> I wish to know which ‘latest’ blobs specifically were used (rainemak, 16:40:02)
    15. <yusssufff> back then, and how much work is still missing (sure giving (rainemak, 16:40:04)
    16. <yusssufff> up on fingerprint, that’s a given) to get it all mostly set (rainemak, 16:40:06)
    17. <yusssufff> up (only volte left to work on?). Could community help crack (rainemak, 16:40:08)
    18. <yusssufff> this nut, if you share with us the exact piece of work still (rainemak, 16:40:10)
    19. <yusssufff> needed to be achieved? (rainemak, 16:40:12)
    20. <yusssufff> Would be so lovely to get the last push for that official (rainemak, 16:40:14)
    21. <yusssufff> Xperia port :blush:. (rainemak, 16:40:16)
    22. <Jolla> The official Jolla ports for 10 IV and 10 V were left pretty (rainemak, 16:40:18)
    23. <Jolla> much to state we communicated earlier. If mal is around, he (rainemak, 16:40:20)
    24. <Jolla> could comment more. (rainemak, 16:40:22)

  7. Sound/microphone issue with audio/video recordings. (5 mins -- asked by Cryx) (rainemak, 16:45:54)
    1. <Cryx> sound in audio and video recordings is very bad, details get (rainemak, 16:45:54)
    2. <Cryx> lost. This may be related to a possible noise cancellation (rainemak, 16:45:54)
    3. <Cryx> process what is good for calls, but very bad for recordings with (rainemak, 16:45:54)
    4. <Cryx> camera or audiorecorder. See some more details in the linked (rainemak, 16:45:54)
    5. <Cryx> thread below. (rainemak, 16:45:55)
    6. <Cryx> (rainemak, 16:45:59)
    7. <Cryx> What’s the reason for that, is there a possible solution that can (rainemak, 16:46:01)
    8. <Cryx> be implemented like disabeling noise cancellation (if that’s the (rainemak, 16:46:03)
    9. <Cryx> reason) for recordings, maybe even with a toggle in camera and (rainemak, 16:46:05)
    10. <Cryx> audiorecorder or their settings? (rainemak, 16:46:07)
    11. https://forum.sailfishos.org/t/very-bad-sound-in-recordings-from-jolla-phone-2026/32800 (rainemak, 16:46:09)
    12. <Jolla> Thank you for asking. Needs more investigation. Let's have open (rainemak, 16:46:11)
    13. <Jolla> discussion. (rainemak, 16:46:13)

  8. The Jolla phone 2026 screen may not have a software problem. (10 mins -- asked by Polatbirdal) (rainemak, 16:55:19)
    1. <Polatbirdal> Hello, this issue was also discussed on August 20, but the (rainemak, 16:55:19)
    2. <Polatbirdal> exact cause still hadn’t been properly investigated. After (rainemak, 16:55:19)
    3. <Polatbirdal> that meeting, some people opened new threads, and we came (rainemak, 16:55:19)
    4. <Polatbirdal> across some interesting information. (rainemak, 16:55:19)
    5. <Polatbirdal> (rainemak, 16:55:21)
    6. <Polatbirdal> Some people who bought the Jolla Phone 2026 were able to (rainemak, 16:55:23)
    7. <Polatbirdal> pass every screen color test without any issues at all. (rainemak, 16:55:25)
    8. <Polatbirdal> However, others experienced problems regardless of which (rainemak, 16:55:29)
    9. <Polatbirdal> color test they ran. Some described it as looking like a (rainemak, 16:55:31)
    10. <Polatbirdal> “Mexico filter,” while others saw a shadowy green tint (rainemak, 16:55:33)
    11. <Polatbirdal> appearing over black areas, or shading near the very top (rainemak, 16:55:35)
    12. <Polatbirdal> of the screen with orange and red colors. (rainemak, 16:55:37)
    13. <Polatbirdal> (rainemak, 16:55:39)
    14. <Polatbirdal> At first, before we had this kind of evidence, most people (rainemak, 16:55:41)
    15. <Polatbirdal> thought the issue was software-related. But now that some (rainemak, 16:55:43)
    16. <Polatbirdal> users experience it while others don’t experience it at (rainemak, 16:55:45)
    17. <Polatbirdal> all, it has made the issue even more interesting and (rainemak, 16:55:47)
    18. <Polatbirdal> raised more questions. (rainemak, 16:55:49)
    19. <Polatbirdal> (rainemak, 16:55:51)
    20. <Polatbirdal> Has any further investigation been done on this? At this (rainemak, 16:55:53)
    21. <Polatbirdal> point, it doesn’t really seem like a software-related (rainemak, 16:55:55)
    22. <Polatbirdal> issue anymore. (rainemak, 16:55:59)
    23. <Jolla> If there are hardware defects, those are covered by warranty. (rainemak, 16:56:01)
    24. <Jolla> Whether you have a hardware defect that is another story. (rainemak, 16:56:03)
    25. https://forum.sailfishos.org/t/display-is-not-colour-managed-vendor-srgb-colour-mode-exists-but-sailfish-never-selects-it/31537 (rainemak, 17:01:41)

  9. Camera Quality and resolution of new Jolla Phone (10 mins -- asked by Cryx) (rainemak, 17:10:08)
    1. <Cryx> The forum starts to discuss about the capabilities and problems (rainemak, 17:10:08)
    2. <Cryx> with the camera. One point is the resolution of pictures taken (rainemak, 17:10:08)
    3. <Cryx> with the native SFOS camera that just seems to use half of the (rainemak, 17:10:08)
    4. <Cryx> possible resolution compared to Advanced Camera or even Android (rainemak, 17:10:08)
    5. <Cryx> camera apps. (rainemak, 17:10:09)
    6. <Cryx> (rainemak, 17:10:11)
    7. <Cryx> SFOS has a max of 4096 with both back cameras, while Advanced (rainemak, 17:10:13)
    8. <Cryx> Camera has a max 4096 and 8192 for the different back cameras. (rainemak, 17:10:15)
    9. <Cryx> (rainemak, 17:10:17)
    10. <Cryx> Front camera resoltion is a little bit more then double with (rainemak, 17:10:19)
    11. <Cryx> Advanced camera compared to SFOS stock camera. (rainemak, 17:10:21)
    12. <Cryx> (rainemak, 17:10:23)
    13. <Cryx> Also the max video resolution is 1440 in all apps - but as the (rainemak, 17:10:25)
    14. <Cryx> camera module is/was also used in Sony’s Xperia Range (if we got (rainemak, 17:10:29)
    15. <Cryx> that right) and capable of recording 4k videos even with an (rainemak, 17:10:31)
    16. <Cryx> Xperia 10 III it should be possible to do 4k videos on the much (rainemak, 17:10:33)
    17. <Cryx> better hardware of the new Jolla Phone too. (rainemak, 17:10:35)
    18. <Cryx> (rainemak, 17:10:37)
    19. <Cryx> Some dome concrete questions: (rainemak, 17:10:39)
    20. <Cryx> (rainemak, 17:10:41)
    21. <Cryx> - Why does the SFOS camera app not use the max resolution for the main (1.0) camera? (rainemak, 17:10:43)
    22. <Cryx> - Is the Jolla Phone capable to take 4K videos from the hardware (rainemak, 17:10:46)
    23. <Cryx> side (especially camera modules and processor)? If yes, what (rainemak, 17:10:48)
    24. <Cryx> must be done to enable this? (rainemak, 17:10:50)
    25. <Cryx> - We had filters on other devices (that were still in Xperia 10 (rainemak, 17:10:52)
    26. <Cryx> III but not working) and now are completely missing on the new (rainemak, 17:10:54)
    27. <Cryx> Jolla Phone. Are there plans to bring that feature back with a (rainemak, 17:10:58)
    28. <Cryx> future update? (rainemak, 17:11:00)
    29. <Cryx> - Several people notice a fisheye effect especially with the (rainemak, 17:11:02)
    30. <Cryx> (0.5) camera in 4:3. Listening to some people this is caused by (rainemak, 17:11:04)
    31. <Cryx> the picture processing. Is there a plan to improve that (maybe (rainemak, 17:11:06)
    32. <Cryx> with Camera API 2 (if I’m right even the new Jolla Phone still (rainemak, 17:11:08)
    33. <Cryx> uses API 1)? (rainemak, 17:11:10)
    34. <Jolla> Thank you asking. We opened Camera app wishlist on January and (rainemak, 17:11:36)
    35. <Jolla> Camera app itself has been open for quite some time already. (rainemak, 17:11:36)
    36. <Jolla> Contributions welcome ;-). (rainemak, 17:11:36)
    37. https://forum.sailfishos.org/t/sailfish-camera-app-wishlist/24497 (rainemak, 17:11:36)
    38. <Jolla> In all seriousness, we all want to get improvements to Camera (rainemak, 17:11:36)
    39. <Jolla> app. Firstly, we need a fix for the max resolution. Further, (rainemak, 17:11:37)
    40. <Jolla> we should have more selections for resolution setting. Also (rainemak, 17:11:39)
    41. <Jolla> people tend to understand megapixels so there could be an easy (rainemak, 17:11:41)
    42. <Jolla> way to select image quality. Maybe nowadays selecting lower (rainemak, 17:11:43)
    43. <Jolla> image quality due to storage usage is not that big of issue but (rainemak, 17:11:45)
    44. <Jolla> there can be other factors like capturing speed that needs to be (rainemak, 17:11:47)
    45. <Jolla> taken into account. (rainemak, 17:11:49)

  10. Open Pull Requests (PRs) to discussion (5 mins -- asked by Jolla) (rainemak, 17:25:07)
    1. https://forum.sailfishos.org/t/jolla-phone-camera-too-many-details-are-lost/32717/35?u=polatbirdal hedgecam vs default camera (Polatbirdal, 17:27:25)

  11. General discussion (10 mins) (rainemak, 17:31:11)
    1. https://forum.sailfishos.org/t/jolla-phone-camera-too-many-details-are-lost/32717/35 (rainemak, 17:31:39)

  12. Next meeting time and date (2 mins) (rainemak, 17:48:06)
    1. Next meeting will be held on Thursday 17th September 2026 at 04:00pm UTC: 2026-09-17T1600Z (rainemak, 17:49:00)


Meeting ended at 17:49:28 UTC (full logs).

Action items

  1. Community task board
  2. Jolla to update regarding recommended charging cables and chargers.
  3. The Privacy Switch in relation to Ambiances


People present (lines said)

  1. rainemak (246)
  2. rubdos[m] (48)
  3. Polatbirdal (31)
  4. mal (23)
  5. Cryx[m] (15)
  6. abr (13)
  7. CLMA31[m] (12)
  8. jmerono (6)
  9. sailbot (2)
  10. attah (2)
  11. renTTu (1)
  12. Keto (1)
  13. Certina (1)
  14. rubdos_ (1)


Generated by MeetBot 0.1.4.