#sailfishos-meeting: Sailfish OS, open source, collaboration -- October 1, 2026

Meeting started by Keto at 16:00:03 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: (rainemak, 16:00:18)
    2. https://forum.sailfishos.org/t/33735 (rainemak, 16:00:19)
    3. Otto Mäkelä, community (extechop[m], 16:00:45)
    4. Raine Mäkeläinen, Jolla (rainemak, 16:00:50)
    5. pherjung, community (pherjung[m], 16:00:55)
    6. Michal Kasík, community, Jolla Phone 2026 user (MiPal75, 16:01:07)
    7. Pami Ketolainen, Jolla (Keto, 16:01:27)
    8. Nico, community (Nico, 16:02:43)
    9. Andrew Branson, sailing by (abr, 16:03:45)
    10. ACTION: Community task board (rainemak, 16:05:10)
    11. https://forum.sailfishos.org/t/community-meeting-on-23rd-april-2026/29030/3 (rainemak, 16:05:10)
    12. ACTION: Jolla to update regarding recommended charging cables and chargers. (rainemak, 16:05:10)
    13. https://forum.sailfishos.org/t/community-meeting-on-7th-may-2026/29253/2 (rainemak, 16:05:10)
    14. ACTION: The Privacy Switch in relation to Ambiances (rainemak, 16:05:13)
    15. https://forum.sailfishos.org/t/community-meeting-on-july-16-2026/30378/7 (rainemak, 16:05:15)
    16. No actions taken yet regarding community task board nor charger / cables. (rainemak, 16:05:17)

  1. Quick app switching gesture (5 mins -- jojomen) (Keto, 16:07:47)
    1. <jojomen> The Quick App Switching gesture works really well and I find (rainemak, 16:09:02)
    2. <jojomen> it essential in my everyday phone usage. Apparently, I’m not (rainemak, 16:09:02)
    3. <jojomen> alone in this: Switching between 2 apps more easilly (eg (rainemak, 16:09:02)
    4. <jojomen> password manager) (rainemak, 16:09:02)
    5. <jojomen> (rainemak, 16:09:02)
    6. <jojomen> Edit: This has also been frequently requested by many new (rainemak, 16:09:04)
    7. <jojomen> members brought here by the Jolla Phone. (rainemak, 16:09:05)
    8. <jojomen> (rainemak, 16:09:07)
    9. <jojomen> However, to enable the gesture one has to issue a dconf (rainemak, 16:09:09)
    10. <jojomen> command in the terminal. Please, could we have a toggle for (rainemak, 16:09:13)
    11. <jojomen> this gesture in the Settings app, section Gestures? (rainemak, 16:09:15)
    12. <jojomen> (rainemak, 16:09:17)
    13. <jojomen> (It can also be set from the pulley menu of the Edge Swipe (rainemak, 16:09:19)
    14. <jojomen> Control app by @nephros, but it is still pretty hidden.) (rainemak, 16:09:21)
    15. <Jolla> Yes, we should have hidden used configuration values visible (rainemak, 16:09:23)
    16. <Jolla> somewhere. Not a high priority item thou. (rainemak, 16:09:25)
    17. nephros, community, observing... (nephros, 16:09:46)
    18. ACTION: Jolla to create sailfish-settings-labs (rainemak, 16:23:11)

  2. Harbour policy: allowing a bundled helper executable (10 mins -- muhnschein) (Keto, 16:23:33)
    1. <muhnschein> Harbour only allows ELF files at /usr/bin/<NAME> or as .so (rainemak, 16:23:46)
    2. <muhnschein> libraries under /usr/share/<NAME>/lib/. This blocks apps (rainemak, 16:23:46)
    3. <muhnschein> like Piirit that bundle an upstream helper binary and run (rainemak, 16:23:46)
    4. <muhnschein> it as a subprocess. There are many legitimate use cases for (rainemak, 16:23:46)
    5. <muhnschein> this. (rainemak, 16:23:46)
    6. <muhnschein> (rainemak, 16:23:48)
    7. <muhnschein> Proposal: allow ELF executables in an app-private directory (rainemak, 16:23:49)
    8. <muhnschein> (e.g. /usr/libexec/<NAME>/), under the same conditions as (rainemak, 16:23:51)
    9. <muhnschein> the main binary (no setuid/setgid, no group/world-writable (rainemak, 16:23:53)
    10. <muhnschein> modes, dynamic libraries on the allow-list). (rainemak, 16:23:55)
    11. <muhnschein> (rainemak, 16:23:57)
    12. <muhnschein> More context: Harbour policy: allowing a bundled helper (rainemak, 16:23:59)
    13. <muhnschein> executable (re Piirit). (rainemak, 16:24:01)
    14. https://forum.sailfishos.org/t/33807 (rainemak, 16:24:03)
    15. <Jolla> Open discussion on this. (rainemak, 16:24:05)
    16. ACTION: Iron out bundled helper executable (https://forum.sailfishos.org/t/community-meeting-on-october-1-2026/33735/4) (rainemak, 16:33:43)

  3. Touchscreen nearby taps detected as drag gesture (bug?) (5mins -- asked by nicov84) (Keto, 16:34:18)
    1. <nicov84> As per BUG report by @HtheB, the touchscreen seems to detect (rainemak, 16:34:33)
    2. <nicov84> subsequent, close distance taps as drags. This causes some (rainemak, 16:34:33)
    3. <nicov84> apps (standard keyboard, futo keyboard) to misbehave. (rainemak, 16:34:33)
    4. <nicov84> For the standard keyboard, this results in sudden layout (rainemak, 16:34:33)
    5. <nicov84> changes. For futo, in problematic swiping and typos. (rainemak, 16:34:33)
    6. <nicov84> Is this a hardware issue or can the sensitivity/behavior be (rainemak, 16:34:34)
    7. <nicov84> tuned in software? (rainemak, 16:34:36)
    8. <nicov84> Two near-simultaneous taps with different fingers are (rainemak, 16:34:38)
    9. <nicov84> delivered as a single touch point dragging between them (rainemak, 16:34:40)
    10. https://forum.sailfishos.org/t/33237 (rainemak, 16:34:44)
    11. <Jolla> This is more like a bug report. Not much to discuss. (rainemak, 16:34:54)
    12. <Jolla> Doubt that two different fingers are treated as a single touch (rainemak, 16:34:54)
    13. <Jolla> point. Gesture it could probably trigger. Impossible to comment (rainemak, 16:34:54)
    14. <Jolla> about a single use case / error. We'll note this to internal (rainemak, 16:34:55)
    15. <Jolla> issue tracker. (rainemak, 16:34:56)
    16. ACTION: Issue to be reported (rainemak, 16:37:42)

  4. Visibility of spare parts for the Jolla Phone at commerce.jolla.com (5 mins -- asked by jojomen) (Keto, 16:41:23)
    1. <jojomen> I didn’t find the spare parts in the new shop and assumed they (rainemak, 16:41:40)
    2. <jojomen> were just not available yet. But then I stumbled upon this (rainemak, 16:41:40)
    3. <jojomen> comment Are the Jolla phones not shipping to the USA? - #26 by (rainemak, 16:41:40)
    4. <jojomen> makrolon, where it turns out they are just a bit hidden. (rainemak, 16:41:42)
    5. <jojomen> (rainemak, 16:41:43)
    6. <jojomen> Could we have all items visible by default in the online shop, (rainemak, 16:41:45)
    7. <jojomen> please? Or, if that would be too cluttered, at least a clearly (rainemak, 16:41:47)
    8. <jojomen> visible option to show the different categories/collections (rainemak, 16:41:49)
    9. <jojomen> you have defined. (rainemak, 16:41:51)
    10. <jojomen> (rainemak, 16:41:53)
    11. <jojomen> more comments and suggestions: Are the Jolla phones not (rainemak, 16:41:56)
    12. <jojomen> shipping to the USA? - #27 by teleshoes. (rainemak, 16:41:57)
    13. https://forum.sailfishos.org/t/are-the-jolla-phones-not-shipping-to-the-usa/28756/26 (rainemak, 16:41:59)
    14. https://commerce.jolla.com/collections/jolla-phone-accessories (rainemak, 16:42:01)
    15. <Jolla> Know improvement topic. Noted. (rainemak, 16:42:03)

  5. Jolla Store: Fix screenshot presentation (5 mins -- asked by muhnschein) (Keto, 16:43:30)
    1. <muhnschein> Jolla Store seems to crop screenshots submitted via (rainemak, 16:43:49)
    2. <muhnschein> Harbour. Without having measured them, these seem like the (rainemak, 16:43:49)
    3. <muhnschein> screen dimensions of the original Jolla Phone. Screenshots (rainemak, 16:43:49)
    4. <muhnschein> with other dimensions are cropped so that top and bottom (rainemak, 16:43:49)
    5. <muhnschein> are missing. (rainemak, 16:43:49)
    6. <muhnschein> (rainemak, 16:43:50)
    7. <muhnschein> While some work around this with letterboxing, this is (rainemak, 16:43:52)
    8. <muhnschein> evident in most of the apps recently added to the store: (rainemak, 16:43:54)
    9. <muhnschein> (rainemak, 16:43:56)
    10. <muhnschein> Sail Prompt (rainemak, 16:43:58)
    11. <muhnschein> Straps (rainemak, 16:44:00)
    12. <muhnschein> Cookbook (rainemak, 16:44:02)
    13. <muhnschein> Radar (Find my Device) (rainemak, 16:44:04)
    14. <muhnschein> BitSailor (rainemak, 16:44:06)
    15. <muhnschein> Meliona (rainemak, 16:44:08)
    16. <muhnschein> Frostlife (rainemak, 16:44:12)
    17. <muhnschein> Sailstream for Plex (rainemak, 16:44:14)
    18. <muhnschein> (rainemak, 16:44:16)
    19. <muhnschein> This is neither mentioned in the Harbour interface nor (rainemak, 16:44:18)
    20. <muhnschein> strictly necessary - and rather unfortunate for the (rainemak, 16:44:20)
    21. <muhnschein> developers. (rainemak, 16:44:22)
    22. <muhnschein> (rainemak, 16:44:24)
    23. <muhnschein> I’m kindly asking for this to be fixed and hope that this (rainemak, 16:44:26)
    24. <muhnschein> is the right place. (rainemak, 16:44:28)
    25. <Jolla> Thank you for raising this one. We'll create an internal issue. (rainemak, 16:44:30)

  6. Android App Support: PIN Code and Authentication Issues (10 mins -- asked by MikkoTenhunen) (Keto, 16:49:37)
    1. <MikkoTenhunen> Many Android applications that rely on secure (rainemak, 16:50:23)
    2. <MikkoTenhunen> authentication methods appear to have problems inside (rainemak, 16:50:23)
    3. <MikkoTenhunen> Sailfish OS Android App Support. I would like to know (rainemak, 16:50:23)
    4. <MikkoTenhunen> whether Jolla has made progress on fixing Android PIN (rainemak, 16:50:23)
    5. <MikkoTenhunen> code, biometric authentication, and secure credential (rainemak, 16:50:23)
    6. <MikkoTenhunen> storage related issues. (rainemak, 16:50:24)
    7. <MikkoTenhunen> (rainemak, 16:50:26)
    8. <MikkoTenhunen> In particular: (rainemak, 16:50:28)
    9. <MikkoTenhunen> - Do banking applications now support PIN code (rainemak, 16:50:30)
    10. <MikkoTenhunen> authentication correctly? (rainemak, 16:50:32)
    11. <MikkoTenhunen> - Do authenticator applications (2FA/TOTP apps) work (rainemak, 16:50:34)
    12. <MikkoTenhunen> reliably with device security features? (rainemak, 16:50:36)
    13. <MikkoTenhunen> - Are there known limitations in Android App Support (rainemak, 16:50:38)
    14. <MikkoTenhunen> regarding Android Keystore, biometric APIs, or PIN (rainemak, 16:50:40)
    15. <MikkoTenhunen> protected authentication? (rainemak, 16:50:44)
    16. <MikkoTenhunen> - Is there an estimated roadmap or planned improvements (rainemak, 16:50:46)
    17. <MikkoTenhunen> for banking and authentication apps? (rainemak, 16:50:48)
    18. <MikkoTenhunen> (rainemak, 16:50:50)
    19. <MikkoTenhunen> This information would help users understand the current (rainemak, 16:50:52)
    20. <MikkoTenhunen> status of Android application compatibility and security (rainemak, 16:50:54)
    21. <MikkoTenhunen> related functionality on Sailfish OS. (rainemak, 16:50:56)
    22. <Jolla> We are looking into this. Too early to comment. Let's hope that (rainemak, 16:50:58)
    23. <Jolla> we'd have some improvements integrated for Sailfish OS 5.3 (rainemak, 16:51:00)
    24. <Jolla> release. (rainemak, 16:51:02)

  7. Community Port - X10V and X10IV AAS update (5 mins -- asked by sharks) (Keto, 16:56:25)
    1. jojomen, community (jojomen, 16:56:30)
    2. <sharks> Per the 03/09/26 community meeting, I’ve attempted reaching out (rainemak, 16:56:47)
    3. <sharks> a few times over the last month on #sailfishos on IRC to see if (rainemak, 16:56:47)
    4. <sharks> anyone from Jolla can let me know what is required of me to (rainemak, 16:56:47)
    5. <sharks> assist / accelerate AAS progress for the community port. (rainemak, 16:56:47)
    6. <sharks> (rainemak, 16:56:48)
    7. <sharks> Given I’ve not received any reply, I am reaching out again (rainemak, 16:56:49)
    8. <sharks> here. Are you able to give us any news? After all, the squeaky (rainemak, 16:56:51)
    9. <sharks> wheel gets the grease. (rainemak, 16:56:53)
    10. <Jolla> We understand the desire for this. However, we haven't had (rainemak, 16:56:55)
    11. <Jolla> chance to test this yet. For Xperia 10 IV and 10 V communinity (rainemak, 16:56:57)
    12. <Jolla> ports we'd need AppSupport that is Android 15 based (simplest (rainemak, 16:56:59)
    13. <Jolla> this way). Along with Sailfish OS 5.2 we should get AppSupport (rainemak, 16:57:01)
    14. <Jolla> upgraded for Jolla C2 to Android 15 base. This should pawe the (rainemak, 16:57:03)
    15. <Jolla> way towards getting AppSupport for 10IV and 10V community ports. (rainemak, 16:57:05)
    16. <Jolla> Bear with us and give us a bit more time on this. (rainemak, 16:57:07)

  8. Jolla Phone 2026 Wi-Fi hardware: 1x1 or 2x2 MIMO? (5 mins -- asked by MiPal75) (Keto, 17:03:18)
    1. <MiPal75> Could Jolla please confirm one specific hardware specification (rainemak, 17:03:41)
    2. <MiPal75> of the Jolla Phone 2026 WLAN subsystem: (rainemak, 17:03:42)
    3. <MiPal75> (rainemak, 17:03:42)
    4. <MiPal75> Is the Jolla Phone 2026 physically designed for 1x1 or 2x2 Wi-Fi MIMO? (rainemak, 17:03:43)
    5. <MiPal75> (rainemak, 17:03:45)
    6. <MiPal75> Several real-world tests indicate that the Jolla Phone 2026 (rainemak, 17:03:47)
    7. <MiPal75> currently operates using only one spatial stream. This has (rainemak, 17:03:49)
    8. <MiPal75> been reproduced by more than one user and with different (rainemak, 17:03:51)
    9. <MiPal75> access points. At the same time, iw phy phy0 info advertises (rainemak, 17:03:53)
    10. <MiPal75> HE MCS support for both NSS 1 and NSS 2. (rainemak, 17:03:55)
    11. <MiPal75> (rainemak, 17:03:57)
    12. <MiPal75> There is an existing forum discussion with measurements here: (rainemak, 17:03:59)
    13. <MiPal75> (rainemak, 17:04:01)
    14. <MiPal75> I have also asked Jolla Customer Care for clarification but (rainemak, 17:04:03)
    15. <MiPal75> have not received an answer. (rainemak, 17:04:05)
    16. <MiPal75> (rainemak, 17:04:07)
    17. <MiPal75> I am specifically not asking whether the current Wi-Fi (rainemak, 17:04:09)
    18. <MiPal75> connection happens to operate as 1x1. I would like to clarify (rainemak, 17:04:13)
    19. <MiPal75> the physical design of the phone: (rainemak, 17:04:15)
    20. <MiPal75> (rainemak, 17:04:17)
    21. <MiPal75> If the WLAN hardware/RF/antenna design is 1x1, then the (rainemak, 17:04:19)
    22. <MiPal75> observed behaviour is expected and the question is (rainemak, 17:04:21)
    23. <MiPal75> answered. (rainemak, 17:04:23)
    24. <MiPal75> (rainemak, 17:04:25)
    25. <MiPal75> If the phone is physically designed for 2x2, then the fact (rainemak, 17:04:27)
    26. <MiPal75> that multiple devices appear to operate as 1x1 may warrant (rainemak, 17:04:29)
    27. <MiPal75> investigation of the driver, firmware or configuration. (rainemak, 17:04:31)
    28. <MiPal75> (rainemak, 17:04:33)
    29. <MiPal75> A confirmation from the Jolla hardware team of “1x1” or “2x2” (rainemak, 17:04:35)
    30. <MiPal75> would therefore be sufficient. (rainemak, 17:04:37)
    31. https://forum.sailfishos.org/t/jolla-phone-2026-wi-fi-6-throughput-appears-limited-to-400-mbit-s-480-mbit-s-phy/32719 (rainemak, 17:04:39)
    32. <Jolla> Jolla Phone 2026 has 1x1 MIMO (rainemak, 17:04:44)
    33. https://en.wikipedia.org/wiki/MIMO (extechop[m], 17:09:01)

  9. Open Pull Requests (PRs) to discussion (5 mins -- asked by Jolla) (Keto, 17:10:24)
  10. General discussion (10 mins) (Keto, 17:16:38)
  11. Next meeting time and date (2 mins) (Keto, 17:27:50)
    1. Next meeting will be held on Thursday 15th October 2026 at 04:00pm UTC: 2026-10-15T1600Z (rainemak, 17:30:38)


Meeting ended at 17:31:07 UTC (full logs).

Action items

  1. Community task board
  2. Jolla to update regarding recommended charging cables and chargers.
  3. The Privacy Switch in relation to Ambiances
  4. Jolla to create sailfish-settings-labs
  5. Iron out bundled helper executable (https://forum.sailfishos.org/t/community-meeting-on-october-1-2026/33735/4)
  6. Issue to be reported


People present (lines said)

  1. rainemak (269)
  2. abr (28)
  3. jojomen (23)
  4. Keto (20)
  5. muhnschein (17)
  6. nephros (14)
  7. extechop[m] (11)
  8. pherjung[m] (10)
  9. MiPal75 (3)
  10. sailbot (2)
  11. Nico (2)
  12. MikkoTenhunen[m] (1)


Generated by MeetBot 0.1.4.